Jump to content

Hasher

Members
  • Posts

    54
  • Joined

  • Last visited

Everything posted by Hasher

  1. I am unable to localise the error, missing class/file or other mistake I could made, because nothing is added into my /var/log/php_errors.log when the white screen occurs. The error itself is irrelevant here and probably trivial, more important for me is why the white screen doesn't return any errors? In my /etc/php5/apache2/php.ini I have: display_errors = On, log_errors = On error_log = /var/log/php_errors.log phpinfo() returns the same values /var/log/php_errors.log does log some errors in other pages In my [Prestashop_dir]/config/defines.inc.php I have define('_PS_MODE_DEV_', true); and in smartyadmin.config.inc.php I also added $smarty->debugging = true; URL of the page that is causing the white screen: [Prestashop_backend_url]/index.php?controller=AdminPdf&token=d10cf8b3819b0922610f36caf0e37c24&submitAction=generateDeliverySlipsPDF&id_order=1
  2. I have in php.ini: display_errors = On in config/defines.inc.php: define('_PS_MODE_DEV_', true); in smartyadmin.config.inc.php: $smarty->debugging = true; Some errors are logged into my php_error_log but not the one that is causing the white screen. I am developing my own module and because of white screen I am unable to localise the error. EDIT: I have found the reason of white screen - in AdminDeliverySlipController.php I had Tools::redirectAdmin($this->context->link->getAdminLink('AdminPdf').'&submitAction=generateDeliverySlipsLabel&id_order='.Tools::getValue('id_order')); instead of Tools::redirectAdmin($this->context->link->getAdminLink('AdminPdf').'&submitAction=generateDeliverySlipsPDFLabel&id_order='.Tools::getValue('id_order')); but I would still like to know how to log such errors?
  3. In case someone might have similar problem, make sure you have php-gd installed on your server, sudo apt-get install php5-gd
  4. Naprawione! Na serwerze brakowało php-gd. sudo apt-get install php5-gd
  5. Po przeniesieniu na nowy serwer nie mogę dodawać zdjęć. (Unexpected token <) Uprawnienia w folderze config/xml, cache i img ustawiłem na 777. Podmieniłem najnowszy plik admin\themes\default\template\controllers\products\images.tpl i wciąż to samo.
  6. lokalizacja_sklepu\config\defines.inc i zmienną: define('_PS_DEBUG_PROFILING_', false); zmień false na true. btw. powiem wam że przeniosłem się z home.pl na VPS microhosta z 2GB ramu i czas wykonania zmniejszył się z 2-8 sekund do 0.5-1 sekundy.
  7. a jak mogę sprawdzić który plik/funkcja wykonuje się tak długo? albo przynajmniej który moduł? na pewno dużo czasu zajmuje wczytanie ostatnio dodanych produktów na stronie głównej, ale to już domyślny moduł Presty >.>
  8. Czy to jest normalne? Wyłączenie kompilacji szablonu i włączenie cache niewiele zmienia. Z czego może wynikać np. tak wielki rozmiar initFooter? Poniżej wyniki z włączonego profilowania: Load time: 6990 ms You'd better run your shop on a toasterExecution Load time (ms) config 174 constructor 0 init 276 checkAccess 0 setMedia 7 postProcess 0 initHeader 0 initContent 1215 initFooter 632 display 4685 Hook processing: 1777 ms / 15.67 Mb 68 methods called in 40 modulesHook Processing displayFooter 1.09 Mb in 632 ms displayTop 2.08 Mb in 431 ms displayHeader 11.13 Mb in 292 ms displayProductTabContent 0.28 Mb in 208 ms displayRightColumnProduct 0.60 Mb in 101 ms displayProductButtons 0.29 Mb in 57 ms displayBanner 0.04 Mb in 22 ms displayProductTab 0.09 Mb in 19 ms displayLeftColumnProduct 0.02 Mb in 12 ms customFooter 0.04 Mb in 2 ms displayTopColumn 0.00 Mb in 0 ms actionProductOutOfStock 0.00 Mb in 0 ms moduleRoutes 0.00 Mb in 0 ms displayMyAccountBlockfooter 0.00 Mb in 0 ms actionDispatcher 0.00 Mb in 0 ms actionFrontControllerSetMedia 0.00 Mb in 0 ms displayProductContent 0.00 Mb in 0 ms displayFooterProduct 0.00 Mb in 0 ms DisplayOverrideTemplate 0.00 Mb in 0 ms Memory peak usage: 36.7 MbExecution Memory (Mb) Total (Mb) config 10.43 10.6 constructor 0.00 10.6 init 7.51 18.3 checkAccess 0.00 18.3 setMedia 0.21 18.4 postProcess 0.00 18.4 initHeader 0.01 18.4 initContent 15.29 33.8 initFooter 1.12 34.9 display 1.63 36.7 Total cache size (in Cache class): 0.00 Mb DB type: DbPDO SQL Queries: 81 queries Time spent querying: 63 ms Included files: 277 Size of included files: 4.21 Mb Globals (> 1 Ko only): 693 Ko_MODULES ≈ 322.3 Ko _LANG ≈ 198.8 Ko context ≈ 139.2 Ko _SERVER ≈ 10.6 Ko _ENV ≈ 9.8 Ko _MODULE ≈ 3.8 Ko _REQUEST ≈ 2.2 Ko _COOKIE ≈ 2.2 Ko
  9. W najnowszej Preście nadal jest Swift Mailer w wersji sprzed 8 lat?
  10. Konfiguracja usługi > Statystyki > Zobacz statystyki odwiedzin serwera i na samej górze będą linki do logów z danego dnia.
  11. Własny pozwala na drukowanie zaznaczonych zamówień (zamiast wg przedziału czasowego), ale w produktach niepotrzebnie się pojawiał.
  12. Problem okazał się dość trywialny, wynikał z tego że miałem moduł który korzystał ze zmiennej $token i trzymał w niej wartość dla innej sekcji panelu, więc token w efekcie faktycznie był nieprawidłowy.
  13. SOLVED: I had to edit: /etc/apache2/sites-available/default change: AllowOverride None to AllowOverride All and restart apache.
  14. Nie mogę przejść na kolejną stronę w przeglądzie produktów, ani wykonywać zbiorczych działań (usuń zaznaczone, itp.) ponieważ przy tego typu akcjach kieruje mnie na URL: http://sklep.com/admin4708/index.php?controller=AdminProducts&id_category=12&token=d928e716fa35681f43300035796be3d7#product na moje zamiast # powinno być & i product powinien mieć jakąś wartość czyli np. product=51 Ktoś wie gdzie siedzi plik odpowiedzialny za tworzenie tego URL, albo lepiej: jak to naprawić? EDIT: a niekoniecznie, jednak URL jest dobry bo na innym sklepie mi działa, tylko czemu tu może nie działać?
  15. No tak, właśnie po tym stwierdziłem że jest włączony Myślałem że chodzi o coś innego. http://windypluspolska.com/php.php
  16. I did no changes in urls. There is some cache in cache/smarty/compile but I can't delete it due to low priveleges. Anyway, caching is disabed in config. Example of friendly URL: http://windypluspolska.com/3_behrens-eurolift Error example: Not Found The requested URL /kontakt was not found on this server. Apache/2.2.16 (Debian) Server at windypluspolska.com Port 80
  17. Tak, zwykłe skrócone linki. Zresztą można zobaczyć tutaj: windypluspolska.com Aha, chyba warto dodać że wywala 404 "serwerowe" a nie te od Presty: Not FoundThe requested URL /kontakt was not found on this server. Apache/2.2.16 (Debian) Server at windypluspolska.com Port 80
  18. Żadne linki poza głównym adresem sklepu nie działają, nie znajduje też obrazków produktów. mod_rewrite jest włączony, jak twierdzi phpinfo(). Wersja PrestaShop: 1.6.0.9 Sklep jest na VPS z systemem Debian 6.0.2, Apache 2.2.16.
  19. None of friendly links work (404) and product images are also not found. mod_rewrite is loaded according to phpinfo(). PrestaShop™ 1.6.0.9 We have a VPS. Web server version is: Apache 2.2.16 System: Debian 6.0.2
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More