Jump to content

Shonen

Members
  • Posts

    268
  • Joined

  • Last visited

Everything posted by Shonen

  1. <IfModule mod_rewrite.c> RewriteEngine on RewriteRule ^(BAavicole)($|/) - [L] </IfModule> Kesskessé ? Enlève ça pour voir.
  2. Salut, Dans le fichier /js/admin/tinymce.inc.js, tu as bien tout ? var materialIconAssoc = { 'mce-i-code': '<i class="material-icons">code</i>', 'mce-i-none': '<i class="material-icons">format_color_text</i>', 'mce-i-bold': '<i class="material-icons">format_bold</i>', 'mce-i-italic': '<i class="material-icons">format_italic</i>', 'mce-i-underline': '<i class="material-icons">format_underlined</i>', 'mce-i-strikethrough': '<i class="material-icons">format_strikethrough</i>', 'mce-i-blockquote': '<i class="material-icons">format_quote</i>', 'mce-i-link': '<i class="material-icons">link</i>', 'mce-i-alignleft': '<i class="material-icons">format_align_left</i>', 'mce-i-aligncenter': '<i class="material-icons">format_align_center</i>', 'mce-i-alignright': '<i class="material-icons">format_align_right</i>', 'mce-i-alignjustify': '<i class="material-icons">format_align_justify</i>', 'mce-i-bullist': '<i class="material-icons">format_list_bulleted</i>', 'mce-i-numlist': '<i class="material-icons">format_list_numbered</i>', 'mce-i-image': '<i class="material-icons">image</i>', 'mce-i-table': '<i class="material-icons">grid_on</i>', 'mce-i-media': '<i class="material-icons">video_library</i>', 'mce-i-browse': '<i class="material-icons">attachment</i>', 'mce-i-checkbox': '<i class="mce-ico mce-i-checkbox"></i>', }; Et code est répété un peu plus bas. toolbar1: "code,colorpicker,bold,italic,underline,strikethrough,blockquote,link,align,bullist,numlist,table,image,media,formatselect",
  3. Essaye de générer un nouveau .htaccess en cliquant sur Enregistrer sous l'onglet Format des URL et URL de la boutique dans Paramètres de la boutique > Trafic et SEO. Ensuite tu peux tester si ton site fonctionne via cette url (actuellement il ne fonctionne pas en effet) : https://www.websiteplanet.com/webtools/down-or-not/?dorn=https://boutique-fermeavicole.fr/ Et enfin, essaye d'appeler OVH pour leur demander pourquoi ton site n'est pas atteignable à l'étranger, ils pourront peut être te guider ? Pour savoir si ça peut venir de l'hébergeur, tu peux tout simplement créer un sous domaine tel que test.monsite.fr et y coller un simple index.html avec un Hello World dedans. Si tu peux le voir, mais que le résultat est négatif via l'url partagée ci-dessus, c'est que ça vient de l'hébergeur. Sinon, ça vient de Prestashop. Et dans ce cas il faut faire le tour des modules.
  4. Si votre site est en production, en effet l'environnement doit être production. Pour le app.engine, les miens sont sur php aussi, je ne sais pas si ça changera grand chose mais à tester. Qu'en est-il de la page Pays en back-office ? Et aussi, quelle est l'indication qui vous dit que les étrangers n'ont pas accès à votre site ?
  5. Salut, Dans ton back-office de /test/, essaye d'aller dans Paramètres de la boutique > Trafic et SEO, de vérifier l'URL en face de domaine de la boutique, domaine SSL et Chemin de base. Si c'est la mauvaise, change la. Si c'est la bonne, clique quand même sur Enregistrer, ça va te générer un nouveau .htaccess à jour. Pense à modifier ton robots.txt pour y mettre un User-agent: * Disallow: / Vérifie aussi si t'as pas un module de redirection, on sait jamais. Et ton thème si y'a pas en dur des URL dans les tpl.
  6. Salut, J'ai essayé avec un VPN en Allemagne et aux US, pas de soucis de connexion à ton site. Dans International > Zones géographiques > Pays, tu as l'option Restreindre les pays sur la boutique aux pays desservis par les transporteurs actifs activée ? Par contre une erreur dans ton footer : Aussi, tu peux passer ton PHP à 7.1, c'est la meilleure compatibilité d'après Prestashop
  7. Pour être plus précis avec ma réponse Quand tu regarde l143 de PrestaShopAutoload, il essaye de récupérer la classe Core quand il ne trouve pas la classe officielle, donc si ici il essaye de choper IndexControllerCore, c'est qu'il ne trouve pas IndexController et donc il va chercher un Core, qui n'existe pas avec IndexController. D'où mon interpellation : je pense que ton dossier controller/ est un peu corrompu. Essaye déjà de regarder dedans rien que pour vérifier si IndexController est présent ou non, une piste. Parfois quelques thèmes vont faire des override directement dans le coeur, sans passer par le dossier override (bouh pas bien), donc même si ton thème est compatible 1.7.7.0, est-ce qu'il est à jour ? Lors de tes test, si tu passes sur un environnement de développement (conseillé), essaye aussi avec le thème classic. Et ça coûte rien de renommer ton dossier controller par _controller par exemple, et de glisser celui du gith Presta à la place, tu peux revenir en arrière en 1 clic. Mais c'est tellement + agréable dans un environnement de dev, no stress.
  8. Tu as modifié la traduction pour ton thème et le thème classic ? Si ce n'est pas le cas, traduis aussi le thème classic.
  9. Salut, Dans ton Product.tpl, tu ne nous montre que la partie "nav-tabs" qui contient donc les tabulations. Mais tu ne nous montre pas le code contenu dans les tabulations, à savoir $product.description et $product.technical Il te faut dans la parie "tab-content", que tu echo ton technical. <div class="tab-content" id="tab-content"> <div class="tab-pane fade in{if $product.description} active{/if}" id="description" role="tabpanel"> {block name='product_description'} <div class="product-description">{$product.description nofilter}</div> {/block} </div> <div class="tab-pane fade in{if $product.technical} active{/if}" id="technical" role="tabpanel"> {block name='product_technical'} <div class="product-technical">{$product.technical nofilter}</div> {/block} </div>
  10. Salut, As-tu essayé de vider le cache ? Suppression des dossier prod/ et dev/ dans /var/cache/
  11. Class 'IndexControllerCore' not found ça pue, je dirais que ton dossier /controller/ ne contient pas tout le code source qu'il devrait avoir. Vérifie l'intégrité du contenu de tes controller par rapport au github officiel : https://github.com/PrestaShop/PrestaShop/tree/develop/controllers Fait la même avec les classes au cas où : https://github.com/PrestaShop/PrestaShop/tree/develop/classes
  12. Ca c'est autre chose, tu as probablement trop de factures (ça arrive à un client aussi, avec ~78 factures). Faut réduire la plage de données pour les sortir en moins grandes quantités. Le script PHP doit être un peu lourd, + pauvres performances de l'hébergeur = ce résultat.
  13. As-tu essayé de vider le cache ? Comme ça ton site va se reconstruire et pas essayer de charger l'ancien code sur une nouvelle version. Dossier /var/cache/ et supprimer prod/ et dev/
  14. Sur Prestashop 1.7, lorsqu'une traduction ne fonctionne pas ou n'apparaît pas même après avoir vidé le cache (suppression des dossier dev et prod dans /var/cache/), essayez de modifier la traduction du thème natif, à savoir classic. Même si celui-ci n'est pas actif, c'est ici que Presta 1.7 va récupérer les informations. Pourquoi ? Aucune idée.
  15. Salut, Le client doit créer une redirection sur sa boite mail. Quand il reçoit un mail via ton site, ou via le sujet de ton mail, il l'envoi à sa compta. Via Prestashop, 1 e-mail seulement est possible par compte de manière native. Sinon il faut modifier le cœur de Prestashop.
  16. Salut, Comment tu peux encore avoir erreur 500 alors que tu as activé les erreurs ? Tu devrais avoir le détail de l'erreur, comme tu nous a partagé précédemment. Dis toi bien que quand tu écris ici "j'ai une erreur 500" ça ne sert A RIEN, mais vraiment strictement à rien, personne ne pourra aider sans le détail de l'erreur.
  17. Dans ce cas je ne vois plus qu'une chose : le filtre de dates en haut de l'affichage des stats. Essaye de prendre une zone suffisamment large (création de ton site) si tu souhaite toutes les stats. Actuellement tu étais réglé sur uniquement le mois de Février. Si ce n'est pas ça, je n'ai rien en stock !
  18. En vrai j'ai testé, et même avec les urls simplifiées j'arrive à tomber sur du maboutique.fr/commande ou maboutique.fr/commande?step=2 Cela survient par contre uniquement lorsque, à l'étape Paiement, je clique sur "Continuer mes achats", et ainsi je suis redirigé à l'étape précédente, et Prestashop me l'informe avec l'url ?step=2. Au clic sur Commander, je n'ai que ?step=1 au moment du choix de l'adresse.
  19. Essaye vraiment de vider ton cache, ça pourrait résoudre ton soucis d'affichage des stats.
  20. Salut, Pour du dropshipping j'ai utilisé le module https://addons.prestashop.com/fr/dropshipping/17943-dropshipping-emails-fournisseurs-et-transporteurs.html Attention vérifie bien si ça ressemble à ce que tu souhaites, mais dans l'idée à chaque commande, si un produit du panier appartient au fournisseur, celui-ci reçoit par mail (une fois le module configuré) les produits qu'il doit préparer. Pour chaque fournisseur tu peux configurer le contenu du mail, à qui le mail sera envoyé, le sujet, le transporteur utilisé, etc.
  21. Salut ! Pour ma part, sur mes 1.6 je passe par le module de @Eolia, paiement générique https://eoliashop.com/generic-payment Sur une version 1.7 par contre, je n'ai pas de module à conseiller, mais fais un tour sur l'addons tu trouveras forcément quelque chose. https://addons.prestashop.com/fr/recherche?search_query=paiement&compatibility=1.7.0& Sinon, de manière native, tu peux surcharger le module de paiement par chèque ou par virement bancaire, de manière à renommer chaque champs pour faire croire à un paiement "spécifique" pour tes précommandes. Dans ce cas bien entendu il ne faut pas que tu ai réellement besoin du paiement par chèque ou virement.
  22. Je ne comprend pas ton problème Le code Presta 1.7 de la fonction generateReference() est strictement identique à 1.6 /** * Generate a unique reference for orders generated with the same cart id * This references, is useful for check payment. * * @return string */ public static function generateReference() { return strtoupper(Tools::passwdGen(9, 'NO_NUMERIC')); }
  23. Je ne comprend toujours pas ton soucis de statistiques. L'information "Commande passées" s'incrémente quand ton statut passe à "Livré" j'imagine. Donc si tu as 13 commandes, pour 9 en état livrées et 4 en cours de préparation ou de livraison, c'est normal. Si ce n'est pas ce que tu souhaites, il te faudra surcharger le code source de Presta sur les stats.
  24. Salut ! Je pense qu'il est mieux de cacher le nom des clients plutôt que le tarif sur une capture d'écran, mais ce n'est qu'un détail Comme le dit Mediacom, il faut que tu vérifie les statuts de tes commandes. Pour savoir quand est créé une facture ou un BL, il faut te diriger vers Paramètres de la boutique > Commandes > États de commandes. Par défaut la facture est générée sur plusieurs type d'états (dont Livré). Si ça n'apparaît pas avant de cliquer sur la commande, c'est probablement rien, juste à vider le cache.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More