Jump to content

serdib

Members
  • Posts

    26
  • Joined

  • Last visited

Everything posted by serdib

  1. Hello guys I installed this module but spammers are still doing their "job" (creating new spam accounts) by disabling javascript. I don't understand which file should I change with this code? As I understand "ContactController.php" used for "Contact us" page on site. But I need to protect also my "create an account" page. I have only this code in override ContactController.php (see below) And I can't see any signs of "$message = Tools::getValue('message');" or something in this file. Please explain this for me. Should I change PHP or any TPL files? Thank you. <?php class ContactController extends ContactControllerCore { /* * module: eicaptcha * date: 2019-04-19 17:23:56 * version: 0.4.15 */ public function checkAccess() { return (bool)Hook::exec('contactFormAccess'); } /* * module: eicaptcha * date: 2019-04-19 17:23:56 * version: 0.4.15 */ public function initCursedPage() { parent::setMedia(); if (!empty($this->redirect_after)) { parent::redirect(); } if (!$this->content_only && ($this->display_header || (isset($this->className) && $this->className))) { parent::initHeader(); } parent::initContent(); if (!$this->content_only && ($this->display_footer || (isset($this->className) && $this->className))) { parent::initFooter(); } parent::display(); die; } }
  2. Thank for your reply. Now this module is installed on clean PrestaShop 1.6.1.11 with default theme on localhost. I've checked hooks. Froggy Toolbar now is hooked in 3 hooks: displayBackOfficeHeader, displayFooter, Header. As you can see on screenshot place for this module exists at the top of the page. I will try to install on older version of Presta.
  3. Thanks for your module. I tried to install this module on PrestaShop 1.6.1.11. Installation was OK but in frontoffice I've got an error (see screenshot). What is it and what should I do to fix it? How could be ps version not defined? Thank you.
  4. What about your Nameserver settings with your registrar? Did you change it to new hosting? Because now I see "DNS_PROBE_FINISHED_NXDOMAIN" error.
  5. Maybe something wrong with your htaccess file. Did you look inside it?
  6. Hello! Today I've updated my shop by 1Click-Upgrade from 1.6.1.2 to 1.6.1.11. And I find out that there is a new catalog in modules folder — emailgenerator. Inside this folder I see "templates_translations" folder with "lang_content.php" file in it (see attach.). Clean 1.6.1.11 installation folder and previous versions of Prestashop doesn't have this folder at all. What is it? And what should I do? lang_content.php
  7. Hello! How can I change the code to make this module to export ALL subscribers from my store to Mailchimp? Because now it just export only subscribed customers. And today I already have subscribers who subscribed by module "blocknewsletter" (they are not customers).
  8. Hello! How can I upgrade for example from 1.6.1.2 to 1.6.1.3 manually? If i go to this page — https://www.prestashop.com/en/developers-versions/changelog/1.6.1.3-stable — I see only list of fixes without request numbers If I go to this page — http://build.prestashop.com/news/prestashop-1613-maintenance-release/ — I see the link called "closes 6 issues" to https://github.com/PrestaShop/PrestaShop/pulls?utf8=%E2%9C%93&q=is%3Apr+base%3A1.6.1.x+is%3Aclosed+merged%3A%3E2015-10-29+ but on that page are showing all requests, not only for 1.6.1.3. What a mess? How can I find for example this two fixes: [-] FIX : (e3eef33) Uncaught Error: Access to undeclared static property: Validate::$field [-] FIX : (0ab3b7d) Uncaught Error: Access to undeclared static property: Validate::$field I even tried to find with 1.6.1.3 keyword without effect. What should I do? Help! P.S. I can't use 1Click Upgrade module because I have many editions in code.
  9. PrestaShop 1.6.1.2. Default but with Multiple Features module installed. If you mean numbers at tabs , I'v made this for better experience in BO. And the reason why I need cover image at this tab is because this is very hard to set features for every product when you don't see actual product image.
  10. Hello everyone. Anyone know how to add product cover image to Features tab on Product page in BO? I'v found the file — admin/themes/default/template/controllers/products/features.tpl but i don't know what code should I insert there. I'v tried with no luck.
  11. Thank Misthero for your reply I think I have found the code (from 2003 line to 2013). Am I right? Or I should comment the code somewhere else?
  12. Hi. I think i have a problem (see screenshot). What is this and what should i do? Why this module try to execute PHP file from — http://syncrea.it/devel/update.php Is somewhere virus or something? Sliders Everywhere (1.6.41) + Presta (1.6.1.2)
  13. How can i change the size of this mini thumbnails? Now it is 45x45 pixels. I tried to change it in Preferences > Images with no luck (I thought that size of mini thumbnails is linked to 'cart_default' size). I can't find "45" digits or something related to this in 'AdminProductsController.php' or 'ImageManager.php'.
  14. For everyone! Don't forget to insert your API key also to /controllers/admin/AdminOrdersController.php Around line 340 (see screenshot) This will fix API warnings in Backoffice. And also remove &sensor=false code.
  15. Hi everyone! I am using official free Google Shopping module (http://addons.prestashop.com/ru/23831-google-shopping.html) to upload product feed to Google Merchant Center. But in my feed there is no product description at all. And i don't know why. See screenshots. I already checked my pages with structured-data testing tool and everething is OK. What should i do to include product descriptions in feed? This is very important. P.S. Presta 1.6.1.2 + Wharehouse theme 3.6.2
  16. SimoneS93, do you have any news about compatibility with Presta 1.6.1+? My hope is still alive!
  17. Disabling checkbox for "Processing in progress" status (Preparation template) will NOT help you. To disable this In-Transit-email you should make some code editing (see screen). Just comment this lines in /controllers/admin/AdminOrdersController.php file. Just don't ask me why developers didn't make this option for backoffice. I wish i knew.
  18. Thanks Bellini for your tip! Now it is installing . I checked and transplant this module to "displayBackOfficeTop" hook manually as described. But it doesn't work as expected So i tried to brutforce by myself (1.6.0.9 and 1.6.1.3) and the table is clear. Dear SimoneS93, what version of Prestashop are you using? I think that this is very usefull module for everyone who have their own shops.
  19. Thanks for reply! I tried to change "module_fail2ban" to "fail2ban" everewhere, but have the same error (tried on clean Presta 1.6.1.0 and 1.6.1.3). But on Presta 1.6.0.9 it installs OK even with "module_fail2ban" text.
  20. I tried to install this module (upload to the "Module" section) on clean Preta 1.6.1.3 installation, but when i go to modules a have this error [PrestaShop] Fatal error in module file :C:\OpenServer\domains\prestaclear1613\Core\Foundation\IoC\Core_Foundation_IoC_Container.php: Uncaught exception 'Core_Foundation_IoC_Exception' with message 'Cannot build a `module_fail2ban`.' in C:\OpenServer\domains\prestaclear1613\Core\Foundation\IoC\Core_Foundation_IoC_Container.php:114 Stack trace: #0 C:\OpenServer\domains\prestaclear1613\Core\Foundation\IoC\Core_Foundation_IoC_Container.php(157): Core_Foundation_IoC_Container->makeInstanceFromClassName('module_fail2ban', Array) #1 C:\OpenServer\domains\prestaclear1613\Core\Foundation\IoC\Core_Foundation_IoC_Container.php(170): Core_Foundation_IoC_Container->doMake('module_fail2ban', Array) #2 C:\OpenServer\domains\prestaclear1613\Adapter\Adapter_ServiceLocator.php(52): Core_Foundation_IoC_Container->make('module_fail2ban') #3 C:\OpenServer\domains\prestaclear1613\classes\module\Module.php(1370): Adapter_ServiceLocator::get('module_fail2ban') #4 C:\OpenServer\domains\prestaclear1613\controllers\admin\AdminModulesController.php(1442): ModuleCore::getModulesOnDisk(true, false, 1) #5 C:\OpenServer\domains\prestaclear1613\classes\controller\Controll How can i fix this? Dev mode is turned off. Thank you.
  21. I am in Presta for 5 months and still cant find the case when new voucher sending to customer. In email template files we have only two templates with voucher codes — voucher.html and voucher_new.html Voucher.html was automatically sent to customer in case i made a refund/return procedure (when i checked this 'Generate voucher' checkbox on order's page). "A voucher has been created in your name as a result of your order with the reference etc..." Can someone explain — in what situation the voucher.html is using?
  22. Hi Musicmaster! Thanks for your great module. I have one issue with Url-SEO Multi-Edit page. Radio buttons don't work. Hide&Show radio-buttons are OK but not Edit. Please see screenshot. Is this bug? PrestaShop 1.6.1.2 + triple_edit-1.09p
  23. If i understand your question right — you can find this codes in BO
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More