Jump to content

gdinari

Members
  • Posts

    91
  • Joined

  • Last visited

1 Follower

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

gdinari's Achievements

Newbie

Newbie (1/14)

14

Reputation

  1. Hi everybody, I ran my site through an SEO auditor and it showed that certain products aren't optimized for search engines. On the product pages the jqzoom image is missing both the alt and title tag. I would like to use the product name as the value both of these attributes. When I inspect the source code the file that I need to edit is not the first image within <div class="zoomPad">. The image that I need to edit is within <div class="zoomWrapperImage">. The image is generated within this div and the only way to edit it is with the function below. I have located the file and function that controls the jqzoom image, but I dont know how to do this. Id really appreciate some assistance with this. Here are the details. File location: /js/plugins/jqzoom/jqzoom.js What I need: To add product name as ALT and TITLE attributes for zoomWrapperImage image Function (line 623 v.1.6): function Largeimage() { var $obj = this; this.node = new Image(); this.loadimage = function (url) { //showing preload loader.show(); this.url = url; this.node.style.position = 'absolute'; this.node.style.border = '0px'; this.node.style.display = 'none'; this.node.style.left = '-5000px'; this.node.style.top = '0px'; document.body.appendChild(this.node); this.node.src = url; // fires off async }; this.fetchdata = function () { var image = $(this.node); var scale = {}; this.node.style.display = 'block'; $obj.w = image.width(); $obj.h = image.height(); $obj.pos = image.offset(); $obj.pos.l = image.offset().left; $obj.pos.t = image.offset().top; $obj.pos.r = $obj.w + $obj.pos.l; $obj.pos.b = $obj.h + $obj.pos.t; scale.x = ($obj.w / smallimage.w); scale.y = ($obj.h / smallimage.h); el.scale = scale; document.body.removeChild(this.node); $('.zoomWrapperImage', el).empty().append(this.node); //setting lens dimensions; lens.setdimensions(); }; this.node.onerror = function () { throw 'Problems while loading the big image.'; }; this.node.onload = function () { //fetching data $obj.fetchdata(); loader.hide(); el.largeimageloading = false; el.largeimageloaded = true; if (settings.zoomType == 'drag' || settings.alwaysOn) { lens.show(); stage.show(); lens.setcenter(); } }; this.setposition = function () { var left = -el.scale.x * (lens.getoffset().left - smallimage.bleft + 1); var top = -el.scale.y * (lens.getoffset().top - smallimage.btop + 1); $(this.node).css({ 'left': left + 'px', 'top': top + 'px' }); }; return this; }; Thanks a lot jquery.jqzoom.html
  2. I added it at the very bottom of the code. It didnt improve the results. Does the placement of the code matter? Where should I add this?
  3. Hi, thanks I tried that, but I still get the same message from Pingdom and Pagespeed...
  4. Hi, I have been trying to optimize my site's Pingdom performance grade and the only issue that Im having now is specifying Etags. I read a number of articles with suggestions but nothing seems to work. This is the message I get from Pingdom and Pagespeed: - The following resources are missing a cache validator. Resources that do not specify a cache validator cannot be refreshed efficiently. Specify a Last-Modified or ETag header to enable cache validation for the following resources: https://www.gizmotrims.com/50308-m_scene_default/versio-mobile-iphone-5-5s-merge-with-stand-black.jpg https://www.gizmotrims.com/50308-scene_default/versio-mobile-iphone-5-5s-merge-with-stand-black.jpg https://www.gizmotrims.com/60173-m_scene_default/apple-iphone-5-official-nfl-protector-dallas-cowboys.jpg https://www.gizmotrims.com/60173-scene_default/apple-iphone-5-official-nfl-protector-dallas-cowboys.jpg https://www.gizmotrims.com/60174-m_scene_default/apple-iphone-5-official-nfl-protector-new-england-patriots.jpg https://www.gizmotrims.com/60174-scene_default/apple-iphone-5-official-nfl-protector-new-england-patriots.jpg https://www.gizmotrims.com/60175-m_scene_default/apple-iphone-5-official-nfl-protector-new-york-giants.jpg https://www.gizmotrims.com/60175-scene_default/apple-iphone-5-official-nfl-protector-new-york-giants.jpg Now at this point, I dont know what else to try, as I have followed the instructions of different articles at a time. Can someone help? Here is my current .htaccess code. Any help will be appreciated. SuPHP_ConfigPath /home/#####/public_html/php.ini # ~~start~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again # .htaccess automaticaly generated by PrestaShop e-commerce open-source solution # http://www.prestashop.com - http://www.prestashop.com/forums <IfModule mod_rewrite.c> <IfModule mod_env.c> SetEnv HTTP_MOD_REWRITE On </IfModule> # Disable Multiviews Options -Multiviews RewriteEngine on RewriteRule . - [E=REWRITEBASE:/] RewriteRule ^api/?(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L] # Images RewriteRule ^([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$1$2$3.jpg [L] RewriteRule ^([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$1$2$3$4.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$1$2$3$4$5.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$1$2$3$4$5$6.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$1$2$3$4$5$6$7.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$1$2$3$4$5$6$7$8.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$1$2$3$4$5$6$7$8$9.jpg [L] RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$8/$1$2$3$4$5$6$7$8$9$10.jpg [L] RewriteRule ^c/([0-9]+)(\-[\.*_a-zA-Z0-9-]*)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2$3.jpg [L] RewriteRule ^c/([a-zA-Z_-]+)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2.jpg [L] # AlphaImageLoader for IE and fancybox RewriteRule ^images_ie/?([^/]+)\.(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L] # Dispatcher RewriteCond %{REQUEST_FILENAME} -s [OR] RewriteCond %{REQUEST_FILENAME} -l [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^.*$ - [NC,L] RewriteRule ^.*$ %{ENV:REWRITEBASE}index.php [NC,L] </IfModule> AddType application/vnd.ms-fontobject .eot AddType font/ttf .ttf AddType font/otf .otf AddType application/x-font-woff .woff <IfModule mod_expires.c> ExpiresActive On ExpiresByType image/gif "access plus 1 month" ExpiresByType image/jpeg "access plus 1 month" ExpiresByType image/jpg "access plus 1 month" ExpiresByType image/png "access plus 1 month" ExpiresByType text/css "access plus 1 week" ExpiresByType text/javascript "access plus 1 week" ExpiresByType application/javascript "access plus 1 week" ExpiresByType application/x-javascript "access plus 1 week" ExpiresByType image/x-icon "access plus 1 year" ExpiresByType image/svg+xml "access plus 1 year" ExpiresByType image/vnd.microsoft.icon "access plus 1 year" ExpiresByType application/font-woff "access plus 1 year" ExpiresByType application/x-font-woff "access plus 1 year" ExpiresByType application/vnd.ms-fontobject "access plus 1 year" ExpiresByType font/opentype "access plus 1 year" ExpiresByType font/ttf "access plus 1 year" ExpiresByType font/otf "access plus 1 year" ExpiresByType application/x-font-ttf "access plus 1 year" ExpiresByType application/x-font-otf "access plus 1 year" </IfModule> FileETag INode MTime Size <IfModule mod_deflate.c> <IfModule mod_filter.c> AddOutputFilterByType DEFLATE text/html text/css text/javascript application/javascript application/x-javascript </IfModule> </IfModule> #If rewrite mod isn't enabled ErrorDocument 404 /index.php?controller=404 # ~~end~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again ## 10-10-2014: Custom .htaccess code RewriteEngine On RewriteCond %{HTTP_HOST} ^gizmotrims\.com [NC] RewriteCond %{SERVER_PORT} 80 RewriteRule ^(.*)$ https://www.gizmotrims.com/$1 [R,L] # BEGIN Compress text files <ifModule mod_deflate.c> <filesMatch ".(css|js|x?html?|php|xml|rss)$"> SetOutputFilter DEFLATE </filesMatch> </ifModule> # END Compress text files # 10-15-2014: Gary - Block user-agent libwww-perl, which can perform simple server attacks to exploit website vulnerablities SetEnvIfNoCase User-Agent "^libwww-perl*" block_bad_bots Deny from env=block_bad_bots
  5. Version: 1.6.0.9 Fix For those looking to apply this solution to the version 1.6.0.9 but may be having trouble finding the exact reference to {$group_reduction}, it is listed differently in this version. - Navigate to the product.tpl file of your theme - Find and replace this: {addJsDef group_reduction=$group_reduction} with this: {addJsDef group_reduction=1-$group_reduction}
  6. Ok for anyone who has been experiencing the same problem that I have which was that the module would include inactive/disabled products in the product listings here is a solution that I came up with: In the homecategoriesplus.php file, find this line: WHERE cp.`id_category` = ".$cat['id_category']." OR c.nleft >= ".$cat['nleft']." AND c.nright <= ".$cat['nright']." AND p.`active` = 1 and replace it with this: WHERE cp.`id_category` = ".$cat['id_category']." AND p.`active` = 1 Please make sure to in "p.active" in the beginning of the sql query execution like so: SELECT p.*, p.id_product as myid, p.active, pi.id_image, pl.name, pl.link_rewrite,pl.id_product, p.`active`, pl.id_lang, (p.`price` * IF(t.`rate`,((100 + (t.`rate`))/100),1)) AS orderprice For whatever reason the "nleft" and "nright" values of the category table are somehow allowing all products to be listed regardless of whether they are actually active. If someone can explain why this is that would be great. In the meantime I hope this solution will bring some relief to anyone experiencing the same problem! Kudos to ckarone for a great module!
  7. Yes there is but Im referring to is a cross-selling plugin for the confirmation page, after the cart page.
  8. Hi everyone, The module works great and all but I notice that there is a bug that displays all products even the ones that are marked as disabled (not active) on the admin side. I went into the module core .php file and add a reference ($produc.active) to try and dedicated whether a product is active or not but it doesn't work. The problem with this is that a customer could click on a product from the categories that is actually marked as disabled and then a page will load saying that the product is no longer available, which doesnt make for a good impression. Im an running the latest version 1.6.0.6. Id appreciate it if anyone have a solution for this. Thank you
  9. This is module is a great convenience to merchant and customers alike. I just signed up for the service and look forward to using it at the launch of my online store!
  10. Hi pneeds, Im not sure if this will work but try resetting the "quick search block." Some others experienced the same problem and that fixed it. reference: http://www.prestashop.com/forums/topic/161890-sort-by-is-not-working/
  11. Hi waynemiller, I was experiencing the same issue as a cause of csv database imports. The problem seems to be that by performing db imports youre actually skipping some of the automated processes that prestashop would perform had you created the entries through the admin. For example, creating a product. If you did it through the admin section, upon saving it, the system automates a whole bunch of processes throughout the database to update that product. But if you create the product directly to the database then those automated process dont get initiated and somethings won't work how they should. To fix it you need to rebuild the site index used for searching for products. This will process all of your products and update them accordingly for the search function. How to fix: Back Office > Preferences > Click "Re-build entire index" You should do this often, especially when you update a lot of items. Also keep in mind that if you have a lot of product (like 1000s) then your server may timeout, so make sure you have enough max_execution time (in php.ini file of server). If you only have a small inventory then no need to worry. This is what worked for me. Hope this helps.
  12. hi inijman, the problem that you're having could be a database issue. What I realized after updating my shop from scratch (fresh install + db imports) is that v.1.5.2 uses a shop feature to determine what is enabled/disabled for your current shop (in the case that you have multiple shops). I suppose that somewhere along the way you import the products multiple times. The table in the database that handles the product listing is the category_product table. In this table you can possibly list the same item multiple times. Meaning you could have is listed once in your inventory but list it as many times as you want within different categories...This could be the problem, but it's hard to say. I would suggest doing a fresh db import using the CSV Import tool (Back Office: Advanced Parameters > CSV Import). From there you can list your product in their default categories. It only allows one category per product. If you need to list them in multiple categories and it's too tedious to do you will need to do a direct db import into the category_product table of the phpMyadmin. This is just a solution, but Im not sure what your probably actually is.
  13. You should try to regenerate all of the "indexes and caches" of the settings in the layered navigation module. When I have problem with the module this is what I do: - Create a new layered template to overwrite the existing one (all the time) - Make sure the "Configuration" settings are correct - Then I regenerate the "indexes and caches" at the top * - If those don't work, I uninstall then reinstall the module. Its a lot to go through, but it helps sometimes
  14. sorry admin_webs, the layered navigation overwrites the default pagination in the categories, so as long it's enabled it will change the pagination based on the amount of results it generates for each filter combination. This might also be a bug in the module itself (i wouldnt be surprised). In that case you should issue a bug report to get further assistance. http://forge.prestashop.com/
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More