Jump to content

jeancgarciaq

Members
  • Posts

    25
  • Joined

  • Last visited

Everything posted by jeancgarciaq

  1. Mi tienda dejó de funcionar repentinamente, estaba creando un producto le di vista previa, para chequear como iba quedando, hice una compra ya que incluía una personalización, y cuando fui a elegir el método de pago, me arrojó tremendo error, ahora no carga absolutamente nada, sólo aparece una página con esta información: [PrestaShopDatabaseException] Unknown column 'w.default' in 'field list' SELECT w.`id_wishlist`, w.`name`, w.`token`, w.`date_add`, w.`date_upd`, w.`counter`, w.`default` FROM `ps_wishlist` w WHERE `id_customer` = 1 AND id_shop = 1 ORDER BY w.`name` ASC at line 635 in file classes/db/Db.php 629. WebserviceRequest::getInstance()->setError(500, '[SQL Error] '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97);630. }631. else if (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS'))632. {633. if ($sql)634. throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>');635. throw new PrestaShopDatabaseException($this->getMsgError());636. }637. }638. 639. /** DbCore->displayError - [line 325 - classes/db/Db.php] - [1 Arguments] DbCore->query - [line 501 - classes/db/Db.php] - [1 Arguments] DbCore->executeS - [line 203 - modules/blockwishlist/WishList.php] - [1 Arguments] WishList::getByIdCustomer - [line 154 - modules/blockwishlist/blockwishlist.php] - [1 Arguments] BlockWishList->hookTop - [line 509 - classes/Hook.php] - [1 Arguments] HookCore::exec - [line 448 - classes/controller/FrontController.php] - [1 Arguments] FrontControllerCore->initContent - [line 37 - controllers/front/IndexController.php] IndexControllerCore->initContent - [line 180 - classes/controller/Controller.php] ControllerCore->run - [line 373 - classes/Dispatcher.php] DispatcherCore->dispatch - [line 28 - index.php] La tienda está operativa, pero la falla se presenta cuando se autentica un cliente o trata de comprar, es prestashop 1.6.0.9 Gracias a Dios, tengo un poco adelantada mi otra tienda, pero todavía no está lista para salir al aire, definitivamente voy a tener que acelerar el proceso. Leí por ahí un foro que una persona realizó una actualización de Prestashop 1.4 a 1.5 y le arrojó algo parecido, el tema que está en inglés no coincide tampoco ya que se refiere a prestashop 1.5. Del resto no he conseguido nada igual. Si alguien tiene alguna idea, se lo agradecería.
  2. Esa actualización nunca me apareció en los Módulos, hasta ahora no me aparece ningún módulo para actualizar, verifique y sigo teniendo la versión v0.4.3. Estaré al corriente por si acaso, pero ya tengo casi lista mi nueva tienda. Gracias de todas formas.
  3. Revisa que no tengas ninguna regla de compra activada, o hayas creado algún precio específico para ese item o cualquier otro.
  4. Si correcto, ya estaba funcionando e indexada por google. No quiero perder lo que he logrado hasta ahora. Con respecto al enlace, si hoy me pasó un mensaje el hosting que están moviendo mi sitio a otro servidor más moderno, así que existen varias cosas que no están funcionando en mi sitio. Entre ellos el blog dejó de funcionar.
  5. Excelente fernando, muchas gracias. Todo esto es lo que necesito, muchos ya los he leído, el problema está que se refieren a las versiones anteriores y cuando tratas de aplicarlo no te funcionan. Igual los módulos gratuitos y todo eso. Pero de verdad, voy a revisar cada uno de los enlaces. Gracias.
  6. Hola, a todos, ¿cómo estás? De antemano gracias por tomarte el tiempo de leer estas líneas, espero que sea de ayuda para ti y está demás decir, cualquier aporte, idea o algo similar que quieras agregar al mismo en bien de toda la comunidad del foro son bienvenidos en los comentarios. Escribo estas líneas para anunciar que estoy realizando un tutorial (o mejor dicho contando mi experiencia) de cómo mover mi tienda que se encuentra en un subdirectorio al directorio raíz, tratando de no perder mi SEO en Google. Así que cree en mi blog un tutorial de lo que estoy haciendo, mi meta es realizarlo en un lapso de tres (3) días comenzando desde hoy, y voy poner a tono mi tienda nuevamente pero en el directorio raíz. Así que de todo lo que voy hacer lo voy a compartir porque creo que le puede servir a personas que como yo se iniciaron en este mundo de prestashop sin saber absolutamente nada del ecommerce. Mis conocimientos sobre el lenguaje html5, javascript y php no son avanzados pero soy bueno para seguir instrucciones así que voy a dar crédito a todo aquel que contribuya en esto. El tutorial completo lo voy a colgar por parte en mi blog, y espero que sea de gran ayuda. En el primer post doy la introducción de lo que pienso hacer: Herramientas necesarias para mover la tienda de un subdirectorio a una raíz sin perder el SEO. Respaldo de la información. Instalando la nueva tienda. Editando el archivo .htaccess. Y aprovecharé para explicar, cómo mejorar el SEO de Prestashop editando la plantilla del tema original. Cómo configurar los Rich Snipets, recordando que esto se basa en la información de schema.org y la importancia que ahora le da google a éste aspecto para el posicionamiento. Cómo configurar un chat en tu tienda online. Cómo colocar un widget de twitter y otras herramientas adicionales gratuitas para mejorar el aspecto social de nuestra tienda. Cómo colocar un capchat a nuestra tienda en todos los formularios para evitar que se nos llene de spam. Y cualquiera otra cosa que se me ocurra en el camino que al momento de escribir estas líneas se me pasan. IMPORTANTE: Por falla en el servidor se borró el segundo tema. Pero ya está disponible en Herramientas necesarias. AVISO: En la medida que escriba lo que voy haciendo lo colocaré como un link de cada punto. Espero que esta contribución ayude a muchos que se inician en prestashop.
  7. He estado buscando la solución a configurar el canal rss de prestashop pero no lo logro. Configuro la URL al modules/feeder/rss.php Pero cuando hago la prueba para suscribirme al canal, al hacer clic en el icono de Canal RSS en vez de lanzarme una opción de suscripción me manda un error 404 de mi sitio: "En construcción, pronto estará disponible". No se supone que este módulo ya viene configurado. Y la otra opción es cuando trato de colocar un bloque de canal rss, con esa dirección dice que no puede enlazarlo. Lo cual me parece que el archivo .php no está bien configurado. ¿Alguien ya lo ha configurado? Porque todo lo que he conseguido son de versiones anteriores y no aplican.
  8. Tienes que dar más detalle, lo estás instalando a nivel local o a nivel servidor. Ya verifcastes todos los requisitos y el servidor está configurado para la instalación. Yo te aconsejaría, descargar nuevamente el paquete de instalación, de repente en la descarga se perdió algún bite y eso produce errores.
  9. Prueba hacero Manual a ver si te lo cambia, haces clic en código </> está al lado de B en la barra de herramientas: Por ejemplo: <a href="dirección url">Texto a Mostrar</a> <a href="http://www.comercito.com">Comercito</a> Y si te funciona, hazlo manual temporalmente, mientras se consigue el bug y se corrige.
  10. Lo único que te puedo decir que un error 500 es un error en el servidor, el cual no puede resolver tú directamente, pero se me ocurre que tiene que ver con el tiempo de ejecución. Trata aumentando el tiempo de ejecución que lo tienes en 300 y haz la prueba con 3000. A ver ¿qué sucede?
  11. Ya coloque un post sobre un error que tengo en el panel de inicio, pero además tengo un problema con las imágenes de los productos. El hecho es que tanto en la vista rápida como la en vista detalles del producto, cuando seleccionó alguna producto la talla y el color, me recarga la página. Ya regeneré la miniaturas y vacié el caché. Nada de eso ha resuelto mi problema. Espero poder recuperarme de esta. La verdad que Prestashop ha sido constante errores, tras cada actualización de cualquier módulo siempre se generan errores. No tengo ni la más mínima idea de dónde buscar lo que está causando este error.
  12. Hola, desde hoy me apareció un error poco peculiar, y creo que tiene que ver con una actualización del dashboard estadística que hice hoy. Copio y pego: Notice on line 116 en archivo /home/comercit/public_html/prestashop/tools/smarty/sysplugins/smarty_internal_templatebase.php(171) : eval()'d code [8] Undefined index: PS_STOCK_MANAGEMENT Notice on line 116 en archivo /home/comercit/public_html/prestashop/tools/smarty/sysplugins/smarty_internal_templatebase.php(171) : eval()'d code [8] Trying to get property of non-object Notice on line 116 en archivo /home/comercit/public_html/prestashop/cache/smarty/compile/27/92/55/2792550cc61cc2be9585e0875dc56fb49416caf2.file.dashboard_zone_one.tpl.php [8] Undefined index: PS_STOCK_MANAGEMENT Notice on line 116 en archivo /home/comercit/public_html/prestashop/cache/smarty/compile/27/92/55/2792550cc61cc2be9585e0875dc56fb49416caf2.file.dashboard_zone_one.tpl.php [8] Trying to get property of non-object Y la verdad que le eché un vistazo y no veo nada raro. Espero solventar pronto. Creo que este error de estos archivos me están creando un problema con los productos, al hacer clic sobre el color de los productos recarga la página.
  13. Si cardo, ya lo hice, pero continúa arrojando el error. Seguiré con carga manual temporalmente hasta que descubra cómo hacerlo correctamente. Gracias por su respuesta.
  14. Hola, vengo de nuevo a ver si logró solucionar este enrrollo. Mi prestashop versión 1.6.0.9. Estoy tratando de importar un fichero csv que tengo, solamente estoy haciendo la prueba con dos (2) productos lleno todos los datos, ver archivo en el link (no estoy autorizado para subir este tipo archivo, jejeje). Y cuando le doy subir, siempre me arroja los mismos errores, honestamente no entiendo ¿qué es lo que se está haciendo mal? No sé si es que mis nombres son muy largos en la opción 1 y 3, cuando creo producto por producto no tengo ningún problema con estos nombres. Y los errores 2 y 4 no los entiendo. Si alguien me puede ayudar, se lo agradezco. 4 errores: Plataformas de Damas Thalia C303 (ID: 33) no se puede guardar Property Product->date_add is not validProperty Product->available_now is not valid Sandalias de Damas Thalia G14_15 (ID: 34) no se puede guardar Property Product->date_add is not validProperty Product->meta_description is not valid
  15. Hola, Moraira, jejeje, tienes razón. No formule bien la pregunta. En realidad dije lo de los módulos así porque fueron como ocho (8) y simplemente le di click a actualizar todos, no recuerdo cuáles. La versión de prestashop es 1.6.0.9, y solucioné de la siguiente manera. Edite el archivo que se encuentra en el tema por defecto, modulos, bloque de contacto de formularios, agregue la url y modifique mi url reescrita en la opción preferencia seo+urls, la tenía como "contactenos" (que es la forma como me gustaría que apareciera la url) y entonces lo puse como "contact" que es lo original en inglés y listo, ya enlazó. Muchas gracias por tu ayuda.
  16. Hola, cómo están? A ver si alguien me puede ayudar. Tengo el error 404 en mi tienda, tras una actualización de algunos módulos, me imagino que se hizo mal y en consecuencia, ahora cuando le doy a formulario de contacto desde cualquier de los link me lanza error 404, página no encontrada. Ya probé una solución que apareció en el forum pero no funcionó. ¿Qué podría estar pasando? Espero solventarlo pronto, no me gustaría ese gran detalla para la tienda. El contacto con el cliente es lo más importante en una tienda online. Cualquier sugerencia se lo agradezco.
  17. Tengo el siguiente error: Seleccionó una imagen de mi computador y la cargo a mi producto. Indica que cargó correctamente la imágen pero resulta que la la imagen en miniatura no es la correcta. Para dar un ejemplo: la imagen 287.jpg de mi producto ubicada en la ruta /prestashop/img/p/2/8/7 es la imagen que cargue. http://www.comercito.com/prestashop/img/p/2/8/7/287.jpg Perfecto, pero prestashop genera automáticamente los diferentes tamaños en los que se va a mostrar la imagen y fíjense que interesante lo que está en directorio: http://www.comercito.com/prestashop/img/p/2/8/7/287-watermark.jpg http://www.comercito.com/prestashop/img/p/2/8/7/287-thickbox_default.jpg Y así sucesivamente todas, debería ser la imagen 287.jpg , pero no lo es, es otra imagen. Así que voy a probar borrando todo del directorio a ver que sucede. Por que ya vacíe la caché y nada. Sigue arrojando el mismo error. Si alguien le ha pasado algo parecido, me gustaría me echaran una ayuda, porque no me deja cargar las imágenes de mis productos. SOLUCIÓN: Aparentemente, no está aceptando formatos png, así que cambie para formato jpg y agarró las miniaturas perfectas. Tendré que revisar por qué paso esto.
  18. Listo, ya lo resolví. Esto fue lo que hice: Me fui al repositorio: https://github.com/P...sController.php Copie y el código, lo pegué en el mío. Listo, gualá. Ya funciona a la perfección. P.D. Utilice el Editor de código online de CPanel, pero también se puede descargar el código y en un editor de texto (inclusive bloc de notas sirve), puedes copiar el código y luego subirlo al directorio, guardas el archivo con el mismo nombre, y lo sobre-escribes, también debería funcionar de esa forma.
  19. Listo, ya lo resolví. Esto fue lo que hice: Me fui al repositorio: https://github.com/PrestaShop/PrestaShop/blob/1.6/controllers/front/AddressController.php Copie y el código, lo pegué en el mío. Listo, gualá. Ya funciona a la perfección. P.D. Utilice el Editor de código online de CPanel, pero también puedes descargar el código y en un editor de texto (inclusive bloc de notas sirve), puedes copiar el código y luego subirlo al directorio, lo sobre-escribes, también debería funcionar de esa forma. ¡Espero que te funcione!.
  20. Tengo el mismo error que tú, todavía no he encontrado la solución, pero la estoy buscando, por las características, tu archivo debe estar vacío como el mío: Ya verifique el archivo, resultó algo interesante, está vacío: <?php class AddressController extends AddressControllerCore { En mi caso, esto se produce después de la actualización de la versión 1.6.0.8 a la 1.6.0.9, no sé porqué.
  21. Muchas gracias felipvens por lo de activar el modo debug, con respecto al otro link que me colocaste no funcionó. Sin embargo, ya pude ver el error, el cual lo copio a continuación: Parse error: syntax error, unexpected end of file, expecting function (T_FUNCTION) in /home/comercit/public_html/prestashop/override/controllers/front/AddressController.php on line 6 Ya verifique el archivo, resultó algo interesante, está vacío: <?php class AddressController extends AddressControllerCore {
  22. Hola, a todos. Bueno tengo, el siguiente problema con mi prestashop, ya he hecho varias pruebas, y en todas he tenido que deshacer la actualización. Porque cuando realizó la actualización a la versión 1.6.0.9 con One-Click, me arroja el error que no me deja editar mis páginas de SEO, es decir, accedo al módulo Preferencias > SEO+Urls, pero cuando seleccionó cualquier página, me queda en blanco la pantalla y de ahí no sale. Y esta vez me vi obligado a actualizar, porque cuando le daba clic a mis productos para verlos me arrojaba error fatal, al actualizar se corrigió, pero ahora no sé que hacer con este otro error. No me recuerdo como activar el modo debug para leer exactamente el error. Y en el Registros/Logs no aparece nada grave. Cualquier pista sería de gran ayuda para mi. Saludos y gracias de antemano. Adjunte las capturas de pantalla.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More