Jump to content

mesflacons

Members
  • Posts

    53
  • Joined

  • Last visited

Everything posted by mesflacons

  1. A priori le fr est en français et le en partiellement traduit. Pour tester ce type de modification je vous suggère de passer en navigation privée et via un anonymous (anonymouse.org par exemple) pour voir l'affichage "réel" de votre site sans les problème de cache.
  2. Bonjour, Pour l'essentiel les aides et les messages postés sur le forum concernent des boutiques avec des sous-domaines. Mon problème est autre : J'ai une boutique principale www.mesflacons.com en français et j'ai d'autres DOMAINES dédiés à chaque langue. Pour l'italien par exemple j'ai un domaine www.miniprofumi.com Il est correctement paramétré chez mon hébergeur (j'y ai mis une page "en cours" qui est accessible sans problème) www.miniprofumi.com L'image jointe "serveur" montre tous mes domaines accessibles au même niveau du serveur. Actuellement j'ai paramétré mon multiboutique suivant image jointe "miniprofumi" l'URL finale qui apparait dans le backoffice est correcte mais ça ne fonctionne pas, j'arrive toujours sur ma page "en cours" J'ai testé en mettant l'url physique dans sa totalité /lamp0/web/vhosts/miniprofumi.com mais çà ne fonctionne pas non plus et de plus ça donne une url finale inutilisable. Je précise que j'ai pour cette boutique modifié la langue par défaut en "italien" Que faut-il faire exactement (je suis très débutant) pour qu'un internaute tapant "www.miniprofumi.com" arrive sur cette boutique miniprofumi. Merci de votre aide.
  3. Non, j'ai détruit par ftp tout le répertoire qui contient les images générées par prestashop et recommencé la génération avec mes images modifiées.
  4. Préférences/rechercher/indexation/reconstruire l'index Vous devez le faire à chaque fois que vous modifiez votre base produits. La tâche peut être automatisée par cron.
  5. J'ai installé aujourd'hui mes langues étrangères. pas de souci pour l'anglais et l'italien. En revanche je rencontre un problème analogue au vôtre avec l'allemand. Lors de l'installation pas de souci particulier mais en front office j'ai un message : Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator at [no address given] to inform them of the time this error occurred, and the actions you performed just before this error. More information about this error may be available in the server error log." J'ai ensuite supprimé la langue pour tenter de la réinstaller mais (malgré un message de récupération réussie) elle n'apparait plus sur mon administration.
  6. Je remonte mon topic en espérant à nouveau votre aide. Je viens d'installer mes langues étrangères, Pour le moment de manière classique www.mesflacons.com (N.B. : je suis conscient que je dois faire les traductions manquantes) mais ma problématique reste entière. Qu'en est-il par exemple en terme de référencement : http://www.mesflacons.com/en/nouveaux-produits c'est, par exemple, médiocre pour référencer un lien pointant sur une page anglaise. Dans l'idéal il faudrait je pense http://www.my-english-url/new-products Et faire une redirection de mon domaine anglais (my-english-url) vers le sous-répertoire /en ne changera pas grand-chose ? (S'il existe une stratégie pour le faire proprement je suis preneur). J'ai lu (mais pour une ancienne version de PS) que certains solutionnaient en utilisant le multiboutique et en paramétrant la langue principale de chaque boutique. Comment faites-vous (avez-vous fait) pour votre site ? Merci merci !
  7. Bonjour, Le filigrane s'installe bien sur mes images lorsque je les importe une par une. En revanche il n'apparaît pas lors de l'import via un fichier csv. Y-a-t-il une solution autre qu'un module payant ? Merci
  8. Bonjour, Je développe sous Prestashop une boutique déjà existante. Actuellement (et je ne souhaite pas changer celà) les versions française,anglaise, allemande et italiennes ont chacune leur propre nom de domaine (avec les mêmes produits). J'aimerai avoir vos retours d'expérience, vos avis sur cette problèmatique. Est-il possible de "brancher" les versions étrangères d'une même boutique sur des domaines différents ? Est-il préférable d'utiliser la fonction multiboutique (faire une boutique pour chaque langue). Quel est le plus simple à mettre en oeuvre (aide bienvenue :-) )et quel est le plus simple en terme de gestion au quotidien ensuite (s'il y a des différences) ? Merci !!!
  9. Sauf erreur il s'agit d'un vieux problème de Prestashop resté sans solution à ce jour. Prestashop calcule la TVA Produit par produit et arrondi AVANT de multiplier. Prix TTC : 33,504 arrondi à 33,50 multiplié par 10 335,04 dans un cas 335 dans l'autre. Il y a de nombreuses personnes qui cherchent la solution à ce problème.
  10. et ceci ? http://codus.acyclique.com/fr/2013/03/20/resoudre-une-erreur-324-neterr_empty_response/
  11. Si le problème se produit durant l'upload du fichier il suffit de l'envoyer par FTP au lieu d'utiliser la fonctionalité. Ensuite il apparait normalement dans la liste. Le dossier où le mettre via FTP est racine/admin_(ton intitulé secret)/import Si ça plante ensuite tu peux essayer : 1ère tentative : supprimer les produits avant l'import : OUI Tentatives suivantes : supprimer les produits avant l'import : NON
  12. J'ai eu des soucis avec des images en .JPG (au lieu de .jpg) or prestashop sous unix est "case sensitive". Avez-vous vérifié cela ?
  13. J'ai regardé çà (je suis aussi en train de développer ma boutique) mais je n'ai aps encore approfondi. Regardez svp le fichier joint Il semble qu'il y ait un problème sur l'affichage du "nom" de la taxe sur la facture J'ai "PRODUIT" pour la TVA à 20% et rien ne s'affiche pour cette TVA à 0% Si vous (ou une âme charitable) trouvez à quel endroit gérer ou modifier l'appelation ... il semble que ça ne soit ni dans taxes ni dans règles de taxes. ici j'ai mis une étoile après le nom du produit d'occasion et un renvoi en bas de page avec la mention légale. Ce n'est pas vraiment satisfaisant mais ce doit être suffisant d'un point de vue légal. (encore une fois il vaut mieux demander une validation à votre expert comptable). Le renvoi en bas de page se gère dans Commandes/factures/options des factures. Tenez-moi au courant :-) FA000005.pdf
  14. Sauf erreur (il est préférable de demander à votre expert comptable) en cas de vente sur des produits d'occasion vous devez en effet faire apparaîre la mention ""TVA article 297 A du CGI »" mais vous ne devez pas faire apparaître la TVA. Source : http://www.assistant-juridique.fr/occasion_tva.jsp : Facturation de la TVA sur la margeEn cas d'application du régime de la marge, vous ne devez pas faire apparaître la TVA sur vos factures. Par conséquent, vos acheteurs ne bénéficient d'aucun droit à déduction de la TVA incluse dans le prix d'acquisition. Néanmoins, vous devez faire figurer sur vos factures la référence à l'article 297 A du CGI, à la directive communautaire 2006/112/CE ou indiquer toute autre mention signifiant que l'opération bénéficie du régime de la marge. Du coup ça ne pose normalement plus de problème avec Prestashop puisqu'il suffit de mettre en taux de TVA 0. Le calcul de votre TVA due (le calcul que vous donnez est exact) ne concerne que vous et le fisc. Il suffit de notifier pour chaque produit la règle de TVA que vous voulez utiliser en fonction de l'état neuf ou d'occasion.
  15. Hum hum ... une question idiote : est-ce que votre image d'origine à la sortie de votre éditeur de photo est dans le bon sens (regardez par exemple vos vignettes sous windows) ?
  16. Voici la réponse de Gandi mon hébergeur, qui confirme que c'est bien la requète qui est trop longue. Oui, le script de la page d'administration depuis laquelle vous g�n�rez l'import d�passe le d�lai d'ex�cution, comme on peut le voir dans l'extrait de logs suivant : [08-Sep-2014 10:49:47] WARNING: [pool www] child 6583 exited on signal 15 (SIGTERM) after 291.548507 seconds from start [08-Sep-2014 11:00:51] WARNING: [pool www] child 6588, script '/srv/data/web/vhosts/www.mesflacons.com/xxxxxxxxxxxxx/index.php' (request: "POST /xxxxxxxndex.php") execution timed out (237.392861 sec), terminating La solution serait, puisque l'import est trop volumineux, soit de le scinder en plusieurs parties, soit de l'effectuer depuis le disque : vous transf�rer votre fichier sur l'instance via SFTP, et ensuite effectuez l'import depuis un dossier local, Le transfert en tant que tel du fichier CSV (première partie de l'importation) ne pose pas de problème et tous mes ficjhiers images sont déjà envoyés par FTP, comment puis-je m'en sortir ? Merci
  17. Oui merci j'ai trouvé, sur ma version de Prestashop il s'appelle "Estimation des livraisons v2.2.0 - by PrestaShop", ça ne règle pas tout mais couplé avec une page d'info accessible via le bas de page ça devrait être suffisant ! Je passe le topic en RESOLU
  18. Bonjour, J'ai une activité assez spécifique qui implique un nombre de produits assez important (800 actuellement mais potentiellement plusieurs milliers) et avec un turn over rapide (souvent produits en un unique exemplaire). Pour ces raisons j'ai choisi de faire ma gestion de produits sous access et d'importer mon catalogue initial (puis ensuite ses modifications) en CSV. Les premiers essais se sont déroulés sans souci mais mes images étaient trop petites. J'ai donc pris des originaux de plus grande taille mais depuis je ne parviens plus à importer mes produits mon serveur s'arrête lors de l'exécution avec un message d'erreur : Error 503 Service UnavailableService Unavailable Varnish cache server Je précise que la récupération du fichier CSV se déroule correctement le problème se pose à l'étape suivante quelques minutes après avoir cliqué le bouton "importer les données CSV. Je me retrouve alors avec seulement quelques images disponibles, la régénération des vignettes ne résoud pas le problème. Par ailleurs, sauf erreur de ma part j'ai bien compris que prestashop générait automatiquement les vignettes cart_default, small_default, medium _default, home_default, large_default et thickbox_default et mettait tout cela dans le répertoire /p avec un grand nombre de sous-répertoires. Mais apparemment (j'aimerais une confirmation) Prestashop ne génère pas ces fichiers directement à partir de mes "vrais" originaux mais à partir d'un autre "original" créé à la volée. Mes originaux sont dans un répertoire images_produit, le fait de modifier un fichier dans ce répertoire puis de régénérer les vignettes ne prend pas en compte la modification, il faut d'abord vider le répertoire /p Que fait précisément le programme d'importation ? Dans un premier temps il récupère le fichier CSV, là pas de souci. Ensuite il traite les informations de ce fichier pour les mettre dans les tables associées aux produits et (en même temps ???) il crée des images à partir de mes originaux envoyés par FTP. Apparemment il tente de créer toutes les tailles de vignettes simultanément et ce pour la totalité du fichier puisque, quand ça se déroule bien, il n'y a pas utilité de générer ensuite les vignettes dans le menu images. C'est bien cela ??? Si le problème est une surcharge du serveur (GANGI Simplehosting instance "Large") est-il possible de traiter uniquement le fichier CSV puis ensuite de générer les images "à la main" via les options de régénération des vignettes ? Je l'ai essayé mais ça ne semble pas fonctionner car il ne trouve pas ce que je supppose être "un autre original" Comment fonctionne exactement l'option "Ne pas régénérer les vignettes" lors de l'import CSV (la formulation négative complique la chose. "Ne pas régénérer les vignettes" NON signifie donc régénérer les vignettes. S'agissant d'une remise à plat c'est l'option que je choisit. Comment faites-vous pour gérer l'import d'une grande quantité d'images ? Merci
  19. @ 2FR3 Oui ce pourrait être une solution mais ça peut être inquiétant pour le client qui, dans la plupart des cas ne paiera que le minimum. J'envisageais : France métropolitaine : 8€90 Etranger et DOMTOM Voir détails Avec renvoi vers une page d'information courte présentant un tableau récapitulatif et indiquant que les frais sont calculés et présentés dès que l'adresse d'expédition est validée. Sur les sites en langue étrangère la proposition par défaut pourrait être CEE, Suisse : 17€90 France et monde entier Voir détails Qu'en pensez-vous ? Ensuite cela implique (je travaille avec le thème de base) de modifier beaucoup de pages du panier et je crains que ça dépasse mes compétences. @ Atch J'ai en effet vu qu'il existait de nombreux modules de frais de port mais je ne suis pas certain qu'il répondent à cette problématique. Je n'ai pas trouvé celui que vous mentionnez. Avez-vous un lien ou son nom exact ? Merci.
  20. C'est exactement ce que je veux dire 2FR3, Mais, en conséquence, est-il préférable de ne rien afficher, d'afficher un montant qui sera valide dans 90% des cas mais inexact (et très négatif d'un point de vue commercial) dans les autres cas ou de trouver une formule qui sera inévitablement floue ou complexe ?
  21. Vider cache/smarty/cache et cache/smarty/compile (sauf fichier index) et Ctr F5 pour le navigateur ça résout pas mal de pb de ce genre.
  22. Bonjour à tous et toutes, J'ai des nouvelles photos de produit pour lesquels j'avais déjà une photo. J'ai écrasé dans le repertoire où j'upload mes originaux les anciennes photos par les nouvelles. Exemple : la nouvelle 1298.jpg remplace l'ancienne 1298.jpg J'ai régénéré toutes les images produit en utilisant la fonction "supprimer les anciennes". Or apparemment cela ne fonctionne pas. Malgré le vidage des caches du naviagteur et du smarty.ce sont toujours mes anciennes photos qui apparraissent sur le front. Comme j'ai, par ailleurs, des problèmes de formats à gérer je voulais savoir tout simplement comment supprimer proprement par ftp mes vignettes produit (sans toucher aux autres images utilisées par prestashop, slider, icone panier ... etc etc) afin de refaire une nouvelle régénération "propre". Y-a-t-il un document (officiel si possible) de Prestashop qui explique comment sont gérer les photos produits dans la version 1.6 ? Concrêtement j'ai par exemple une image qui affiche dans ses propriétés l'url : http://www.mesflacons.com/276-thickbox_default/amore-mio.jpg Or par ftp je ne trouve aucun répertoire "276-Thickbox_defaut" à l'intérieur de mon répertoire nom de domaine. Merci
  23. Visualiser votre commande Puis (en bas) modifier / n° de suivi / mettre à jour. Il faut appuyer sur "modifier" pour faire apparaitre le champ de saisie.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More