Jump to content

Autourdupc

Members
  • Posts

    200
  • Joined

  • Last visited

Everything posted by Autourdupc

  1. Oui... Mais devant le souci permanent, j'ai désactivé la commande rapide sans ouverture de compte car cela ne marchait que trop peu souvent. Depuis, j'ai ce souci latent, et j'ai bien de la chance quand les clients appellent pour me le signaler. A noter qu'actuellement avec mes navigateurs sur mes 2 P,c je n'ai pas l'erreur.
  2. Bonjour, Ce type d'erreur... https://www.prestashop.com/forums/topic/1012683-solved-technical-error-unable-to-save-account-details/ Cordialement,
  3. Bonjour, Sur ma boutique en PS 1.6.1.17, j'ai mis en place ce Catpcha https://shop.devcustom.net/fr/content/9-mise-en-place-captcha?content_only=1 Mais j'ai moi aussi des utilisateurs qui tombent sur une erreur... En fait, les utilisateurs qui sont sous Firefox ne voient pas le Captcha et lorsqu'ils valident ils se voient afficher un message d'erreur. Par contre cela fonctionne sous Edge (les 2 versions) et Chrome. Une idée ? Merci d'avance, Laurent.
  4. Hi all. Same issue here ! I have 3 shops working well (2 x PS1.6.1.17, 1 x PS1.6.1.23), and suddendly all of them get the error "TECHNICAL ERROR: unable to save account Details: Error thrown: [object Object] Text status: parsererror" This appears when customer try to validate its basket using the quick check-out without creating account. It was working perfectly yesterday. Today none of my site are working. In one of them, (PS version 1.6.1.17) I tried to do the FIX: find in .\themes\your_used_theme\js\order-opc.js rows 185-187 But in rows mentionned, I do not have thoses values... I find them in rows 171 (function updateCarrierSelectionAndGift) or 215 (function confirmFreeOrder). Existing values are already set correctly... type: 'POST', url: orderOpcUrl, async: true, cache: false, dataType : "json", Any help would be appreciated !!!
  5. Bonjour, Sous Prestashop 1.6.1.17 en PHP7, il semble que la connexion à la base pose problème... J'ai ce type d'erreur quand j'entre dans le module via le BO : [PrestaShop] Fatal error in module file :/home/MONSITE/public_html/modules/exportleguide/class/mysql.php: Uncaught Error: Call to undefined function mysql_connect() in /home/MONSITE/public_html/modules/exportleguide/class/mysql.php:35 Stack trace: #0 /home/MONSITE/public_html/modules/exportleguide/guide-script.php(32): My_sql->__construct('localhost', 'MONSITE_pres.....', 'MONSITE_pres.....', 'S]PSU2l7-7') Une idée ?
  6. Bonjour, Je tente désespérément d'afficher ce module au-dessus du bloc nouveaux produits, mais rien n'y fait. Le live Edit m'indique qu'il ne peut pas être placé ailleurs... Un idée ? Laurent.
  7. Merci du retour... Je viens de tester et bien non, cela me génère "Disallow: /*cart" dans mon robot.txt C'est dingue... J'ai un autre site mais créé en 1;6.0.9 puis migré successivement et je n'ai pas ce problème. Le site qui me génère ce mauvais robot.txt a été installé en 1.6.1.x (je ne me souviens plus) puis migré successivement. Savez-vous où le peux modifier le code source ?
  8. Bonjour. Je viens ici car je suis aussi concerné... Ma présence ne sera pas d'une grande aide, mais je serai informé des suites. Cordialement, Laurent.
  9. Petit up pour ce thread... J'ai toujours mon ennui avec le blocage des ressources par le fichier robot.txt... Disallow: /*cart
  10. J'ouvre de nouveau ce topic car j'ai de nouveau ma page /2-home qui revient en erreur 404 sur Google. J'ai 2 boutiques, l'une en Prestashop V1.6.1.17, l'autre en V1.6.1.18 avec le même problème. En définitive, le gsitemap 3.2.1 ne résout pas forcément le problème... J'ai donc cherché un peu dans la génération du sitemap et il s'avère que la requête de génération des liens de catégories ne tient pas compte de la "root_category". Il faut donc modifier la requête SQL de manière très simple afin de ne pas générer l'd de catégorie pour le catégorie root. Aller dans le chemin /home/NOMDUSITE/public_html/modules/gsitemap Ouvrir le fichier gsitemap.php A la ligne 431 nous trouvons la requête générant les catégories... $categories_id = Db::getInstance()->ExecuteS( 'SELECT c.id_category FROM `'._DB_PREFIX_.'category` c INNER JOIN `'._DB_PREFIX_.'category_shop` cs ON c.`id_category` = cs.`id_category` WHERE c.`id_category` >= '.intval($id_category).' AND c.`active` = 1 AND c.`id_category` != 1 AND c.id_parent > 0 AND c.`id_category` > 0 AND cs.`id_shop` = '.(int)$this->context->shop->id.' ORDER BY c.`id_category` ASC' Il faut juste rajouter "AND c.`is_root_category` = 0" (sans les guillemets) dans la claude WHERE ce qui permet de ne sélectionner que les catégories qui ne sont pas "root" La requête devient alors : $categories_id = Db::getInstance()->ExecuteS( 'SELECT c.id_category FROM `'._DB_PREFIX_.'category` c INNER JOIN `'._DB_PREFIX_.'category_shop` cs ON c.`id_category` = cs.`id_category` WHERE c.`id_category` >= '.intval($id_category).' AND c.`active` = 1 AND c.`is_root_category` = 0 AND c.`id_category` != 1 AND c.id_parent > 0 AND c.`id_category` > 0 AND cs.`id_shop` = '.(int)$this->context->shop->id.' ORDER BY c.`id_category` ASC' Et voilà... Il suffit de sauver le fichier ainsi modifié pour que la correction soit prise en compte. Il faut maintenant aller dans le BO, module Sitemap, et cliquer en bas de la page de paramétrages sur le bouton "Créer votre sitemap". Pour être sûr du résultat, il suffit d'ouvrir le fichier sitemap à la racine du site (en général 1_fr_0_sitemap.xml) et faire une recherche de "2-home". --> Il ne devrait plus y avoir d’occurrence. Bonne journée à toutes et tous.
  11. Bonjour, Je suis vivement intéressé par cette méthode car moi aussi j'ai des paniers énormes ! Cordialement, Laurent.
  12. Bonjour, J'ai trouvé ça en étiquettes A4, 2x A5 passe-partout https://www.amazon.fr/dp/B01N7Y8JM9/ref=asc_df_B01N7Y8JM949202464/?tag=googshopfr-21&creative=22698&creativeASIN=B01N7Y8JM9&linkCode=df0&hvdev=c&hvnetw=g&hvqmt= Et c'est moins cher que la même référence sur le site du vendeur 41 € avec port pour 500 étiquettes soit 0.082 cents l'unité. Qu'en penses-vous ?
  13. Rynraf. Try to change browser... Google seem to be not the good choice for Prestahsop. I now use Mozilla and get no cache issue. Presta is aware of this issue with Google but did not do anything. Let me know.
  14. Bonjour, Merci pour cette information. Malgré tout, cela me laisse un goût d'inachevé. Soit on fait tout, soit on ne fait rien. D'autant plus qu'il suffit de cliquer sur une déclinaison et de cliquer de nouveau sur la déclinaison par défaut pour obtenir les bonnes images... La bonne requête du premier coup aurait été tout de même appréciée !
  15. Bonjour, Je viens de créer une nouvelle boutique PS en V1.6.1.11. Dans le principe, je créé un produit avec des déclinaisons. Mon produit contient 5 images dont 2 sont communes à toutes les déclinaisons, et chaque déclinaison contient en plus sa propre image. Decl1 --> Image 1 + Imgprod 1 + Imgprod 2 Decl2 --> Image 2 + Imgprod1 + Imgprod2 Decl3 --> Image 3 + Imgprod1 + Imgprod2 Quand je clique sur mon produit à partir de la page d'accueil de mon site, toutes les images sont affichées. Ensuite, si je "joue" avec les déclinaisons, alors les bonnes images s'affichent correctement en fonction de mon choix. Dans le réel, j'ai plus d'images et j'ai 2 groupes de 3 déclinaisons ce qui me fait 6 choix possibles. Le bug : Quand je clique sur le produit à partir de la page d'accueil du site, je ne devrais pas avoir toutes les images qui s'affichent. Il semblerait que le filtre ne fonctionne pas sur les images. A vous lire, Laurent.
  16. Oups ! Ne fonctionne plus avec mon prestahsop en 1.6.1.7 de production, alors que cela fonctionne sur mon PS de test ! Erratum : les cookies récalcitrants... Voilà le problème ! Fonctionne très bien !!! Merci.
  17. Merci ! La version précédente fonctionnait très bien en 1.6.1.7 et 1.6.1.9, mais je vais tout de même mettre à jour avec celle-ci ! Top ce module gratuit !!!
  18. Voici la réponse... Etant donné que j'utilise un thème Prestacrea, il faut vider le cache du thème et tout re-fonctionne.
  19. Hi ! I found the problem. Because I'm using a theme, I have to clear the cache of the theme. After clearing the cache, all comes fine !
  20. Hi all, In my shop, products in the same category are not all visible... It depends on the selected product (for the same category). Here are some explanations In a category, I've created in this order products named P1, P2, P3, P4 and P5. In front office : Clicking on P1, there is no other product in the same category. Clicking on P2, I can only see P1 in the same category. Clicking on P3, I can only see P1 and P2 in the same category. Clicking on P4, I can only see P1, P2 and P3 in the same category. Clicking on P5, I can only see P1, P2, P3 and P4 in the same category. In fact, I can only see products previously entered from the BO. Any help would be appreciated.
  21. Bonjour, Sur ma boutique, les produits dans la même catégorie ne sont pas tous présents... C'est fonction du produit à l'écran (pour une même catégorie). Je m'explique. Dans 1 catégorie, j'ai créé dans cet ordre les produits P1, P2, P3, P4 et P5. Dans la boutique : Si je clique sur P1, je ne vois aucun autre produit dans la même catégorie. Si je clique sur P2, je ne vois que P1 dans la même catégorie. Si je clique sur P3, je ne vois que P1 et P2 dans la même catégorie. Si je clique sur P4, je ne vois que P1, P2 et P3 dans la même catégorie. Si je clique sur P5, je ne vois que P1, P2, P3 et P4 dans la même catégorie. En définitive, dans la même catégorie, je ne vois que les produits entrés précédemment. Une idée ?
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More