Jump to content

Web-Wave

Members
  • Posts

    58
  • Joined

  • Last visited

Posts posted by Web-Wave

  1. Good evening everyone,

     

    I allow myself to contact you because I am stuck on a installation of a new shop with an SSL certificate under Nginx. After various searches for Nginx, I can not set up the SSL certificate, here is my situation:

     

    - I have a Nginx server and PHP 7.1 who works normally for other websites.
    - A version of Prestashop 1.7 is in place and runs correctly in classic version http.
    - I installed on the server cerbot / letsencrypt.
    - The certificate generated for the domain name is recognized if I do https://www.mondomain.com/test.php : it works.
    - Certificat generated by letsencrypt works well on others websites.

     

    If I go to the page https://www.mondomain.com to see the homepage of prestashop 1.7, I get errors in the console because the css and images as well as the js are not sent Via https but via http.

     

    I searched inside the database, I have no link in http to edit in https.

    The theme used is the default one and I do not have any cache system enabled.

     

    So I want to activate the https for the shop inside the backend.
    In the administration interface, under Shop Settings -> General, the button called:

    "Please click here to verify that your shop supports HTTPS." does not seem to work.

    If I click on it I am redirected to the same page in the format https. And that's all.

     

    Capture_d_e_cran_2017_07_31_a_23_22_43.p

     

    The Enable SSL button is still in grey color, I can't click on it.
    I try to do this with a fresh installation and it's the same.
    I guess it's my nginx vhost configuration file.

    But someone have an idea or a vhost sample please ?

    Thank you [;)]

  2. Bonjour,

     

    Je reviens vers vous pour savoir si quelqu'un aurait une idée ?

    Je viens de supprimer tout le contenu à la racine du ftp en supprimant également la base de données.
    En ayant une toute nouvelle installation en passant par l'url https, cela me fait également la même chose.

    Faut il installer dans un premier temps la boutique en http pour ensuite la passer en https ?

     

    Je vous remercie.

  3. Bonsoir tout le monde,

     

    Je me permets de vous contacter car je bloque sur l'installation d'une nouvelle boutique avec un certificat SSL sous Nginx. Après différentes recherche pour Nginx, je n'arrive pas à mettre en place le certificat SSL, voici ma situation :

     

    - J'ai un serveur Nginx et PHP 7.1 qui fonctionne normalement bien.

    - Une version de Prestashop 1.7 est en place et tourne correctement en version classique http.

    - J'ai installé sur le serveur cerbot / letsencrypt.
    - Le certificat généré pour le nom de domaine est reconnu si je fais https://www.mondomain.com/test.php.

    - J'obtiens un joli cadenas vert avec aucune erreur.

     

    Maintenant je souhaite activer le https pour la boutique depuis l'interface. Car si je me rends sur la page https://www.mondomain.com pour voir la page d'accueil du prestashop 1.7, j'obtiens des erreurs dans la console car le css et les images ainsi que le js ne sont pas envoyé via https mais via http.

    J'ai fouillé dans la base de données, je n'ai aucun lien en http à éditer en https. Le thème utilisé est celui par défaut et je n'ai pas de système de cache activé.
     

    Dans l'interface de l'administration, sous Paramètres de la boutique -> général, le bouton appelé : "Veuillez cliquer ici pour vérifier que votre boutique supporte le protocole HTTPS." ne semble pas fonctionner.
    Si je clique dessus je suis redirigé vers la même page au format https. Et c'est tout.

     

    Capture_d_e_cran_2017_07_31_a_23_22_43.p

    Le bouton Activer le SSL sur tout le site reste grisé et impossible de l'activer.
    Avez vous une idée ?

    Je vous remercie ;)

     

  4. Il y a peut être une chose simple à faire avant de tout tester sous le module, désactivez votre thème et reprenez le thème de base. Simulez une commande pour voir ce qu'il se passe.

     

    Si le problème survient, cela peut provenir du module ou autre chose mais pas du thème.
    Si cela fonctionne avec le thème de base, c'est qu'il faudra revoir les modifications faites en tpl en surcharges également ;)

    • Like 1
  5. Ok et le linking, vous le faites comment ? 

     

    - On a renseigné une fiche dans des annuaires conseillés

    - On a fait des demandes de partenariats qui publient sur leurs sites des liens vers la boutique dans un article

    - On a un blog en place à jour

    - Une page facebook qui publie les articles et qui proposent des réductions

     

    Le SEO a été retravaillé en prenant en compte les commentaires au dessus.

     

    Avez vous d'autres pistes ?

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More