Jump to content

KriptonitaDesing

Members
  • Posts

    31
  • Joined

  • Last visited

Everything posted by KriptonitaDesing

  1. Habla con el desarrollador, y coméntale. De igual manera te viene siempre que especifiques cuando es un dominio test.
  2. Vale , tras investigar un rato he conseguido hacer que funcione en mi versión: Prestashop 1.7.6.5 Os dejo la solución por aquí por si alguno la necesita. En el archivo /classes/order/OrderInvoice.php y agregue el siguiente código en la línea 179 if( end($products) === $row ) { $row['first_order_message'] = nl2br($order->getFirstMessage()); } En el archivo pdf/invoice.product-tab.tpl agregue esto al final. <!-- Customer Order Message --> <br/> {if isset($order_detail.first_order_message) && $order_detail.first_order_message} <table class="product" width="100%" cellpadding="4" cellspacing="0" style="margin-top: 10px"> <thead> <tr class="product" style="width: 100%"> <th class="product header small" width="100%">{l s='Observaciones del cliente' d='Shop.Pdf' pdf='true'}</th> </tr> </thead> <tbody> <tr class="product left {$bgcolor_class}" style="width: 100%"> {foreach $order_details as $order_detail} <td class="product left"> {$order_detail.first_order_message} </td> {/foreach} </tr> </tbody> </table> {/if} <!-- Customer Order Message --> A mi me funciona perfectamente. SOLUCIONADO.
  3. Hola buenas tardes, Tengo un problema a ver si me pueden ayudar. Tengo prestashop 1.7.6.5 - Me gustaría que cuándo genere la factura me apareciera las observaciones del pedido, es decir el mensaje del cliente que pone al realizarlo.
  4. Ha sido una locura pero dejo la solución por si a alguien le pasara alguna vez: Resulta que faltaba este rol ROLE_MOD_TAB_ADMINMODULESPOSITIONS_CREATE no existía en la base de datos.
  5. Hola buenas, justamente estoy ahora con el mismo problema y te cuento: En mi caso tengo el servidor en dinahosting y los dominios en loading, hablando con ellos ambos me dicen que tengo que contratar un certs (certificado ssl) donde tengo el servidor, habla con el servidor con tu hosting porque al parecer para multitienda necesitas contratarlo. Lo normal es que para el dominio principal te regalen el LET´S ENCRYPT pero para el segundo dominio multitienda lo necesitas.
  6. Buena a todos, Necesito ayuda con un error que me trae de cabeza, se trata de cuando me dispongo a insertar un modulo en un hook desde Diseño>Posiciones y lo selecciono todo al guardarlo me da el error: "No tienes permiso para editar esto." He puesto permisos 775 a la carpeta, mi usuario es superadmin, lo borre, lo cree nuevo, he probado otro navegador, he hablado con el servidor y allí esta todo bien, se me agotan las opciones y no se como solucionarlo. Alguna Idea?
  7. Vale ya lo arregle, por si alguien quiere agregar una columna de transportista en la zona de pedidos del backoffice: 1º. Buscamos el archivo: /controllers/admin/AdminOrdersController.php Añadimos los campos que están en negrita. $this->_select = ' a.id_currency, a.id_order AS id_pdf, CONCAT(LEFT(c.`firstname`, 1), \'. \', c.`lastname`) AS `customer`, osl.`name` AS `osname`, os.`color`, ca.`name` AS `carrier_name`, IF((SELECT so.id_order FROM `' . _DB_PREFIX_ . 'orders` so WHERE so.id_customer = a.id_customer AND so.id_order < a.id_order LIMIT 1) > 0, 0, 1) as new, country_lang.name as cname, IF(a.valid, 1, 0) badge_success'; $this->_join = ' LEFT JOIN `' . _DB_PREFIX_ . 'carrier` ca ON (ca.`id_carrier` = a.`id_carrier`) LEFT JOIN `' . _DB_PREFIX_ . 'customer` c ON (c.`id_customer` = a.`id_customer`) INNER JOIN `' . _DB_PREFIX_ . 'address` address ON address.id_address = a.id_address_delivery INNER JOIN `' . _DB_PREFIX_ . 'country` country ON address.id_country = country.id_country INNER JOIN `' . _DB_PREFIX_ . 'country_lang` country_lang ON (country.`id_country` = country_lang.`id_country` AND country_lang.`id_lang` = ' . (int) $this->context->language->id . ') LEFT JOIN `' . _DB_PREFIX_ . 'order_state` os ON (os.`id_order_state` = a.`current_state`) LEFT JOIN `' . _DB_PREFIX_ . 'order_state_lang` osl ON (os.`id_order_state` = osl.`id_order_state` AND osl.`id_lang` = ' . (int) $this->context->language->id . ')'; $this->_orderBy = 'id_order'; $this->_orderWay = 'DESC'; $this->_use_found_rows = true; mas abajo.... $this->fields_list = array( 'id_order' => array( 'title' => $this->trans('ID', array(), 'Admin.Global'), 'align' => 'text-center', 'class' => 'fixed-width-xs', ), 'reference' => array( 'title' => $this->trans('Reference', array(), 'Admin.Global'), ), 'new' => array( 'title' => $this->trans('New client', array(), 'Admin.Orderscustomers.Feature'), 'align' => 'text-center', 'type' => 'bool', 'tmpTableFilter' => true, 'orderby' => false, ), 'customer' => array( 'title' => $this->trans('Customer', array(), 'Admin.Global'), 'havingFilter' => true, ), 'carrier_name' => array( 'title' => $this->l('Transportista'), 'width' => 220, 'havingFilter' => true, 'orderby' => true, ), );
  8. Buenas tardes, Quería añadir una columna en la parte de pedidos de mi backoffice, para que me mostrara el transportista. Le añadí lo que puse en negrita y me lo realizo bien, me muestra la columna con el transportista del pedido, el problema es que el buscador que aparece arriba no me funciona, cuando quiero filtrar por transportista y escribo algo me sale: Consulta SQL incorrecta Unknown column 'carrier' in 'where clause' $this->_select = ' a.id_currency, a.id_order AS id_pdf, CONCAT(LEFT(c.`firstname`, 1), \'. \', c.`lastname`) AS `customer`, osl.`name` AS `osname`, os.`color`, ca.`name` AS `carrier`, IF((SELECT so.id_order FROM `' . _DB_PREFIX_ . 'orders` so WHERE so.id_customer = a.id_customer AND so.id_order < a.id_order LIMIT 1) > 0, 0, 1) as new, country_lang.name as cname, IF(a.valid, 1, 0) badge_success'; $this->_join = ' LEFT JOIN `' . _DB_PREFIX_ . 'carrier` ca ON (ca.`id_carrier` = a.`id_carrier`) LEFT JOIN `' . _DB_PREFIX_ . 'customer` c ON (c.`id_customer` = a.`id_customer`) INNER JOIN `' . _DB_PREFIX_ . 'address` address ON address.id_address = a.id_address_delivery INNER JOIN `' . _DB_PREFIX_ . 'country` country ON address.id_country = country.id_country INNER JOIN `' . _DB_PREFIX_ . 'country_lang` country_lang ON (country.`id_country` = country_lang.`id_country` AND country_lang.`id_lang` = ' . (int) $this->context->language->id . ') LEFT JOIN `' . _DB_PREFIX_ . 'order_state` os ON (os.`id_order_state` = a.`current_state`) LEFT JOIN `' . _DB_PREFIX_ . 'order_state_lang` osl ON (os.`id_order_state` = osl.`id_order_state` AND osl.`id_lang` = ' . (int) $this->context->language->id . ')'; $this->_orderBy = 'id_order'; $this->_orderWay = 'DESC'; $this->_use_found_rows = true; mas abajo..... $this->fields_list = array( 'id_order' => array( 'title' => $this->trans('ID', array(), 'Admin.Global'), 'align' => 'text-center', 'class' => 'fixed-width-xs', ), 'reference' => array( 'title' => $this->trans('Reference', array(), 'Admin.Global'), ), 'new' => array( 'title' => $this->trans('New client', array(), 'Admin.Orderscustomers.Feature'), 'align' => 'text-center', 'type' => 'bool', 'tmpTableFilter' => true, 'orderby' => false, ), 'customer' => array( 'title' => $this->trans('Customer', array(), 'Admin.Global'), 'havingFilter' => true, ), 'carrier' => array( 'title' => $this->l('Transporte'), 'width' => 220, 'align' => 'ocultar' ),
  9. Buenas, Tengo un error respecto aun slider de imagenes, tras contactar con el desarrollador del tema me dice que hay un js de un tercero que esta provocando el error. En concreto el error es este: Si pinchas en la lupa para ampliar la imagen del producto y le das al deslizante lateral para cambiar de imagene y no cambia. Si entras en inspecionar, el error que lanza es este: Uncaught TypeError: $(...).live is not a function at HTMLDocument.<anonymous> (1294-fakro-cubiertaplana-tipog:2433) at l (jquery.min.js:4) at Object.fireWith [as resolveWith] (jquery.min.js:4) at Function.ready (jquery.min.js:4) at HTMLDocument.S (jquery.min.js:4) Alguien podría decirme por donde tirar.
  10. Buenas tardes, tengo un pequeño problema a ver si me podéis ayudar. En mi web tengo un menu horizontal con 4 categorías fuertes: HOMBRE | MUJER | CASA | JARDIN estas cuatro categorías a su vez tienen tiene subcategorias, la cuestión es cuando entras entras en hombre, mujer y casa en la parte izquierda aparece un menu con todas las categorias que hay en ella, pero en jardin no, la columna lateral con las categorias se ha perdido.
  11. Buenos días, Tengo un problema que me ha pasado hoy y normalmente me funciona bien. Quiero importar masivamente combinaciones de productos, y normalmente lo hago asi: http://i59.tinypic.com/spc301.jpg Siempre me a funcionado bien, pero hoy me da el siguiente fallo: Me introduce todas las combinaciones bien en los productos menos la combinacion de "Selecione un color" que no me la introduce si lo hago masivamente. Si lo hago por csv uno a uno si, si lo hago todos no. Alguna idea de por que puede ser? gracias.
  12. Buenas, Mi pregunta es si existe alguna manera o un modulo para que cuando compres un producto, automáticamente, se te meta uno adicional, como haces con los regalos, pero cobrandolo. Por ejemplo Compro un mando para la tele, y automáticamente te mete en el carrito un paquete de pilas que he asociado, dando la opción de borrarlo antes de finalizar la compra. La función es la misma que la de regalos, pero cobrando el producto y dando la opción a borrarlo.
  13. Buenas, Veo que la mayoría de los prestashop tienen para dejar un comentario cuando van a hacer una compra, así: http://www.subeimagenes.com/img/1-1093647.html pero el mio no, como pueden ver aqui: http://www.subeimagenes.com/img/2-1093650.html Eso se activa en algún sitio o como debo hacer. Gracias.
  14. Buenas, Tengo un pequeño problema, en mi web, tengo puesto que a partir de 150 euros de compra , los gastos de envío son gratuitos. La cuestión es que por festejo de la web he creado un vale descuento del 5% extra en todos los productos, y se me a dado en algunos clientes la siguiente situación. Un pedido de 151, 64 € por lo tantos portes de envío gratis, pero cuando le meten el código cupón y le hace el 5% el precio pasa a ser de: 144,06 € pero el envío sigue gratis, entonces no se muy bien si en la configuración del código cupón se puede configurar o en la zona de transportista, gracias.
  15. Buenas, Estoy subiendo archivos de forma masiva a mi prestashop, y me gustaría saber si es posible subir los accesorios que quiero ponerle a cada producto para no ponerlo manual. Gracias.
  16. Hola rafaelamargo, pues aquí puedes ver el mensaje de error. Notice: Constant _PS_DEBUG_PROFILING_ already defined in /home/ubricarmotos/www/config/defines.inc.php on line 54 Strict Standards: Declaration of Customer::getByEmail() should be compatible with that of CustomerCore::getByEmail() in /home/ubricarmotos/www/override/classes/Customer.php on line 29 Notice: Undefined index: PAYMENTREQUEST_0_SHIPTOSTATE in /home/ubricarmotos/www/modules/paypal/express_checkout/payment.php on line 102 Fatal error: Uncaught exception 'PrestaShopException' with message 'Can't load Order status' in /home/ubricarmotos/www/classes/PaymentModule.php:174 Stack trace: #0 /home/ubricarmotos/www/modules/paypal/paypal.php(1361): PaymentModuleCore->validateOrder(57, 2, 33.71, 'PayPal', 'Payment accepte...', Array, 2, false, '52e4256b66f1055...', Object(Shop)) #1 /home/ubricarmotos/www/modules/paypal/express_checkout/payment.php(290): PayPal->validateOrder(57, 2, 33.71, 'PayPal', 'Payment accepte...', Array, 2, false, '52e4256b66f1055...', Object(Shop)) #2 /home/ubricarmotos/www/modules/paypal/express_checkout/payment.php(306): validateOrder(Object(Customer), Object(Cart), Object(PaypalExpressCheckout)) #3 {main} thrown in /home/ubricarmotos/www/classes/PaymentModule.php on line 174 La verdad que no tengo mucha idea de qué está pasando ni cómo solucionarlo. Ojalá alguien pueda ayudarme. Muchas gracias, un saludo!!
  17. Hola buenas, tengo un problema bastante gordo con el módulo Paypal (v3.7.2) para Prestashop 1.6.0.9. Básicamente, cuando confirmo el pago con mi usuario-contraseña de Paypal, no me hace el retorno a Prestashop. Se queda la página en blanco y queda cargada la siguiente URL: http://www.ubricarmotos.com/paypal/express_checkout/payment.php?token=EC-1UOIHSDFSFSDF261S&PayerID=612657646 Si desde esta página recargo (F5) o le doy al botón "Atrás" del navegador, se realiza el pago en Paypal pero no me guarda el pedido en la administración de Prestashop. Ahora mismo el módulo está desactivado para que la gente no se quede colgada, y no lleguen pagos sin saber nada del pedido. Muchas gracias, un saludo!!
  18. Efectivamente eso esta asi. En cuanto daros la url puedo darosla, pero el prestashop esta en modo mantenimiento por lo tanto no podréis entrar, y perdonadme, pero no puedo abrirla, tengo una cartera de unos 30 mil clientes y no puedo permitir que entren con los fallos que ahora genera. La versión de prestashop es la 1.6 , alguna idea mas que mirar? Edito --> Le comentamos a compañeros que miren y les damos acceso, a algunos le aparece y a otros no.
  19. Buenas a todos. Necesito arreglar este problema , he leído todos los artículos que hay en el foro, en español y ingles, y el problema persiste. Cuando agrego un producto a la cesta y me voy a la caja para confirmar, me aparece "Su carrito está vacío" una y otra vez. He probado con las 3w , sin las 3w, a borrar cache del pc, a borrar cache del prestashop, todos los rituales que andan por el foro y nada... una vez puntual me funciono y al poco tiempo me dejo de funcionar. Estoy un poco desesperado, hice la migración de la web que tenemos en zencar, y ya las dns y todo apuntan a la web de prestashop, la cual esta en mantenimiento a la espera de arreglar este problema. Tenemos a bastantes clientes esperando y no se que hacer ya para solucionar este problema... Alguien que me eche un cable?? Gracias. Edito --> Para colmo llamo a prestashop para comprar una hora de soporte técnico o que me informen y me llevo 45 min en espera...
  20. Buenas, Tras recorrerme el foro buscando soluciones para arreglar el bloque de marcas no he encontrado solución a mi problema. Cuando seleccionas la marca, no hace absolutamente nada, no muestra los productos de esa marca. He probado varios arreglos que ofrecían en otros hilos sobre cambiar la paginacion y demás, pero nada, nada me a funcionado, alguna idea? Gracias de antemano.
  21. Gracias por contestar, pero no , ya probé y nada, el resultado es el mismo.
  22. Buenas, Tengo un problema, estoy en una pagina cms de prestashop y quiero hacer una una tabla con una celda para colocar un iframe y abrir dentro paginas determinadas según el enlace que haga click. El problema es que cuando clico me abre el enlace en una venta nueva y no en el iframe y no tengo manera humana de hacer que la habrá en el iframe. Esto es un ejemplo de lo que estoy haciendo. <table border="1" width="631"> <tbody> <tr> <td><a href="http://www.google.com" target="celda-de-destino" class="iframe"> enlace 1 </a> <br> <td><a href="http://www.as.com" target="celda-de-destino" class="iframe"> enlace2 </a> <br> </td> <td> <iframe name="celda-de-destino" src="index.html" target="_self" frameborder="1px" height="300" scrolling="yes" width="500">Tu Navegador no esta configurado para soportar estos frames </iframe></td> </tr> </tbody> </table> La cuestión es que si hago una pagina normal y la abro con el explorador funciona bien. Alguna idea?
  23. Buenas, He comprado una plantilla premiun en prestashop adonns y tengo un problema a la hora de dar altura al banner que trae. http://addons.prestashop.com/es/demo/FO7936.html Esa es la plantilla que he comprado, he conseguido reducir la anchura, pero la altura no puedo, inspeccionando elemento me sale que se reduce en el element.style pero no lo encuentro por ningún sitio. He leido varios sitios y dice que esta fuera del css pero no doy por ningún lado, alguien podría decirme?? Muchas gracias.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More