Jump to content

fuegonju

Members
  • Posts

    17
  • Joined

  • Last visited

Profile Information

  • Location
    spain
  • Activity
    Other

Recent Profile Visitors

290 profile views

fuegonju's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. I found it, i have to complete all languages information, i only fill one language. Hope this helps someone.
  2. Hi all, i can create products with web api service but the big problem is that they don't appear when searching . So i went to product edit page , didnt change anything and save. After that i can find results in searchings. I compare both XML files with /api/products/xxx , before save the product and after, and are equals. I know when we upload products we need to specify categories to find products, but this is not the case. I specify two categories and id_main_category too. What is happening? Thanks!
  3. Hi, i've installed a Prestashop shop with 300.000 products and all it's ok until few days. Then i start to loose search results and finally i only can retrieve a few results. This only happens at 'public search', not admin product search. I suppose there is some problem indexing products. All becames ok when i reindex all products but seems something is going wrong if i have todo this every few days. Can anyone explain what is happening? It's normal i have to reindex all products? Thank you in advance!
  4. Hi all, i update from prestashop 1.6.0.4 to the last version, and i don't have problems to add/delete products but now i can't modify products( i didn't change any code ). I can't update products, server returns me error 400 (bad request) xml seems ok ( it's the same schema for adding new products ). Anyone has the same error? there is a solution? Thank you!
  5. Hello, i have a local webserver. I configure domain link at SEO+URL admin section with a public ip. So i can access outside my home but if i want to access inside my lan to prestashop home public page ( not admin ) returns ip public and of course i finish at my router. How can i avoid this? ( i don't want change prestashop ip public link ) Thank you in advance!
  6. Hi all, i'm inserting products at my prestashop website (1.6), actually i have about 83000. But the more products i insert the more slow it's the process. Actually an insert takes about 11 seconds. Analyzing Mysql i found this query that takes 9,3 in the inserting process: DELETE FROM ps_search_index WHERE id_product IN (83734); what can i do to reduce dramatically this? Thank you in advance!
  7. Thank you to all, mono1: testing the import i suspect that at first 50k products give me about 3-4 days but i think that along i uploading products speed reduces dramatically... tuk66: thank you, i will try to remove temporarily indexing El patron: well i have experience with huge volume of products, i came from oscommer but newbie at prestashop but i will try to help and learn at this forum to others. Best regards!
  8. Hi all, i'm starting the process to import a large quantity of products to a new prestashop. The problem is that i have about 190.000 and seems that using csv import i will need more than 3 days to import all data. Any idea to accelerate this? Anyone has experience with this very large imports? Thank you in advance!
  9. Error comes from blockcategories module : [PrestaShopDatabaseException]You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND nright <= AND c.id_category IN ( SELECT id_category FROM `ps_cat' at line 8 SELECT c.id_parent, c.id_category, cl.name, cl.description, cl.link_rewrite FROM `ps_category` c INNER JOIN `ps_category_lang` cl ON (c.`id_category` = cl.`id_category` AND cl.`id_lang` = 1 AND cl.id_shop = 1 ) INNER JOIN `ps_category_shop` cs ON (cs.`id_category` = c.`id_category` AND cs.`id_shop` = 1) WHERE (c.`active` = 1 OR c.`id_category` = 0) AND c.`id_category` != 1 AND `level_depth` <= 4 AND nleft >= AND nright <= AND c.id_category IN ( SELECT id_category FROM `ps_category_group` WHERE `id_group` IN (1) ) ORDER BY `level_depth` ASC, cl.`name` ASC at line 635 in file classes/db/Db.php 629. WebserviceRequest::getInstance()->setError(500, ' '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97); 630. } 631. else if (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS')) 632. { 633. if ($sql) 634. throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>'); 635. throw new PrestaShopDatabaseException($this->getMsgError()); 636. } 637. } 638. 639. /** DbCore->displayError - [line 325 - classes/db/Db.php] - [1 Arguments] DbCore->query - [line 501 - classes/db/Db.php] - [1 Arguments] DbCore->executeS - [line 226 - modules/blockcategories/blockcategories.php] - [1 Arguments]220. AND c.id_category IN ( 221. SELECT id_category 222. FROM `'._DB_PREFIX_.'category_group` 223. WHERE `id_group` IN ('.pSQL(implode(', ', Customer::getGroupsStatic((int)$this->context->customer->id))).') 224. ) 225. ORDER BY `level_depth` ASC, '.(Configuration::get('BLOCK_CATEG_SORT') ? 'cl.`name`' : 'cs.`position`').' '.(Configuration::get('BLOCK_CATEG_SORT_WAY') ? 'DESC' : 'ASC')); 226. foreach ($result as &$row) 227. { 228. $resultParents[$row['id_parent']][] = &$row; 229. $resultIds[$row['id_category']] = &$row; 230. } BlockCategories->hookLeftColumn - [line 509 - classes/Hook.php] - [1 Arguments] HookCore::exec - [line 445 - classes/controller/FrontController.php] - [1 Arguments] FrontControllerCore->initContent - [line 58 - controllers/front/SearchController.php] SearchControllerCore->initContent - [line 180 - classes/controller/Controller.php] ControllerCore->run - [line 373 - classes/Dispatcher.php] DispatcherCore->dispatch - [line 28 - index.php]
  10. yes... i think i updated some days ago a module but i don't remember which was..hope that someone search the same sql query at google at arrives here and tell us how to solucionate this!
  11. no, the only think i did is put new products with rest webservices. I see that the error comes by 'category'. I delete all products but i can't remove stock_availables items... at this moment i don't know to resolve this problem..any ideas?
  12. Hello, i have exactly the same problem. waiting for a solution. thanks
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More