Jump to content

PilOop

Members
  • Posts

    15
  • Joined

  • Last visited

PilOop's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Bonjour, Je me permets de déterrer le topic a coup de pelleteuse! J'ai rencontré le même problème j'avais bien les bons droits (chmod et chown) sur upload et download. Après investigation je me suis aperçus qu'il manquait la colonne "file_size" dans la table ps_attachment . Très étonnant car par défaut la table est bel et bien composé de la colonne "file_size" j'ai retrouvé la même anomalie sur mon deuxième environnement. Si ça peut aider certains ALTER TABLE `ps_attachment` ADD `file_size` bigint(10) unsigned NOT NULL DEFAULT '0';
  2. Salut, L'erreur suivante Error when calling request binary, system exit code: 127, text output: Peux également apparaître si le chemin "Location of ATOS binaries" est incorrect. Pour les gens qui tente d'installer le module sur un environnement Windows (ex: avec wamp) vous avez surement rencontré le problème des anti-slash qui disparaît au moment de la sauvegarde de votre configuration. Voici une première solution : Dans la méthode getContent() du fichier tggatos.php, ligne 1686. On utilise la méthode getValue() de la classe "Tools" public static function getValue($key, $default_value = false) { if (!isset($key) || empty($key) || !is_string($key)) return false; $ret = (isset($_POST[$key]) ? $_POST[$key] : (isset($_GET[$key]) ? $_GET[$key] : $default_value)); if (is_string($ret) === true) $ret = urldecode(preg_replace('/((\%5C0+)|(\%00+))/i', '', urlencode($ret))); return !is_string($ret)? $ret : stripslashes($ret); } La méthode effectue une urldecode suivi d'un preg_replace. Pour palier à cet inconvénient j'ai crée la méthode suivante : public function getPath($key) { if (!isset($key) || empty($key) || !is_string($key)) return false; $ret = (isset($_POST[$key]) ? $_POST[$key] : (isset($_GET[$key]) ? $_GET[$key] : '')); return $ret; } Puis dans la méthode getContent() j'ai remplacé la ligne : $this->set($varname, Tools::getValue('tggatos_'.$varname)); Avec la ligne suivante : if ($declaration['type'] == self::T_PATH) $this->set($varname, $this->getPath('tggatos_'.$varname)); else $this->set($varname, Tools::getValue('tggatos_'.$varname)); En précisant bien le type "self::T_PATH" pour impacter uniquement les input text avec pour contenu des chemins.
  3. Bonjour, Il est possible que le problème provienne d'une surcharge. Avez-vous récemment fait des surcharges sur les controllers dans le front ? (override\controllers\front). Si, oui. Vérifier le fichier surchargé (ex: ProductController.php) et contrôlé la présence de la ligne FrontController::initContent(); dans la function initContent() si celle-ci figure supprimé là. Si ça ne fonctionne toujours pas vider et supprimer votre cache (\cache\smarty) supprimer les dossiers "compile" et "cache". Si vous avez récemment supprimé des surcharges pensez a supprimer le fichier class_index.php (\cache). Bon courage.
  4. Bonjour, Je dois réaliser un site pour un client qui lui-même s'appuis sur un fournisseur en Belgique. Il s'agit de produit unique (meuble etc..) . Sur le prestashop figure tous les produits du fournisseur mais le fournisseur ne met à jour son catalogue que toutes les semaines par conséquent si une personne commande un produit mon client ne sais pas si le produit est toujours dispo. Alors il voudrait mettre en place un système de pré-commande. C'est à dire que l'internaute commande une pièce mais doit attendre la vérification de mon client auprès de son fournisseurs pour permettre à l’internaute de payer. Avez-vous une idée ? Merci.
  5. Bonjour, je m'occupe de l'installation d'un site en presta pour un grossiste en aménagement de salle de bain qui vends des produits de luxe comme des douches, hammams et SPA... Il aimerait avoir un certain panel de produits présents sur son site au lancement de celui-ci. Mon soucis vient du fait qu'il ne fournit aucune information de poids sur ses produits et je me retrouve donc bloqué au niveau de la facturation. Selon ma manière de voir les choses un client qui prépare un panier de produits en ligne doit avoir un prix exact total comprenant les frais de port. D'après vous faut-il que je donne une estimation à la louche dans un premier temps pour ensuite lui donner la main en modification, ou alors dois-je laisser de côté cette partie en attendant d'en savoir plus. Comment procédez-vous de votre côté en cas de client imprécis? Merci d'avance..
  6. Dans se cas tu as surement raison, si tu le fais qu'il n'y a pas de problème.. je vais vérifier la cfg easyphp j'ai peut être fait des modifications php ou apache.. Mais j'en doute car j'ai pris la version "easyphp + prestashop"
  7. Oui j'ai fais exprès de mettre la même version de easyphp par conséquent les mot de passe c'est les même. @ini_set(‘display_errors’, ‘off’); j'ai bien passé là variable à ON mais la page est blanche blanche il n'y a aucun code source apparent. Je sais pas s'il n'y a pas une clé générer lors de l'installation avec une date. Merci pour ta réponse
  8. Bonjour, J'ai un soucis, je développe sur mon pc fixe avec un package WAMP (easyphp EasyPHP 5.2.10). PS fonctionne très bien sur mon PC fixe rien à dire.. Mais pour le mettre sur mon pc portable j'ai fais un simple copier/coller du répertoire prestashop et un import/export vers la bdd de mon ordinateur portable. Mais si je lance PS sur mon pc portable le site ne s'affiche pas..il charge indéfiniment pour finir sur une page blanche sans code source... J'ai l'impression que le soucis proviens de la classe "Administration" Donc je ne sais pas si je dois modifier une clé ou pas pour venir revalider mon copier/coller du site.
  9. J'ai trouvé comment faire : http://www.prestashop.com/forums/viewthread/54552/integration/solved_how_to_move_the_breadcrumb_to_its_own_hook
  10. Je dois avoir un soucis car j'ai crée un {$HOOK_BREADCRUMB} cela fonctionne parfaitement.. Si j'install le module de shagshag il s'installe correctement sauf que je ne vois rien dans mon fil d'ariane ensuite le module de phinette s'installe correctement lui aussi et là j'ai un plus je vois "You are here » Home" mais sur toutes les pages.. Donc je ne comprend pas trop.. Vous avez une idée ?
  11. j'ai réussi c'est vraiment génial.. Il suffit de tout simplement ajouter {l s='Home'} ou autre chose pour voir le mot apparaitre automatiquement dans l'admin/outils/traductions Je ne pensais pas que le mot apparaitrai automatiquement dans la partie traductions de l'administration. Merci thecat22 d'avoir répondu
  12. Bonjour, Merci pour ta réponse, mais je sais faire ça en faite Je voudrais rajouter des phrases à traduire qui ne figure pas dans le module et même dans le Front Office (et autres).. Par exemple : la phrase "article dans votre" je voudrais la traduire en anglais et Italien je sais pas comment faire car c'est une phrase que je trouve nul part donc je conclus que je dois la créer.
  13. Bonjour, J'aimerais savoir comment on fait pour tout simplement traduire la phrase : "article dans votre" pour pouvoir ensuite avoir la phrase traduit en plusieurs langue.. Je sais que je peux modifier des mots ou des phrases mais comme je fais pour rajouter une phrase à traduire. Module : Blockcart.tpl. Mercii
  14. Pour le blockpermanentlinks je viens de comprendre je me suis trompé avec blocklink Mais ma seconde question reste un mystère
  15. Bonjour, Je débute avec PrestaShop donc j'aurais quelques question bête à poser. J'aimerais comprendre pourquoi il n'y a pas un formulaire pour ajouter/modifier/supprimer des liens dans le module blockpermanentlinks pourtant ces fonctions figure dans la classe, comment je dois faire pour finalement modifier des liens ? aller dans la BDD ou faire un formulaire rapide ? Dernière question, comment je fais pour venir dire que tel ou tel block ou tel module appartient à {$HOOK_HEADER} ou bien {$HOOK_TOP} ou même {$HOOK_LEFT_COLUMN} ? Merci.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More