Jump to content

webempresa

Members
  • Posts

    36
  • Joined

  • Last visited

Everything posted by webempresa

  1. Hola, Al tratarse de la categoría root no la puedo editar, solo se editan las categorías que se crean a partir de estas. Entiendo que este es ya el funcionamiento normal, porque ya ocurría lo mismo en PrestaShop 1.5.
  2. Hola, He probado a actualizar PrestaShop a la versión 1.6.0.6 y el problema continúa, es decir, sigue sin cargar la categoría home o padre, arrojando un error 404, como si esta categoría (id 2) no existiera.
  3. Hola, Sí, he probado temas de caché y no se soluciona el tema, ni siquiera dejándolo desactivado. No parece que sea un problema de la caché, sino del funcionamiento propio de PrestaShop 1.6. Lo de darle a Control+F5 entiendo que lo dices por si tengo cacheado algún script o css en el navegador, pero tampoco parece ser cuestión de eso ya que veo que cuando pulso en el enlace que lleva a la categoría de inicio me redirige a la página de error.
  4. Hola Grafeco, He probado lo que indicas y no me funciona. Es decir, he editado el módulo Blocklayered, le he dado a los 4 botones pero el enlace a la categoría padre sigue sin ir. No se si has realizado algún paso más que yo no haya hecho.
  5. Hola, Tendrías que ir a una ficha de producto de tu tienda y ver el código fuente de la página. Aquí tendrías que comprobar que para el meta og:image realmente se encuentra la url hacia la imagen principal del producto. De no ser así significaría que el código que has agregado para cargar esa imagen no es correcto.
  6. Hola, Es bastante probable que el problema lo tengas en la configuración de las monedas. Vete en la administración de PrestaShop a Localización->Monedas. Para la moneda que estés usando por defecto (supongo que será el euro) asegúrate de que en el parámetro Tipo de cambio tienes puesto el valor 1. De no ser así se producen errores en los cálculos de los sobrecostes de los atributos.
  7. Hola felixdpg, La solución que propones también debería ser válida, ya que así se respetaría la posición de los scripts, incluido el que se usa para cargar el recaptcha. ¿La opción para que los scripts se vayan al final de la web está en la administración de PrestaShop? De todas formas me parece mejor solución hacer el cambio que indico ya que precisamente el aplazamiento de la carga de los scripts (colocarlos al final) sirve para acelerar la carga de la web.
  8. Hola, El problema me ha ocurrido nada más terminar con la actualización a PrestaShop 1.6, sin cambiar nada en la configuración de las categorías. Por si acaso he comparado las tablas relativas a las categorías de la tienda antes y después de la actualización y los parámetros siguen siendo los mismos.
  9. Hola, Este módulo ya se encarga de agregar de forma automática el código de seguimiento de google analytics a todas las páginas de tu web con PrestaShop, sin necesidad de poner más que el código de seguimiento, que tiene una estructura de tipo UA-1234567-1 (cambiando los números por lo que te salgan en tu cuenta de analytics). Cuando se crea la cuenta en google analytics y solicitas el código de seguimiento verás que te da un código script para colocar en la web. Este código script ya lo coloca automáticamente el módulo de google analytics, por lo que solo será necesario que pongas el id de seguimiento. Ten en cuenta que desde que configuras al módulo hasta que se empiecen a recoger datos en la cuenta de google analytics pueden pasar unos días.
  10. Hola, He estado realizando pruebas en PrestaShop con este sistema de captcha y he visto que el problema está en que en esta nueva versión los scripts se cargan al final, supongo que para acelerar la carga de la web. Esto provoca que el script que carga el recaptcha también se ejecute al final, lo que provoca que se cargue al final de la página fuera del formulario, con lo que no funciona. Para solucionar esto he encontrado un truco que parece funcionar, al menos en las pruebas que he realizado. Para ello hay que editar el archivo modules/recaptcha/lib/recaptchalib.php y cambiar la líneas de código: define("RECAPTCHA_API_SERVER", "http://www.google.com/recaptcha/api"); define("RECAPTCHA_API_SECURE_SERVER", "https://www.google.com/recaptcha/api"); por estas otras: define("RECAPTCHA_API_SERVER", "//www.google.com/recaptcha/api"); define("RECAPTCHA_API_SECURE_SERVER", "//www.google.com/recaptcha/api"); De esta forma el recaptcha se cargará en el lugar correcto y funcionará bien. Por supuesto, seguirá siendo necesario aplicar las modificaciones que indicaba soy.amarillo en el archivo authentication.js, si se usa el tema por defecto de PrestaShop, o en el lugar que corresponda si utilizamos otra plantilla.
  11. Hola, He actualizado un PrestaShop de la versión 1.5.6.2 a la versión 1.6.0.5. Tras pequeños retoques veo que todo funciona correctamente excepto el enlace con la categoría padre. Este enlace mostraba un listado de todas las categorías de la tienda, pero ahora al pulsar en él me da un error 404 (página no encontrada). La estructura del enlace para la categoría raíz es del siguiente tipo: www.nombredelaweb.com/index.php?id_category=2&controller=category que coincide con la estructura de enlace a otras categorías de la tienda y que sí funcionan correctamente, por ejemplo www.nombredelaweb.com/index.php?id_category=3&controller=category ¿Ha desaparecido en PrestaShop 1.6 la opción de enlazar con la categoría raíz o hay que cambiar algo en la configuración de la tienda? He probado con varias plantillas y el resultado es el mismo error 404. También he probado a asignar productos a la categoría de inicio y tampoco funciona. Gracias.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More