Jump to content

cupcakes

Members
  • Posts

    49
  • Joined

  • Last visited

Everything posted by cupcakes

  1. Maybe it's something to do with where I upload the php file? I uploaded it to the themes' directory > modules > productscategory > productscategory.php
  2. This client has domain names on one host, and the server at another one. The back office I'm not sure of, I don't believe it's Cpanel since it looks a lot different. I will ask them and see.
  3. If I'd like to have a multishop with different domains, how do I do that? And do I need to have the domains at the same host as I have my server? Thanks!
  4. Thanks Vekia, I've cleared it (also have it on force comp and no cache while I work on this website), but still doesn't show just 4. :/
  5. I tried to change this in productscategory.php $category_products = $category->getProducts($this->context->language->id, 1, 10); /* 10 products max. */ To: $category_products = $category->getProducts($this->context->language->id, 1, 4); /* 4 products max. */ But it still shows more than that. Anyone got a good solution to limit it?
  6. Woops, forgot about that the 1.6 probably uses different codes now. So used {hook h="MENU2"} instead and now it doesn't give off that error. Still can't transplant the menu to it though. Should I change this in the blocktopmenu.tpl to something else? public function hookdisplayMenu2($params) { return $this->hookhome($params, 'displayMenu2'); } Thank you for your help! It's very helpful to use this forum, I get to learn fast.
  7. Not sure why I get this warning. Sure it's not visible when I don't have dev mode on, but still wonder what it is. Anyone know? Warning: trim() expects parameter 1 to be string, array given in /storage/content/21/104221/website.se/public_html/classes/Tools.php on line 1144
  8. Replaced {$HOOK_displayMenu2} with {$HOOK_MENU2} in header.tpl. Yes, the new hook appears in the database. I still get this Notice: Undefined index: HOOK_MENU2 in /storage/content/21/104221/website.se/public_html/cache/smarty/compile/87/88/21/878821c06e433b5fc177942e9804ae4e0e6f5a4c.file.header.tpl.php on line 160 Notice: Trying to get property of non-object in /storage/content/21/104221/website.se/public_html/cache/smarty/compile/87/88/21/878821c06e433b5fc177942e9804ae4e0e6f5a4c.file.header.tpl.php on line 160
  9. Yes, adblocker can be a bit tricky. I have allowed the domain in adblocker. If I pause adblocker all together it still looks that way. :/
  10. If I go to edit a product in Chrome, the list takes up the whole page and is not clickable (nothing happens). If I instead open up back office in Firefox the list takes up a normal amount of the page (to have a place for what's going to open when I click the links) and the links work. Not sure if this is already something someone else have noticed or if it's something weird with my installation?
  11. The homepage works but if I click a product page this comes up: Strict Standards: Declaration of FrontControllerCore::addCSS() should be compatible with ControllerCore::addCSS($css_uri, $css_media_type = 'all', $offset = NULL) in /storage/content/21/104221/website.se/public_html/override/controllers/FrontController.php on line 1154 Fatal error: Call to undefined method ProductController::useMobileTheme() in /storage/content/21/104221/website.se/public_html/controllers/front/ProductController.php on line 40 Maybe it's easier if I just backup products and the theme (, then re-install the whole thing into 1.6?
  12. It was 1.5.6.2. I downloaded the 1.6.0.5 now and opened up a fresh defines, overwrote the one in the ftp with the new one. After that it all works, however I wonder if there's any other files that have gone wrong during the upgrade. Hopefully not, and if they have then I guess I'll notice somehow along the way. Thank you so much for your help!
  13. Staring at line 56 I have: /* Directories */ define('_PS_ROOT_DIR_', realpath($currentDir.'/..')); define('_PS_CLASS_DIR_', _PS_ROOT_DIR_.'/classes/'); define('_PS_CONTROLLER_DIR_', _PS_ROOT_DIR_.'/controllers/'); define('_PS_FRONT_CONTROLLER_DIR_', _PS_ROOT_DIR_.'/controllers/front/'); define('_PS_ADMIN_CONTROLLER_DIR_', _PS_ROOT_DIR_.'/controllers/admin/');
  14. This one I don't know what to do with though: The code says: require_once(_PS_CLASS_DIR_.'PrestaShopAutoload.php'); And the error I get is: Notice: Use of undefined constant _PS_CORE_DIR_ - assumed '_PS_CORE_DIR_' in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 63 Warning: scandir(_PS_CORE_DIR_/classes/): failed to open dir: No such file or directory in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 170 Warning: scandir(): (errno 2): No such file or directory in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 170 Warning: Invalid argument supplied for foreach() in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 170 Warning: scandir(_PS_CORE_DIR_/controllers/): failed to open dir: No such file or directory in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 170 Warning: scandir(): (errno 2): No such file or directory in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 170 Warning: Invalid argument supplied for foreach() in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 170 Warning: scandir(_PS_CORE_DIR_/override/classes/): failed to open dir: No such file or directory in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 170 Warning: scandir(): (errno 2): No such file or directory in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 170 Warning: Invalid argument supplied for foreach() in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 170 Warning: scandir(_PS_CORE_DIR_/override/controllers/): failed to open dir: No such file or directory in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 170 Warning: scandir(): (errno 2): No such file or directory in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 170 Warning: Invalid argument supplied for foreach() in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 170 Warning: rename(/tmp/class_index.php.Axf4dI,_PS_CORE_DIR_/cache/class_index.php): No such file or directory in /storage/content/21/104221/website.se/public_html/classes/PrestaShopAutoload.php on line 149 Fatal error: Class 'Tools' not found in /storage/content/21/104221/website.se/public_html/config/config.inc.php on line 64 Wow, there are so many errors after this upgrade I did. How come?
  15. I've checked the FTP for the file in the config-directory, and it's present. So I don't understand why it gives off this error. :/ In the config.inc.php it tries to call it by this line: require_once(_PS_CONFIG_DIR_.'autoload.php'); Is there something wrong with it? As of now I can't access neither front or back-office. Edit: I think I just figured it out, I removed the _PS_CONFIG_DIR_. from it, as the config is in the config dir it doesn't need a dir I think... When I removed it a new error came up instead, and so I did the same for that. Now there's another big error instead that mentiones something else. Will take a look at it.
  16. I upgraded to 1.6 and after five minutes or so clicking through front/back office to check if everything was fine - I get this message: Notice: Use of undefined constant _PS_CONFIG_DIR_ - assumed '_PS_CONFIG_DIR_' in /storage/content/21/104221/website.se/public_html/config/config.inc.php on line 53 Warning: require_once(_PS_CONFIG_DIR_autoload.php): failed to open stream: No such file or directory in /storage/content/21/104221/website.se/public_html/config/config.inc.php on line 53 Fatal error: require_once(): Failed opening required '_PS_CONFIG_DIR_autoload.php' (include_path='.:/usr/share/php:/usr/share/pear') in /storage/content/21/104221/website.se/public_html/config/config.inc.php on line 53
  17. I mean, to have it like this in the one-paged checkout
  18. I found a free theme that does this that I can learn from. Thanks anyway
  19. Nevermind this one, I will try and re-do it all instead. Hopefully this results in something better, by taking small steps when I edit everything.
  20. Oh okay But then they can't choose a payment option by radio, and they still need to confirm on the second page (the page it goes to after clicking payment-option) :/
  21. Is there a known way to have a confirm button at the end of the one paged checkout?
  22. I'm currently trying out some things with the checkout form. I wonder how I remove the validation of the phone-field, I have removed some lines (incl. "required") from different places that mentions phone, but doesn't work fully. The error-message saying that the phonenumber is invalid doesn't show up the first time, but if I change the phonenumber after saving and then click save again. Also if I refresh the page and try to click save this happens.
  23. I copied the "schema of URLs" from a functioning install and now it works again. Pew <3 Also figured out that the issue of the product-pages not showing up, was that I had missed on that first module-page that they adviced to remove .html after route to products. So now it all works!
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More