Jump to content

shv

Members
  • Posts

    20
  • Joined

  • Last visited

Everything posted by shv

  1. Hi, My dispatcher.php looks as follows (still need to find out which module's doing is that override though:-): <?php class Dispatcher extends DispatcherCore { protected function loadRoutes() { parent::loadRoutes(); $orderby = (isset($_REQUEST['orderby']) && $_REQUEST['orderby']) ? $_REQUEST['orderby'] : 'position' ; $orderway= (isset($_REQUEST['orderway']) && $_REQUEST['orderway']) ? $_REQUEST['orderway'] : 'asc' ; $results = Db::getInstance()->executeS(' SELECT s.id_searchterm, s.term,s.url,s.title,s.description FROM '._DB_PREFIX_.'searchterm s '); foreach($results as $result) foreach (Language::getLanguages() as $lang) $this->addRoute('search_'.$result['id_searchterm'],$result['url'],'search',$lang['id_lang'],array(), array('search_query' =>$result['term'], 'orderby' => $orderby, 'orderway' => $orderway)); } }
  2. Hi el Patron, Thanks for the hint. It looks like I got a problem with dev mode, getting the following error message when turning error reporting on: Strict Standards: Declaration of Dispatcher::loadRoutes() should be compatible with that of DispatcherCore::loadRoutes() in /home/sportand/public_html/sport-und-hobby.ch/pr/override/classes/Dispatcher.php on line 16 Warning: Cannot modify header information - headers already sent by (output started at /home/sportand/public_html/sport-und-hobby.ch/pr/override/classes/Dispatcher.php:16) in /home/sportand/public_html/sport-und-hobby.ch/pr/classes/Tools.php on line 143 Trying to chase this issue now with other posts, if you have some link/idea in mind, please share:-). Thanks, shv
  3. Hi, Same here, after updating the shop to 1.6.0.8 and then 1.6.0.9 bank wire indeed returns a blank page and hangs the checkout process. The friendly URL ¨rder confirmation¨ is set as it should be. Cannot find the reason as yet. Anybody found a solution? Thanks, shv
  4. Thanks misthero for your help! Now it is working perfectly. The informaiton in the category.tpl was there but somehow it was not working. I have checked, and there was actually this code line re: sliders hook in the file, but it seems to have appeared twice (perhaps initially when I was troubleshooting I tried to patch the files twice or similar, cant really comment on what have happened exactly:-). At any rate, just removed one copy of the same line, saved the .tpl - and the module now works fantastically. Thanks again for such a nice contribution and your kind assistance :-), shv
  5. Thanks for the hint. Are there any instructions available for PS 1.6x? Thanks, shv
  6. Hi everybody, Just found a plugin which saved me time for chasing the modifications for PS 1.6.0.9. There is a free plugin from a Spanish PS agency, available for free download directly from their page: http://www.alabazweb.com/en/modulos-para-la-administracion-de-prestashop/295-modulo-para-completar-el-editor-de-prestashop-.html Just download and install the module - and voila, enjoy extended editor in your back office! Best, shv
  7. Hi misthero, Thanks for your hints, that worked - actually in positions the module was not in the footer and product pages, so I just hooked the module there and it started to work just fine! Is it any possibility to use the slider on category product listing page by any change? Thanks - for your help and a great module! Best, shv
  8. Hi misthero, Thanks for your answer. By product tab or footer I mean hooks where one can hang your module - so when I try to use those hooks, the slider does not appear there, after clearing smarty cache etc., just nothing happens. As to the browser: you were right, Mozilla did make a trick (partly, not totally as yet, though). I managed to upload a picture there, it works, on home page and in the top column, but does not appear on product page or in the footer as I said above, neither the slider goes to the top - only to the top column. So practically I can use the slider now on the homepage (home & home tab), shopping cart footer and in the top column - but nowhere else (banner however I did not check as it is off in our configuration). The module version installed is 1.6.38, I guess it is the latest? The PS v. is 1.6.0.9, in reality it is partly 1.6.0.8 as it has recently been updated and we kept our theme. Something with recognizing the hooks, perhaps you can hint what can I try to make it work? It would be interesting to try it in R/L column and of course on category/product pages as well. By black screen I meant that this window which is supposed to visualize the uploaded image goes black, so for fuzzy description. So there was something strange during the uloading stage - but it seems now that it was some picture name incompatibility, now I got rid of all special characters in picture names (and also updated my browsers and cleaned smarty cash after each operation) - and picture uploading works out. As to the placing the slider in the top column hook option - is there some way to display this hook everywhere but the homepage, or on some selected pages? Or it is designed to be present everywhere with no way to switch some pages off? Thanks again, shv
  9. Hi, I just installed this module and the sample slider worked after I have made modifications in the .tpl files as suggested, though there is no visible effect in neither product tab nor footer. It seems also problematic to add new pictures to the existing slider or make new sliders, as when uploading new pictures there is just black screen appearing so obviously pictures are not recognized/accepted somehow. Do I need to upload pictures in exact resolution set in preferences, or do they need to be in some specific format? I have tried .png (transparent) and .jpg but no luck so far:-). Or could it be the browser I use which is not supported (I used now Opera)? Could you hint what can be a problem here please? We use PrestaShop 1.6.0.8 upgraded recently to 1.6.0.9. Many thanks, shv
  10. Hi Vekia, Thanks for your reply. There is one tinymce.min.js file of course in the dir, I just meant that there is a tinymce.min.js file and not the /js/tinymce.inc.js as mentioned in the tutorial. I tried to substitute tinymce.min.js the same way as described for tinymce.inc.js, and it did not really work out (so if I substitute the whole file with the code as described in the tutorial for tinymce.min.js, the whole rich text editing is gone ie. does not appear anymore, so I have to revert to the original file). What modifications should I do for tinymce.min.js in this case? Thank you very much for your help, shv
  11. HI Vekia, We just upgraded to the PS 1.6.0.9 (from 1.6.0.8), and we lost this beautiful feature. I went to the js/tinymce folder and there is another file ¨tinymce.min.js¨, so one cannot apply directly your instructions re: tinymce.inc.js. Any way one can set up extended MCE in the PS 1.6.0.9? Thanks for any hint, Best, shv
  12. Hi, I use the default bootstrap theme. Whereabout in bootstrap css can I do a similar modification? Thanks, shv
  13. Hi reno123, I found the solution now, perhaps it helps you as well. 1. Category pics - just disable in PS category settings (via a simple ¨edit¨ in PS back office, as suggested above); 2. The same trick does not work on subcategories though if one wants to keep subcategory pics for displaying them on category listing pages (but omit displaying them on respective subcategory listing pages) - so one needs to modify the category.tpl file instead. Simple modification is just as described below, to comment part of the code: http://www.prestashop.com/forums/topic/336397-remove-subcategory-image-on-product-list-page/ The manipulation which worked for me from those listed in the above link (you can try it first, and if not working, go to the above link to see more possibilities) is as follows: One needs to change category.tpl from: <!-- Category image --> <div class="content_scene_cat_bg"{if $category->id_image} style="background:url({$link->getCatImageLink($category->link_rewrite, $category->id_image, 'category_default')|escape:'html':'UTF-8'}) right center no-repeat; background-size:cover; min-height:{$categorySize.height}px;"{/if}> {if $category->description} <div class="cat_desc"> <span class="category-name"> {strip} {$category->name|escape:'html':'UTF-8'} {if isset($categoryNameComplement)} {$categoryNameComplement|escape:'html':'UTF-8'} {/if} {/strip} </span> {if Tools::strlen($category->description) > 350} <div id="category_description_short" class="rte">{$description_short}</div> <div id="category_description_full" class="unvisible rte">{$category->description}</div> <a href="{$link->getCategoryLink($category->id_category, $category->link_rewrite)|escape:'html':'UTF-8'}" class="lnk_more">{l s='More'}</a> {else} <div class="rte">{$category->description}</div> {/if} </div> {/if} </div> {/if} </div> to: <!-- Category image --> {* <div class="content_scene_cat_bg"{if $category->id_image} style="background:url({$link->getCatImageLink($category->link_rewrite, $category->id_image, 'category_default')|escape:'html':'UTF-8'}) right center no-repeat; background-size:cover; min-height:{$categorySize.height}px;"{/if}> {if $category->description} <div class="cat_desc"> <span class="category-name"> {strip} {$category->name|escape:'html':'UTF-8'} {if isset($categoryNameComplement)} {$categoryNameComplement|escape:'html':'UTF-8'} {/if} {/strip} </span> {if Tools::strlen($category->description) > 350} <div id="category_description_short" class="rte">{$description_short}</div> <div id="category_description_full" class="unvisible rte">{$category->description}</div> <a href="{$link->getCategoryLink($category->id_category, $category->link_rewrite)|escape:'html':'UTF-8'}" class="lnk_more">{l s='More'}</a> {else} <div class="rte">{$category->description}</div> {/if} </div> {/if} </div> *} {/if} </div> It just comments part of the code, so one can go back to the file and simply enable it (by erasing comment signs) in case of necessity. Hope that helps, shv
  14. Hi Vekia, I have installed this module, works fantastic, just removed it from the homepage view to allow for a wider slider in the theme settings. Thanks for such nice contributions:-), shv
  15. Hi Vekia, I can change the background color, but what I actually needed to do is to also get rid of category pictures on product listing pages. That is of course possible to do via PS preferences, but then subcategory pictures on subcategory listing pages pop up - so the question is, what modification do I need to do to in category.tpl for subcategory pics not being visualised on the listing pages? Many thanks, shv
  16. HI, I'd need the same modification (removing category pictures on listing pages) but for the PS 1.6.0.8 now. What would be the best way of doing it? Many thanks, shv
  17. Hi Loulou66, Is the new version now available for download? Thanks :-)
  18. HI, Many thanks for your reply. The issue was most probably due to the fact that I used it on the 1.6.0.8 shop version. I'll send you a pm as you suggest. Have a lovely day:-)
  19. Hi, Just downloaded and installed the module, it is however version 2.4.3 and not 3.0 as it seems. Could you share a link to the newest module please? Merci bien :-)
  20. Hi, oops, no, I did not. Where can I find it? The other question is now what to do with my shop - because even though I rolled back to a previous backup, I get the same error message over and over again without any possiblity to enter the modules and install or modify anything concerning the modules. Can I modify the files somehow so your module does not cause this trouble? Then I can go ahead and make a proper installation again. Does your module modify some global parameters in the environment perhaps that I could manually change back? Or I could see where the module left-overs are in the shop directory, and try to kill them if it helps to restore the previous environment (otherwise your module makes some requests even though it physically should not be existing if I rolled back to my previous backup, so I need to make sure that I clean all the left-overs before I try again on the clean shop). Many thanks.
  21. Hi, I tried to install the module and it gave an error during the installation (see below), what is worse is that after that I cannot enter the modules section in the shop office, getting the error message all over even if I roll back to one of the previous shop backups (DB+directories backup). Can you suggest how can I fix it? Thanks in advance. The error message is ass follows: Warning: require_once(/home/sportand/public_html/sport-und-hobby.ch/pr/modules/smartblog/smartblog.php) [function.require-once]: failed to open stream: No such file or directory in /home/sportand/public_html/sport-und-hobby.ch/pr/modules/smartblogaddthisbutton/smartblogaddthisbutton.php on line 4 Fatal error: require_once() [function.require]: Failed opening required '/home/sportand/public_html/sport-und-hobby.ch/pr/modules/smartblog/smartblog.php' (include_path='/home/sportand/public_html/sport-und-hobby.ch/pr/tools/htmlpurifier/standalone:.:/usr/local/php53/pear') in /home/sportand/public_html/sport-und-hobby.ch/pr/modules/smartblogaddthisbutton/smartblogaddthisbutton.php on line 4 [PrestaShop] Fatal error in module smartblogaddthisbutton: require_once() [function.require]: Failed opening required '/home/sportand/public_html/sport-und-hobby.ch/pr/modules/smartblog/smartblog.php' (include_path='/home/sportand/public_html/sport-und-hobby.ch/pr/tools/htmlpurifier/standalone:.:/usr/local/php53/pear')
  22. Hi, If I want to change the font size in product listing on category page (grid view), whereabout in globalcss file should I make changes? I'd also like to change text size of ¨Add to cart¨ and ¨More¨ buttons on category in product listing, in both views (list and grid), where the respective settings are located? The PS I am using is 1.6.0.8. Thanks a lot.
  23. Hi, I got the ¨add to wishlist¨ message in the product listing grid view (upon hover, a box with ¨more details¨, price etc. appears, and an ¨add to wishlist¨ options is also displayed there at the bottom of the box). I want to remove this wishlist option (it's enough to have the wishlist option in the product detail view, so in the listing grid view it needs to be erased). How can I get rid of the ¨add to wishlist¨ option in the product listing grid view? Tried to see if I can unhook the module in the positions tab, but did not really find any wishlist related to the grid view (if that would be a possibility, which ¨display¨ option in the positions tab should I check?). Another possibility would be modifying CSS and/or .tpl, could you hint where should I look? Thanks.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More