Jump to content

beyonceuk1

Members
  • Posts

    82
  • Joined

  • Last visited

Everything posted by beyonceuk1

  1. Hi all - I've been using PS 1.6.1 for years for many stores, very happy with it and will move to 1.7 one day. The only hurdle I've never been able to overcome is shipping. Our carrier (Royal Mail) calculates pricing based on weight and package dimensions. Although PS allows product dimensions to be entered it only seems to restrict carriers based on the largest item in an order, not on the total package dimensions. This seems like madness to me but up to now I've been stuck with it. Has anyone ever solved this problem, or does anyone know where I would amend the formula PS uses to calculate the order dimensions? At this stage I'm just reaching out in the dark and hoping to find a caring genius...
  2. I needed to change p.quantity in the second section to pq.quantity or it would show zero stock.
  3. Hi all. Running into big problems with our PS1.6 multistore set-up. All works fine except for orders paid for using either the ModuleMarket or Prestashop WorldPay modules where there is a new carrier set-up (or an old carrier is amended so PS give the carrier a new carrier ID in the database). Although the correct payment comes through, the order fails due to the carrier not being shown on the order (so it looks like the customer has overpaid by the value of the postage amount). We're up to 300+ lines in the PS carrier table where we only use around 10 carriers across all of our shops. What would the implications be of manually deleting carrier information from the database and setting everything up again? Any help would be massively appreciated!
  4. Hi - solved this by un-ticking the validate order box in the Payment Error status.
  5. Not 100% sure yet but we've had another major issue on the same shop and the only difference between that shop and the others is we have the partial payment module from Bestkit on there. I think that may be what's causing issues. Looking into it.
  6. Thanks for that - good idea! It's a pretty busy shop however so I'd have to pick a quiet time to change the theme temporarily.
  7. I changed the options for a couple of statuses (payment error and preparation in progress) but those affect all multistores and the others all still work correctly. It has to be something with the specific theme used. Are there any files within a theme folder that could affect stock transactions?
  8. Doesn't seem to be anything in the webserver error log that relates to this.
  9. Nothing in the logfile showing an error. Everything severity level 1.
  10. I'm using PS 1.6 Multistore. The stock quantities in one store have stopped updating when we get an order. The only thing I can think of that we changed was the Status options (we have another problem with the WorldPay module setting all orders on that shop to Payment Error so we tried to change the Payment Error status to validate the order). Any ideas? Seems to be working in other stores so it has something to do with the files in that store's theme.
  11. Solved it. In the "structure" section of global.css I changed the following z-index value: #header {z-index:0) All good. Marking as solved.
  12. I'm trying to use my header logo as a full screen background image (so it appears on top of my already tiled background). I'm nearly there I think and all looks great except the logo is appearing on top of my products, etc. Can I move the layer back somehow?
  13. I regularly run into the problem of one CSS change (ie. text colour/size) affecting sections where I don't want the change to appear. Particularly a problem when I'm setting up a store with a dark background so a lot of colours on the homepage/featured products need changed so they can be seen. What is the best practice for changing the text colour of a line - product name/description/price for example? Should I be changing the CSS code sourced by the TPL file? Adding code to my CSS file?
  14. I think you're right. I'm going in and resetting the cart module now and I can get it to show up again. Strange that it's moved everything else on the homepage around so quite a bit of coding to do to fix all the stores. This is why I'm pretty terrified to upgrade to 1.7.... wish I could do it store by store.
  15. Hi - I have Prestashop 1.6 running several multistores, each with a custom theme. For some reason last week the shopping cart block disappeared from all of the stores, and the layout on the homepage changed (text no longer centered, etc.). Instead of the cart and login links, the products all have an Add To Cart button. Customers can use "Add to cart" to process a new order but existing customers have nowhere to login to their account. I'm baffled - I've tried resetting the cart block module. Can anyone help?
  16. They're definitely there - all working perfectly on the normal shop. Just the mobile version where there's a problem. And if the customer selects an attribute the correct reference is displayed. It's only when the customer initially clicks on a product there is no reference showing, although the default attribute is shown. If they choose to add to cart straight from that page we don't get any attributes showing in the back end, only the main product reference.
  17. Removing this code displays the main product reference but not the default attribute reference. If the customer adds to cart without changing the attribute then the order has no attribute listed for the product and we have no way of knowing which attribute they wanted (size, colour, etc.). Any ideas?
  18. Thanks for that. For some reason in this custom theme there is no .footer-container in global.css - if I just add that code nothing changes. Do know which file looks up .footer-container? May be something missing there.
  19. Is there any way to force the footer to the bottom of the browser window when there is only a little content? the big white space is horrible.
  20. Yes. that was already set to "no" so that's not the problem.
  21. "Allow ordering of out-of-stock products" is set to "no".
  22. I have a product in a custom-themed multistore that went out of stock yesterday. Despite the "deny orders" when out of stock being selected, customers were still able to keep ordering and the order status would be "on backorder". I had to manually go into the product information page and untick the "available for order" box. I've not noticed this problem before. Could this happen if peop;e have the item in a shopping cart before the stock runs out? Could be a big problem potentially as I have hundreds of products and I can't keep watching them all.
  23. Still haven't found a solution to this - if anyone has any ideas it would really be appreciated. The items where this is happening are paper tickets, so the weight is tiny and only one shipping option is allowed.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More