Jump to content

silviu_25

Members
  • Posts

    61
  • Joined

  • Last visited

Profile Information

  • Activity
    Freelancer

Recent Profile Visitors

2,302,012 profile views

silviu_25's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. I manually copied everything one by one including titles descriptions pictures .... and rebuilded all products into new ps installation. I didn't succeeded using table transfer.
  2. Hi, I try to use cookie free domains for media/images, so I created a subdomain named cdn ( cdn.mydomain.com ) and I pointed its root folder to img. I inserted this subdomain in BO>Advanced>Performance and when I refresh FO all images are missing. If I copy image link I get: https://cdn.mydomain.com/473-home_default/image-mane.jpg if I try to access https://mydomain.com/473-home_default/image-mane.jpg image is there So I think I should add cdn.mydomain.com in .htaccess file because: # Images RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$1$2$3.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$1$2$3$4.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$1$2$3$4$5.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$1$2$3$4$5$6.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$1$2$3$4$5$6$7.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$1$2$3$4$5$6$7$8.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$1$2$3$4$5$6$7$8$9.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$8/$1$2$3$4$5$6$7$8$9$10.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^c/([0-9]+)(\-[\.*_a-zA-Z0-9-]*)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2$3.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^c/([a-zA-Z_-]+)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2.jpg [L] # AlphaImageLoader for IE and fancybox RewriteRule ^images_ie/?([^/]+)\.(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L] all jpg links are rerwited to a shorter link like : 473-home_default and they are not pointing to the actual path like /img/p/3/2/7/9/..... So, how can I configure media servers in PS 1.7.6.1? I read on different forums that this is because of Friendly URL id ON (how I would prefer to keep it) LE After more digging on the web I fount that I need to regenerate the .htaccess file after I add the cdn domain by going to BO> SEO & URL> set friendly url to NO and save then set to YES and save. and image path are updated to https://cdn.mydomain.com/473-home_default/image-mane.jpg But here comes another problem: If I try to access https://cdn.mydomain.com/473-home_default/image-mane.jpg I get 403 Forbidden If I try to access https://cdn.mydomain.com/4/7/3/image-mane.jpg image is displayed.
  3. Hi, I have the following error pn PS 1.7.6.1: Fatal error: Uncaught Error: Class 'Cache' not found in .../classes/db/Db.php:595 Stack trace: #0 ..../classes/shop/Shop.php(345): DbCore->executeS('SELECT s.id_sho...') #1 ..../config/config.inc.php(119): ShopCore::initialize() #2 ..../admin..../index.php(40): require('/home/tablouri/...') #3 {main} thrown in ..../classes/db/Db.php on line 595 I deleted the "class_index.php" in cache folder I reuploaded entire /classes folder from a native PS 1.7.6.1 I also restored some backups including all files and database. I switched from PHP 7.2 to 7.1 I checked System requirements for PrestaShop 1.7 https://devdocs.prestashop.com/1.7/basics/installation/system-requirements/ I tried almost everything found on web but nothing seems to work for me. Any idea how can I fix it? (i can't access FO or BO)
  4. Hi, I'm Trying to upload an attachment for a product, but I got an error saying "The file is too large. Maximum size allowed is: 8192 kB. The file you are trying to upload is......" in my php settings: post_max_size is 1G and upload_max_filesize is 512MB is this a Prestashop error or something? how can I change the maximum size allowed? (this old topic didn;t helped...)
  5. Finally I moved everything one by one from old PS to new PS .. ;(
  6. multumesc, dar asta exporta in csv si importa doar in xml...... (poate vrei sa arunci o privire si la topicul acesta? ) ☹️
  7. Can you recommend any good and free module for import/export ?
  8. Hi, I had a shop running on 1.7.5.2 and I decided to upgrade to 1.7.6 but what I want to do is to install also a new theme and get rid of all old modules, so I decided the best option is to Install a fresh new PS 1.7.6 onto a provisional subdomain and transfer Categories, Attibutes and Products with all images combinations...etc from 1.7.5.2 to 1.7.6 then to apply the new theme. The problem is I;m not shure what MYSQL tables to export and import into new one. I tried to export categories and products from admin menu but when I try to import into new one the options for import are limited for example I don't have price, reference number ... and so on. I also upgraded the old shop based on 1.7.5.2 to 1.7.6 and I still don't have those options for import. there is anyone who can tell me which tables from mysql database i should export and then import into new installation ? By now I tried with almost all tables but I dont have the product pistures and names under Catalog > Products. Just ID Reference Price and combinations.
  9. Salut, este compatibil cu 1.7.5.2? Poti sa mi-l trimiti te rog?
  10. I removed a theme which was not used and now is working ok. Strange enough...
  11. Hi all, I have a issue with product combinations, I created 2 attributes: sizes and material if I go to one product and configure everything, then hit Generate, then config the combinations with sesired prices and options and etc on product page are displayen only few of them or all of them but when I select for example a size and another material the price is not changing. Or sometimes they are simply not displayed on product page. I;m using the default theme and no other extra module installed Any idea what should I check?
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More