Jump to content

sowthierno

Members
  • Posts

    21
  • Joined

  • Last visited

Everything posted by sowthierno

  1. Bonjour à tous J'ai suivi la piste de julien merci à lui au passage. J'ai donc apporté assez de modifications. Au niveau du back office j'arrive à l'affichage ci-joint Pour l'envoi du mail au client j'ai donc définie un statut que j'ai nommé en attente du premier chèque, definie dans mail le un fichier .txt et un .html(voir ci joint) mais j'ai un souci les dates et montants des différentes transactions ne s'affichent pas. Est ce que quelqu'un aurait-il une piste?
  2. La seule modification que j'ai effectué pour l'instant c'est de renommer l'admin en gestadmin.
  3. J'ai installé prestashop en local donc l'url du back office est http://localhost/prestashop/gestadmin'>http://localhost/prestashop/gestadmin et celui du front office est http://localhost/prestashop J'ai egalement remarqué que les images des produits ne s'affichent pas (back office) voici des captures pour mieux voir ce que j'ai comme affichage.
  4. J'ai donné le droit 777 à tous les dossiers et 666 à tous les fichiers avec la commande chmod. J'ai verifié j'ai bien php5. J'ai changé tous les none en All dans default d'apache et j'ai fait un restart. Au niveau du back office tout est bon mais toujours aucun affichage du front office.
  5. Bonjour à tous J'ai installé prestashop sous ubuntu 10.4. J'ai donné les droits à tous les fichiers et dossiers de prestashop. J'ai acces a mon back office mais cependant je n'ai aucune image, aucun affichage sur le font-office. Est ce que quelqu'un pourrai m'aider. Merci d'avance.
  6. J'ai trouvé le problème c'etait dans mon template des dimensions des images IE prenais 1px. Merci.
  7. Ce module une fois installer permet à chaque fois que l'on recharge la page d'accueil par exemple, de changer la position des produits ce qui rend le page d'accueil plus dynamique. Voici l'utilité de ce module.
  8. S’il vous plait, personne pour m’aider à résoudre ce problème ?? d’après les capture, ça vient d’où selon vous ? Merci d'avance
  9. Bonjour à tous , Si je ne l'ai pas posté au bon endroit je m'en excuse. Je travail sur un module qui me permet d'afficher les produits sur la page d'accueil. j'ai utilisé la méthode de Pierre Yves homefeatured2 merci a lui au passage. Le module fait exactement ce que je veux sous firefox mais sous internet explorer les images ne s'affichent pas. Est ce que quelqu'un saurait à quoi c'est due? Vous trouverez ci-joint les images qui illustrent les deux cas. Voici le code de mon template. <!-- /MODULE Home Products --> {l s='Produits' mod='homeproducts'} {if isset($products) AND $products} <!--{assign var='liHeight' value=360} {assign var='nbItemsPerLine' value=4} {assign var='nbLi' value=$products|@count} {assign var='nbLines' value=$nbLi/$nbItemsPerLine|ceil} {assign var='ulHeight' value=$nbLines*$liHeight}--> {foreach from=$products item=product name=homeProducts} {$product.name|truncate:27:'...'|escape:'htmlall':'UTF-8'} {$product.description_short|strip_tags|truncate:130:'...'} getImageLink($product.link_rewrite, $product.id_image, 'home')}" height="{$homeSize.height}" width="{$homeSize.width}" alt="{$product.legend|escape:html:'UTF-8'}" /> {if !$priceDisplay}{convertPrice price=$product.price}{else}{convertPrice price=$product.price_tax_exc}{/if} {l s='Plus d\'info' mod='homeproducts'} <!--{if ($product.quantity > 0 OR $product.allow_oosp) AND $product.customizable != 2} Pour obliger l'utilisateur d'aller voir les declinaisons {l s='Ajouter au panier' mod='homeproducts'} {else} Pour obliger l'utilisateur d'aller voir les declinaisons <!--L'ajout au panier--> {l s='Ajouter au panier' mod='homeproducts'} {/if}--> <!--Pour obliger l'utilisateur d'aller voir les déclinaisons--> {if ($product.allow_oosp OR $product.quantity > 0) && $product.customizable != 2 && $product.id_product_attribute == 0} <!--L'ajout au panier--> {l s='Ajouter au panier' mod='homeproducts'} {else} <!-- {l s=' '} --> <!--{l s='Voir les options'}--> {l s='Voir les options' mod='homeproducts'} {/if} {/foreach} {else} {l s='No featured products' mod='homeproducts'} {/if} <!-- /MODULE Home Products --> Est-ce que quelqu'un pourrait m'aider svp? Merci d'avance.
  10. Bonjour à tous Je m'excuse si je ne l'ai pas posté au bon endroit. j'ai créé un module qui me permet de faire de l'affichage. J'ai essayé avec firefox tout fonctionne il m'affiche toutes les images, mais quand j'essaie avec internet explorer il m'affiche tout sauf les images. Est ce que quelqu'un pourrait m'aider s'il vous plait. Vous trouverez ci-joint les captures d'écran. Le premier celui sous IE et le second sous FF. Merci d'avance.
  11. Salut à tous Si je ne l'ai pas posté au bon endroit je m'en excuse. Je cherche à rajouter un block dans la catégorie des produits et je cherche le hook que je dois référencer. J'ai joint un fichier qui montre exactement ou je voudrai le rajouter, il est représente par un rectangle avec : ici mon block. Dans ce block je souhaiterai avoir toutes les déclinaisons du produit concerné, un champ quantité dans lequel l'utilisateur peut mettre la quantité qu'il souhaite avoir et puis cliquer sur le bouton ajouter au panier. Est ce que quelqu'un pourrait m'aidez s'il vous plait? Merci d'avance !!!! hook.doc
  12. Bonjour à tous, Je cherche à afficher une requête dans l'admin en rendant modifiable certains champs de cette requête. Pour l'instant j'ai réussi à afficher dans l'admin le résultat sous forme de liste, je cherche à présent le moyen d'ordonner cette liste qui pour l'instant est une succession de lignes en ligne par ligne, en rendant certains champs modifiable(poids, prix_achat, prix_vente). Vous trouverez ci-joint le code source. Est ce que quelqu'un pourrait m'aider? Ou me donner une autre piste svp je suis vraiment bloqué? Merci d'avance !!!!!!!!!!! AdminPrice.php
  13. J'ai essayé mais çà ne marche pas. Je vais t'être essayer de partir de la table product_lang et voir à cause du intval($cookie->id_lang) je pense que c'est du au fait qu'il n'y a pas de id_lang dans product.
  14. Bonjour à tous J’espère avoir poster dans la bonne section, si ce n’est pas le cas je m'en excuse ! J'essaie de faire un affichage dans l'admin avec le code ci-dessous et je ne sais pas pourquoi il ne fait rien est-ce que quelqu'un pourrait m'aider svp. Merci !!! <?php include_once(PS_ADMIN_DIR.'/../classes/AdminTab.php'); /** * * */ class AdminPriceFixing extends AdminTab { /** *le constructeur de la class */ public function __construct() { global $cookie; //************************************************** //********************la requete******************** //************************************************** $this->table = 'product'; // FROM // SELECT $this->_select = ' IF(pa.`supplier_reference` > 0,pa.`supplier_reference`,a.`supplier_reference`)as reference, pl.`name`as nom, GROUP_CONCAT(CONCAT(agl.`name` ," : ", " ", al.`name` )) AS valeurs, a.`weight`, IF(pa.`wholesale_price` > 0,pa.`wholesale_price`,a.`wholesale_price`) as prix_achat, (((100*(COALESCE(pa.`price`,0)))/(100+(t.`rate`)))+ a.`price`) as prix_vente_ht, t.`rate` , ((1+(t.`rate`)/100)*(((100*(COALESCE(pa.`price`,0)))/(100+(t.`rate`)))+ a.`price`)) as prix_final, (((IF(pa.`wholesale_price` > 0,pa.`wholesale_price`,a.`wholesale_price`))/(((100*(COALESCE(pa.`price`,0)))/(100+t.`rate`))+ a.`price`))*100) as marge'; $this->_join = ' LEFT JOIN `'._DB_PREFIX_.'product_lang` pl ON (pl.`id_product` = a.`id_product`) AND pl.`id_lang` = " . $this->_lang. " LEFT JOIN `'._DB_PREFIX_.'tax` AS t ON t.`id_tax` = a.`id_tax` LEFT JOIN `'._DB_PREFIX_.'product_attribute`AS pa on (a.`id_product`=pa.`id_product`) LEFT JOIN `'._DB_PREFIX_.'product_attribute_combination` AS pac ON pac.`id_product_attribute`= pa.`id_product_attribute` LEFT JOIN `'._DB_PREFIX_.'attribute` AS atr ON atr.`id_attribute` = pac.`id_attribute` LEFT JOIN `'._DB_PREFIX_.'attribute_group` AS ag ON ag.`id_attribute_group` = atr.`id_attribute_group` LEFT JOIN `'._DB_PREFIX_.'attribute_lang` AS al ON (atr.`id_attribute` = al.`id_attribute`) AND al.`id_lang` = 2 LEFT JOIN `'._DB_PREFIX_.'attribute_group_lang`AS agl ON (ag.`id_attribute_group` = agl.`id_attribute_group`) AND agl.`id_lang` =2'; $this->_group="GROUP BY a.id_product, pa.id_product_attribute"; //les champs à afficher $this->fieldsDisplay = array( 'reference' => array('title' => $this->l('Reference'), 'align' => 'center', 'width' => 25), 'nom' => array('title' => $this->l('Noms'), 'align' => 'center', 'width' => 25), 'valeurs' => array('title' => $this->l('Valeurs'), 'align' => 'center', 'width' => 25), 'prix_achat' => array('title' => $this->l('Prix Achat'), 'align' => 'center', 'width' => 25), 'prix_vente_ht' => array('title' => $this->l('Prix Vente'), 'align' => 'center', 'width' => 25), 'rate' => array('title' => $this->l('Taux'), 'align' => 'center', 'width' => 25), 'prix_final' => array('title' => $this->l('Prix Final'), 'align' => 'center', 'width' => 25), 'marge' => array('title' => $this->l('Marge'), 'align' => 'center', 'width' => 25) ); parent::__construct(); } // /** * la methode pour afficher */ public function display() { global $cookie; $this->getList(intval($cookie->id_lang), !Tools::getValue($this->table.'Orderby') ? 'id_product' : NULL, !Tools::getValue($this->table.'Orderway') ? 'DESC' : NULL); $this->displayList(); } } ?>
  15. Bonjour à tous, Je vais essayer d'être plus explicite que mes derniers messages. j'ai définie 2 classe , l'une qui extend module et l'autre AdminPrix.php qui extend AdminTab. Dans ma classe j'ai définis les méthodes : display($token), displayList($token) dans cette méthode je fais appel à header puis content et enfin footer displayListHeader($token) cette méthode gère l'affichage de l'entête displayListContent($token) cette méthode gère l'affichage du contenu displayListFooter($token) cette méthode gère l'affichage du bas de page j'ai écris une requête que je voudrais mettre dans la méthode display() pour avoir reference_pdt, nom_pdt, valeurs de ces attributs, poid_pdt, prix_vente_ht, px_achat, tva, prix_vente_ttc, marge_brute j'ai testé ma requete sous easy et j'ai bien le resultat que je veux. j'ai essayé de mettre dans ma methode $sql='ma_requete'; $resul=Db::getInstance()->Execute($sql); je sais peut être qu'il y a dejà une methode dans AdminTab qui permet de le faire. Donc voilà en gros mon problème. Est- ce que quelqu'un a une autre idée?
  16. Bonjour à tous, Je cherche à développer un module prix. J'ai établi une requête qui me renvoi le résultat souhaité. J'ai codé une méthode display dans laquelle j'essaie de mettre ma requête, mais sa ne marche pas. Est ce que quelqu'un pourrait m'aider. Merci !!!!!
  17. Bonjour à tous; Je suis débutant avec prestashop. J'ai récupéré le tuto création de module I, j'essaie de l'appliquer mais j'arrive pas à afficher le résultat. J'ai créer le repertoire dans modules que j'ai nommé unmodule, dans lequel j'ai mis unmodule.php et unmodule.tpl. J'ai installé le module mais quand je charge la page le résultat n'apparait pas. Est-ce que quelqu'un pourrait m'aider. Merci.
  18. Bonjour, C'est la signification du trait continu entre les tables que je ne comprend pas. Merci.
  19. Bonjour, je suis débutant avec prestashop, j'ai récupérer le mcd sur ce site mais j'ai un peu de mal à déchiffrer les relations entre les tables. Est ce que quelqu'un pourrait m'éclaircir? Merci
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More