Jump to content

CHP

Members
  • Posts

    221
  • Joined

  • Last visited

Posts posted by CHP

  1. Buenas tardes,

     

    La plantilla que estoy trabajando no tiene ningun link asignado en el logo, es decir, no es posible pinchar en el, es simplemente una imagen.
    He mirado en el Header.tpl pero no he visto nada.

     

    Os dejo el codigo:

     

     

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="{$lang_iso}">
        <head>
            <title>{$meta_title|escape:'htmlall':'UTF-8'}</title>
            <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0">
    {if isset($meta_description) AND $meta_description}
            <meta name="description" content="{$meta_description|escape:html:'UTF-8'}" />
    {/if}
    {if isset($meta_keywords) AND $meta_keywords}
            <meta name="keywords" content="{$meta_keywords|escape:html:'UTF-8'}" />
    {/if}
            <meta http-equiv="Content-Type" content="application/xhtml+xml; charset=utf-8" />
            <meta http-equiv="content-language" content="{$meta_language}" />
            <meta name="generator" content="PrestaShop" />
            <meta name="robots" content="{if isset($nobots)}no{/if}index,{if isset($nofollow) && $nofollow}no{/if}follow" />
            <link rel="icon" type="image/vnd.microsoft.icon" href="{$favicon_url}?{$img_update_time}" />
            <link rel="shortcut icon" type="image/x-icon" href="{$favicon_url}?{$img_update_time}" />
            <script type="text/javascript">
                var baseDir = '{$content_dir|addslashes}';
                var baseUri = '{$base_uri|addslashes}';
                var static_token = '{$static_token|addslashes}';
                var token = '{$token|addslashes}';
                var priceDisplayPrecision = {$priceDisplayPrecision*$currency->decimals};
                var priceDisplayMethod = {$priceDisplay};
                var roundMode = {$roundMode};
            </script>

    {if isset($css_files)}
        {foreach from=$css_files key=css_uri item=media}
        <link href="{$css_uri}" rel="stylesheet" type="text/css" media="{$media}" />
        {/foreach}
    {/if}
            
        {if $LEO_SKIN_DEFAULT &&  $LEO_SKIN_DEFAULT !="default"}
        <link rel="stylesheet" type="text/css" href="{$content_dir}themes/{$LEO_THEMENAME}/skins/{$LEO_SKIN_DEFAULT}/css/skin.css" media="{$media}" />
        {/if}
        {if $LEO_PANELTOOL}
        <link rel="stylesheet" type="text/css" href="{$content_dir}themes/{$LEO_THEMENAME}/css/paneltool.css" media="{$media}" />
        {/if}
    {if isset($js_files)}
        {foreach from=$js_files item=js_uri}
        <script type="text/javascript" src="{$js_uri}"></script>
        {/foreach}
    {/if}
    <!--[if lt IE 9]>
    <script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->
    <link href='https://fonts.googleapis.com/css?family=Arvo:400,400italic,700,700italic' rel='stylesheet' type='text/css'>
        <script type="text/javascript" src="{$content_dir}themes/{$LEO_THEMENAME}/js/bootstrap.js"></script>
        <script type="text/javascript" src="{$content_dir}themes/{$LEO_THEMENAME}/js/custom.js"></script>
        
        
        {$HOOK_HEADER}
        </head>
        
        <body {if isset($page_name)}id="{$page_name|escape:'htmlall':'UTF-8'}"{/if} class="{if $hide_left_column}hide-left-column{/if} {if $hide_right_column}hide-right-column{/if}">
        {if !$content_only}
            {if isset($restricted_country_mode) && $restricted_country_mode}
            <div id="restricted-country">
                <p>{l s='You cannot place a new order from your country.'} <span class="bold">{$geolocation_country}</span></p>
            </div>
            {/if}
            <div id="page" class="{$LEO_BGPATTERN} {if $lang_iso=='fr'}frcss{/if} clearfix"><div class="page-container">

                <!-- Header -->
                            
                            <div  id="header" class="leo-header">    
                                <div class="container">
                                    <div class="row-fluid">
                                        
                                        <div class="span4">
                                            <a id="header_logo" href="{$base_dir}" title="{$shop_name|escape:'htmlall':'UTF-8'}">
                                                <img class="logo" src="{$logo_url}" alt="{$shop_name|escape:'htmlall':'UTF-8'}" {if $logo_image_width}width="{$logo_image_width}"{/if} {if $logo_image_height}height="{$logo_image_height}" {/if} />
                                            </a>
                                        </div>
                                        <div id="header_right" class="span8 pull-right">
                                            <div id="leo-mainnav" class="leo-mainnav">
                                                <div class="row-fluid">
                                                    {Hook::exec('topNavigation')}
                                                </div>
                                            </div>
                                            {$HOOK_TOP}
                                        </div>    
                                    </div>
                                        
                                </div>
                            </div>
                            {if $page_name =='index'}
                            <section id="slideshow" class="slideshow">
                                <div class="container">
                                    <div class="row-fluid">
                                        {Hook::exec('displaySlideshow')}
                                    </div>
                                </div>
                            </section>    
                            {/if}
                            {if $page_name !='index'}
                            <section id="promotetop">
                                <div class="container">
                                    <div class="row-fluid">
                                        {include file="$tpl_dir./breadcrumb.tpl"}
                                    </div>
                                </div>
                            </section>
                            {/if}
                            
                            <div  id="leo-maincontainer">
                                <div class="container">
                                    <div class="row-fluid" >
                                    
                                        
                                    
                                    <!-- Center -->
                                    <div id="leo-centercol" class="span9">
                                        <div id="center_column">
        {/if}

     

    Gracias!!

  2. Buenas noches,

     

    Estoy trabajando sobre esta plantilla de Leo:

    http://www.leotheme.com/prestashop/themes/200-leo-tshirt.html

     

    Demo: http://www.leotheme.com/demo/prestashop14x/?template=leo_tshirt

     

    Bien, si os fijais en el Slider, las imagenes las hace transparentes, lo que a su vez hace que deje ver esas gotas de pintura.

    Llevo casi 3 horas dandole vueltas el Slider y al tema en general, y he llegado a la conclusion de que la imagen esta en el propio Slider, es decir, no es algo que se quite desde el global.css. Desde el global.css he quitado todas las demas gotas de pintura que aparecen por el background, pero esas del fondo del Slider, va a ser que no.

    He revisado a fondo el codigo del Slider. Lleva varios archivos .js y .css, pero no hay nada, no hay ninguna ruta de donde cargue esa imagen, al igual que esa imagen tampoco esta en ningun sitio.
    Incluso he hecho comparaciones con otro Slider tambien de Leo, para ver si encontraba las diferencias en cuanto a la opacidad de las imagenes o la ruta de esa imagen, pero nada de nada, la mayoria de los archivos entre ambos Slider son iguales.
    Es desesperante...

     

    Me gustaria, o bien quitar esa imagen, o bien que las imagenes no sean transparentes para que no se vea la imagen de fondo, pero nada, no hay forma.

    ¿Alguna ayuda?

     

    Gracias!!

  3. Buenos días compañeros.

     

    Estoy trabajando en esta plantilla:

     

    http://www.leotheme.com/demo/prestashop14x/?template=leo_sportshoes

     

    ( http://www.leotheme.com/prestashop/themes/216-leo-sportshoes.html )

     

    Como vereis, tiene un fondo que se repite, concretamente este codigo:

     

    body{
        color: #222;
        background-image: url('../img/bg_background.png');
        font-family: 'Source Sans Pro', sans-serif;
        font-size: 14px;

     

    Lo que quiero es dejarlo como muestro en la imagen. Basicamente quiero toda la zona central de un color y los laterales en otro, o con un fondo. El problema es que no tengo claro como dejar la zona central, es decir, todos los bloques en un color, para que al poner el fondo no lo cubra todo.

     

    Espero haberme explicado bien.

    Muchisimas gracias.

    post-695665-0-48839400-1389956305_thumb.jpg

  4. Buenos días.

     

    En referencia a este hilo, he abierto este actual para comentar que, a pesar de que la base de datos funciona bien (ventas, clientes, productos etc), ahora no se ven las imagenes, simplemente me carga una imagen de un interrogante. Me estoy fijando en la ruta donde deberian estar, y es completamente diferente a donde estan actualmente.

    No puedo copiar y pegar de una carpeta a otra y solucionarlo, ya que segun veo, algunas estan en img/p/1 etc otras en p/1/4... y asi sucesivamente.

    Son unas 2000 imagenes y la actualizacion la estoy haciendo en local. ¿Puede ser algun tipo de problema con permisos de escritura o solo lectura de algunas carpetas? ¿O simplemente al cambiar la base de datos de PS 1.4 a 1.5 y ademas con otra plantilla nueva la ruta anterior de las imagenes ya no sirve? Me parece un poco extraño porque hasta donde yo se, al actualizar, no se pierden las rutas de las imagenes...

     

    Muchisimas gracias.

  5. Buenas tardes amigos.

     

    Vereis, tenemos una tienda en 1.4 y queremos actualizar a 1.5, concretamente a la version 1.5.4 porque la plantilla que tenemos preparada solo funciona en esa version concretamente, 100% comprobado, en la 1.5.6 da muchos problemas y en 1.5.4 funciona rendonda.
    Bien, desde el BackOffice de la version 1.4 no podemos actualizar porque nos actualiza a la ultima version de PS, y como ya he comentado, no nos interesa.
    Entonces, ¿que solucion hemos pensado?

    Hemos pensado en hacer la siguiente prueba:

     

    Crear una carpeta en el hosting llamada "tiendanueva" (por ejemplo) y ahi dentro meter PS 1.5.4. Instalar, y seguidamente activar la nueva plantilla. Hasta aqui todo correcto, ¿no?
    Bien, pues el problema que hemos pensado que puede surgir, es a la hora de conectar con la base de datos de la tienda en 1.4, ya que, existen diferencias entre la base de datos de una tienda 1.4 a otra en 1.5, ¿cierto?

    En estos momentos hay 2000 productos y un buen puñado de clientes.

     

    ¿Podemos conectar con la base de datos antigua 1.4 asi como asi? En caso negativo, ¿como podemos migrar todo de una base de datos a otra (de 1.4 a 1.5)?
    Estubimos probando modulos para exportar la base de datos, pero siendo sinceros, de 4 modulos que probamos, los 4 era una basura.

    ¿A alguien se le ocurre una solucion en caso de que no sea posible conectar directamente la base de datos?

    En resumidas cuentas, queremos tener PS 1.5.4 funcionando con la base de datos de la tienda 1.4.

    Un millon de gracias anticipadas.

  6. Buenas tardes compañeros,

     

    ¿Existe algun modulo que se encargue de cambiar precios de manera automatica en cierto dia o a cierta hora?

     

    Ejemplo: Queremos bajar de precio 100 productos durante 48h, y una vez finalizadas las 48h, lo mas logico seria poder cambiar esos 100 precios de golpe a su precio inicial.

    ¿Alguna idea?

    Muchas gracias anticipadas.

  7. Soy experto en irme a lo mas difícil cuando lo mas sencillo esta delante de las narices.

     

    Te debo una Felix. Problema resuelto!

     

    De todas formas, antes de dar esto por solucionado, ¿no podría cambiar o eliminar el resto? Al configurarlo a 12, el resto siguen ahí, 10, 20, 50...

     

    Thanks

  8. Buenas tardes amigos.

     

    Estoy trabajando en local una plantilla donde puedes elegir el tipo de vista y numero de productos, sin embargo estan especificados en grupos de 10, 20 y 50, y el problema surge cuando seleccionas la vista en cuadricula, que al ser filas de 3, pues abajo del todo siempre queda un articulo suelto. Me gustaria ponder cambiar a 12, 24 y 48 por ejemplo, asi siempre tendria filas completas de 3 productos.

     

    He estado mirando todos los .TPL, pero no localizo donde cambiar estos valores. He llegado ha encontrar la opcion de la izquierda, donde te deja seleccionar como quieres ver los productos (por precio, etc), pero no hay rastro de la opcion del numero de productos visualizados.

    Estoy desesperado ya.

     

    Gracias anticipadas compañeros.

     

    PD: Os dejo un pantallazo.

    post-695665-0-08475800-1387378432_thumb.jpg

  9. Buenas tardes:

    Descargue e instale la nueva versión 1.6.0.1 parece bastante bien, estuve probando y al tratar de cambian las imágenes de publicidad que se encuentran el modulo "Theme configurator" me sale una pagina en blanco con el siguiete error:

     

    [PrestaShop] Fatal error in module themeconfigurator:

    Call to undefined method ThemeConfigurator::_deleteImages()

     

    Me imagino que es por ser una version Alpha, alguien ha tenido el mismo problema?

    En espera de vuestros comentarios.

    Saludos.

     

    Acabo de probarlo y me ocurre lo mismo.

     

    Supongo que debe ser uno de tantos detalles de una versión Alpha, jeje.

  10. Buenos días,

     

    Estoy teniendo muchos problemas con los permisos de las carpetas. No puedo acceder a las traducciones del CMS, ni tampoco puedo subir el logotipo desde el BO, ya que me aparece este error:
     

    Se produjo un error durante la copia del logotipo

     

    He revisado los permisos y están como se supone que deben estar, pero sigo teniendo problemas.

     

    ¿Alguna idea? Estamos a punto de migrar de servidor, pero queríamos resolver unos temas antes de la migración.

     

    Muchas gracias.

  11. Muchas gracias a los dos, efectivamente me sobraba un if. Ya funciona :)

     

    En cuanto a los warning, también los reparare, ya puestos pues lo arreglo y listo.

     

    Por cierto, tengo curiosidad, ¿existe otra forma de extender el footer y además la barra de reaseguros?

     

    PD: Estoy probando otro modulo de footer, concretamente el lof advance footer, y es increíble.

    PD2: La ultima pregunta que he realizado no tiene importancia, doy el tema por solucionado, y de nuevo mil gracias, sois los mejores.

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More