Jump to content

Atout

Members
  • Posts

    23
  • Joined

  • Last visited

Profile Information

  • Location
    CH
  • Activity
    User/Merchant

Atout's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. Find out - PS version incompatible with PHP version. Downgrade PHP version solved the question.
  2. Hello, I have a challenging project to upgrade website currently running version PrestaShop 1.5.4.1 with StoreCommander 1.3.4 over PHP 5.6 and mySQL 5.7. Ideally, I would like to end with latest PS 1.7 and StoreCommander (compatible with PS 1.7.6) over PHP 7.4. I'm looking for an informed plan respecting compatibilities between versions to move up with updates of different pieces. Are there any issues with database tables when updating PS majors versions and at what version it happens? Already, I know that moving to PHP 7.0 first does not work PS. Then, should I first upgrade PS each version step by step? What highest PS version still work with PHP 5.6 and would be compatible with PHP 7.0 when I switch to it? Which highest PHP version still compatible with PS 1.7? What PHP version I shouldn't move to and avoid issues with PS? For those who know StoreCommander, do I need any major steps updating from 1.3.4 to the latest? Are there any intermediary versions mandatory to maintain compatibility? I thanks everyone for your recommendations to set up my migration plan.
  3. Bonjour, Mon hébergeur Infomaniak, me fait changer de serveur pour une machine plus performante avec des outils à jour. L'étape intermédiaire de la procédure est un nom de domaine transitoire pour les testes. En //, je regarde la procédure Prestashop de mogration suivante: http://doc.prestashop.com/pages/viewpage.action?pageId=12943372#Guidedel'administrateursystème-DéplacerPrestaShop Dans le point 4.b du chapitre "Déplacer PrestaShop vers un nouveau serveur", il faut changer le domaine et le domaine SSL à la page "SEO & URLs" du menu "Préférences", la section "Configuration des URL". L'enregistrement du domaine transitoire ne se fait pas. J’accède bien le back-office transitoire - il y a un message que mon domaine diffère de celui de page "SEO & URLs" - et quand je les modifie et enregistre, c'est la page blanche ?! Je reviens sur la page principale du back-office et rien a change avec le domaines. Le points 4.a et 5 de la procédure sont aussi faits. Comment faire svp? Sinon, la prévisualisation me renvoie sur mon domaine d'origine. Du coup, impossible de tester le nouveau serveur et le domaine transitoire n'affiche pas mes pages migrées. Je vous remercie de votre aide.
  4. Hello, I did both your recommendations (debug and cache), thanks for answering. Unfortunately, I get no tip about errors neither on Prestashop nor on Prestashop forge (google search gets no results). I have 2 following errors - 1st comes on any page, 2nd is specific to the authentication blanc page. Any idea how to solve the 2nd? ... Strict Standards: Declaration of Tools::ps_round() should be compatible with that of ToolsCore::ps_round() in /home/www/5a1f16fb99d113457192b51868e4a541/web/boutique/override/classes/Tools.php on line 32 Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home/www/5a1f16fb99d113457192b51868e4a541/web/boutique/controllers/front/AuthController.php on line 364 .... Thanks.
  5. Hello, Until moving from from v1.5.6.3 to v1.6.1.4, I used 1-Click upgrade with success. Now on v1.6.1.4, my account access is a white page - the link to .../fr/authentification?back=my-account - points to a blanc page, also on the default theme. Could you please help me how to troubleshoot this issue? Other front- and back-office functions work fine and the DB is ok having all customers records. Also, my host configuration conforms the upgrade requirements. Thanks for you help. Salut, Jusqu'à ma màj de v1.5.6.3 to v1.6.1.4, j'utilisais 1-Click upgrade avec succès. Sous v1.6.1.4, la connexion au compte client est une page blanche - le lien .../fr/authentification?back=my-account - pojnte sur une page vide, et ceci même sur le thème par défaut. Pouvez-vous svp m'aider à corriger cette erreur? Le reste de front- et back-office fonctionne et la BD contient tous les enregistrements clients. Aussi, mon serveur d'hébergement est conforme aux recommandations de la misa à jour. Merci pour votre aide.
  6. Bonsoir, 1- infos versions ci-dessous 2- je parle d'affichage FO 3- si je désactive ce module ma catégorie n'affiche/liste plus rien merci pour un conseil. Version de Prestashop: 1.4.9.0 Informations sur votre serveur: Linux #1 SMP Mon Jul 15 08:36:46 CEST 2013 i686 Version du logiciel serveur: Apache/2.2.16 (Debian) Version de PHP: 5.3.3-7+squeeze15 Version de MySQL: 5.1.66-0+squeeze1
  7. Comment obtenir le bon affichage de mes produits? La page d'accueil de ma boutique devrait afficher 2900 produits de ma BD. La liste mentionne 248 pages à 12 produits p.p. et ma navigation par facettes (blocklayered) en liste autant. Quand je sélectionne la dernière page (p.248), je suis envoyé à la page 97 et le nombre total de produits tombe à 1134. Pourquoi? Comment et où modifier cette limite pour avoir toutes les pages et tous les produits? Sur conseil, je tente d'indexer les URL et attributs dans le module 'blocklayered' et je tombe sur l'erreur suivante: DROP command denied to user 'User1'@'localhost' for table 'ps_layered_friendly_url' TRUNCATE ps_layered_friendly_url Aidez-moi svp.
  8. Bonjour, Est-il possible et comment faire fonctionner la navigation à facettes dans les sous-catégories? Par défaut, celle-ci fonctionne avec les catégories principales (hommes p.ex.) mais dans la sous-catégorie (hommes-manteaux p.ex.) cette navigation n'est plus visible alors que j'aimerais encore donner la navigation de tailles ou de couleurs. Merci pour vos conseils.
  9. C'est une erreur SQL, forcer une clé primaire (insérer 2x la même). Remplace INSERT par REPLACE Voire, ajoute ON DUPLICATE KEY UPDATE id=id en fin de l'INSERT
  10. Bonjour, Pour mes produits, j’ai des déclinaisons dont un attribut (la taille) est donné en l’une de 2 unités de mesure soit cm et soit in. Dans la navigation à facettes, j’aimerai organiser la recherche facile par taille équivalente i.e. afficher en même temps les produits de 2.54 cm et 1 in. De base, il faut cocher les deux valeurs pour filtrer et afficher l’ensemble des déclinaisons. Pas facile de calculer à chaque fois les multiples pour 3 in ou 4 cm, etc. Alors, je veux proposer un regroupement d’office par valeurs équivalentes « 1 in et 2.54 cm », « 0.79 in et 2 cm », « 2 in et 5.08 cm », etc. (Bien sûr, vous ne me proposez pas de tout convertir en une seule unité, la question n’est pas là.) J’ai voulais faire simple, filtrer par sous-catégories ou caractéristiques mais ni l’un ni l’autre s’appliquent aux déclinaisons. Dommage ce serait bien efficace. J’ai essayé aussi d’utiliser un attribut en plus de la taille pour le regroupement. Dans la navigation à facettes, c’est ce qu’il me faut. Par contre, j’aimerai que cet attribut n’apparaisse pas dans le détail d’un article car il fait alors double emploi avec la taille (il faut sélectionner la taille et le groupe), un peu lourd. - Avez-vous des idées si comment solutionner ma situation ? - Voire, y-a-t-il un module de navigation à facettes qui permet de synchroniser 2 échelles de valeurs/mesure en un groupe ? Merci.
  11. J'aurai exporté les produits et les déclinaisons pour changer les ID dans XLS puis importé le tout en écrasant les vieux (option dans l'import). Attention aux photos, je ne crois pas que l'on puisse refaire les liens avec les existants, à tester avec un produit en mettant l'URL de la photo actuelle (http://www.monsite.com/img/p/2/8/28.jpg). Sinon, bien marquer dans le CSV de les purger et mettre les nouveaux URLs (bien sûr avant d'en faire la purge, faire une sauvegarde FTP en local de toutes les photos s'il n'y a pas de back-up).
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More