Jump to content

abroucek

Members
  • Posts

    59
  • Joined

  • Last visited

Everything posted by abroucek

  1. Hi guys, I have found a solution... it uses Block Cart module... I have created a new hook with help of this post and then I hooked the module Block Cart to my new hook and to be able to change the template especially for my new hook (to remove checkout button, make the product name longer) I copied the tpl file and named it blockcart-payment.tpl and in its php file I put this code: function hookdisplayCartSummary($params) { if (Configuration::get('PS_CATALOG_MODE')) return; // @todo this variable seems not used $this->smarty->assign('order_page', strpos($_SERVER['PHP_SELF'], 'order') !== false); $this->assignContentVars($params); return $this->display(__FILE__, 'blockcart-payment.tpl'); } I hope I helped... its not the original cart like on the order page but you can change the design in the tpl and css
  2. I am also looking for this solution... Anyone knows?
  3. On my Module page the Upgrade button is not appearing I want to update my prestashop from 1.5.5. to 1.5.6 with 1-Click Upgrade and the pre-upgrade checklist table it says the module is not up to date (my version is 1.1.7)... where can I download 1.1.8?
  4. Today, I needed to do the same thing and by trying I found out how to do it and I want to share it with others... First thing you should do is to try that thickbox is working on the page you want to have a video in, if it is not, first thing is to get it working - linked topic helped me to solve that If it works properly now you have to use following code to link to youtube video which will be shown in thickbox <a class="thickbox iframe" href="http://www.youtube.com/embed/q4a9CKgLprQ?autoplay=1&hd=1">Text</a> Please note how the link in href attribute is written... http://www.youtube.com/embed/youtubevideocode Following attributes like autoplay or hd are not necessary That's it Hope it helps
  5. Když ponechám adresu vygenerovanou automaticky TinyMCE, tedy tu absolutní, tak se obrázek v FO nezobrazí (obrázek nenalezen), proto musím právě vždy ručně umazat část té vygenerované cesty (udělat z ní relativní), aby se obrázek v FO zobrazil
  6. Zdravím, nevěřím, že by se tento problém v minulosti neřešil, každopádně jsem ale jeho řešení nenašla. Mám problém s TinyMCE - nahraju obrázek a když ho chci vložit, tak se mi jako cesta k obrázku zobrazí automaticky absolutní adresa (http://doména.cz/opt/php5/další_složky/obrázek.jpg). Aby se pak obrázek v návrhovém okně TinyMCE zobrazil, musím ručně smazat část cesty, aby byla relativní. Kde změnit, aby se přímo zobrazovala relativní cesta k obrázku? Děkuji za info.
  7. I have 1.4.7 and I had to use the code written here by ecoloures and it helped! Thank you very much!
  8. Wow a to jsem řešení na foru opravdu hledala Díky Pro ostatní, je to jednoduché... V souboru classes/Link.php je potřeba změnit funkci public function getCatImageLink($name, $id_category, $type = null) původní část kódu této funkce __PS_BASE_URI__.'c/'.$id_category nová část kódu __PS_BASE_URI__.$id_category Upravený soubor uploadujte a refreshněte eshop... tadá, fotky kategorií jsou tam
  9. Zdravím, na verzi 1.4.7 pracuji na novém eshopu a nefungují mi správně friendly url pomocí generování v administraci. Při jejich zapnutí vše funguje správně, pouze obrázky kategorií se nezobrazují (před zapnutím friendly url je vše v pořádku, zobrazují se). Obrázky produktů fungují správně. URL obrázku kategorie před zapnutím přátelských url: /img/c/7-medium.jpg URL obrázku kategorie po zapnutí přátelských url: /c/7-medium/nhfgnhfgn.jpg Do přílohy ještě přikládám kopii svého .htaccess, ale je to ten výchozí z Presty, nijak neupravovaný. htaccess.TXT
  10. V Doprava => Země změň zelené fajfky pod Aktivováno u všech zemí, které tam nechceš
  11. Oh yes, tomm is the last day of february... when is it gonna be ready for business? thank you
  12. Hi, so today I had time to try it again. I downloaded revision 13370 from svn, installed it and created 2 new subcategories in Ipods category. I checked the front office and the result is same with new revision, new installation. There is no list of subcategories before products listed in parent category page (Ipods). I am not attaching a new image because the outcome is still the same The image I attached is showing what is supposed to be (the image was taken from demo here on prestashop.com) I checked it in Firefox and IE, but no difference. How can I help?
  13. I just made two subcategories and moved few products so the created subcategories have product assigned, that's it. I did not do anything else. :-( The code for showing that is there but it is not shown... This weekend I will have time to try new revision and I will let you know if it works in the new one... Thank you anyway
  14. I have version 1.5.0.5 from svn downloaded yesterday, using default theme. Im testing 1.5. I made two subcategories to category Ipods (which was already created after instalation) but when I click on category Ipods in front-office it does not show the list of subcategories of Ipods I made. I checked category.tpl, there is code for that (as it was in older versions, it should be showing subcategory image, if it exists, subcategory title and description if it exists. But it doesnt show them at all even the subcategories exists (they are shown in categories in the left column). There are products assigned to those two subcategories. Do I have to check something in admin to allow that? I haven't found anything. Can you try that, please? Is it a bug or I'm just doing it wrong. Thanks. PS: to be clear, there is a picture attached
  15. Vím, o čem mluvíš, ale tohle není ten problém, obrázky se jinde zobrazují, jen při zvolení kombinace ne (mám i produkty bez kombinací a také defaultní obrázek k produktům s kombinací se zobrazuje...) Nikdo se s tím ještě nesetkal?
  16. Zdravím, mám eshop s textilem, kde by měl být k barvě přiřazen obrázek daného produktu v dané barvě. Ještě nedávno vše fungovalo jak má, ale teď už ne. Snažím se přijít, kde může být chyba. V databázi jsem se dívala, v tabulce _image jsou obrázky tak, jak mají být, stejně tak jejich přiřazení v _product_attribute_image. Když se ale na produkty podívám přes BO, na kartě Obrázky tam jsou všechny obrázky zobrazeny, které k produktu patří, ale na kartě Kombinace jsou opět všechny kombinace, jak mají být, ale nejsou k nim přiřazeny žádné obrázky (tzn. v tabulce je uvedeno Obrázek - žádný), ale přitom v databázi je atribut s obrázkem propojen... Nesetkal jste se s tím někdo? Děkuji.
  17. When are you going to post new version of this module? I would really appriciate to get this module to be faster... I cannot use it now because I have thousands of products and it is very very slow to show product page... I have tried the code that Sergey put here but I cannot get it to work. Thank you for your help.
  18. Zdravím, potřebuji na stránku detailu produktu přidat textareu, do které by mohl zákazník napsat svůj text a ten by se pak uložil a zobrazoval s produktem v objednávce. Našla jsem placené řešení více méně dle mých představ a chtěla bych se zeptat zkušenějších programátorů, zda stojí za to si toto řešení koupit (40 USD, pouze návod, co a v jakých souborech změnit, nejedná se o modul) a nebo se jedná jen o úpravu pár řádků. Odkaz na zmiňované řešení Děkuji za názor.
  19. Tento modul pro verzi 1.2.5 je zde úplně dole: http://www.prestashop.com/forums/viewthread/2451/P90/third_party_modules/tools_url_rewriting__maj_1_dot_2 Když se ale snažím něco vytvořit nebo přidat pravidlo napíše mi to při Create... An error occurred while creating rules for all products při přidání pravidla An error occurred while adding the rule čím to je? dělalo to někomu taky? vyřešili jste to?
  20. Zdravím, u objednávek s hodnotou vyšší 500 Kč mám nastavenu dopravu zdarma. Ale v praxi to nefunguje. Do přílohy přidávám nastavení + screen z objednávky, kde je hodnota objednaného zboží nad 12 000 a přesto se započte i doprava (i na faktuře). Mám pouze jednoho dopravce - PPL. Mám něco špatně nastavené? Děkuji.
  21. tak snad už to mám vyřešeno... je nutné provést následující úpravy v product-sort.tpl přidat do selectu {l s='reference'} do product-sort.php doplnit orderByValues o tu sedmou část $orderByValues = array(0 => 'name', 1 => 'price', 2 => 'date_add', 3 => 'date_upd', 4 => 'position', 5 => 'manufacturer_name', 6 => 'quantity', 7 => 'reference'); a pokud chcete mít řazení dle reference i jako defaultní a nastavit to přes BO, tak je třeba upravit AdminPPreferences a do array(...) na řádku 48 přidat následující řádek array('id' => '6', 'name' => $this->l('Reference')), to by mělo být vše... snad to pomůže dalším
  22. podle toho jsem to taky dělala ;o) mám to jak v product-sortu, tak v AdminPPreferences, v BO je nastaveno defaultně řazení dle reference, ale řešení na můj problém, že při výběru v selectu to neudělá to, co má, tam nevidím...
  23. Takže tam jsem to přidala taky. Když rozkliknu kategorii, řazení dle kódu funguje, ale v nabídce Třídit dle: ... není označeno "reference", ale "nejprve výrobky skladem". Vypadá to, že v tom product-sortu to nějak ignoruje a nepracuje s tím. Když vyberu v Třídit dle: reference, tak se stránka obnoví a v tom selectu se vybere překvapivě dle "názvu od A do Z". Byla by další rada? Ten kód výše v prvním příspěvku je napsán správně, že?
  24. Zdravím, chtěla bych, aby bylo možné řadit produkty nejen podle názvu, ceny a zda jsou skladem, ale chci přidat možnost řazení podle kódu, tzv. reference. Do product-sort.tpl jsem vložila do selectu následující kód {l s='reference'} Nová možnost řazení se zobrazí, ale při kliku se zboží správně neseřadí a automaticky se seřadí podle defaultního nastavení (v mém případě název). Kde je třeba ještě něco doplnit, aby bylo možno přidat toto příp. další možnosti řazení? Děkuji.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More