Jump to content

Jurist

Members
  • Posts

    150
  • Joined

  • Last visited

Everything posted by Jurist

  1. Hello, We are PS a 1.7.6 user. Our ERP will synchronise stock of combinations. In case the combination is not in stock, we would still allow the customer to buy, he would only have longer delivery time (alternative source). At the moment we have Enable stock and Allow ordering out of stock products enabled. However with quantity 0, attributes cannot be sold, as the add to cart button is disabled and there's Product available with different options message. Is there a way to allow the customers to order attributes that are not in stock? Thanks
  2. @202 ecommerce could you help me on fixing the issues related to PayPal module for PS 1.7 please? We use latest PayPal module 5.4.4 and we have PS 1.7.6. We get the following errors with PayPal module enabled: shortcut.js?v=5.4.4:formatted:86 Uncaught TypeError: prestashop.on is not a function at Object.init (shortcut.js?v=5.4.4:formatted:86) at waitPaypalIsLoaded (duschrinne-wiper-premium-600-mm-ponente:3180) and another error: Uncaught ReferenceError: jQuery is not defined at jquery-migrate-1.2.1.min.js:2 It is caused by PayPal JS being loaded too high in the site, before prestashop object is initialised. Is there a way to push the PayPal to the bottom of the list of the loaded items? I think this would resolve both problems. Thanks
  3. Thank you for your effort @musicmaster, however looks like you didn't understand what the problem is. With mollie module enabled, bots were creating accounts in our store (which was triggering new account emails). We have decided to make around to that and edited CustomerPersister.php so it blocks account from being created if the account has the characteristics of account being created by bot. Thanks
  4. We created a workaround to this. Now popup opens when someone clicks paypal/amazon button and there's more information there. If cart is empty, the button shows notification to add products to shopping cart. If cart is not empty, it opens a regular paypal checkout (the same as in cart/login page). Hopefully this will sort out the issue. However we are facing another problem now. Sometimes when the page is refreshed, PayPal button is just not loaded. No idea why this is happening, we also do same integration for amazon pay and all works great. It happens that the button is not displayed until I press ctrl + F5. What could be the reason of that happening? maybe I should move the module to the very top or very bottom in the hook list? Can it be caused by cache module?
  5. I am sure it can be done, but the paypal integration would need to be done the other way, without iframe. I guess we will need to work on some kind of workaround then. Thanks for your reply though.
  6. I mean, with Mollie module enabled, those bots are creating accounts, sometimes hundreds per hour. When new account is created, the customer received an email confirming that, and that's the spam I am talking about. The problem we have now, is that only with Mollie enabled, those bots are creating new accounts. If we are unable to find solution to that, I will just add an override, blocking new account creation if company of the new account is 'google'
  7. Hello, We have PS 1.7.6 store operating in netherlands with Mollie as main payment method. We use the official payment module downloaded from github. The problem with module is, that with it enabled it sends SPAM to customers. See attached image. It happens only with module enabled. In addition to that, the logs show that it is Mollie script that is used to send spam. At first I thought its a hosting or store issue, but after moving to another hosting the issue persists, therefore it's 100% caused by the module. The logs are showing the following script is sending spam (only with mollie enabled): /home/mydomain/domains/mydomain.tld/public_html/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/SimpleMailInvoker.php:34 The thing all those accounts have in common is that they all use "google" as the company name. How do we fix this?
  8. @CedCommerce Team are you owner of the module? Would paid modification be an option? The store we created is starting to perform better and better, however the owner is still reporting problems with Mollie payments.
  9. I have exactly the same problem, prestashop 1.7.6 Did you manage to fix it @pimpyourbottle2?
  10. Hello, We have PS1.7 store and problem with webservice. When we open: https://mydomain.com/api/ the prompt asks for username and password, we type API KEY generated into the back office into username field, password remaing empty, however nothing happens, the store just asks for those credentials again. when we try to access: https://mydomain.com/api?ws_key=MYAPIKEYHERE we can see a response. I tried adding .htaccess to /webservice folder, however it doesn't help. Store runs PHP 7.3 with cgi interpreter. How do we fix that? At the moment no API connection to the store is possible.
  11. I see how it works. Would in such case be possible to use shopping cart behaviour on product page? When someone clicks Pay with Paypal, it first executes add to cart and then opens standard PayPal checkout window. In fact, I tried to do it myself, but it seems to be impossible since PayPal button is displayed in an iframe and because of samesite policy it is impossible to execute events on elements displayed in iframe from another domain. Do you offer customisation for that?
  12. Hello, We use Prestashop 1.7 with latest PayPal module version. There is PayPal buy now button right next to the shopping cart on our product page. The only problem is, it removes products existing in cart before opening checkout. Example: 1. Customer has ProductA, ProductB, ProductC 2. goes to product page of ProductD 3. Clicks on add to cart on ProductD page. 4. Cart is emptied, checkout is opened only with ProductD. Is there any way to stop PayPal from removing products from shopping cart? I've noticed that PayPal button during checkout works perfectly fine. It created PayPal express window with all the products that were in shopping cart.
  13. Obviously it's not the default behaviour of payment modules, since we integrated many and it's the first module using that model.
  14. Hi. Mollie module for prestashop creates an order at the time person is taken to the payment page. Is there a way to change that? so the order is created only when the payment is done? We are losing multiple sales every day because of that, people can't return to their shopping basket to change the goods/addresses.
  15. Hello, Do you have any recommended warehouse program for Prestashop 1.7 that operated within the UK? We only have some requirements: - WMS available - availability to join products into packs, - integration wtih Prestashop 1.7. telling which program you use and if you are happy with it could help us a lot. Many thanks ☺️
  16. Jest problem z dopasowaniem wyszukiwania do wyników. Np. po wpisaniu "siemianowic" pojawia się chorzów, zamiast siemianowice. Po wpisaniu całej nazwy miejscowości jest ok, ale może dałoby się jakoś zrobić żeby wyszukiwało by po kilku znakach wpisanych? Ogólnie moduł świetny jak na to że jest darmowy. Wybór opcji modal zepsuty.
  17. Hello, We have a problem with loading times of category pages of products with many attributes (close to 2000). While we know that it is not recommended for products to have so many attributes, this is requirement of customers and we can't change his mind. We tried reducing the amount of products on category pages which is obviously less than ideal. Is there some option or module that allows not loading attributes on category pages? How to solve the problem? Maybe some cache attribute would help with the issue. Thanks
  18. Module generates items with price being <g:price>0 EUR</g:price> instead of the actual price it has. Only part of the items seem to be generated with incorrect price. There doesn't seem anything in common between those products. Anybody knows the soltution for that?
  19. We are going to install the module and test it soon. Can we use that module in a store that we are creating for our customer? thanks
  20. any chance this will be updated for PS 1.7? I have paid for 2 similar modules for my customers, disappointed with both.
  21. I've created a module that adds a link to marketplace on product page (for example to amazon or eBay). It adds a tab to back office, after accessing that tab you see it's AdminController who handles the form and saving the link (url, name, type, related product) to database. It all works well. However now I need to create a different link for different language. I've created appropriate _lang database, however despite this, when I try to save new object, it says Property Mwrmarketplacebuttons->mwr_content is empty. That's the field that needs to be translated. So far I've added: public function __construct() { $this->bootstrap = true; $this->table = 'mwrmarketplacebuttons'; $this->className = 'Mwrmarketplacebuttons'; $this->lang = TRUE; $this->bootstrap = TRUE; $this->addRowAction('edit'); $this->addRowAction('delete'); $this->context = Context::getContext(); and my input looks like that: 'input' => array( array( 'type' => 'text', 'label' => $this->l('Button URL'), 'name' => 'mwr_content', 'id' => 'mwr_content', 'lang' => true, 'size' => 33, 'desc' => $this->l('Full listing address. Example: https://amazon.com/your-listing-url'), 'required' => true ), my sql for lang table: Db::getInstance()->Execute(' CREATE TABLE IF NOT EXISTS `'._DB_PREFIX_.'mwrmarketplacebuttons` ( `id_mwrmarketplacebuttons` int(11) NOT NULL AUTO_INCREMENT, `mwr_button_type` int(11) DEFAULT NULL, `mwr_content` varchar(5000) DEFAULT NULL, `mwr_product` int(11) DEFAULT NULL, `mwr_product_name` varchar(5000) DEFAULT NULL, `mwr_status` int(11) DEFAULT 0, `active` int(11) DEFAULT 0, PRIMARY KEY (`id_mwrmarketplacebuttons`) ) ENGINE='._MYSQL_ENGINE_.' default CHARSET=utf8'); Db::getInstance()->Execute(' CREATE TABLE IF NOT EXISTS `'._DB_PREFIX_.'mwrmarketplacebuttons_lang` ( `id_mwrmarketplacebuttons` int(10) unsigned NOT NULL, `id_lang` int(10) unsigned NOT NULL, `mwr_content` TEXT DEFAULT NULL, PRIMARY KEY (`id_mwrmarketplacebuttons`,`id_lang`), KEY `id_mwrmarketplacebuttons` (`id_mwrmarketplacebuttons`) ) ENGINE='._MYSQL_ENGINE_.' default CHARSET=utf8'); anything else I need to change to make it work? When I add new button it looks good, but it doesn't save it. Picture attached. Help appreciated.
  22. Hi Rod, That's what default PS alias functionality does. If someone types "blouse" you see search results matching "blouse" keyword. Without any alias, if someone types "blous" there are no results since it's not matching anything. However if you add alias "blous" -> "blouse" in back office, when someone types "blous" he sees search results as if he typed "blouse". I tested it and it was working, however it was not quite the functionality I wanted. Maybe I should add wildcard option with redirection to my module, for example you could add search query: "%blous%" that would match any query with "blous" keyword inside, that would either show search results for another keyword "blouse" for example or redirect to specified site. If someone was interested I may add that. Kind regards
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More