Jump to content

TomGla

Members
  • Posts

    15
  • Joined

  • Last visited

About TomGla

  • Birthday 07/25/1988

Profile Information

  • Activity
    Web development agency

TomGla's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. Bonjour à toutes et à tous, Après avoir testé les modules Programme de parrainage et Programme de fidélité, j'ai remarqué que les bons de réductions générés étaient en hors taxe. Or, dans la configuration du module parrainage par exemple, rien n'annonce que le Montant du bon de réduction est en HT. Les clients se voient donc obtenir 1€ de plus pour un bon de réduction de 5€. Ce problème est également présent sur le module Chèque cadeau: http://addons.prestashop.com/fr/prix-promo-modules-prestashop/2376-bons-cadeaux-bons-de-reduction.html Est-ce une logique PrestaShop ou un défaut de celui-ci? Ma version de PS actuelle: 1.5.5.0 Merci d'avance pour votre aide.
  2. Est-ce que vous pouvez m'expliquer pourquoi PrestaShop vend alors un module afin de mettre les e-commerces PS conforme à la loi Hamon? 150€ T.T.C. (même si c'est écrit en tout petit), c'est le deuxième prix le plus élevé des modules "Hamon" et ce n'est pas comme si nous étions obligés de l'acheter sous peine de ne pas être conforme à la loi et d'être sûr que c'est bien compatible avec PS. Il devrait être mis à jour et inclure ce système nativement. La loi est certes étrange sur certains points, mais certains en profitent bien apparemment.
  3. Merci pour vos retours. Je pense qu'une custom font doit seulement être utiliser sur des éléments de type titre ou label, et non sur tout type d'élément parce que ces éléments possèdent une taille importante et rend la custom font toujours lisible. Cependant, une custom font sur un élément de 12px, c'est plus compliqué. On connaît tous les navigateurs et leur rendu aléatoire. PrestaShop 1.6 semble être une belle avancée avec de belles fonctionnalités qui pourront permettre aux e-commercants de mieux gérer leur boutique. Ne laissez pas un choix de couleurs trop large ou mal géré pour votre back-office. Cela risque de gâcher vos efforts à rendre un BO clair. En effet, Xavier, je n'avais pas vu qu'on pouvait changer la couleur du BO dans les préférences. En même temps, il faut le trouver. A ce propos, je pense qu'il y a un soucis avec le hover sur menu de gauche. Sur le style de base, ça fonctionne, sur les autres styles, je ne peux pas accéder aux sous-menus lors du hover. Il doit y avoir un pixel qui pose problème. Je viens de tester le BO sur les écrans à mon boulot. Le rendu des couleurs est différent. C'est plus clair. Par contre, à la maison, c'est moins contrasté.
  4. L'override a l'air de fonctionner. PrestaShop passe bien dans le fichier. Cependant, le fichier de surcharge se fait surcharger par PrestaShop. Quand je regarde le class_index.php, le fichier de surcharge est appelé avant le controller natif de Presta. Est-ce normal? A savoir que le fichier ne surcharge qu'une fonction de la class ProductController et non la class complète. Si, par contre, je surcharge toute la classe en modifiant la fonction à l'intérieur, ça fonctionne.
  5. Bonjour à toutes et à tous, je me permet de créer un post concernant l'ergonomie du back-office de la future version de PrestaShop. En effet, après installation et découverte de cette version, je me rend compte que le back-office est un loin d'être clair et surtout lisible. Il y a, je pense, un énorme problème avec les couleurs choisies et la police utilisée. La police Je remarque que la font utilisée pour le back-office est identique pour tous les éléments que ce soit contenu en général et titres. Il faut vraiment éviter une custom font sur le back-office et surtout sur l'ensemble des éléments. Les couleurs le back-office est bien sûr limité à la charte de PrestaShop ce qui n'est pas un problème en soi, mais je trouve que la lisibilité est très faible. PrestaShop est basé sur des couleurs plutôt flashies ou pastels et un texte gris clair n'est pas visible. Je me suis permis de faire quelques screenshots pour vous faire des comparaisons très rapides, et voir par vous même ces problèmes. http://postimg.org/image/5ee9k4e7j/ http://postimg.org/image/j6sofr4z3/ Je pense surtout aux commercants qui vont passer 6 heures voir + sur le BO ou même aux daltoniens... Le BO possède beaucoup plus d'informations, des graphiques, des données sur l'ensemble de la fenêtre, des tableaux, des listes et je pense que de la lisibilité dans cette complexité est plus qu'essentielle. Il faut arrêter le gris sur blanc, c'est ingérable. Et si je me permet de poster tout ça, c'est surtout parce que je vois que l'avancement du design "intuitif" est à 90%... Merci pour vos futurs avis. Tom
  6. Bonjour à toutes et à tous, j'ai installé un module afin de rediriger tous les produits supprimés ou désactivés vers différentes pages. Le module surcharge le controller ProductController. Cependant, lorsque je vais sur la page d'un produit supprimé, la redirection n'est pas effective. Après avoir fait 2-3 tests, l'override n'a pas l'air d'être pris en compte. Le fichier qui surcharge est situé ici: /override/controllers/front/ProductController.php /modules/nom_du_module/override/controllers/front/ProductController.php J'ai installé ce même module sur un PrestaShop vierge, et tout fonctionne correctement. J'ai également modifié le controller directement dans le core, et la redirection fonctionne également. J'ai supprimé le fichier class_index.php dans le dossier cache, et le nouveau fichier comprend bien ces lignes: 'ProductController' => 'override/controllers/front/ProductController.php', 'ProductControllerCore' => 'controllers/front/ProductController.php', Pour info, le prestashop était sur 1.3 et mis à jour sur la version 1.5.6.1 Est-ce que quelqu'un aurait une idée? Merci pour vos futures réponses. Cordialement,
  7. Bonjour à toutes et à tous, Après avoir mis à jour une plate-forme PrestasShop vers la version 1.5.6.1, il semblerait que la fonction mot de passe oublié pour les clients ne fonctionne pas. Cette même fonction pour les administrateurs fonctionnent, et l'envoie des e-mails en général fonctionne également. J'ai eu l'occasion d'installer une version neuve de PrestaShop sous cette même version, et le problème est le même. La fonction mail() est bien entendu activée. Après de multiples recherches, je n'ai pas trouvé de solutions. Certains parlent du TPL du mail qui n'est pas bon ou du thème en général qui peut provoquer cette erreur. C'est pour ça que j'ai installé une version neuve pour confirmation. Avez-vous une idée? Est-ce un problème connu de cette version? Merci d'avance.
  8. Merci pour votre réponse. Je vais faire une backUp si jamais ca plante. Cordialement,
  9. Bonjour à toutes et à tous, J'ai actuellement mis à jour une plate-forme PrestaShop 1.3 vers 1.5.6. Tout a très bien fonctionné. J'ai cependant une petite question concernant le moteur de stockage SQL qui était MyISAM sur la 1.3: L'upgrade ne met pas à jour le moteur en InnoDB (ce qui préférable). Est-ce qu'il y a un moyen de convertir la BDD? J'imagine qu'une requête SQL peut faire ce genre de conversion mais vu la complexité des tables, il y a surement des risques. Cordialement,
  10. J'ai réussi à résoudre ce problème d'affichage dans la configuration du module. Mettre "Toujours afficher le bloc" sur Non. ça résoud partiellement le problème en fait parce que je ne sais pas pourquoi pas dans le cas contraire.
  11. Bonjour à toutes et à tous, J'ai mis à jour un PrestaShop d'une ancienne version 1.3 vers la dernière 1.5.5. J'ai greffé le bloc nouveaux produits sur la home page mais malheureusement il m'affiche aucun produit nouveau. La configuration du bloc semble correcte. Je précise bien que j'ai ajouté un produit à la minute qui a suivi l'ajout du bloc, mais il ne s'affiche pas. Le cache est désactivé, le mode DEV est activé. J'ai également une version 1.5.4.1 en local pour mes tests. Sur cette version, le bloc fonctionne très bien. J'ai mis à jour cette version vers la 1.5.5. et le bloc ne fonctionne plus. Quand j'accède à l'onglet Modules dans le backoffice, un encadré m'indique les modules qui ont été mis à jour et je vois que ce bloc en question a été mis à jour sur un fichier. (mais je ne sais pas lequel) Dans le fichier TPL du module, j'ai remarqué que cette variable $new_products est null et donc le foreach qui suit est vide. Est-ce que cette variable existe encore ? Et comment résoudre ce problème d'affichage? Cordialement,
  12. Bonjour à toutes et à tous, J'ai mis à jour un PrestaShop d'une ancienne version 1.3 vers la dernière 1.5.5. J'ai greffé le bloc nouveaux produits sur la home page mais malheureusement il m'affiche aucun produit nouveau. La configuration du bloc semble correcte. Je précise bien que j'ai ajouté un produit à la minute qui a suivi l'ajout du bloc, mais il ne s'affiche pas. Le cache est désactivé, le mode DEV est activé. J'ai également une version 1.5.4.1 en local pour mes tests. Sur cette version, le bloc fonctionne très bien. J'ai mis à jour cette version vers la 1.5.5. et le bloc ne fonctionne plus. Quand j'accède à l'onglet Modules dans le backoffice, un encadré m'indique les modules qui ont été mis à jour et je vois que ce bloc en question a été mis à jour sur un fichier. (mais je ne sais pas lequel) Dans le fichier TPL du module, j'ai remarqué que cette variable $new_products est null et donc le foreach qui suit est vide. Est-ce que cette variable existe encore ? Et comment résoudre ce problème d'affichage? Cordialement,
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More