Jump to content

generalexperts

Members
  • Posts

    395
  • Joined

  • Last visited

Everything posted by generalexperts

  1. Still didn't work. I will leave it with the new htaccess file for now... Until it's working...
  2. I removed the SSL to my site and it no longer works. Does anyone know how to undo all the redirects I put in and what to set my Shop URL's to? Currently it's set to www.mydomain.com www.mydomain.com / And my htaccess file is: RewriteEngine off RewriteEngine on RewriteCond %{HTTP_HOST} ^savvymarina\.com$ [OR] RewriteCond %{HTTP_HOST} ^www\.savvymarina\.com$ RewriteRule ^big\-boat\-blocks\/brands$ "https\:\/\/savvymarina\.com\/brands" [R=301,L] # ~~start~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again # .htaccess automaticaly generated by PrestaShop e-commerce open-source solution # https://www.prestashop.com - https://www.prestashop.com/forums <IfModule mod_rewrite.c> RewriteEngine on RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule . - [E=REWRITEBASE:/] RewriteRule ^api/?(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L] # Images RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$1$2$3.jpg [L] RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$1$2$3$4.jpg [L] RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$1$2$3$4$5.jpg [L] RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$1$2$3$4$5$6.jpg [L] RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$1$2$3$4$5$6$7.jpg [L] RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$1$2$3$4$5$6$7$8.jpg [L] RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$1$2$3$4$5$6$7$8$9.jpg [L] RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$8/$1$2$3$4$5$6$7$8$9$10.jpg [L] RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^c/([0-9]+)(\-[\.*_a-zA-Z0-9-]*)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2$3.jpg [L] RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^c/([a-zA-Z_-]+)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2.jpg [L] # AlphaImageLoader for IE and fancybox RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^images_ie/?([^/]+)\.(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L] # Dispatcher RewriteCond %{REQUEST_FILENAME} -s [OR] RewriteCond %{REQUEST_FILENAME} -l [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^.*$ - [NC,L] RewriteCond %{HTTP_HOST} ^savvymarina.com$ RewriteRule ^.*$ %{ENV:REWRITEBASE}index.php [NC,L] </IfModule> <IfModule mod_expires.c> ExpiresActive On ExpiresByType image/gif "access plus 1 month" ExpiresByType image/jpeg "access plus 1 month" ExpiresByType image/png "access plus 1 month" ExpiresByType text/css "access plus 1 week" ExpiresByType text/javascript "access plus 1 week" ExpiresByType application/javascript "access plus 1 week" ExpiresByType application/x-javascript "access plus 1 week" ExpiresByType image/x-icon "access plus 1 year" </IfModule> FileETag INode MTime Size <IfModule mod_deflate.c> <IfModule mod_filter.c> AddOutputFilterByType DEFLATE text/html text/css text/javascript application/javascript application/x-javascript </IfModule> </IfModule> #If rewrite mod isn't enabled ErrorDocument 404 /index.php?controller=404 # ~~end~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again # block visitors referred from semalt.com RewriteCond %{HTTP_REFERER} semalt.com [NC] RewriteRule .* - [F] AuthName "Savvy Marina" AuthUserFile "/home1/kristio5/.htpasswds/public_html/savvymarina/passwd" # Start CloudFlare:savvymarina.com rewrite. Do not Edit RewriteCond %{HTTP_HOST} ^savvymarina.com RewriteRule ^(.*)$ https://www.%{HTTP_HOST}/$1 [R=301,L] # End CloudFlare rewrite. <FilesMatch "\.(ttf|otf|eot|woff)$"> <IfModule mod_headers.c> Header set Access-Control-Allow-Origin "*" </IfModule> </FilesMatch> RewriteBase / RewriteCond %{HTTP_REFERER} !^$ RewriteCond %{HTTP_REFERER} !^http://(www\.)?askapache\.com/.*$ [NC] RewriteRule \.(gif|jpg|swf|flv|png)$ /feed/ [R=302,L] # ---------------------------------------------------------------------- # CORS-enabled images (@crossorigin) # ---------------------------------------------------------------------- # Send CORS headers if browsers request them; enabled by default for images. # developer.mozilla.org/en/CORS_Enabled_Image # blog.chromium.org/2011/07/using-cross-domain-images-in-webgl-and.html # hacks.mozilla.org/2011/11/using-cors-to-load-webgl-textures-from-cross-domain-images/ # wiki.mozilla.org/Security/Reviews/crossoriginAttribute <IfModule mod_setenvif.c> <IfModule mod_headers.c> # mod_headers, y u no match by Content-Type?! <FilesMatch ".(gif|png|jpe?g|svg|svgz|ico|webp)$"> SetEnvIf Origin ":" IS_CORS Header set Access-Control-Allow-Origin "*" env=IS_CORS </FilesMatch> </IfModule> </IfModule> # ---------------------------------------------------------------------- # force the "www." at the beginning of URLs or vise versa as long as your using one or the other only and not both! # ---------------------------------------------------------------------- RewriteCond %{HTTP_HOST} ^savvymarina.com RewriteRule ^(.*)$ https://www.savvymarina.com/$1 [R=301,L] # ---------------------------------------------------------------------- # Cross-domain AJAX requests # ---------------------------------------------------------------------- # Serve cross-domain Ajax requests, disabled by default. # enable-cors.org # code.google.com/p/html5security/wiki/CrossOriginRequestSecurity # <IfModule mod_headers.c> # Header set Access-Control-Allow-Origin "*" # </IfModule>
  3. Yeah most of my site has been edited. I don't think an upgrade to 1.6 is possible. Unless someone knows how to detect every small change i've made. Lot's of things still need correcting to improve my store. The biggest right now effecting my site is "Reduce server response time" as I have mentioned in a different post. Most likely it's the redirect issue, which I am completely out of ideas. And yes, I have JavaPro
  4. This is because my site is redirecting. It has nothing to do with the XML file being created. Thank you though!
  5. None of the web hostings ideas worked. Anyone know what else I can try? Is there a reason why I have two .htaccess files? Google Merchant center is still saying the same thing.
  6. Im having 408 errors on my nav header. would that have anything related to this? Thanks
  7. Using http://www.seoptimer.com/ on my site, the report says 8 images found and 2 without ALT attribute. How would I add that for the two images that are using the htmlbox module? Thanks
  8. This has been solved. /modules/blocktopmenu_ext.php, (where Manufacturers was changed in Brands) a preceding '/' was missing Thank you Pascal!
  9. I received information back from my hosting provider. They replied with I tried this (below) and gave it a day and it did not make any change changed 'public_html/mydomain/.htaccess' top two lines. Removed "RewriteOptions inherit" from top line Now it reads: RewriteEngine off RewriteEngine on I've resubmited my sitemap and the google shopping xml and now waiting to see what happens. Am I capable of seeing if my site redirects any faster, instead of waiting to see if this isn't going to work? I have put things back to the way they were. Now I've changed the public_html htaccess to just read: # Use PHP5 Single php.ini as default AddHandler application/x-httpd-php5s .php (Edit): That above did not work. Now I've tried changing the .htaccess to just the publichtml htaccess RewriteEngine on RewriteCond %{HTTP_HOST} ^.*$ RewriteCond %{HTTP_HOST} !^mydomain.com$ RewriteRule ^furler\-pre\-feeders\-fairleads\/brands$ "https\:\/\/mydomain\.com\/brands" [R=301,L] RewriteCond %{HTTP_HOST} ^.*$ RewriteCond %{HTTP_HOST} !^mydomain.com$ RewriteRule ^mid\-range\-blocks\/brands$ "https\:\/\/mydomain\.com\/brands" [R=301,L] RewriteOptions inherit # Use PHP5 Single php.ini as default AddHandler application/x-httpd-php5s .php RewriteCond %{HTTP_HOST} ^.*$ RewriteCond %{HTTP_HOST} !^mydomain.com$ RewriteRule ^small\-boat\-blocks\/brands$ "https\:\/\/mydomain\.com\/brands" [R=301,L]
  10. This is my .htaccess file. maybe someone can pinpoint something that should be changed. I do wonder about CloudFare. It is a service I tried and then it didn't work so I disabled it. I went to my hosting side of things and purged the cache.... # Start CloudFlare:savvymarina.com rewrite. Do not Edit RewriteCond %{HTTP_HOST} ^savvymarina.com RewriteRule ^(.*)$ https://www.%{HTTP_HOST}/$1 [R=301,L] # End CloudFlare rewrite. So I deleted this section. Then site didn't work, had to replace old .htaccess for it to work. .htaccess # ~~start~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again # .htaccess automaticaly generated by PrestaShop e-commerce open-source solution # http://www.prestashop.com - http://www.prestashop.com/forums <IfModule mod_rewrite.c> RewriteEngine on RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule . - [E=REWRITEBASE:/] RewriteRule ^api/?(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L] # Images RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$1$2$3.jpg [L] RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$1$2$3$4.jpg [L] RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$1$2$3$4$5.jpg [L] RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$1$2$3$4$5$6.jpg [L] RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$1$2$3$4$5$6$7.jpg [L] RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$1$2$3$4$5$6$7$8.jpg [L] RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$1$2$3$4$5$6$7$8$9.jpg [L] RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$8/$1$2$3$4$5$6$7$8$9$10.jpg [L] RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^c/([0-9]+)(\-[\.*_a-zA-Z0-9-]*)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2$3.jpg [L] RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^c/([a-zA-Z_-]+)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2.jpg [L] # AlphaImageLoader for IE and fancybox RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^images_ie/?([^/]+)\.(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L] # Dispatcher RewriteCond %{REQUEST_FILENAME} -s [OR] RewriteCond %{REQUEST_FILENAME} -l [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^.*$ - [NC,L] RewriteCond %{HTTP_HOST} ^www.mydomain.com$ RewriteRule ^.*$ %{ENV:REWRITEBASE}index.php [NC,L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule . - [E=REWRITEBASE:/] RewriteRule ^api/?(.*)$ %{ENV:REWRITEBASE}webservice/dispatcher.php?url=$1 [QSA,L] # Images RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$1$2$3.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$1$2$3$4.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$1$2$3$4$5.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$1$2$3$4$5$6.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$1$2$3$4$5$6$7.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$1$2$3$4$5$6$7$8.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$1$2$3$4$5$6$7$8$9.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])([0-9])(\-[_a-zA-Z0-9-]*)?(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/p/$1/$2/$3/$4/$5/$6/$7/$8/$1$2$3$4$5$6$7$8$9$10.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^c/([0-9]+)(\-[\.*_a-zA-Z0-9-]*)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2$3.jpg [L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^c/([a-zA-Z_-]+)(-[0-9]+)?/.+\.jpg$ %{ENV:REWRITEBASE}img/c/$1$2.jpg [L] # AlphaImageLoader for IE and fancybox RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^images_ie/?([^/]+)\.(jpe?g|png|gif)$ js/jquery/plugins/fancybox/images/$1.$2 [L] # Dispatcher RewriteCond %{REQUEST_FILENAME} -s [OR] RewriteCond %{REQUEST_FILENAME} -l [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^.*$ - [NC,L] RewriteCond %{HTTP_HOST} ^mydomain.com$ RewriteRule ^.*$ %{ENV:REWRITEBASE}index.php [NC,L] </IfModule> <IfModule mod_expires.c> ExpiresActive On ExpiresByType image/gif "access plus 1 month" ExpiresByType image/jpeg "access plus 1 month" ExpiresByType image/png "access plus 1 month" ExpiresByType text/css "access plus 1 week" ExpiresByType text/javascript "access plus 1 week" ExpiresByType application/javascript "access plus 1 week" ExpiresByType application/x-javascript "access plus 1 week" ExpiresByType image/x-icon "access plus 1 year" </IfModule> FileETag INode MTime Size <IfModule mod_deflate.c> <IfModule mod_filter.c> AddOutputFilterByType DEFLATE text/html text/css text/javascript application/javascript application/x-javascript </IfModule> </IfModule> #If rewrite mod isn't enabled ErrorDocument 404 /index.php?controller=404 # ~~end~~ Do not remove this comment, Prestashop will keep automatically the code outside this comment when .htaccess will be generated again # block visitors referred from semalt.com RewriteEngine on RewriteCond %{HTTP_REFERER} semalt.com [NC] RewriteRule .* - [F] AuthName "Savvy Marina" AuthUserFile "/home1/kristio5/.htpasswds/public_html/mydomain/passwd" # Start CloudFlare:mydomain.com rewrite. Do not Edit RewriteEngine On RewriteCond %{HTTP_HOST} ^mydomain.com RewriteRule ^(.*)$ https://www.%{HTTP_HOST}/$1 [R=301,L] # End CloudFlare rewrite. <FilesMatch "\.(ttf|otf|eot|woff)$"> <IfModule mod_headers.c> Header set Access-Control-Allow-Origin "*" </IfModule> </FilesMatch> RewriteEngine On RewriteBase / RewriteCond %{HTTP_REFERER} !^$ RewriteCond %{HTTP_REFERER} !^http://(www\.)?askapache\.com/.*$ [NC] RewriteRule \.(gif|jpg|swf|flv|png)$ /feed/ [R=302,L] # ---------------------------------------------------------------------- # CORS-enabled images (@crossorigin) # ---------------------------------------------------------------------- # Send CORS headers if browsers request them; enabled by default for images. # developer.mozilla.org/en/CORS_Enabled_Image # blog.chromium.org/2011/07/using-cross-domain-images-in-webgl-and.html # hacks.mozilla.org/2011/11/using-cors-to-load-webgl-textures-from-cross-domain-images/ # wiki.mozilla.org/Security/Reviews/crossoriginAttribute <IfModule mod_setenvif.c> <IfModule mod_headers.c> # mod_headers, y u no match by Content-Type?! <FilesMatch ".(gif|png|jpe?g|svg|svgz|ico|webp)$"> SetEnvIf Origin ":" IS_CORS Header set Access-Control-Allow-Origin "*" env=IS_CORS </FilesMatch> </IfModule> </IfModule> # ---------------------------------------------------------------------- # force the "www." at the beginning of URLs or vise versa as long as your using one or the other only and not both! # ---------------------------------------------------------------------- RewriteCond %{HTTP_HOST} ^mydomain.com RewriteRule ^(.*)$ https://www.mydomain.com/$1 [R=301,L] # ---------------------------------------------------------------------- # Cross-domain AJAX requests # ---------------------------------------------------------------------- # Serve cross-domain Ajax requests, disabled by default. # enable-cors.org # code.google.com/p/html5security/wiki/CrossOriginRequestSecurity # <IfModule mod_headers.c> # Header set Access-Control-Allow-Origin "*" # </IfModule>
  11. They have also shown that these temporary redirects may be a problem as well. I tried to remove them but they reappear. It looks to be the same as what is in my .htaccess for images. The permanent ones is what i created for the 24 URL's I have errors for. I guess my site likes to add /brands to urls and create 404 errors
  12. My hosting company says I have permanent redirects but they don't have access to tell me where they are... Would anyone know how to find those and change it so those aren't an issue?
  13. El, are you seeing the redirect still? I did this change a while ago. and then recently I dropped the www Thanks!
  14. I have changed it to https://www.mydomain.com. I asked google and they said that would not be the issue, but I did it anyway. however, most of my things on google, ie merchant center and webmaster tools still say www.mydomain.com and not domain.com. [i just edited merchant center to now say https://mydomain.com] does that help? El, I am surprised when you say there is a redirect to force https. I removed that from my .htaccess. I don't know what would be triggering that. Thanks!
  15. It says "Product pages cannot be accessed" so I don't know which ones are redirecting on my site. They all eventually become disapproved so I would say all of them. My XML file has this at the top and then each product. I'm showing one product, they all have the same https://mydomain.... <?xml version="1.0" encoding="UTF-8"?> <rss version="2.0" xmlns:g="http://base.google.com/ns/1.0"> <channel> <title><![CDATA[MY DOMAIN]]></title> <description><![CDATA[My Domains offers the ... ]]></description> <link>https://mydomain.com</link> <item> <g:id>SMUS39</g:id> <title> <![CDATA[ Harken crossover block 44mm ]]> </title> <description> <![CDATA[ The description.... ]]> </description> <link> <![CDATA[ https://mydomain.com/hardware/39-harken-crossover-block-organizer.html ]]> </link> <g:image_link> <![CDATA[ https://mydomain.com/106-thickbox_default/harken-crossover-block-organizer.jpg ]]> </g:image_link> <g:condition>new</g:condition> <g:product_type> <![CDATA[ Products Hardware ]]> </g:product_type> <g:google_product_category> <![CDATA[ Vehicles & Parts > Vehicle Parts & Accessories > Watercraft Parts & Accessories > Sailboat Parts ]]> </g:google_product_category> <g:availability>in stock</g:availability> <g:price>155.23 USD</g:price> <g:gtin>097653016175</g:gtin> <g:brand> <![CDATA[ Harken, Inc ]]> </g:brand> <g:mpn> <![CDATA[ HAR 1984 ]]> </g:mpn> <g:shipping_weight>1.00 lb</g:shipping_weight> <g:shipping> <g:country>US</g:country> <g:price>0.00 USD</g:price> </g:shipping> I al asked google for more information to explain further since this problem has been causing a nightmare that nobody can figure out. they replied with "the issue is not with accessibility but the URL apparently leads to redirects which can't be crawled, will you be able to check that?"
  16. Yes, let me know if you need anything else. I appreciate every ones help! http://www.kristinamooney.com/savvymarina/gmerchantcenter5
  17. My site is not allowing me to have products on google shopping. When I submit the xml file I receive a an error saying Server redirects too often. I have inquired a web developer to help me who is familiar with prestashop. He had a few solutions but none of them worked, however the redirects were cut down. My site started out with http://www.mydomain.com and has now gone to https://mydomain.com. I had force SSL, and that has been removed and fixed. I edited the .htaccess and regenerated the robots.txt. Neither of those worked. Google webmaster tools says robots is 'allowed' for google bot. It has always said it was allowed. Google Adwords has replied with (in short): We realized all of your items were disapproved with the reason "Product pages cannot be accessed." When we tried to access the page with our bots, it returns an error. e.g.) https://mydomain.com/big-boat-blocks/38-harken-flip-flop-mast-block.html This is because your item page can not be shown when accessing as "googlebot"(Google's crawler). When we tried to see your webpage as "googlebot", it returned many redirect loop and we could not see your webpage. My site is: http://tinyurl.com/kch3wou Thank you for you help!
  18. My best bet is because you are visiting your site www.yourdomain.com/psadmin. This same error occurs for me when I don't add the https. When you visit https://www.yourdomain.com/psadmin the error goes away. Hope that works! I use PS 1.5.4.1.
  19. The Bad - From my experience this module doesn't work. There are still bugs to where I can't do a full product upload. I still have to check each page to make sure it actually worked. Customer support is awful! The person responding is so unhelpful, rude and very unresponsive. (Search Prestashop for English Help forums... It doesn't exist). You will be on your own. Find a module where there is a community of people that have this). ALL their training information must be paid for and it's not cheap! Maybe that's why customer support doesn't want to help me. I have spent so much time just trying to configure this CSV document, it's been such a waste of my time! The good - I can view all descriptions for each product at once, along with SEO meta data.
  20. Just an update. I purchased Store Commander almost 2 weeks ago. It still doesn't work properly and I have spent a lot of time trying to get it to work. The module doesn't upload everything it says it does because of current bugs. I will continue to use store commander solo, but I wouldn't recommend it as being the best way to import products.
  21. Thank you taoufiqaitali for the response! This was solved by changing the products.tpl Going to <form id="buy_block" and replacing this part {$link->getPageLink('cart',true)|escape:'html':'UTF-8'} All pages have SSL now. Thanks!
  22. I have kept friendly URL's enabled (hasn't changed). I am unable to replicate the problem. Yesterday it was doing it every time. I also noticed I have ID's in my URL's and the links that show up in webmaster tools are showing no ID's. So maybe it has something to do with that? What do you think is best to go from here? Turn off friendly URL's, turn it on, and see if the URL errors go away? Thanks! {edit} I have the redirect URL module and asked Presto Changeo if that was from their module. They logged in and verified it is not caused by their module... They said search engines try to crawl pages that don't exist by removing parts of the URL. Their suggestion was to try adding a manual 301 redirect for them on my htaccess or try removing them from google. I will try removing them from Google first in webmaster tools. [Nov 3] - In Webmaster tools - Not Found errors remains the same. Is this supposed to change immediately or does Google have to recrawl for the errors to go away (after Removing URL's)?
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More