Jump to content

webmaster_Rubex

Members
  • Content count

    20
  • Joined

  • Last visited

About webmaster_Rubex

  • Rank
    PrestaShop Newbie
  • Birthday 10/22/1980

Profile Information

  • Gender
    Male
  • Location
    Fondettes,, France
  • Interests
    Prestashop 1.5, modules de personnalisation de produits
  • Activity
    Developer

Contact Methods

  • Website URL
    http://www.rubex-pharma.fr/
  1. Mon problème a été résolu. Cela venait d'une mise à jour de php sur le vps de mon hébergeur planethoster. Lors de la mise à jour, l'extension php suhosin était restée activée, ce qui crée un bug lors de la création de compte ou de la connexion sur l'espace client de la boutique. Donc lors d'une mise à jour de php, vérifier que l'extension suhosin a bien été désactivée pour éviter ce bug. Cordialement, CHristophe Beauquel
  2. Re_bonjour mon problème a été résolu. Cela venait d'une mise à jour de php sur le vps de mon hébergeur planethoster. Lors de la mise à jour, l'extension php suhosin était restée activée, ce qui crée un bug lors de la création de compte ou de la connexion sur l'espace client de la boutique. Donc lors d'une mise à jour de php, vérifier que l'extension suhosin a bien été désactivée pour éviter ce bug. Cordialement, CHristophe Beauquel
  3. Merci de m'avoir répondu, mon problème n'est pas là alors. Je continue à chercher...
  4. Bonjour, j'ai également ce problème, pouvez-vous me dire comment l'avez-vous résolu ? Merci beaucoup
  5. Bonjour, j'ai exactement le même problème et la même configuration serveur que vous, pourriez-vous m'indiquer si vous avez trouvé une solution à ce problème svp ?
  6. Bonjour, depuis la mise à jour de ma boutique qui était en 1.5.6 à la 1.6.1.1 j'ai un problème de compatibilité avec litespeed qui est installé sur mon serveur VPS. Lorsqu'un client à un produit dans le panier et qu'il souhaite le retirer en cliquant sur la corbeille (depuis la page "récapitulatif de commande"), la page se recharge mais le produit reste en place. Il faut rafraîchir la page pour que le panier indique (votre panier est vide). à première vue ce serait la gestion du cache qui crée cette erreur mais je ne sais pas comment remédier à ce problème. Je pourrais repasser sur Apache mais j'ai payé pour la licence litespeed donc autant s'en servir :-) Pour tester le bug : http://rubex-pharma.fr Si quelqu'un a une idée je suis preneur Merci d'avance pour vos réponses
  7. Bonjour, j'ai réglé mon problème en actualisant les fichiers javascript de mon thème avec ceux de la dernière version du thème default bootstrap. Voilà si quelqu'un à la problème ça pourra surement être utile.
  8. Bonjour, depuis la mise à jour de ma boutique prestashop de la version 1.6.1.0 à la 1.6.1.1, je rencontre un problème sur la modification des déclinaisons dans le back office. je dois obligatoirement passer par le générateur de déclinaisons pour que les modifications soient prises en compte. De plus en front office, lorsque je clique sur les différentes couleurs ou dimensions le prix ne se met pas à jour (pb de JS ?), il reste au prix de la déclinaison par défaut. Pensant que c'est un pb de mon thème, j'ai remplacé les fichiers JS par ceux de la dernière version du thème default-bootstrap et lorsque je teste en cliquant sur une déclinaison, la page se recharge pour m'afficher la déclinaison par défaut. J'ai cherché une bonne partie de la journée, mais là je ne vois vraiment pas. Quelqu'un aurait-il une idée pour que je puisse diagnostiquer ce problème ? Cordialement Christophe
  9. Ok très bien, il va falloir que je cherche ailleurs alors, car je n'ai pas de module de ce genre. Merci en tout cas d'avoir répondu rapidement. Cordialement
  10. Bonjour ALphageekV2, je rencontre le même genre de problème, pourriez vous me dire quel module causait ce problème, cela m'aiderai dans mes recherches pour corriger le bug sur ma boutique. Je vous remercie d'avance. Cordialement.
  11. Bonjour, je suis sur un prestashop 1.5.6.2 et sur un serveur virtuel dédié (VPS 3G de RAM et 3 cores) hébergé chez Planethoster. Dans l'onglet performance de prestashop, le cache est activé, CCC coché, xcache est activé et j'ai désactivé les caractéristiques produit. Mon site (http://rubex-pharma.fr) fonctionne correctement mais certaines pages sont lentes comme cette page : http://rubex-pharma.fr/295-maroquinerie-pvc Côté serveur, il n'a pas l'air surchargé, la catégorie ne contient que 41 produits mais certains produits dans cette catégorie ont beaucoup de déclinaisons (+ de 500 avec une image par combinaison) comme ce produit : http://rubex-pharma.fr/maroquinerie-pvc/5907-porte-carte-vitale-gomme-luxe-vernis-2-poches.html J'ai interrogé pagespeed de google qui me dit (réduire le temps de réponse du serveur), et yslow qui ne me dit rien de spécial sur cette page par rapport aux autres. Les seuls modules que j'utilise sont : ads and slideshow, advanced top menu et footercustom. La navigation à facette est désactivée et plusieurs modules de stats également. J'aurai besoin de vos avis sur ces lenteurs et si on peut améliorer ce temps de chargement. Merci pour vos réponses. Cordialement Christophe
  12. Bonjour, j'ai donc réussi à régler mon problème en remontant le bug sur la forge. Il y a deux fichiers à modifier pour retrouver les sauts de ligne dans les champs de personnalisation produits, voici les modifications (veiller à faire les modifications de classes en faisant un override, ainsi vos modifications survivront à la prochaine mise à jour ;-)) : Tout d'abord, retirer ces lignes dans le fichier cart.php : https://github.com/PrestaShop/PrestaShop/commit/4d327a537fd8262dbb7a0fda613a968ccc16e207 Ensuite, ajouter les lignes suivantes : https://github.com/PrestaShop/PrestaShop/commit/c1969028f2bac39c12b1c35bcf7bb72ca13a7c17 Il faut modifier également le fichier blockcart-json.tpl du module blockcart : https://github.com/PrestaShop/PrestaShop/commit/c1969028f2bac39c12b1c35bcf7bb72ca13a7c17 Ces modifications vous permettront de retrouver les sauts de ligne en base. En revanche, ils seront affichés comme des espaces dans les e-mails de confirmation (côté clients et côté admin (bloc mailalerts), dans le panier et dans le B0. Pour répercuter les sauts de lignes sur les e-mails, vous devez modifier le fichier "classes/PaymentModule.php", et dans le module alert "modules/mailalerts/mailalerts.php" avec des fonctions str_replace, je pourrais vous fournir les modifs en MP si vous avez besoin. Bonne continuation à tous.
  13. Bonjour, je vends sur ma boutique (http://rubex-pharma.fr) des produits personnalisables. Sur ma fiche produit j'ai donc deux champs de textes où les internautes saisissent les infos. Le hic, c'est que sur l'ancienne version de mon site (prestashop 1.4.8.2) les retours à la ligne qui étaient fait par l'internaute lors de sa saisie étaient retranscrits dans sa commande et répercutés dans le résumé de commande en BO et dans les e-mails de notifications. Depuis la 1.5.x les retours à la ligne sont directement supprimés lors de l'enregistrement des données de personnalisation. Ces retours chariot sont d'ailleurs supprimés au moment de l'envoi des données à la base puisque sous la version 1.4.8.2 des <br /> apparaissaient dans la base de donnée mais là plus rien. C'est handicapant pour mes collègues qui se charge de la production car ce n'est pas facile à relire et à comprendre sans les retours à la ligne. Je commence à m'arracher les cheveux, si quelqu'un à une idée je suis preneur :-) Merci pour vos réponses suggestions, tout ce qui peut m'aider
  14. Bonjour donc pour ceux que ça intéresse c'est un bug Prestashop que j'ai pu corriger en rajoutant un morceau de code dans le module "mailalerts". Le fichier à modifier est le fichier mailalerts.php dans le module mailalerts. La modification est la suivante, : création d'une boucle supplémentaire pour "single custom" de la ligne 294 à 297 : foreach ($customization as $singlecustom) { if (isset($singlecustom['datas'][_CUSTOMIZE_TEXTFIELD_])) foreach ($singlecustom['datas'][_CUSTOMIZE_TEXTFIELD_] as $text) $customization_text .= $text['name'] . ': <strong>' . $text['value'] . '</strong><br /><br />';
  15. Bonjour, depuis que je suis passé sur la version 1.5.4.1 de Prestashop, je n'ai plus les textes de personnalisation dans l'e-mail de notification de nouvelles commande. Le nom de l'article s'affiche, les attributs aussi mais pas la personnalisation.(voir images jointes) Sous la version 1.4.8 cela fonctionnait, j'avais bien dans l'e-mail de notification les différents textes issus des champs de perso, mais là, rien. Quelqu'un a t-il été confronté à ce problème et par chance résolu ? PS : j'ai essayé avec une installation de base de prestashop 1.5.5.0 avec le thème par défaut et il y a le même problème.
×