Jump to content

Number Nine

Members
  • Posts

    53
  • Joined

  • Last visited

Number Nine's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Hello, I found a wrong URL in my site. Just suppose I have a page about CARS, with this URL: www . mysite . com /8-vehicles It would be more obvious to have a URL like this: www . mysite . com /8-cars I then corrected the URL and wrote this redirect in .htaccess (Prestashop 1.2.5): redirect 301 /8-vehicles http://www . mysite .com/8-cars When you click in Google the old URL ( /8-vehicles ) you are redirected to the right page but the URL in the browser has changed. Instead of being www . mysite . com /8-cars ... it has been changed into: www . mysite . com /8-cars?id_category=8 I cannot find a way to remove ?id_category=8. Anyone has an idea? Thank you everybody.
  2. Hello, I have some articles which I would like to sell ONLY AS ACCESSORIES of other articles. Customers should not have the chance of buying them individually. Suppose you sell shoes and have a shoe cream as accessory. I would like to sell the shoe cream only if bought together with a pair of shoes, and not as a single item. Is there a way of achieving this? Thank you.
  3. Ringrazio Checco per l'ottima spiegazione per l'attribuzione di diverse spese di trasporto per il Sud Italia e le isole. Ne avevo bisogno anch'io.
  4. Thank you Isotech, your advice just saved my shop!
  5. Yes, I am testing the same module and have encountered the same problem. Any idea? Thanks.
  6. Yes, I am having a similar trouble with express checkout after upgrading to 1.4.4.1. How did you solve your problem? It might be an inspiration to solve my problem: the first express checkout page goes blank when you click on the "Check Out" button. Thanks.
  7. Ciao a tutti, avete per cas risolto la pagina blank quando si va nell'express checkout? Anch'io ho aggiornato a 1.4.4.1 ma quando chiedo di andare alla cassa con l'express checkout abilitato mi dà pagina bianca al centro e non posso fare altro. Ho avuto questo problema subito all'aggiornamento.
  8. Io ho risolto andando in Preferenze / Seo e URL e cambiando manualmente il nome della URL in ogni singola pagina, ad esempio: carrito => cart e tutto ha ripreso a funzionare.
  9. Bene, per ora ho tamponato con un escamotage: sono andato nel DB e nella tabella ps_meta ho editato manualmente il campo page, cambianto authentication in authentication.php, bypassando il controllo del sistema, e ora tutto funziona... ... almeno fino alla prossima sorpresa.
  10. Ho trovato che disabilitando la riscrittura delle URL tutto funziona. Il problema è che il sito originale, nella sua versione 1.2.5.0, cliccando su Entra dà la seguente URL: http : // www . sitovecchio . com/authentication.php?back=my-account.php mentre il sito di prova in aggiornamento alla 1.4.4.1 dà questa URL: http : // www . sitonuovo . com/authentication?back=my-account.php Manca quindi il .php in /authentication, cher però nella pagina di settaggio, Preferenze / Seo e URL non posso impostare. Qualche idea?
  11. Mal chi ce lo ha fatto fare di aggiornare a 1.4x? Dopo vari problemi risolti ora non permette la creazione di un nuovo cliente, quando si deve procedere a un acquisto. Sto lavorando ancora su un sito di prova prima di trasferire il vero shop, ma quanti problemi! Ma non le provano queste cose prima di rilasciare le nuove release?
  12. Ciao a tutti, Dopo aver trovato vari post in Google senza soluzioni provo a postare di nuovo in questo forum. Dopo aver installato da 1.2.5.0 a 1.4.4.1 mi ritrovo nell'impossibilità di attivare la funzione URL FRIENDLY perche altrimenti le pagine tipo Carrello, Benvenuti / Entra... vengono rese con URL in spagnolo (carrito / mi-cuenta ecc.) e il CMS restituisce errore 404 e conseguente pagina .../404-error. Il sito è in sola lingua italiana. C'è chi dice che l'italiano nella nuova versione ha l'ID 5 invece del 3 che aveva prima. Ho provato a cambiare l'ID lingua nel DB ma ottengo solo un errore. Ho provato a far generare un nuovo file .htaccess ma niente cambia. Ho provato a manipolare l' .htaccess commentando la linea che fa riferimento a carrito (# RewriteRule ^carrito$ /order.php [QSA,L]) ma niente cambia. Avete avuto lo stesso problema? Avete forse un consiglio o una soluzione? Grazie a tutti.
  13. Ho scoperto che se installo il sito in /root invece che in un terzo livello tutto funziona. Se qualcuno ha qualcosa da aggiungere è il benvenuto.
  14. Salve a tutti, Aggiornare da 1.3 a 1.4 si sta rivelando molto più complicato di quanto non ci vogliono far credere. Ho fatto una copia di www . nomesito . it e l'ho montato su un altro dominio, un terzo livello, per provare l'aggiornamento. Ho avuto diversi problemi, ma questo è veramente strano: Se visito http . terzolivello . nomesito . com ottengo il reindirizzamento alla pagina /404-error e visualizzo il messaggio C'è 1 errore: 01 Categoria inesistente. Se invece visito http . terzolivello . nomesito . com / index.php allora tutto funziona normalmente, come pure se visito una qualsiasi altra pagina. Ho provato a cambiare l' .htaccess con un'altra versione, a rigenerarlo e anche a cancellarlo e disattivare la riscrittura delle URL ma niente da fare. Qualcuno ha un'idea? Grazie a tutti.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More