Jump to content

lynbbor

Members
  • Posts

    14
  • Joined

  • Last visited

About lynbbor

  • Birthday 12/22/1958

Profile Information

  • Location
    USA
  • Activity
    Freelancer

lynbbor's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. Right, because that would require the makers of PrestaShop to actually test and pay attention to what people using their product are saying about it. Their bug reporting process is so tight that if you can't describe a process that produces the bug 100% of the time then their immediate response is "it must be your Hosting Company" or Your configuration or something on your end. So go away and stop bothering us. We have new and exciting features to add and more fun things to do that try and chase down a ghost that only a small number of people are ranting about in the forum. They obviously just don't know what they are doing and we don't have the resources to do anything for them. Thanks for trying PrestaShop and we are sorry it's not working out for you. Buh Bye now. FYI, I have encountered this same bug in another shopping cart program that is of a similar design to PrestaShop. Makes me wonder if either they are forks from a single source or, more likely they both use the same coding environment or library that has this bug in it. In any case, I've now learned to do a basic setup and test test test before committing any more time than necessary on setup of any shopping cart program. It's really frustrating because I do like a lot of things about PrestaShop. It think it is one of the best when it comes to SEO and marketing. But it's not ready to be used for virtual products and likely won't be any time soon. sad..
  2. Yes, in the version of the shop that I did no updates on. The other installation that failed to update misserably the categories were all there but I could not see or edit them in the admin now did they show for site visitors, but if the visitor did a search product would show up as being in one of the previously defined categories. That shop has now been changed to different software. So, back to the original installation that has never been updated since it's install and which is the one I've been talking about here for the most part. You can view the shop at http://www.itdrtw.com if you wish. Everything works as expected except the association to existing product for download tends to disappear. People then make a purchase and can't download the product. I've "fixed" this by manually editing the file name(s) in phpmyadmin only to have it break again later. It's really weird behavior.
  3. Touching base after much time with this problem. It continues to haunt me. Each time I think I have resolved it the next customer to make a purchase can't download the file. It is very annoying. On a different site I attempted to upgrade to the latest version of Presta and it totally broke the install. So very frustrating. I've worked with shopping cart programs and all kinds of PHP scripts and web apps over the years. I have to say that PrestaShop does not seem to be ready for prime time use. It lacks reliability and the developement seems to be more about getting new features out the door than making sure everything is stable. I've given it more chances than any other program in my past because I really like the look and the features, but it's been a maintenance nightmare from the beginning with no sign of it getting better for me. At this point I'm wishing I had installed Zen-Cart or OScommerce instead because that's the amount of work I'm going to have to go through again to get something stable.
  4. I'm having a very similar problem after upgrading to the 1.6 version. I had abou 10 categories but none show on the home page (default theme) and when I go to edit categories in the admin it shows that I have Zero categories, however the icons above indicate that I have 1 empty category and a top category and it is displaying the correct category name. And that I have an average of 5 products per category. So my categories are still there, but something it preventing them from being found. Perhaps someone can explain how the system pulls category info from the database so we can have a clue as to how to resolve these problems. How is the total number of categories displayed on the admin page get generated? One would think it just looks at the categories table in the database, but apparently not.
  5. I did the manual upgrade from 1.5.6 to 1.6.05 or whatever it is. After which I had no categories on my home page and none listed in the admin. However it tells me which is the most popular category of the month and my average number of products per category. I can see the category info in the database via phpmyadmin. But my store home page has a categories block header with nothing under it. WTH?? I'm wondering if there are some folder permissions messed up?? I sure wish that auto update module would work so I didn't have to go through all these problems every time I have an upgrade.
  6. Reporting in, Since changing my method to how I previously described in this thread I've added over 30 more virtual products without any disappearing on me. It certainly seems that if you avoid clicking on the SAVE icon and just use the "Save and Stay" and "Back to List" icons everything works as it should. I'd sure like to know if anyone else has tried this and if it worked or not for them.
  7. I just experienced the exact same thing this morning. A new customer sent me a nasty gram about his password being exposed via an email message. I logged on to this forum and now thanks to El Patron that email will now have Stars (*****) instead of the users password. Note, there was one minor step missing from the instructions. After selecting the language flag you will need to click the button to "Expand" all so you can see your search results. I did it using chrome which found 2 but showed me nothing until I eventually noticed the expand button. Then it found 7 and could jump to the matches. I only changed the welcome email to hide the password and added a message to the user to login and change their password immediately because passwords sent via email are no longer secure. I assume one of these were for when someone requests a new password because they forgot theirs. And there was another that was about converting a user from a guest to a customer. Anyway, nice to see this forum work this well at providing the exact solution to my problem.
  8. OK, more info in case anyone is interested. I used PHPmyAdmin to have a look at the database. Specifically the table ps_products_download and found many duplicate entries and several entries missing the download filename and most entries with the "active" field set to 0. (off in my mind). So I began a clean up operation. Removing duplicate records keeping the oldest and also using FTP to verify filename field entry matched a file on the server in the /download folder. Once that was done for my existing 50 products, I started adding new products again. So far I have entered 6 more virtual products without the table becoming messed up. The only thing that I've done differently was to avoid the SAVE button. My process exactly has been to create the product description(s) and then click the "Save and Stay" button. Then select the Virtual Product radio button, choose the file, then (without saving) select the Image menu choice on the left, upload the image, then work my way up through the left menu filling out as I go still without clicking on any SAVE or Save and Stay button. When I'm back at the top of the menu and have no more data to enter for this product I click on the Virtual Product menu choice on the left and see the screen just as I left it and now I click the SAVE and STAY button to record everything. I wait patiently for the button menu across to completely render and lastly click the BACK to LIST button. I then check the table via PHPmyAdmin. So far, doing this has worked. At this point I don't know if the SAVE button was causing the problem or if the fact that the table had duplicate entries was the problem. But it would seem that one of those two is likely. I will provide more info here as I learn more. BTW, I'm not a programmer, but I have been in a past life. I have 25 years experience working with desktop computers and computer networks. I've also run my own hosting company for the last 15 years and installed and troubleshot many many many cgi scripts. So my avatar says it all, I'm a grunt out here in the field of Web doing battle against all the bugs and hackers.. LOL...
  9. Just now I got what may be a clue to what is going on with the software. I was checking my products and finding missing virtual products that were fine yesterday. I decided to just provide the original filename instead of using the select a file button. After entering the filename and clicking on "save and stay" I got the following. This file "020_head_shop_manual.pdf" is missing. : /home/kwadmin1/public_html/om/download//20806aae40205321782c783954faaf85ae8270c4 Notice after the folder name "download" there are two forward slashes? That file will never be found like that.
  10. So frustrating. I"ve not got 51 products added to my store and every time someone orders a product it's not there so far. I keep looking at my products and usually they seem fine. It's so annoyingly random! I still have another 40 products to add which is a bit time consuming as you can imagine. But I don't want to have spent all this time adding products only to find that I can't live with a shopping program that constantly forgets where it put the product files. Anyone out there got some help? Please? P.S. I did try maniT4C's solution above without success.maniT4c
  11. New fresh install of 1.5.6.1 (since the upgrade from 1.5.6.0 failed so miserabily) Other version info is.. Server informationServer information: Linux #1 SMP Wed Mar 27 16:49:32 MSK 2013 i686 Server software version: Apache/2.2.25 (Unix) mod_ssl/2.2.25 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP version: 5.3.27 Memory limit: 96M Max execution time: 60 Database informationMySQL version: 5.1.70-cll MySQL engine: InnoDB I've been experiencing this problem with both the previous version 1.5.6.0 and now this new install of 1.5.6.1. After entering several virtual products I find that when I go back to look at products there is no download file associated with them. The main product page shows that it is a "Virtual Product" but when I click on the virtual product tab it's a blank window with the "is there a file associated" question currently showing NO as the choice. There does not appear to be any rhyme or reason as to which products are affected by this. I can go down the list and maybe one day the first 2 products have lost their file association and the rest are fine and the next day it might be product 7 and 8. I'm able to select YES and upload a file without any problem but I've learn that there is no gaurantee it will be there the next time I go look at it.
  12. I'd give up on the 1-click update. I and others have not been able to make it work. In fact you will likely find that following the manual update instructions also will not go as they say it should go. I ended up preparing for the update as told in the manual instructions and then simply uploading those files over my existing store files and done. Delete the install folder and you are back in business. I did attempt to run the upgrade.php as instructed, however it claimed that I was already updated to 1.5.5 so it refused to run. Better instructions for updating, at least from 1.5.4 to 1.5.5 are definitely called for. Best of luck to you.
  13. I just attempted upgrading from 1.5.4 to 1.5.5. I just have to say that was one of the most confusing updates to an online program I've ever experienced. I started by searching for updating instructions on the website. I found what looked like exactly what I needed. I followed the instructions but when I got to the place where I go to the install folder of my prepared files the install/update program presented me with a message that I should not use this method for my upgrade and gave me a link to a set of instructions specifically for PS15. So I went there and read those instructions that varied mainly in that I should upload my prepared files directly overtop of my existing online store. It also talked about doing my update locally first to make sure it would go smoothly. Not gonna do that, rather pointless. If the update online doesn't go well I just restore from my backups. So I pressed on, Deleted the sub-folder where I had uploaded my prepped files and re-uploaded over top of my existing store. Then, following the instructions, I went to mystore/install/upgrade/upgrade.php where I was met with error 28. Error 28, after digging into the upgrade.php file, apparently means there is nothing to upgrade. So am I done? I try to login to my admin, which I can't do until I delete the install folder. OK, I do that and I login. Everything looks OK. It says I'm running 1.5.5 now and there don't seem to be any other errors. I then go ahead and take my site out of maintenance. I go look around and all seems to be working as it should. But.... Did I complete the upgrade? Are there going to be any issues? No CLEAR indication that my upgrade was successful or even proper. It certainly did NOT happen anything like the upgrade instructions said it would happen. Oh yeah, I forgot to mention that before all this I attempted the 1-click update which failed to even download the update file. IMHO this is a huge issue. Upgrades are always painful enough and I do understand that the programmers have to deal with all kinds of different web server configurations that can throw a monkey wrench into any instructions for updating an online app. I know this because I've updated many different kinds of PHP and Perl programs over the years on differing web server configurations. But this one was one of the worst experiences I've had on one of the most common web server configs available these days. Based on my experience the PS15 upgrade doc should simply say "back up your exiting site, upload the contents of the new version overtop, and you are good to go." And that information should be in an UPDATE154-155.TXT file in the root of the 155 zip file. I feel like I spent 4+ hours transferring files around that I really didn't need to do simply because the updating instructions were really bad! If I had been given reasonable instructions to follow this would have been at most a 1 hr. job. I'll be back to let you know if I discover any problems with my new 1.5.5 update.
  14. Similar issues for me. Mine fails on the download.. Analyzing the situation ...Shop deactivated. Now downloading (this can takes some times )... [Ajax / Server Error for action download] textStatus: "error " errorThrown:"Internal Server Error " jqXHR: " " I'd be happy to do the download and place the new zip where it needs to be manually and then click a button to perform the upgrade. Guess I'll go see if I can find the manual instructions for upgrading. :-(
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More