Jump to content

Devil089

Members
  • Posts

    42
  • Joined

  • Last visited

Profile Information

  • Activity
    Project Owner

Devil089's Achievements

Newbie

Newbie (1/14)

4

Reputation

2

Community Answers

  1. Hi prestashop community , I need the following scenario: I want to split each article from my shopping chart after payment into his own order_reference code and oder number. Prestashop has no option for order splitting. So I try the following: I know that if i add to each product different shipping-service, prestashop split the order automatically after payment. Cause of different shipping-services This works quite good. The only thing is, that these splitted orders have the same order_reference code. . How can i change the core that each splitted order have his own order_reference_code Can anyone help me how i can archive this? This would be nice. Thank you Devil
  2. Hi Prestashop Community, i need your help I want to modify my module blocksearch as the following. Want to use 2 search input fields instead only one1. (My Example Search for Location & for Product) In the browser http search query it should look like this if i click on the search button: ....?controller=search&orderby=position&search_query=input1+input2 This is the code in my blocksearch-top.tpl for the input field <form method="get" action="{$link->getPageLink('search', true)|escape:'html'}" id="searchbox"><p> <label for="search_query_top"><!-- image on background --></label> <input type="hidden" name="controller" value="search" /> <input type="hidden" name="orderby" value="position" /> <input type="hidden" name="orderway" value="desc" /> <input class="search_query" type="text" id="search_query_top" name="search_query" value="{$search_query|escape:'html':'UTF-8'|stripslashes}" /> <input type="submit" name="submit_search" value="{l s='Search' mod='blocksearch'}" class="button" /> </p> </form> Can anyone help what i have to change in the blocksearch-top.tpl and in the classes/search.php file ? Thanks Devil
  3. Hi , I want to override the following file prestashop/admin/theme/default/template/header.tpl i try every combination in the prestashop/override folder but nothing work Anyone knows how to override this header.tpl ? Thanks Devil
  4. Hi i have found a module do you mean something like this the price for this module is fair. http://codecanyon.net/item/prestashop-seo-manager/4662419?WT.ac=category_item&WT.z_author=Onasusweb Devil
  5. Hi Benjamin, thank you for the answer actually the Store is not online. but in the next days. which module do you mean ? Do you mean the automated one ? yes i give you right i believe that no automated software is able to to the whole seo process for me. but can be a big time saver. the combination make sense if i understand you ? wich module do you favor ? Devil
  6. Hi UltraSeopro Thanks for your answer. looks very automated to me. Is it possible to test it for few days ? Devil Does anyone know another good SEO Tool for Prestashop ? Devil
  7. Thank you for your answer, which software do you mean ? Devil
  8. Hi everyone , i have a question. i finished my PS1.6 shop an looking for a good SEO-module. ( do i need such a module ? ). the prestashop module site is flooted from such modules and now i don´t know whats a good choice. Can anyone give me tips which module is good or not ? Do i need such a module ? Devil089
  9. Hi Bill, thanks for your replay. works great now i can fix this stupid issue Devil
  10. Hi Community , I have found that if you install Prestashop 1.6.0.8 or 1.6.0.9 and use SSL (Geotrust not shared) you get in chrome or other browsers firefox IE a unsecure SSL notification. the modules which causes this issure are blocksearch(blocksearch-top.tpl) and blocknewsletter (blocknewsletter.tpl) this line causes the error in every tpl file. <form method="get" action="{$link->getPageLink('search')|escape:'html'}" id="searchbox"> . . . </form> the https is no longer unsecure if i remove this lines ,but what is exactly wrong with this line. ? how can i change this line that the getPage link method get the right https link ? am not a php expert Devil
  11. Hi Vekia, thank you for you replay i got a solution from the theme developer i think its working for other solutions too. edit product.php Add the following lines right after this line $row['category'] = Category::getLinkRewrite((int)$row['id_category_default'], (int)$id_lang); $category = new Category((int)$row['id_category_default']); $row['category_name'] = $category->getName((int)$id_lang); then use {$product.category_name} Greatings Devil
  12. hi vekia, yes its only a module from the transformer theme it display only the new products in a slider. now i want to add the default category name in this module but i don´t know how the code for the tlp file look like with {$product.id_category_default} i got only the id´s but i need the names of this id´s do you have any ideas to realize this ? Vekia i have found your code in a thread of you <span style="font-size:10px;"> {foreach from=Product::getProductCategoriesFull($product.id_product) item=cat} <a href="{$link->getCategoryLink({$cat.id_category})}" title="{$cat.name}">{$cat.name}</a>, {/foreach} </span> this code works for me but i only need the default category name not all category names how can i modify it to realize this ? Devil
  13. Hi i tried to display the name of the default category in the new products slider without any result the ids work with {$product.id_category_default} but not the name of the category {$product.category_default} can somebody help me wich is the right code for the tlp file in product.tlp it works for me with this guide but how can i add the default category name for the new products slider (module) and the featured products ? i use ps 1.6.0.8 Devil
  14. hi vekia, yes i think thats relatetd to missing translation file. but i think this topics are missing in the lang.php file but dont know how i can add the missing. or have this emails no topics ? not all standart emails are affected only the following. bankwire, cheque, employee_password, newsletter order_cancled outofstock payment_error payment preparation refund shipped voucher_new want to fix this. have anyone the same phanomenom, or a solution for this ? Devil
  15. Hi have problem, in some email topic translations i got this blue box with a question mark. (for.. nothing can found in the database) instead of the email topic. does anyone know why this happend and how i can fix this ? i have this in some standard emails and in some module email-topics. but not in all. Devil089
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More