Jump to content

Twenki

Members
  • Posts

    8
  • Joined

  • Last visited

Profile Information

  • Activity
    Web development agency

Twenki's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Hi guys, I need to modificate the home page of prestashop 1.5.4 and introduce a previous home page, something like a bridge home page. It will be like a previous front page with a custom image slider, some pics, banners, promotional text and stuff.. it should include the head and footer of prestashop, with the menu, in order to make posible to the user an easy access to the rest of the website. Once inside the catalog, this "pre home page" will not be accesible by any link. I have builded a custom page and created a url in the SEO&URL section, it is accesible only tipping the url in the box of the web browser... is done but need to make it accesible by default, I dont know how to set this page as default home page.. Another posibility whould be to rename de original home page of prestashop to something like "domain.com/home/" and maybe could use a rule in the .htcaccess with a redirection of "domain.com" to "domain.com/custom_home_page".. but I rewrited the index friendly url in SEO&URL section with no succes... Also I thougth if a custom module could make this more easily but I dont know if is the best strategy, is my first full prestashop mod and need some help on this. Thanks to all PD: Sorry if I failed on english, not native
  2. Buenas, "Por exigencias del guión" necesito poner una primera página como portada antes de que se cargue la tienda y quería hacerlo con el propio prestashop. He creado una página personalizada, sin problemas, pero ahora no encuentro la forma de definirla como primera página a cargar. Para simplificar, lo que quiero es que cuando un usuario entre a http://www.dominiodemitienda.com la tienda le redirija a http://www.dominiodemitienda.com/portada/ y a partir de ahí que la tienda siga su flujo natural. He buscado en los foros tanto en castellano como en inglés pero no consigo encontrar nada de utilidad. Gracias!!! PD: Todo esto para prestashop 1.5.4
  3. Pues es una pena.. no he posteado mucho por aquí, sobre todo leo pero se va a notar tu ausencia, eso está claro. Mucha suerte en lo que hagas
  4. Buenas, Estoy probando la versión 1.5.6 principalmente porque me ha llamado mucho la atención una de las novedades que aparecen destacadas en el index llamada "Navegación por capas potente" y que aparece ilustrada con la siguiente imagen No me negaréis que resulta atractivo y funcional ese menú... Pues bien, mi pregunta es si esta funcionalidad ha de ser activada en algún rincón del backoffice que no logo encontrar, o es simplemente un engaño y te lo tienes que currar como toda la vida. Gracias y saludos!
  5. Buenas, Estoy intentado modificar el menú de categorías de la columna izquierda para que se comporte de un modo distinto. Este menú por defecto muestra el arbol de categorías de la tienda al completo con las subcategorías hasta 4 niveles. Mi intención es que deje de mostrarlas todas y únicamente muestre "la familia" de la subcategoría en curso hasta la categoría padre (root) Ejemplo gráfico, navegando en zapatos Árbol completo (comportamiento default): complementos calzado invierno zapatos [*]verano sandalias [*]ropa jerséis camisas [*]joyería Árbol de familia (como quiero dejarlo): calzado invierno zapatos [*]verano sandalias Estando navegando en la categoría zapatos, mostramos su familia (calzado) al completo y se oculta el resto de categorías de la web (complementos, ropa y sus subcategorías, joyería) Existe un mod que ya haga esto? Podríais aconsejarme cómo hacerlo? Qué archivo debo tocar? NOTA: Mi actual estrategia es alterar el listado de categorías que usa el bloque de menú izquierdo. Estoy intentando modificar el archivo blockcategories.php para usar el método getParentsCategories() en la función hookLeftColumn, pero no lo consigo, nunca había modificado un prestashop a este nivel. Muchas gracias
  6. Solucionado, el adblock me estaba cogiendo el banner, añadida una simple excepción ([spam-filter]|http://localhost) y listo, es la primera vez que me pasa en 7 años de desarrollo web xDDD
  7. Buenas, No creo que sea problema de permisos ya que en ese caso no hubiera sido posible subir la imagen a la carpeta física y he comprobado varias veces que la imagen sube, si la borro la vuelve a subir sin problemas. No puedo ponerte un enlace a la tienda ya que estoy trabajando en local, lo que sí puedo enseñarte es una captura: Ahí puedes ver que la imagen está bien colocada, el firebug puede acceder a ella sin problemas, lo que ocurre es que en la ubicación del banner no se ve la imagen y no entiendo el porqué. He probado a poner manualmente una imagen en el archivo "modules\blockadvertising\blockadvertising.tpl" como método directo (toda la etiqueta img correctament) y tampoco la muestra, y eso es lo que me tiene desconcertado, en cambio si escribo texto simple, sí aparece. Gracias por contestar tan rápido EDIT: Se me acaba de ocurrir la peregrina idea de comprobar qué tal se va viendo la web en IE(9.0.8) y Safari (5.1.7) [navegadores que apenas uso, sólo para estas cosas] y mira tu por donde, sí que veo el banner. En Firefox (19.0) y GoogleChrome (24.0.1 actualizando ahora mismo) [navegadores que uso a diario exhaustivamente] no veo la imagen, aunque no tiene mucho sentido que para visualizar una simple imagen necesite una actualización.. Por tanto, la pregunta tendrá que ir encaminada hacia algún problema asociado con imágenes y caché, porque me da la impresión de que por mucho Ctrl+F5 y forzar compilación y teniendo en cuenta que he desactivado la caché en las opciones de rendimiento, NO se limpia la caché. EDIT2: Limpiar la caché de forma manual en ambos navegadores no surte efecto. Entrando a la tienda DESDE OTRA IP con FIREFOX si veo la imagen, cada vez lo tengo menos claro :S Sugerencias?
  8. Buenas a todos, Me estreno en el foro con una consulta sencilla, he instalado la versión 1.5.3.1 y llevo unos días configurandola a mi gusto, por ahora ha ido todo genial aunque no siempre doy con la respuesta a la primera. He movido el módulo de publicidad para poner banners a la columna derecha a través del Live Edit (muy útil), a continuación he ido al módulo para crear un banner y he subido una imagen .jpg del tamaño exacto al que indica (155x163), indico un enlace, pongo un título, le doy a validar... y parece que no es capaz de mostrar la imagen. Voy a la carpeta ...\modules\blockadvertising\ efectívamente allí está la imagen con nombre "advertising-s1.jpg", inspecciono el html resultante y veo el div "advertising_block", el enlace y la imagen a la que se le ha añadido automáticamente una clase "rbfoizpwjhfyxrkxyfxi" con los estilos [ [ height: 200px; position: relative; top: 0; visibility: visible;] Por mucho que los cambie, no se ve la imagen, al crear el banner en el admin, entiendo que debería mostrarte el resultado, ahí sólo veo el texto del título pero no la imagen del banner. Qué estoy haciendo mal? He revisado las opciones de rendimiento para que la caché no me la juegue pero ni por esas, algo hago mal o algo hace mal esta versión de prestashop. Alguna pista?? Gracias a todos.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More