Jump to content

oberton

Members
  • Posts

    88
  • Joined

  • Last visited

Everything posted by oberton

  1. Je peux te rassurer: j'avais fait cette même erreur il y a 2 ans...6 mois pour remonter mais après le site marchait tres tres bien...jusqu'à ma 2e boulette: changement d url images lors d une refonte il y a 6 mois! Depuis je me suis payé une bonne formation SEO (Ranking Metrics)!
  2. Il faut que le plus rapidement possible tu trouves un moyen de faire une recriture d url par le htacess faire des redirection 301 des anciennes url vers les nouvelles sinon tu vas perdre tout ton referencement pour un bon bout de temps. La bonne nouvelle c'est que va devrait être assez simple a ecrire comme regle car c'est toujours la même chaîne de texte apres id product. La mauvaise est que je ne connais pas assez bien la syntaxe url rewriting pour te le faire. Idéalement il faudrait mettre en place les urls simplifié sur ton nouveau site mais le format d url va encore changer Il devrait mettre un gros warning sur prestashop avant d effectuer une migration...il n'y rien de pire que les changements d url pour flinguer le réf
  3. Je pourrais tester mais il serait intéressant de vérifier dans le code source de ces pages qu'il y ait bien la balise noindex dans le header. ..on sait jamais!
  4. Ccilou: la seule utilité d'un sitemap est de te donner des stats sur l'indexation des images, catégories etc... et c'est grâce a gwt dans sitemap que tu peux voir l état d indexation des images. Tu peux aussi taper dans Google: site:nomdedomaine et aller dans images pour voir les images indexées. (Attention au www ou pas, c'est 2 url différentes) Il semble que ton sitemap soit vide. Ouvre le fichier xml et regarde ce qu'il y a dedans ca te donnera une indication. Les modifs que j'ai fait son dans le code php du module gsitemap pour générer un sitemap avec le bon format d'image. Sinon effectivement une maj va modifier les url images et Google a indexé tes anciennes url et ne connais pas encore les nouvelles. C'est un problème. Ca fait combien de temps que tu as effectué la migration?
  5. Patrick: fait une analyse Google insight de ton site. Tu devrais voir une recommandation de Google sur la compression des images. Va ensuite sur l'aide de Google et tu verras les outils qu ils recommandent pour compresser. Ca ma permis d'augmenter ma note de 6 points!
  6. Bon en fait je viens de vérifier et les attributs ALT sont renseignés pour la plupart de mes images. Par contre ils manquent sur le zoom thickbox...je pense que ça doit se passer dans la fonction thickbox mais je ne sais pas ou elle se trouve....
  7. Ca remet une balise ALT sur toutes les images existantes ou seulement les nouveaux produits?
  8. Cool! Ca aurait peut être fonctionné aussi avec thickbox si tu avais attendu 24h? Si tu te penches comme moi sur l indexation des images as tu regardé la compression lossless? C'est un élément important de Google page speed insight...
  9. De memoire ca avait pris un peu de temps (au moins 24 heures) avant de mettre a jour le graph
  10. Essaie ca... RewriteRule ^fr/$ http://www.tondomaine.fr [R=301,L] RewriteRule ^fr/sitemap$ http://www.tondomaine.fr/plan-du-site [R=301,L] RewriteRule ^fr/(.+)$ http://www.tondomaine.fr.com/$1 [R=301,L]
  11. La plupart des balises en doubles viennent de l'indexation des paginations et parametres d'URL. Il semble que le plus efficace est l'utilisation de la balise Canonical. Je l'ai implementé avec un module (SEO canonical de prestaworld) mais je réserve mon jugement sur l’efficacité car 2 semaines ont passées et j'ai toujours des doublons...
  12. Je m'etais penché sur ce problème et ce qui a fonctionné pour moi est de modifier le module google sitemap: Dans gsitemap.php j'ai modifié cette ligne: $image_link = $this->context->link->getImageLink($product->link_rewrite, $product->id.'-'.(int)$id_image['id_image'], 'thickbox_default'); Apparement thickbox_default passe mais ne demandez pas pourquoi :-) J'ai maintenant 1100 images indexées...mais ca ne veut pas dire qu'elles sont toutes bien positionnées! Pour info, j'ai aussi modifié la balise title pour utiliser le nom du produit plutot que la description courte mais cela ne s'applique peut etre aps a tous: 'title_img' => htmlspecialchars(strip_tags($product->name J'essaie de regler aussi le probleme de la balise ALT si qqun a des infos.
  13. Interressant, donc dans le product.tpl il faut rajouter {$product->name|escape:'htmlall':'UTF-8'} dans le ALT?
  14. En fait je suis entre les 2: les fichiers sont toujours dans l'ancienne arborescence (sous /img/p/) alors que le parametre indique a Presta d'utiliser le nouveau systeme...donc je me demande bien ce que cela a comme impact?! Je vois bien cette nouvelle arborscence avec pleins de img/p//0/1/2 et en regardant au hasard je vois des produits...j'imagine que les nouveaux produits utlisent donc cette nouvelle arborescence alors que les anciens sont sur l'ancienne arborescence...en tous cas je pense qu'il faudrait que je fasse une regle dand htaccess pour rediriger les anciennes URL image /ref-123456-large/nomproduit.jpg vers /123456-large/nomproduit.jpg... Des idees sur la syntaxe a suivres?
  15. Problème de referencement car nous avions 90000 impressions jour sur ces images et moins de 5000 après migration. Les images n'apparaissent plus dans Google images. Je viens de vérifier: Sur l'ancien site le paramètre était utliser l'ancien système de nommage: oui Sur le nouveau le paramètre est a NON alors que les images n'ont pas été déplacées! Je ne comprends pas bien l'impact de ce paramètre. ..
  16. Oui mais nous avons bien conservé l'ancien système de nommage donc ca vient d'autre chose
  17. Bonjour Suite a la refonte de notre site les URLs d'images ont change. Elles avaient ce format: 12678-6977-large/meuble-d-entree-metal-taupe-amadeus-meribel.jpg Et Maintenant: 6977-large/meuble-d-entree-metal-taupe-amadeus-meribel.jpg (la reference produit n'apparait plus) - Est ce que ces changement d'URL sont un fonctionnement "normal" lors d'un passage de 1.4 a 1.5 de Prestashop? - Si oui, quel type d'URL rewriting dans le htaccess devrait être effectue pour eviter des problemes de referencements? Merci
  18. Bonjour Je recherche un thème mono colonne, responsive, tres simple. Un truc qui ressemble a ça par exemple : http://www.creedboutique.com/ Vous auriez ca sous la main?! Merci
  19. C'est bon, ca ma permis de reviser mon SQL: INSERT INTO ps_category_product (`id_category`, `id_product`, `position`) SELECT 202, `id_product`, `position` FROM ps_category_product WHERE `id_category`= 200
  20. Je pensai me rapprocher avec: SELECT `id_product` FROM `ps_category_product` WHERE `id_category`=200; INSERT INTO `ps_category_product` (`id_product`,`id_category`) VALUES (`id_product`,203); Mais j'ai une erreur : #1062 - Duplicate entry '203-0' for key 'PRIMARY'
  21. Bonjour J'ai un millier de produits qui sont dans 1 ou 2 categories existantes. J'ai recree une trentaine de nouvelles categories. J'aimerai ajouter une 3e categorie a ces produits. Par exemple, produit A appartient deja a cat 3 et 4, je voudrais qu'il appartienne en plus a 5 si il appartient a 2. Existe t'il une requete SQL qui ferait ca: si produit X appartient a cat Y, rajouter une entree pour qu'il soit aussi associe a Z? Sachant que l'association se fait dans ps_category_product avec une ligne par categorie pour le meme produit: id_product 10885 id_category 86 id_product 10885 id_category 35 Il faudrait donc selectioner tous les n id_produits pour id_category = Y et faire un insert dans la table pour que les n id_produits avec id_category = Z Si un pro du SQL traine par ici, merci du coup de main! Sinon si quelqu'un a une autre idee pour faire ca je suis aussi preneur.
  22. Resolu! Pour info il faut copier les tables suivante pour recuper les produits: ps_category_product ps_product_lang (grosse table, presque une heure a renvoyer sur le serveur) ps_product_tag ps_image_lang ps_image ps_product Et evidement tout le repertoire /img/p (2 heures de copie dans mon cas)
  23. Bon j'avance : mes fiches produits sont restaurées mais elles ne sont plus associes avec les catégories...c'est quelle table pour ca?
  24. Help! personnes?? J'ai restaure les tables product, product_lang, product_tag mais toujours rien en BO ou front!!!
  25. Énorme erreur de ma part: j'ai coche "remplace les produits" lors d'un import en voulant juste importer 5 produits et mes 2000 produits ont disparus!! J'avais une sauvegarde de BdD d’aujourd’hui mais pas des photos (1 mois) J'ai restaure la table ps_products ma mes produits n'ont pas reaparu ... Je suis en train de renvoyer mes 20000 images dans \img\p mais je suis pas sur que ca suffise C'est la cata pour moi a cette période....comment faire pour récupérer juste toutes les fiches produits? MERCI d'avance
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More