Jump to content

Beautiful Makeup

Members
  • Posts

    10
  • Joined

  • Last visited

Profile Information

  • Location
    Nivå
  • Activity
    User/Merchant

Beautiful Makeup's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. Jeg fandt ikke umiddelbart noget modul der kunne løse min problemstilling. Men jeg har fundet min egen løsning, som jeg syntes jeg vil dele. Jeg har oprettet en pakke for hver af kombination, og skjult dem så de ikke komme frem nogen steder. Så har jeg oprettet en kategori med produktnavnet, og forsynet kategoribeskrivelsen med "radio-knapper" så kunden kan tilpasse sit produkt. Så har jeg lavet et jquery script der aflæser "radio-knapperne" og lægger den rigtige pakke i kurven når kunden trykker på køb-knappen. Løsningen kan ses her: http://www.beautifulmakeup.dk/78-beauty-basic Det eneste der ikke virker er animationen når jeg lægger noget i kurven, men det er til at leve med. Mvh. Jean
  2. Vi sælger nogen makeup startsæt hvor der indgår flere produkter, og som giver os lidt udfordringer mht. til lagerstyringen. Umiddelbart er det nemt nok at løse med produktpakker, men inde på produkterne skal man gerne kunne vælge sin hudfarve (fair, medium, tan og dark). Så farverne i startsættet bliver tilpasset til en, og så kan man ikke bruge produktpakker mere. Derud over kunne jeg godt tænke mig at kunne tilbyde noget i stil med: "Ønsker du at tilføje xxx for kun xxx,00 kr?". Pt. klare vi os med en del manuel lageropdatering, som ikke er holdbar i længden. Umiddelbart er det ikke noget der kan løses i standard Prestashop (1.5), men er der nogen der kender et, eller flere, moduler der kan klare ovenstående? Dbh. Jean
  3. Jeg har sammenlignet hvad der står under SEO & URLS" på min rigtige shop og på min testshop, og det er det er ens - på min testshop er der ingen problemer. Jeg har også prøvet at bruge testshoppens htaccess-fil på min rigtige shop (omdøbte alle url'er naturligvis), men uden held. Jeg har så prøvet at sidde og udkommentere forskellige linier i htaccess-filen og er kommet frem til, at hvis jeg udkommentere disse 2 linjer kan jeg tilgå mit backoffice - desværre giver alle sider på frontenden, undtagen forsiden, 404 fejl. :-) RewriteCond %{HTTP_HOST} ^www.beautifulmakeup.dk$ RewriteRule ^.*$ %{ENV:REWRITEBASE}index.php [NC,L] Det er meget mystisk for både shoppen og testshoppen ligger på samme server hos Meebox. Den eneste forskel er at www.beautifulmakeup.dk er hoveddomænet, og jeg har derfor flg. htaccess-fil liggende for at flytte domænet ned i en undermappe: RewriteEngine on RewriteCond %{HTTP_HOST} ^(www.)?beautifulmakeup.dk$ # (i stedet for "ditdomæne.dk", indsætter du dit eget domænenavn) RewriteCond %{REQUEST_URI} !^/beautifulmakeup.dk/ # (ændre "mappe" til den mappe du vil bruge til domænet) RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ /beautifulmakeup.dk/$1 # (ændre "mappe" til den mappe du vil bruge til domænet) RewriteCond %{HTTP_HOST} ^(www.)?beautifulmakeup.dk$ # (i stedet for "ditdomæne.dk", indsætter du dit eget domænenavn) RewriteRule ^(/)?$ beautifulmakeup.dk/ [L] # (ændre "mappe" til den mappe du vil bruge til domænet) Kan det have noget at gøre med den? /Jean
  4. Hej, Jeg har fået en underlig fejl på min shop. Når jeg prøver at tilgå mit backoffice, får jeg en 404-fejl (page-not-found). Hvis jeg så sletter min htaccess-fil, kan jeg godt tilgå mit backoffice. Men så virker de "user friendly" url'er i front office ikke. Hvis jeg så tvinger shoppen til at generere en ny htaccess-fil, ved at deaktivere de "user friendly" url'er og aktivere dem igen, får jeg igen samme fejl. Jeg har været i dialog med Meebox, om hvorvidt det kan have noget at gøre med dem - men det mener de ikke. Jeg hælder dog stærkt til at fejlen ligger der, da det passer nogenlunde sammen med at de har opdateret til Apache 2.4. Jeg køre Prestashop vers. 1.5.1.0. Er der nogen der har en ide til hvor fejlen kan ligge? Mvh. Jean
  5. I didn't realy found a solution. I just installed the shop again from a backup and now i works.
  6. Jeg har også prøvet det du foreslog, men uden held. Jeg valgte at kopiere filerne fra test shoppen igen, og nu virker det. Tak for hjælpen. /Jean
  7. Ja, jeg har læst denne tråd og jeg har indsat Quickpays ip adresse under maintenance. Jeg har prøvet at fjerne alle redirects og at slette og geninstallere Quickpay modulet uden held. Jeg har også haft kontakt til Meebox for at høre om de skulle have slået mod_security til, men de har de ikke.
  8. Hi, I'm running Prestashop vers. 1.5.1.0, i have a problem the validation of orders in my shop. It have emerged after i have moved the shop from our test domain, to our real domain. The problem is that the payment is processed correctly, but after ordering im directed to my order history, and the cart isn't emptied. No order have been placed. I have checked my log-file, and i get the following error when i try to place an order: [22-Feb-2013 00:36:41 UTC] PHP Fatal error: Call to a member function addOrderPayment() on a non-object in /home/beautifu/public_html/beautifulmakeup.dk/classes/PaymentModule.php on line 307 I have checked my servers traffic log and i can see that im getting following traffic when i try to place an order: 1. call from Quickpay (my payment provider) to /modules/quickpay/validation.php 2 call from my ip to /modules/quickpay/complete.php?key=8eb3e64d62a5ee26e84dbf0268110ecf&id_cart=378&id_module=111 3. call from my ip to /order-history It looks to me like there's no problem with the callback from my payment provider, but the order dosen't get validated. Any help will be highly apriciated. Regards Jean
  9. Hej igen, Jeg har gravet lidt i det og jeg kan se i loggen i mit cPanel at efter jeg har forsøgt at placere en ordre sker der flg.: 1. kald fra Quickpay's server til /modules/quickpay/validation.php 2. kald fra min ip til /modules/quickpay/complete.php?key=8eb3e64d62a5ee26e84dbf0268110ecf&id_cart=378&id_module=111 3. kald fra min ip til /order-history Det hele sker på under et minut - ingen ordre placeret. Det ser ud som at selve quickpay delen virker fint, så jeg er lidt lost på hvor det går galt. Igen enhver hjælp vil blive værdsat. Mvh. Jean
  10. Hej, Jeg har i et stykke tid arbejdet på at skifte fra vores Oscommerce shop til Prestashop. Planen var at gå i luften med den nye fra i morgen, men jeg har lige opdaget et stort problem, da jeg lige ville teste betalingsmodulet en sidste gang. Betalingen går i gennem hos Quickpay, og der kommer ingen callback fejl fra dem. Men efter betaling bliver jeg redirectet til orderoversigten, og der bliver ikke oprettet nogen ordere. Jeg har testet både med shoppen i aktiveret og deaktiveret (Quickpays ip-adresse er indsat). Jeg har tjekket logfilen i Quickpays modulmappe og den giver flg. fejl hver gang jeg prøver at placere en ordre: [22-Feb-2013 00:36:41 UTC] PHP Fatal error: Call to a member function addOrderPayment() on a non-object in /home/beautifu/public_html/beautifulmakeup.dk/classes/PaymentModule.php on line 307 Jeg har lavet en masse 301 redirects i htaccess filen, jeg ved ikke om det kan have indflydelse på dette. Det har virket for et par dage siden hvor jeg havde shoppen liggende på et test domæne på samme server hos Meebox.. Jeg køre PrestaShop™ 1.5.1.0 og Quickpay standard modulet vers. 3.17. Enhver hjælp vil blive værdsat. Med venlig hilsen Jean www.beautifulmakeup.dk
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More