Jump to content

smonnard

Members
  • Posts

    18
  • Joined

  • Last visited

Profile Information

  • Location
    suisse
  • Activity
    Freelancer

smonnard's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Bonjour à tous, Je viens donner des nouvelles suite au post précédent. Selon le message de mon hébergeur (oxito), l'envoi de message qui utilise une autre adresse que celle de l'hébergement n'est pas permise. Il faudrait que l'adresse de l'émetteur de la notification reste celle de l'hébergement. Est-ce qu'il existe une manière simple de remédier à ce problème ? J'imagine, peut-être à tort, qu'il faut utiliser le service SMTP ? Bonne fin de matinée !
  2. Hello Graphics, J'ai renvoyé une précision sur les erreurs à mon hébergeur Oxito. J'attends d'eux un retour de réponse et je la posterai en retour ici. Pour l'en-tête, rien de spécial à signaler. Nom de l'envoyeur : Service client Adresse email de l'envoyeur : [email protected] Je penche aussi pour un problème de service smtp. A suivre avec la réponse de l'hébergeur.
  3. Excellent, alors si j'envoie un email avec le même email qui va le recevoir, je reçois les deux. Edit : toutes les adresses finissant par @mon-nom-domaine.ch fonctionnent. Hors quand j'envoie depuis une autre adresse, je n'ai ni : - accusé de réception - ni notification email C'est une piste à suivre non ?
  4. C'est vraiment que la notification de départ par email qui est un problème. Est-ce que je peux activer un log ou quelque chose chose comme ça ? Graphique mis à jour
  5. 1. Le formulaire L'adresse du formulaire est la même pour : - service client - adresse de login de prestashop L'adresse avec laquelle je teste est une adresse avec un nom de domaine (hébergé chez oxito). Les mails sont configurés pour l'envoi par PHP MAIL. 2. Non pas d'emails dans les spams malheureusement. Notes : A. Par contre, lorsque je répond à l'email du client dans l'interface SAV de prestashop. Le client reçoit un message lui indiquant qu'il a reçu une réponse. B. Qui plus est, si je transfert dans le SAV la question du client à un employé (le seul employé et la seule adresse email), je reçois un email m'annonçant que je dois répondre au client.
  6. Afin de compléter mon problème, voici un schéma représentant mon problème.
  7. Bonsoir Grafics et merci pour ton apport à ma question ;-). Dans le backend, les emails sont configurés pour : - service client - webmaster Dans paramètres avancés également : - php mail Et le test fonctionne également, je reçois un email avec ce message : "Ceci est un e-mail test, votre serveur est prêt pour envoyer des e-mails." Cependant, lorsque je remplis le formulaire de contact, aucun email n'arrive. La notification est seulement est dans le backend.
  8. Bonjour à tous, J'aimerais recevoir une notification par email lorsqu'un client utilise le formulaire "contactez-nous". Pour le moment reste uniquement accessible par le biais de l'administration. Je reçois des emails pour : - nouvelle commande - requête sur une commande Je suis sur prestashop 1.6. J'avais le même problème sous la version 1.5.6. Mon thème est celui par défaut. Dans mes recherches, je tombe systèmatiquement sur des problèmes d'hébergement qui ne gère pas le "php mail", etc. Merci d'avance pour les quelques cheveux qui me restent, Samuel
  9. Hello Sab74, J'ai le même problème que toi. Autrement dit j'ai deux attributs : 1. Dimension 2. Couleur Je crée manuellement tous les attributs car suivant la taille j'ai pas toutes les couleurs. Hors sur Prestashop (même version que toi), lorsque je choisis une taille toutes les couleurs apparaissent aussi. Je remarque toutefois que lorsque je mets une taille avec les couleurs indisponible, le bouton "ajouter au panier" ne s'affiche pas. C'est bien, car j'ai pas de commandes de produits inexistants, mais un peu embêtant d'avoir des produits inexistants... Pour information, j'ai essayé avec le theme prestashop par défaut -> même problème. J'ai lu toute la doc concernant les attributs également. Voilà, à qui passera dans le coin ;-) !
  10. Hello à tous, Récemment j'ai migré une boutique prestashop 1.4.9 à la version 1.5.4.1. Dans la foulée j'ai rencontré quelques petits soucis avec : - les attributs (complètement dans le désordre) - aucune taxe sélectionné sur tous les produits - plus de photos (toutes les images étaient signalés comme invalides) Bref, tant bien que mal j'ai résolu grâce à la communauté du forum tous les problèmes, sauf un, celui des taxes. J'ai remarqué par la suite, que c'était le champ id_tax_rules_group qui indiquait si un produit a une taxe ou pas. Au départ, j'ai trouvé une réponse sur le forum avec une requête sql. Mais rien ne changea. En faite, ce champ se trouve dans deux tables : ps_product et ps_product_shop. UPDATE ps_product SET id_tax_rules_group = 1 UPDATE ps_product_shop SET id_tax_rules_group = 1 Si cela peut aider quelqu'un ;-) !
  11. J'ai enfin trouvé un début solution temporaire pour modifier le nouveau template. Dans le template officiel (ou par défaut de prestashop) on a <span id="our_price_display"> : <div class="price"> <p id="our_price_display"> {if $priceDisplay >= 0 && $priceDisplay <= 2} <span id="our_price_display">{convertPrice price=$productPrice}</span> <!--{if $tax_enabled && ((isset($display_tax_label) && $display_tax_label == 1) OR !isset($display_tax_label))} {if $priceDisplay == 1}{l s='tax excl.'}{else}{l s='tax incl.'}{/if} {/if}--> {/if} </p> Hors sur le template que j'ai acheté il est écrit ainsi <span class="our_price_display price"> : <div class="price"> <p class="our_price_display"> {if $priceDisplay >= 0 && $priceDisplay <= 2} <span class="our_price_display price">{convertPrice price=$productPrice}</span> <!--{if $tax_enabled && ((isset($display_tax_label) && $display_tax_label == 1) OR !isset($display_tax_label))} {if $priceDisplay == 1}{l s='tax excl.'}{else}{l s='tax incl.'}{/if} {/if}--> {/if} </p> Je constate également que le code de ce "nouveau template" a été mis à jour en 2012... Cela m'invite à comprendre le label "Attesté par Prestashop". A suivre pour cet apparté. La solution. Il d'ajouter l'id our_price_display en plus de la class our_price display et price. <div class="price"> <p class="our_price_display"> {if $priceDisplay >= 0 && $priceDisplay <= 2} <span [color=#b22222][b]id="our_price_display"[/b][/color] class="our_price_display price">{convertPrice price=$productPrice}</span> <!--{if $tax_enabled && ((isset($display_tax_label) && $display_tax_label == 1) OR !isset($display_tax_label))} {if $priceDisplay == 1}{l s='tax excl.'}{else}{l s='tax incl.'}{/if} {/if}--> {/if} </p> Même si cela est résolu, je me demande où se trouve ID our_price_display ?
  12. J'ai continué mes recherches et j'ai une nouvelle piste. En remplaçant le code product.tpl du nouveau thème par celui du thème par défaut de prestashop, mon prix change en fonction de la déclinaison choisie. Par contre (ce qui est logique), la mise en page change également. Le nouveau template qui ne prend pas en charge le changement de prix de la déclinaison : Le nouveau template avec le product.tpl du template par défaut de prestashop qui prend en charge le changement de prix de la déclinaison : Donc ma conclusion est que cela ne se passe pas au niveau du code javascript mais du php du fichier product.tpl Reste à savoi où :-) !
  13. Bonjour à tous, J'ai commencé à utiliser prestashop en novembre 2012 et j'ai toujours trouvé mes réponses dans ce forum. Mais depuis dimanche, je bloque sur un problème dont les réponses ne m'ont pas apportées de solution. Du coup, j'ai décidé de m'inscrire et en cherchant la réponse à mon problème j'ai trouvé quelques pistes et posté quelques réponses ou plutôt début de réponses dans d'autres posts. Affichage automatique d'une déclinaison de produit Sur le template de base de Prestashop 1.5.4.1 (front-end), lorsqu'on change de déclinaison dans la liste déroulante d'un produit, le prix se met automatiquement à jour. Sur le template que j'ai récemment acheté, le changement automatique ne se fait pas. J'ai contacté le vendeur du template en question et il m'a répondu que ce n'était pas une fonctionnalité faisant partie de son template. Du coup, je me demande comment modifier le code pour obtenir cette même fonctionnalité. Mes connaissances sont assez sommaires mais voici un début de piste : Le bloc div "product_attributes" renvoie des valeurs à l'adresse de la page sous la forme : index.php?id_product=94&controller=product[b]#/evo_prime_led_barre-xil_ep1020_20[/b] <div class="product_attributes"> <div id="attributes"> <div class="clear"></div> <fieldset class="attribute_fieldset"> <label class="attribute_label" for="group_7">EVO PRIME LED BARRE : </label> <div class="attribute_list"> <select id="group_7" class="attribute_select" onchange="findCombination();getProductAttribute();" name="group_7"> <option value="151" title="XIL-EP420 20°">XIL-EP420 20°</option> <option value="139" title="XIL-EP1020 20°">[b]XIL-EP1020 20°[/b]</option> </select> </div> </fieldset> </div> J'imagine alors bien qu'un code javascript s'occupe de mettre à jour automatique le prix. Mais comme dit précedemment je sais comment ça fonctionne dans les grandes lignes, mais pas davantage. Je vous remercie pour toute aide à dénicher le fameux code derrière ce fonctionnement :-) !
  14. Hello à tous, J'ai remarqué quelque chose de particulier en changeant de thème, peut-être que cela peut donner une piste de solution. Avez-vous essayé de mettre le template par défaut de Prestashop (qu'importe la version) pour voir comment sont gérées les déclinaisons ? Dans mon cas, le template de base gère très bien les déclinaisons dans tous les cas. Par contre avec un template fraîchement acheté, je rencontre le problème suivant : - lorsque je regarder les articles de la boutique et que je choisis une autre déclinaison, le prix ne change pas. Donc problème de template ? Bonne journée à tous !
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More