Jump to content

razaro

Global Moderators
  • Posts

    2,533
  • Joined

  • Last visited

  • Days Won

    22

Everything posted by razaro

  1. Hi and welcome to the forum. First part of code shows hook named displayNav, and hook are place where you attach code from modules. So there is no tpl file for hooks. Check http://doc.prestashop.com/display/PS16/Managing+Hooks. But what you what to edit is module blocklanguages and its tpl file that is "hooked" there. https://github.com/PrestaShop/PrestaShop/blob/1.6/themes/default-bootstrap/modules/blocklanguages/blocklanguages.tpl is tpl file for module in default theme, so if you use another find file in similar path.
  2. OK opened Pull request, with 2 changes. Added code so customer can be searched by username when creating new order from BO. Wanted also to override admin/themes/default/template/controllers/orders/form.tpl file, with small change to add username next to searched customer, but could not find a way from module install.
  3. On one page there could be multiple tpl used like for example category page. So no easy way to know all. But what you can see from page is name of controller that is used. If you check page html source you can see in body element id name of current controller and main tpl that is connected to that name. For modules in that id is made from module name and modules controller it uses. But in tpl there are often hooks with holds several modules attached, but that you can check in back office, Modules > Positions and search for name of the hook. Also use prestashop github search to find pats of code.
  4. I added modules override for AdminCustomerController.php so it saves username on form in back office and also show username in list, so customer can be searched by it. hslogginusername.zip
  5. Did you uploaded some modules or files recently ? Maybe some corrupt file transfer, so try uploading again. And ask your hosting about memory limit, current value and if it is 32M tell them to increse to 128 or 256M
  6. Try to enable debug mode http://www.prestashop.com/forums/topic/224525-how-to-turn-on-error-reporting-for-debug-information/ and see if any error appears. Also what is your memory limit, check Advanced Preferences > Configuration Information.
  7. If you search for F.A.Q try this free module http://www.prestashop.com/forums/topic/306420-faq-module-for-prestashop-15-16-versions-updated/
  8. First check that when you are installing module zip file it contains just module and not documentation and some other file. Because most of modules comes with all filles packed in one zip which contain inside another zip that should be used. If you have more issues try to contact developer after weekend. On http://addons.prestashop.com/en/front-office-features-prestashop-modules/2072-advanced-top-menu-responsive.html you have on right side , info about developer and link "Contact the developer" also try theirs contact form at https://www.presta-module.com/en/contact-us.
  9. Great, glad to hear that. Yeah it is strange, if it is paid theme check files you first downloaded, if it was there all along. It should not because it probably cause same error. And that Id "UA-562952[spam-filter]1" is it yours ?
  10. Yeah, you have <script> (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','//www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-562952[spam-filter]1', 'auto'); ga('send', 'pageview'); </script> there , delete it , or made backup in some file, and try then. If all works use default module and check if that "UA-562952[spam-filter]1" is yours.
  11. Hmm check then maybe themes/watchstore/header.tpl to see if there is by any chance some Google Analytics code, which would be strange a bit.
  12. File looks ok to me, but if module is disabled and still white screen try again to turn debug mode on. Maybe there is some other error now.
  13. OK but just to narrow it down, try to disable Google Analitics module , clear cache and try again. And check file header.tpl in modules/ganalytics/views/templates/hook ,or post it here.
  14. Check http://www.prestashop.com/forums/topic/386321-solvedfatal-error-when-updating-google-analytics-module/ think updating module would help.
  15. There is official paid guide http://addons.prestashop.com/en/user-guide/17304-prestashop-16-user-guide.html 500 pages like you asked :-) But there is documentation http://doc.prestashop.com/display/PS16/English+documentation and also you could check http://nemops.com/prestashop-101-series/ videos.
  16. Try other way then from wamp icon menu, Apache > Apache Modules and tick rewrite_module , also restart server.
  17. Do you use some program on localhost, what is your OS ? In apache , httpd.conf file line LoadModule rewrite_module modules/mod_rewrite.so needs to be uncommented. But if you are using Windows WAMP should be easier just from menu, and for linux think there is one command to type.
  18. Try to turn friendly url ON on local too, if not working check if php extension mod_rewrite is enabled. For live configurator, not sure, try to clear cache in back office > advanced preferences and if you working on local leave cache off . P.S check http://www.prestashop.com/forums/topic/256751-read-first-forum-rules-and-best-practices/
  19. Try to delete .htaccess file, and check back office and section SEO and URLS , it should contain link to local store. And try to turn off and on again Friendly urls.
  20. Hi Peter Welcome to the forum. What steps did you take and where you got stack in installation process ? Also check if you have in your hosting control panel , option to auto install software. Maybe Prestshop is in the list.
  21. Can you share link to your website ? What theme are you using ?
  22. Strange you do not have it, if it is got deleted download from https://github.com/PrestaShop/editorial/archive/master.zip and install. And if you already edited header.tpl, looks you are ok with FTP and editing files, so you could do this another way. Move that code to index.tpl file, that way it also will be displayed on homepage only.
  23. Just begin to type home in module search it will show Home text editor.
  24. Hi It looks nice, good use of default theme. Most of images are great choice. And while I was thinking what to write Paulito give some points that I would said also. Top menu is empty, you have blog, great, add link to it there. Social just Facebook, both in footer and on product page ? You are missing potential customers. Email in footer, agreed with Paulito again. That " Deluxe ejuice premium..." looks good on homepage but not needed on other pages. Especially on product page where beside it takes a lot of room and on lower resolution you would even miss image when page load, it also as H1 conflict with real H1 - product name. Product name that is optimized for SEO.
  25. Hi Welcome to Prestashop forum hope you have nice time with your store. PrestaShop is free so no reason to pay any money for it, before or after. It comes with a lot of free modules and nice default theme that you can customize. So you can install it on your machine and test it as much as you like. Check pinned posts in this sub-forum http://www.prestashop.com/forums/forum/7-installing-prestashop/. Also this is new option but you can try also http://www.prestashop.com/en/beta cloud version (but would have to wait couple of days).
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More