Jump to content

razaro

Global Moderators
  • Posts

    2,533
  • Joined

  • Last visited

  • Days Won

    22

Everything posted by razaro

  1. You should contact presto-changeo to help you out with your issue, because AWP id good choice for jewelry, as I guess you have lot of combinations. But for current issue try to disable all overrides for test only. Check in back office under Advanced Preferences > Performance, under Debug mode set disable all overrides to Yes. This is just for test to see if customer page works. If it does then check in override/controllers/admin/templates is there some view.tpl file. Also try to clear cache in Advanced Preferences > Performance.
  2. Do you have some new module installed, one that could override that and have some connections to customers ? Also could you post content of that view.tpl here ?
  3. Check this topic https://www.prestashop.com/forums/topic/338099-solved-problems-in-prices-with-combinations-000-16-1606/ and bur report mentioned there.
  4. Yes do that, but check positions in Home hook later, if you have few modules. Usually there is slider, then it should be theme configurator, and after that featured products module. Could be different for you. But just check that out.
  5. Try to go to Modules > Positions in back office and click transplant module. Find Theme Configurator and "hook" it to displayHome hook. If needed check order in Home hook in Modules > Positions.
  6. Is this module you asking about ? http://addons.prestashop.com/en/administration-tools-prestashop-modules/2937-store-manager-for-prestashop.html You have documentation on their website under support http://store-manager-for-prestashop-documentation.emagicone.com/
  7. Root category is main one for single shop, as Prestashop have multi-shop option. Home category is subcategory of root and contain every other category plus it is important as it holds featured products.
  8. Like helldog2004 said, link to your website could help but I think file is ajax-cart.js. It could be in your theme folder js/modules/blockcart/ or in root modules/blockcart. You can check latest version at https://github.com/PrestaShop/blockcart/blob/master/ajax-cart.js and look at line 214 // add picture to cart. Try to comment out all lines until 262 ajaxCart.updateCartInformation(jsonData, addedFromProductPage); That should not be commented out/deleted. Note this is just example as your code could be different.
  9. How does your category csv looks like? Did you force id maybe when importing? Note you should see in database, with phpMyadmin for example, that there are at least two categories Root with id 1 and Home with id 2.
  10. Have you register that hook in install method with $this->registerHook('pipposhow') and in back office Module > Positions do you see module "hooked" there ?
  11. Do you have multiple languages in store ? Also check directly in database, tables ps_category and ps_category_lang, if you think they are created. For info, what is your Prestashop version?
  12. Check this https://github.com/PrestaShop/homeslider/blob/master/views/templates/hook/homeslider.tpl and compare with you homeslider.tpl, in your_theme/modules/homeslider/ folder. {if isset($homeslider_slides.0) && isset($homeslider_slides.0.sizes.1)}{capture name='height'}{$homeslider_slides.0.sizes.1}{/capture}{/if}
  13. You need to go in back office to Preferences > Search and there you can re-build index. Plus there is link for cron job that will do auto indexing for you.
  14. Backup all files first, before any change. 1) Try this code, not sure exactly in what files, because your CCC options are on and css is compressed, but probably global.css and blocksearch.css in theme css folder. #header_right { margin-top: 15px; font-size: 11px; float: right; height: 165px; width: 100%; color: #aeaeae; } element.style { } #header_logo { position: absolute; right: 0; left: 0; top: 25px; height: 141px; display: inline-block; margin: 10px auto; text-align: center; background: url(http://www.thegeishapearl.com/themes/pt_chaussure/css/../img/bg-logo1.png) center center no-repeat; } #search_block_top { position: absolute; top: 53px; left: 0; } That should give you But that is quickest solution that is not responsive so additional css changes are needed or modification of tpl files and theme. 2) Go to back office and in Module > Positions find footer hook section. There drag/move block reassurance to first place. 3) Product page looks ok on 1920px width but on smaller screens it shows like that . Try to find and change in product.css this code #pb-right-column { float: left; width: 45%; margin-right: 2%; } #pb-left-column { float: left; width: 52% !important; } Note important is added here because of next code, not sure again where it is two_column #pb-left-column, .two_column .grid_16 #pb-left-column, .three_column .grid_15 #pb-left-column, .three_column .grid_16 #pb-left-column { width: 100%; margin-top: 20px; } That set pb-left-column to 100% but only if width of screen is less then 1280. 4) That needs bit code change in product.tpl find {if isset($HOOK_PRODUCT_FOOTER) && $HOOK_PRODUCT_FOOTER}{$HOOK_PRODUCT_FOOTER}{/if} and move it bit down in code almost to end just before last closing div tag.
  15. Well depends how your csv file looks. If you use , as field separator, that is ok just set in Advanced Preferences > CSVImport "Field separator" to , But then you will have to set "Multiple value separator" to something else like ; if you use that in csv file. Now I checked I think you have , in csv for both field and multiple value separator, judging from your image and how images are separated. That would cause problems if you try to import with , as selected separator. So I am sorry to say but think you will need to edit that csv file. Or if you can generate it again but with ; as main field separator. Can you post or PM beginning of csv, just first line and couple after ?
  16. Check themes/default-bootstrap/js/product.js //update display of the large image function displayImage(domAAroundImgThumb, no_animation) { if (typeof(no_animation) == 'undefined') no_animation = false; if (domAAroundImgThumb.attr('href')) { var new_src = domAAroundImgThumb.attr('href').replace('thickbox', 'large'); var new_title = domAAroundImgThumb.attr('title'); var new_href = domAAroundImgThumb.attr('href'); if ($('#bigpic').attr('src') != new_src) { $('#bigpic').attr({ 'src' : new_src, 'alt' : new_title, 'title' : new_title }).load(function(){ if (typeof(jqZoomEnabled) != 'undefined' && jqZoomEnabled) $(this).attr('rel', new_href); }); } $('#views_block li a').removeClass('shown'); $(domAAroundImgThumb).addClass('shown'); } }
  17. By the look of it, think you are using , as field separator but Prestashop by default have ; Did you change those settings before import ?
  18. Hi Sorry to hear about all your trouble with cloud. What is your website ? Will try to register and check reset password link. Edit: Found link in other topic. To me it is working ok. Link is correct, but this is maybe just me, it was not clickable, but pasted link worked. After inspection it had wbr tags in few places, but not sure that have to do with anything.
  19. There is also http://addons.prestashop.com/en/marketplace-prestashop-modules/6967-reseller.html but for 1.5 version or Prestashop. But from those 2 Agile Multiseller/vendors have better response from users, saw comments that is working well plus I am sure it have great support. On other hand Advance Marketplace Module, did not heard some positive comments only few bad ones. But either way make sure you write what options to you need through whole process of selling. What kind of products to you intend to sell, with or with combinations, what payment and shipping options you need, commissions from sellers and so on. Because those modules have addition modules that goes with them that adds to total cost.
  20. You could check this paid module https://www.prestashop.com/forums/topic/238033-module-retina-images/
  21. What do you expect from theme from 5 years ago :-) Think it was for version 1.2.5 of prestashop. Here is theme page with working link http://dgcraft.free.fr/blog/index.php/themes-prestashop/element-themes-prestashop-gratuits/
  22. Try to turn debug mode on in folder config, file defines.inc.php set if (!defined('_PS_MODE_DEV_')) define('_PS_MODE_DEV_', true); Maybe it will get some hint what is wrong. And if you get count maybe to try with this (int)Db::getInstance(_PS_USE_SQL_SLAVE_)->getValue($sql);
  23. yeah something like that. I changed instead test to have default image, got code from product.tpl but not sure if this could work . This is not tested so make backups {assign var=current_image value=getimagesize($link->getImageLink($product.link_rewrite, $product.id_image, 'home_default')|escape:'html')} {if $current_image[0] eq 125} <img src="{$img_prod_dir}{$lang_iso}-default-home_default.jpg" alt="{if !empty($product.legend)}{$product.legend|escape:'htmlall':'UTF-8'}{else}{$product.name|escape:'htmlall':'UTF-8'}{/if}" title="{if !empty($product.legend)}{$product.legend|escape:'htmlall':'UTF-8'}{else}{$product.name|escape:'htmlall':'UTF-8'}{/if}" {if isset($homeSize)} {/if} height="170" /> {else} <img src="{$link->getImageLink($product.link_rewrite, $product.id_image, 'home_default')|escape:'html'}" alt="{if !empty($product.legend)}{$product.legend|escape:'htmlall':'UTF-8'}{else}{$product.name|escape:'htmlall':'UTF-8'}{/if}" title="{if !empty($product.legend)}{$product.legend|escape:'htmlall':'UTF-8'}{else}{$product.name|escape:'htmlall':'UTF-8'}{/if}" {if isset($homeSize)} {/if} height="170" /> {/if} but instead {$img_prod_dir}{$lang_iso}-default-home_default.jpg you could have full path to your server if those variables are not defined.
  24. Think it is a problem with $dateJour variable. It is undefined in displayForm () function. You could move date calulation in displayForm or make dateJaour class variable.
  25. yeah 50000 is a problem. Did you check that folder, question mark image there ? If it is there then for presta that image is ok and that is why it does not show default language image. One thing I notice is that question mark image is 125x125 but regular, good images are 212x170. So maybe with some coding you could check width of image and then if equals 125 then use language default, otherwise if 212 use regular image. {assign var=current_image value=getimagesize($link->getImageLink($product.link_rewrite, $product.id_image, 'home_default'))} {if $current_image[0] eq 125} <img ... {else} <img ...{/if} Something like that maybe.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More