Jump to content

vpaban

Members
  • Posts

    32
  • Joined

  • Last visited

Profile Information

  • Location
    france
  • Activity
    Project Owner

vpaban's Achievements

Newbie

Newbie (1/14)

3

Reputation

  1. Quoi qu'il arrive ca ne fonctionne pas. Nouveau test: Quand je mets "ajouter au panier" lorsque le produit a des attributs sur non, dans mes nouveaux produits sur la page d'accueil il y a bien écrit "VOIR". Quand je passe par la catégorie j'ai "Ajouter au panier" qui apparait alors qu'il devrais y avoir "voir" je pense. MAJ 15:50 J'ai trouvé d'ou venait mon problème, c'est la navigation à facette qui fout le bordel et empêche la fonction. Je vais essayer comme ca et aprèsje chercherais le problème avec la navigation à facette. Merci Vectorus
  2. {if ($product.id_product_attribute == 0 || (isset($add_prod_display) && ($add_prod_display == 1))) && $product.available_for_order && !isset($restricted_country_mode) && $product.minimal_quantity <= 1 && $product.customizable != 2 && !$PS_CATALOG_MODE} {if ($product.allow_oosp || $product.quantity > 0)} {if isset($static_token)} {if $product.id_product_attribute > 0} <a class="button exclusive" href="{$product.link|escape:'htmlall':'UTF-8'}" title="{l s='Choice'}"><span></span>{l s='Choice'}</a> {else} <a class="button ajax_add_to_cart_button exclusive" rel="ajax_id_product_{$product.id_product|intval}" href="{$link->getPageLink('cart',false, NULL, "add&id_product={$product.id_product|intval}&token={$static_token}", false)}" title="{l s='Add to cart'}"><span></span>{l s='Add to cart'}</a> {/if} {else} <a class="button ajax_add_to_cart_button exclusive" rel="ajax_id_product_{$product.id_product|intval}" href="{$link->getPageLink('cart',false, NULL, "add&id_product={$product.id_product|intval}", false)}" title="{l s='Add to cart'}"><span></span>{l s='Add to cart'}</a> {/if} {else} <a class="button exclusive" href="{$product.link|escape:'htmlall':'UTF-8'}" title="{l s='View'}">{l s='View'}</a> {/if} {/if}
  3. voici le code ajouté dans product_list.tpl: {if ($product.id_product_attribute == 0 || (isset($add_prod_display) && ($add_prod_display == 1))) && $product.available_for_order && !isset($restricted_country_mode) && $product.minimal_quantity <= 1 && $product.customizable != 2 && !$PS_CATALOG_MODE} {if ($product.allow_oosp || $product.quantity > 0)} {if isset($static_token)} {if $product.id_product_attribute > 0} <a class="button exclusive" href="{$product.link|escape:'htmlall':'UTF-8'}" title="{l s='Choice'}"><span></span>{l s='Choice'}</a> {else} <a class="button ajax_add_to_cart_button exclusive" rel="ajax_id_product_{$product.id_product|intval}" href="{$link->getPageLink('cart',false, NULL, "add&id_product={$product.id_product|intval}&token={$static_token}", false)}" title="{l s='Add to cart'}"><span></span>{l s='Add to cart'}</a> {/if} {else} <a class="button ajax_add_to_cart_button exclusive" rel="ajax_id_product_{$product.id_product|intval}" href="{$link->getPageLink('cart',false, NULL, "add&id_product={$product.id_product|intval}", false)}" title="{l s='Add to cart'}"><span></span>{l s='Add to cart'}</a> {/if} {else} <a class="button exclusive" href="{$product.link|escape:'htmlall':'UTF-8'}" title="{l s='View'}">{l s='View'}</a> {/if} {else} {/if} </div> </li> {/foreach} </ul> <!-- /Products list --> {/if}
  4. Merci pour ton info mais ca ne fonctionne pas avec moi sniifff. Il n'y a pas de différence
  5. Bonjour, Ma boutique étant maintenant en ligne http://www.smartphone-access.fr, je souhaiterais pouvoir obliger le client à faire le choix d'un attribut (dans mon cas une couleur avant de mettre les articles au panier? J'ai fait des recherches sur le forum mais je ne trouve pas d'infos clair sur PS 1.5.3 j'ai fais des tests de modifications sur le fichier Product-list.tpl mais rien ne fonctionne. Quelqu'un a-t-il une solution ou une module? Merci à tous
  6. es tu en gestion des stocks avancées? Si oui regard si ton transporteur est activé dans l'entrepôt.
  7. Dans le transporteur As-tu assigné les ID Nom de groupe pour visiteur et invité?
  8. Problème résolu: Explication En gestion des stocks avancés vous sélectionné vos transporteurs dans l'entrepôt. Ensuite retourner dans Catalogue/produit, aller dans l'onglet "entrepots" et cocher la case stocké sur l'entrepot de votre choix. Enregistrer et la ca fonctionne nickel!!!!!!! Je me doutais qu'il y avait un réglage quelque part qui foutait le bordel hihihihi....... J'espère que cela va reussir à tout ceux qui ont ce problème.
  9. Merci a tous pour ces remonter d'info. J'ai tout repris à zero avec la MAJ 1.5.4 cependant le problème persiste. Pour tout faire fonctionner correctement j'ai du retirer la gestion avancée des stock snifffff..... Depuis tout les tests sont au vert. Mais j'aimerais bien que les développeurs trouve une solution pour la bonne et simple raison c'est que la gestion avancé sera très important en cas de développement. Merci à tous et si vous avez d'autres idées avec la gestion des stock je prends.
  10. Ok j'ai trouvé. dans la ligne 672 Tools::addonsRequest: Tools doit être remplacé par $this->addonsRequest J'espere que ca servira à certains. Merci Mise à jour 1.5.4.0 ok pour moi
  11. Bonjour, Je suis en train de mettre à jour prestashop en manuelle car mon hebergeur ne peut me permettre de le faire en automatique. J'ai bien réussi a faire fonctionner le site avec la base de donnée cependant j'ai des galère pour acceder au BO. J'ai d'abord activer les messages d'erruer sur le fichier config.inc.php. Quand je rentre dans le back office il me demande mes identifiants mais des que je valide les identifiant il me met: Fatal error: Call to undefined method Tools::addonsrequest() in /web/smartphoneacces/www/controllers/admin/AdminHomeController.php on line 672 En regardant à la ligne 671/672 du fichier j'ai: if (!$this->isFresh(Module::CACHE_FILE_DEFAULT_COUNTRY_MODULES_LIST, 86400)) file_put_contents(_PS_ROOT_DIR_.Module::CACHE_FILE_DEFAULT_COUNTRY_MODULES_LIST, Tools::addonsRequest('native')); De la je ne sais pas quoi faire. Merci de vos réponses.
  12. J'ai appelé le service technique. En fait le script de mise a jour 1 clic dure 2 min mais les serveurs de 1hebergement.com bloque à 30 seconde. seul solution passer en manuel.... Sniff je vais chercher comment faire.
  13. Merci pour cette info. J'ai deja fait une sauvegarde de ma base et de mon site pas de souci pour ca. J ai une erreur 404 des que je valide le fait de ne pas sauvegarder dans Option de sauvegarde je ne comprend pas pourquoi désolé encore de demander de l'aide.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More