Jump to content

zi-dan

Members
  • Posts

    60
  • Joined

  • Last visited

Everything posted by zi-dan

  1. Pour ma part j'ai développé un module qui permet de supprimer un paiement, changer un mode de paiement, changer le mode de livraison... au moins tout est pratique pour l'utilisateur en back office et le client ne se rend compte de rien!
  2. Hum... en plus clair. Le problème de TVA se situe au moment où le système la TVA du produit et l'insère donc dans la table order_detail_tax. Concernant le fait que je ne cherche plus de solution c'est tout simplement que pour éviter le problème lié à la livraison gratuite qui crée un code promo et fausse donc la TVA j'ai développé une fonction supplémentaire à mon module pour pouvoir supprimer les frais de livraison d'une commande. Du coup au lieu d'avoir 100€(produits) + 5€ (fdp) - 5€ (FDP) mon module fait tout simplement que le commande se résume au montant des produits. Est-ce plus clair?
  3. Le problème vient au moment du calcul et de l'insertion dans order_detail. Par contre, comme j'avais développé un module de modifications de commandes sur la détail de la commande dans le BO (suppression de factures, suppression de paiements, changement de client sur la commande...) je viens d'ajouter la suppression de frais de livraison. Du coup je ruse... et ça fonctionne très bien. Cela sera donc une bonne solution en attendant la résolution du calcul de la taxe par produit.
  4. Bonjour, En fait, ce n'est même pas lié à la réduction mais uniquement à la livraison offerte. Si depuis le BO on crée une commande en cochant livraison gratuite par exemple 1 Produit x 10€ Livraison offerte 5€ on a une ligne réduction qui note 10€! Donc il y a doublon, le site prend livraison offerte plus la remise lié à cette livraison. Forcement le calcul de la TVA devient par conséquent aussi fausse. Je vais voir pour corriger ce problème pour mon client. Je vous tiens au courant si je le fais... :-)
  5. Cliquez sur Réinitialiser... vous devez faire un tri sur la liste du coup les flèches ne sont pas activées.
  6. Voir ma réponse de ce jour ici... si jamais ça peut fonctionner pour vous... http://www.prestashop.com/forums/topic/251116-resolu-probleme-maj-error-unable-to-check-md5-files/page__p__1249156__hl__unable%20to%20check%20md5%20files__fromsearch__1?do=findComment&comment=1249156
  7. Bonjour, J'avais le même problème et je l'ai visiblement résolu... Je ne sais pas ce qui a été déterminant mais voici ce que j'ai fait: - désactivé le module autoupgrade (j'avais bien la dernière version mais j'avais une précédente auparavant) - désinstallé '' '' - supprimé '' '' - j'ai refais une installation du module - j'ai modifié les droits sur /modules/autoupgrade (qu'ils sont bien en executable) - idem sur le repertoire /admin/autoupgrade - bon pour éviter les soucis j'ai aussi téléchargé moi-meme prestashop que j'ai déposé dans le repertoire /admin/autoupgrade/download Et je viens juste de faire la mise à jour, enfin... Donc soit c'était un problème de droit sur le module à la fois sur le répertoire modules/autoupgrade et sur le répertoire admin/autoupgrade....
  8. Bonsoir, Je confirme et je suis rassuré que nous ne sommes pas seuls à avoir ce problème. Nous avons plusieurs boutiques touchées. Heureusement des clients nous ont contacté et nous avons desactivés de suite le module. Entre fianetfraud (certissim) qui rame tout le temps et fait ramer chaque ouverture de commande dans le back office et maintenant le module kwixo... c'est vraiment pénible. Les conséquences de tous ces aléas l'emportent sur les bénéfices de ces solutions pourtant interressantes. Dommage.
  9. Hum. ok. Moi j'ai tout modifié au niveau du module toprelais donc je peux pas te dire si ça vient du module ou non sans mettre les mains dedans... par contre, au niveau themes, il est récent ? Tu connais la version du theme ? Autre question, le relais colis est bien sélectionné vu que tu vas jusqu'au bout du processus, non? Ça ne peut pas être un problème de prise en compte du relaiscolis? Normalement la prise en compte du relais colis n'est utile que pour le module pas pour le prix (donc module transporteur) donc ça ne devrait pas être lié mais ce module je le trouve un peu particulier... et pas fini.
  10. Au niveau transporteur tout est bon? Au niveau des tranches de poids il n'y a pas de problèmes? Par exemple de 0 kg à 1 exclu et de 1 inclus à 2 par exemple. Et pas 1.001 à 2... J'ai deux clients qui avaient des problèmes de tarifs à cause des tranches de poids mal configurées. Dan.
  11. Oui et puis surtout qu'il n'est pas fonctionnel avec la version 1.3.2 sans modification. Mais ça ne va pas tarder :-) Pour ceux qui ont des problèmes en suivants nos posts vous devriez pouvoir le faire fonctionner sans problème. dans le cas contraire postez vos problèmes ici ou contactez le créateur du module ou moi si vous voulez.
  12. Par contre, une petite question... que penses-tu d'un passage automatique des commandes de préparation en cours à en cours de livraison quand le client a généré le CSV pour les BL... en tout cas c'est la demande de mon client... et c'est vrai que ça pourrait être une option avec une configuration possible pour les changements statuts dans l'admin du module... je te soumets l'idée.. :-) Ps : au départ je lui ai proposé uniquement un outil pour réimporter un fichier de rapport que doit certainement généré le logiciel de toprelais comme j'ai pu le développé pour le logiciel de la poste expeditor inet mais c'est vrai que pour ceux qui préparent leur colis au fur et à mesure ça peut être un plus en option... :-)
  13. Et moi, j'ai rajouté d'autres informations car ces modifications n'étaient pas suffisante pour mon client. Du coup, je me dis merci et je dis aussi merci à tout ceux qui ont permis de rendre la version fonctionnelle sous 1.3.2.
  14. Le mieux serait d'afficher ce chemin absolue directement dans la gestion du module non? Il ne faut pas oublier que normalement pour un client tout ça est abstrait et ce qui fait la force de prestashop c'est que l'on peut mettre en service (pour aller plus loin, il faut un professionnel comme nous deux...) sans avoir de connaissance ou besoin d'aller dans le code. Enfin, c'est juste un détail, une suggestion pour ta prochaine version :-)
  15. Salut! C'est Dan. Nous nous sommes eu au téléphone à propos du module que vous développé : toprelais. je viens de corriger l'erreur car même avec ces modifications cela n'était pas suffisant! je précise sur une 1.3.2 avec template à jour! Apparemment la modification proposé ne permettait toujours pas de remplir le champ caché back donc ce que j'ai fais tout simplement c'est dans le fichier toprelaiscarrier.php : En fait à la ligne 352 le script initialise la variable $_POST['back'] = 'extracarrier' ; Mais le truc c'est que dans le fichier order-carrier.tpl il y a <input type="hidden" name="back" value="{$back}" /> donc ce que j'ai fais c'est simplement mettre extracarrier dans la variable smarty back : $smarty->assign('back', $_POST['back'] ); juste après la ligne 352. Et donc là je n'ai plus aucun problème ! Que cela soit par chèque ou paypal... (vous ne m'aviez pas dit que le module ne fonctionnait pas avec payapl ?) Il ne me semble pas avoir modifié autre chose... A si mais ça c'est par gout ! Dans l'administration je ne vois pas l'intérêt de lister toutes les commandes en cours de préparation dans l'onglet BL toprelais. Pour des sites avec de nombreuses commandes une liste sans pouvoir différencier mieux que cela n'a aucun intérêt donc pour moi il vaut mieux mettre INNER JOIN plutôt que LEFT JOIN pour la jointure avec la table _orders_delivery_toprelais. Parce que toprelais n'est pas le seul transporteur à être utiliser sur une boutique. Par contre avec ma modification (ou peut-être c'était censé fonctionner comme cela de base) j'ai dans l'affichage de la commande dans le back office l'encart toprelais même si le système toprelais n'a pas été choisi. Bon il est vide mais ça ne me satisfait pas et mes clients n'ont plus je pense donc du coup j'ai aussi modifié le fichier TopRelaisTools.php en rajoutant un test sur la valeur de l'id toprelais ligne 311 après $topRelais = TopRelaisBean::getByOrderId( $orderId ) ; if($topRelais->point_relais_id>0){ et bien sûr il faut fermer le test à la ligne 325 environ. Voilà. En espérant que cela pourra vous aider pour corriger votre module ou le faire évoluer... Cordialement. Dan.
  16. Ce post est vieux mais juste pour ceux qui passeraient et verraient ce problème ! C'est un problème de mémoire allouée ! Il faut donc modifier le php.ini du serveur. En espérant que cela soit utile !
  17. Il se passe simplement que, semble-t-il suite à un manque de réactivité de la part de l'éditeur du module, fashionprice a décidé de trouvé un prestataire. Étant le prestataire qu'il a sélectionné, j'ai donc mis à jour son site en 1.3.2 et résolu son problème.
  18. Pour tous les autres qui ont ce problème, je suis le prestataire qui a résolu le problème de fashionprice. Vous pouvez donc me contacter par MP si besoin.
  19. Pour ceux que cela intéresse. J'ai mis à jour le module mondial relay pour la version prestashop 1.3.2. Cordialement. Dan.
  20. Pour ceux que cela intéresse. J'ai mis à jour le module mondial relay pour la version 1.3.2 de prestashop qui est sortie il y a quelques jours. Cordialement. Dan.
  21. Pour ceux que cela intéresse. J'ai mis à jour le module mondial relay pour la version 1.3.2 de prestashop. Cordialement. Dan.
  22. C'est de la grosse daub ! Je viens d'essayer de le désactiver ca fait foirer tout le site ! Surtout n'achetez pas !!! Moi qui pensait gagner du temps en ne le développant pas...
  23. " -customers real e-mail address;" when i test on my website i see only [email protected] in my facebook account i have choose "email is private, not show". "customers real e-mail address" is only if the customer choose to show e-mail addres in Facebook account ?
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More