Jump to content

Olaf

Members
  • Posts

    23
  • Joined

  • Last visited

Olaf's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. On the third step of the installation/update process, the updater checks your configs. "System compatibility"... One section is checking the permissions on folders (/img, /modules, /themes/prestashop/lang, /translations). I have all configs in green/ok, but the /img check appears with a red flag. I have set 777 to this folder recursively, so i don't know how to fix this warning. The installer doesn't let me continue with the installation. In the next step it show a warning that i haven't correct config. Wait, I try to continue in spite of the warning and now it lets me continue. Installation complete... Something strange... Greetings, Olaf Marcos
  2. Hi! I can not remove this error. I have set 777 permissions on img and subfolders... Any advices? Best regards, Olaf Marcos
  3. A little update !! I see some files on /compile folder: -rw-r--r-- 1 www-data www-data 4091 ene 28 23:00 % ^099^0994CDE0%%blockbestsellers.tpl.php -rw-r--r-- 1 www-data www-data 10621 ene 28 23:00 %^18E^18EC2E74%%blockcart-json.tpl.php -rw-r--r-- 1 www-data www-data 458 ene 28 23:00 %$^24D^24D1B7C7%%footer.tpl.php -rw-r--r-- 1 www-data www-data 2184 ene 28 23:00 %D^44D^44DAF8FD%%blockcategories.tpl.php -rw-r--r-- 1 www-data www-data 15855 ene 28 23:00 %^5C7^5C7822C5%%blockcart.tpl.php -rw-r--r-- 1 www-data www-data 5871 ene 28 23:00 %o^6FC^6FC7A4E3%%blockwishlist.tpl.php -rw-r--r-- 1 www-data www-data 3253 ene 28 23:00 %
  4. Mmmm, yes and no. I can change themes from the BO setting 777 permissions to all files and folders. But now, I don't know what are the correct permissions to the file and folders structure? Setting 644(664) to all files, 755(775) to all folders and 777 to folders as install intructions, I back to the begginng. Can not change themes in BO. So, yes and no... I know that is something with permissions, but what are the correct permissions? Regards, Olaf Marcos
  5. I guess those aren't the correct permissions or I have any other problem... I have tried with these two little scripts... find ./ -type f -exec chmod 644 {} \; find ./ -type d -exec chmod 755 {} \; chmod 777 ./config ./upload ./download ./tools/smarty/compile chmod 777 ./img ./mails ./modules ./themes/*/lang ./translations -R and find ./ -type f -exec chmod 664 {} \; find ./ -type d -exec chmod 775 {} \; No luck! Any other suggestions about the correct permissions?? Regards, Olaf Marcos
  6. The last permissions try... All files and folders 777... and... BINGO. I will try to set now the correct permissions???? All files 644, all folders 755 and the 777 as the install instructions??? I will post with news... Better regards, Olaf Marcos
  7. I tried to set the same permissions for user and group on themes folder structure and settings.inc.php, but no luck... Wowhh!! I can't belive !! So easy thing !! :-S Regards, Olaf Marcos
  8. Yes, the themes are installed correctly. But, why I can not change them from the Appearance menu in the BO? Regards, Olaf Marcos
  9. I think permissions are as documentation, but I have some ideas about where the problem might be. First, I apologize for no comment this... I have over an ISPCONFIG system... This system set virutal domains with these file owners: webX_user:webX(group) For example: drwxr-xr-x 7 web10_sac web10 4096 ene 25 18:15 themes ./themes rw-r-r— 1 web10_sac web10 5521 ene 24 22:06 debug.tpl drwxr-xr-x 7 web10_sac web10 4096 ene 25 18:07 descanso drwxr-xr-x 8 web10_sac web10 4096 ene 25 18:14 elrey rw-r-r— 1 web10_sac web10 298 ene 24 22:06 index.php drwxr-xr-x 7 web10_sac web10 4096 ene 25 18:02 iris drwxr-xr-x 8 web10_sac web10 4096 ene 24 22:06 prestashop drwxr-xr-x 6 web10_sac web10 4096 ene 24 22:06 .svn Well, apache is running with "www-data" user, which is included in group "web10". So, in my case, I think the group must have the user permissions that you suggest. Am I in the correct way? But, I dude cause this is the only problem that I have. And if I am correct with these sentences, I imagine that some things would be crashing... I don't know... What you think? Regards, Olaf
  10. Hi KGal: I change the config.xml of all folders/themes to reflect their folders' name... No change... Anyway, the free themes I download to test have the default name and description in config.xml: "Prestashop", "This is de default Prestashop..." Has anybody the permissions table that must have themes folder??? Regards, Olaf Marcos
  11. Hi KGal: Yes, the previews are in theme's folder and I see them in BO --> Apperance... Regards, Olaf Marcos
  12. Hi Dahl99: I tried that with 2 differentes free themes. I see the changes in FO, but I can not change themes in BO (although the changes saves succesfully). I must do editing the config.settings.php directly... I hope more suggestions, tests, etc. Best regards, Olaf Marcos
  13. Any change... I just copied, set permissions and owners and try to change through the BO. No luck yet... Greetings, Olaf Marcos
  14. I've copied the default theme and rename. Set permissions and owners. Regards, Olaf Marcos
  15. Permissions as you tell, but no change... drwxr-xr-x 7 web10_sac web10 4096 ene 25 18:15 themes ./themes -rw-r--r-- 1 web10_sac web10 5521 ene 24 22:06 debug.tpl drwxr-xr-x 7 web10_sac web10 4096 ene 25 18:07 descanso drwxr-xr-x 8 web10_sac web10 4096 ene 25 18:14 elrey -rw-r--r-- 1 web10_sac web10 298 ene 24 22:06 index.php drwxr-xr-x 7 web10_sac web10 4096 ene 25 18:02 iris drwxr-xr-x 8 web10_sac web10 4096 ene 24 22:06 prestashop drwxr-xr-x 6 web10_sac web10 4096 ene 24 22:06 .svn Aghhhh. So trivial... Is there anywhere some debug file or anything to look at? Best regards, Olaf Marcos
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More