Jump to content

larson210

Members
  • Posts

    42
  • Joined

  • Last visited

Everything posted by larson210

  1. Je viens de mettre comme ceci: <h1>{$category.name} {$smarty.get.page}</h1> Cela me met bien un numéro sur les pages paginées j'aurais aimé malgré tout qu'on ai ma mention "page" et le numéro. une petite idée pour mettre en dur ce nom "page" avant le numéro de la page? merci
  2. Bonjour à tous, je ne vais pas rouvrir un autre topic concernant ce soucis. J'ai changé radicalement de thème en achetant un Template vraiment optimisé SEO, qui est vraiment pas mal sur ce point… je rencontre néanmoins un petit soucis. J'aimerais que les pages paginées génèrent automatiquement sur le {$category.name} le numéro de page (sauf page 1). Exemple: page 1 de la catégorie "attache tétine" --> <title><h1>attache tétine</h1> page 2 de la catégorie "attache tétine" --> <h1>attache tétine - page 2</h1> page 3 de la catégorie "attache tétine" --> <h1>attache tétine - page 3</h1> etc.... Le but de l'opération: N'avoir qu'UN seul H1 du même nom… Car dans cette histoire, si j'ai 10 pages de produits paginés sur cette catégorie "attache tétine" alors j'ai 10 pages avec ce même nom en balise tille H1... Quel serait alors le code qui me permettrait d'automatiser l'opération de renommage des pages paginées en reprenant le numéro de la page (comme dans les url) et l'intégrer dans la balise H1 du {$category.name} ? Voici mon bout de code de catégory.tpl: {block name="category_head"} {if isset($category)} <section class="kl-category-section"> {if $category.image.large.url} <img class="img-fluid" src="{$category.image.large.url}" alt="{$category.name}" loading="lazy"> {/if} <div class="container"> <div class="row"> <div class="col"> <div class="kl-intro"> <h1>{$category.name}</h1> {if isset($category) && $category.description && !isset($smarty.get.page)} <div id="category-description"> {$category.description nofilter} </div> {if $category.description|strip_tags|strlen > 330} <p class="more-description kl-see-more">{l s='Read more' d='Shop.Fashionseo'} <br> <i class="material-icons">expand_more</i></p> {/if} {/if} </div> </div> </div> </div> </section> {/if} {/block} Merci beaucoup de votre aide!
  3. Merci de ton retour et de tes explications bien détaillées je pense que tu vas aider beaucoup plus de personnes que tu ne le penses qui seront dans la même situation que toi comme je l'ai été de mon côté aussi passe une bonne journée et profite bien de ta nouvelle boutique
  4. Ce qui serait sympa mon ami pour tous ceux qui liront les postes de ce topic ce serait d'expliquer comment vous avez réussi à résoudre votre problème car bien souvent et c'est ce que je déplore un petit peu sur beaucoup de forum divers et variés c'est que des personnes pose des question d'autres personnes essaient de résoudre selon nos compétences sur les problèmes et ensuite on a pas le retour de savoir quelle procédure a été utilisée pour la résolution Donc ce qui serait sympa c'est de décrire où était le problème est la méthode de résolution pour les autres à la ligne je suis content que vous ayez retrouvé votre boutique et vous souhaite de bonnes ventes.
  5. Je comprend bien le but étant malgré tout de s'entraider j'essaie de contribuer au mieux espérant qu'il retrouve sa boutique fonctionnelle 😉
  6. Ça fonctionnera pas forcément.. Du moins de mon côté ça n'a pas fonctionné.. J'ai effacé cette ligne et je n'ai plus de soucis..
  7. Bonjour, J'ai installé récemment une boutique en Prestashop 1.7.7.1 j'ai essayé de mettre le mode debug pour résoudre un problème sur un module Une fois le mode debug me je me retrouve avec ces erreurs : Pourriez-vous me dire ce que je dois faire pour les corriger si tenté ces erreur sont déjà connu je vous remercie
  8. Je te le souhaite, Pour ma part, j'ai réinstallé une boutique toute neuve pour des tests, et rien mis dessus après l'installation. J'ai testé directement le mode debug et paf, les mêmes soucis après avoir effacé cette ligne, ça a refonctionné mais le front office est super lent, la j'attends que mon fournisseur fasse le taff pour voir et résoudre ce soucis de lenteur, tout en réglant ce problème de droits au dossier du php.ini car je ne trouve pas ça normal de base. Pour ta migration, personnellement j'ai investi dans le module migration pro qui fait le taff au delà de mes espérances... Récupération des catégories, clients, mots de passes produits, photo, etc... en quelques clics. Je le lance et suivant ton catalogue (moi j'ai plus de 800 produits et 9000 clients) il va me mettre en gros 2h pour tout le rapatrier sans soucis particuliers, et je garde toutes les ID de mon ancienne boutique idéal pour ne pas casser mon référencement.. Voilà pour le conseil !
  9. Alors j'ai le meme soucis... pour régler temporairement le soucis, tu vas dans cpanel/logiciel/Éditeur INI MultiPHP a la troisième avant dernière ligne tu retrouvera le champ: /var/cpanel/php/sessions/ea-php72 Cpanel autorise les champs "null" donc efface cette ligne et sauvegarde... cela va refonctionner mais le mode debug a un soucis... bref c'est une solution temporaire.... j'ai contacté mon hébergeur qui galere avec ca pour autant ca me parait simple de changer les permission mais bon.... voila pour t'aider TEMPORAIREMENT. Autre piste également, trouver le fichier : user.ini dans la public html (paramètre de cpanel en haut a droite du ftp / afficher fichier cachés). Supprimez le il sera automatiquement régénéré avec le bon chemin (/var/cpanel/php/sessions/ea-php72) lors d'un rafraichissement de page, et cela devrai refonctionner. par contre cela n'enlève pas les soucis de droit qui causent l'erreur donc retour à l'erreur si on met en mode débogage. Ne pas oublier avant toutes choses de désactiver le mode déboggage dans le ftp fichier: public html/config/define.inc en changeant "true" par "false"...
  10. je vais regarder ca avec attention. merci de vos réponses une fois de plus.
  11. C'est vraiment dommage malgré tout que cela se passe ainsi.... prestashop est un bel outil à la base, dommage
  12. Je suis mille fois d'accord avec vous..... j'aimerais tellement que ca soit aussi simple. Autant je travaille avec prestashop depuis des années ( premiere version 1.4 si je ne me trompe pas...) autant à chaque mises à jour de prestashop c'est la croix et la bannière.. car les modules spécifiques n'avancent pas en même temps que les versions de prestashop, entrainant d'attendre que ceux ci indispensable pour moi soient compatibles, autant , dés que je teste que ce soit en local ou sur un autre hébergement de faire la MAJ prestashop se met à chaque fois en carafe....Donc pour finir je me retrouve toujours à refaire une boutique complète en partant de 0 et en refaisant toutes mes catégories, articles et modification de fichiers pour mes modules etc.... ( cela me prend presque 3 semaines 1 mois) pour tout refaire.... Sans compter je vous le donne en mille, un gros soucis de référencement car les URL ne sont plus tout a fait les mêmes.... C'est vraiment dommage que la MAJ de prestashop ne se fasse jamais sans soucis de mon côté, ce qui me rend fébrile de les tenter au risque de tout planter.
  13. C'est une excellente nouvelle, donc le soucis à déjà été relevé et modifié! reste à savoir ou... Avez vous une idée des fichiers qui codent cette pagination (j'ai vérifié pagination.tpl sans succès). Je suppose que c'est dans un autre ficher ou fichier de module que ca se trouve.
  14. Nous pouvons remarquer qu'on a : et en début de code . quelle en est la différence, et comment y remédier pour qu'il n'y ai qu'une seule "description_short"
  15. Surement mais je ne développe pas du tout de mon côté, mais c'est sympa de m'avoir conseillé
  16. Ok, votre réponse ne m'enchante pas j'eu espéré que c'était déjà remonté ou qu'il eu fallu simplement réinitialiser un module qui m'aurai mis le Bazard ou revoir du code de mon thème... bref un truc "connu" . Merci en tout cas du temps que vous m'avez consacré. bonne journée à vous! PS @Mediacom87: je viens de poster un autre soucis , si vous en avez la réponse, ca serai avec plaisir!
  17. @Mediacom87 Donc ceci est un soucis d'ordre général, que vous retrouvez tous sur vos boutique et non suite à l'installation d'un Template mal codé ou module comme celui que vous m'avez précédemment cité (la div dans le head)
  18. Je te comprends, et quand on vois les prix auxquels on paye ces modules, c'est d'autant plus frustrant… Et tout d'abord, @Mediacom87, je tenais sincèrement à te remercier de ton aide et de la rapidité à laquelle tu réponds!
  19. Boutique: https://www.bebecreation.fr Page d'exemple pour ce post: https://www.bebecreation.fr/m-mouse/411-1658-m-mouse-souris-fuchsia-silicone.htm Version de Prestashop: 1.7.4.2 Bonjour à tous et toutes. je vous soumet un soucis qua j'ai remarqué dans mon code source provocant une duplication de texte et de balises <h1></h1> En effet, quand j'affiche le code source de cette page (url en ref ci-dessus), j'obtiens en ligne 1505 ce code: <div id="product-description-short-411" itemprop="description"><h1><span style="color: #2445a2;"><span color="#2445a2" style="color: #2445a2;">Accroche tétine personnalisée en silicone Souris Fuchsia.</span></span></h1> <p><span style="color: #8f28fe;"><strong>Livrée dans son sachet Organza ou pochette plastifiée.</strong></span></p> <p><span style="color: #8f28fe;"><strong>Délai de conception: 7 à 10 jours ouvrés, jusqu'à 10 jours en cas de forte affluence</strong></span></p> <p><b style="color: #2445a2;">Fabrication </b><span style="background-color: #d4d4d4;"><b><span style="color: #0f00ff;">FRA</span><span style="color: #ffffff;">NÇA</span><span style="color: #f90202;">ISE</span></b></span><b style="color: #2445a2;">, <span style="color: #fb0303;">Sans BPA,</span> parfaitement adapté aux bébés dés la naissance.</b></p> <table width="360" height="123"> <tbody> <tr> <td> <p style="text-align: center;"><span style="text-decoration-line: underline;"><b style="color: #2445a2;">Nos engagements sécurité ici:</b></span></p> <p style="text-align: center;"></p> </td> </tr> <tr> <td style="text-align: center;"><a href="https://www.bebecreation.fr/content/8-securite-de-nos-produits" target="_blank"><img src="https://www.bebecreation.fr/img/cms/Images sources/securite enfant mini.png" alt="Sécurité de nos accroche tétine prénom" width="70" height="70" /></a> </td> </tr> </tbody> </table></div> et en ligne 3442: <div id="product-description-short" itemprop="description"><h1><span style="color: #2445a2;"><span color="#2445a2" style="color: #2445a2;">Accroche tétine personnalisée en silicone Souris Fuchsia.</span></span></h1> <p><span style="color: #8f28fe;"><strong>Livrée dans son sachet Organza ou pochette plastifiée.</strong></span></p> <p><span style="color: #8f28fe;"><strong>Délai de conception: 7 à 10 jours ouvrés, jusqu'à 10 jours en cas de forte affluence</strong></span></p> <p><b style="color: #2445a2;">Fabrication </b><span style="background-color: #d4d4d4;"><b><span style="color: #0f00ff;">FRA</span><span style="color: #ffffff;">NÇA</span><span style="color: #f90202;">ISE</span></b></span><b style="color: #2445a2;">, <span style="color: #fb0303;">Sans BPA,</span> parfaitement adapté aux bébés dés la naissance.</b></p> <table width="360" height="123"> <tbody> <tr> <td> <p style="text-align: center;"><span style="text-decoration-line: underline;"><b style="color: #2445a2;">Nos engagements sécurité ici:</b></span></p> <p style="text-align: center;"></p> </td> </tr> <tr> <td style="text-align: center;"><a href="https://www.bebecreation.fr/content/8-securite-de-nos-produits" target="_blank"><img src="https://www.bebecreation.fr/img/cms/Images sources/securite enfant mini.png" alt="Sécurité de nos accroche tétine prénom" width="70" height="70" /></a> </td> </tr> </tbody> </table></div> Avez vous une idée d'où cela peux t'il provenir? ca fait une duplication de titres, de blaises, et de texte sur toutes mes pages produits. Merci de vos réponses
  20. hi, @Verlonimoi use 1.7.4.2 version
  21. Suggères tu donc qu'elle soit inséré après le </head> c'est ca?
  22. merci de vos réponses Mediacom87, pour te répondre, ils ne m'ont pas encore parlé de cette div, il va falloir que je me penche dessus en effet Concernant la canonical, ils me l'ont fait mettre en commentaire, il faut que j'en recherche la raison Doekia, je ne souhaite vexer personne dans ce post mais essayer de trouver des solution à un soucis, je ne fait que mentionner les raisons de ma questions, sur un soucis relevé par l'agence de référencement que j'ai mandaté pour optimiser ma boutique… Il ne s'agit en rien d'évaluer les compétences de chacun et de les mettre en concurrence. Pour autant ils ont eu le même discours que toi sur le fait que google savais interpréter les résultats, mais que dans un sens il serai préférable malgré tout que le code soit fait de sorte à ce que ca "coule de source" si je puis m'exprimer ainsi. Pour ma part personnelle je pense que si dans Wordpress ils ont codé de sorte à ce que ce soucis n'existe pas je pense que prestashop peux aussi le faire alors pourquoi ne pas faire en sorte que cela le soit. Je ne sais pas si les différents modules installés peuvent mettre le Bazard, ou le thème utilisé… j'aimerais juste savoir si une solution pour résoudre ce soucis était possible et je suppose que oui mais je ne sais pas par ou commencer. Comment faire en sorte que la pagination de la page 1 ne s'affiche pas: "?page=1" mais tout simplement l'url de la page? ceci que ce soit en cliquant sur le chiffre "1" de la pagination ou sur la flèche "prev" à côté du chiffre "1" quand on est sur la page "2" ? Quels fichiers sont en relation avec cette fonctionnalité, et comment éventuellement les modifier pour obtenir le résultat escompté? Encore merci pour vos réponses. oui c'est ce que j'aimerais résoudre.
  23. Merci de votre réponse, le soucis c'est que mon Template le fait... après avoir regardé dans le fichier "pagination.tpl" c'est le même code que celui d'origine Prestashop... Outre le fait de la balise canonical, quand on prend un wordpress il n'y a pas ce soucis, la page est directement dirigée en URL comme il le faut sans le "=1"... je suppose donc qu'un défaut de programmation est à l'origine de ce soucis. Ce qu'il serait bon c'est d'en trouver la source et la résoudre pour ne plus avoir ce problème. Petite info, ce soucis à été relevé par l'agence de référencement (Eskimoz) , qui m'a demandé de le résoudre pour le SEO. Ce qui me laisse à penser que cela à son importance quand même quelqu'un aurait il un début de piste pour remédier à ce soucis de codage? merci
  24. In English (translate google) My prestashop store: https://www.bebecreation.fr Version of my prestashop: Prestashop 1.7.4.2 Hello to all the community, I have a problem with the pagination in my categories of my prestashop store. indeed, we have a duplication of url on page 1 of the store using pagination. Let me explain: we can notice that if we click on the number 1 of the pagination (wood category for example) we have the url of the page which ends with:? page = 1 The concern is that it is exactly the same page as the basic one without this "? Page = 1" that makes us a duplicate page for google. if you are on page 2 and you use the "prev" function it's the same, you will have the front page with "? page = 1" instead of the base url. I give my personal example: when I go to my "wood" category of my shop the url is: https://www.bebecreation.fr/16-bois if I click on the pagination to see the other pages, (2,3,4 ...) I would have this url: https://www.bebecreation.fr/16-bois?page=2, https://www.bebecreation.fr/16-bois?page=3, https://www.bebecreation.fr/16-bois? page = 4 ...... If I click on 1 I will get this URL: https://www.bebecreation.fr/16-bois?page=1 while I should have obtained this one: https://www.bebecreation.fr/16-bois Ditto with prev on page 2, if I am on page 2 of my category, using the peview button I will have the url with the end in: "? Page = 1" instead of https: // www .bebecreation.fr / 16-wood this is valid for all the categories of the store with pagination. Please bring us solutions if there are any. Kind regards. En Français: Ma boutique prestashop: https://www.bebecreation.fr Version de mon prestashop: Prestashop 1.7.4.2 Bonjour à toute la communauté, j'ai un soucis avec la pagination dans mes catégories de ma boutique prestashop. en effet, nous avons une duplication d'url sur la page 1 de la boutique en utilisant la pagination. Je m'explique: nous pouvons remarquer que si nous cliquons sur le numéro 1 de la pagination (catégorie bois par exemple) nous avons l'url de la page qui fini par: ?page=1 Le soucis c'est que c'est exactement la même page que celle de base sans ce "?page=1" cela nous fait une page doublon pour google. si vous êtes en page 2 et que vous utilisez la fonction "prev" c'est pareil, vous aurez la page d'avant avec "?page=1" au lieu de l'url de base. je donne mon exemple personnel: quand je vais dans ma catégorie "bois" de ma boutique l'url est: https://www.bebecreation.fr/16-bois si je clique sur la pagination pour voir les autres pages, (2,3,4...) j'aurais cette url: https://www.bebecreation.fr/16-bois?page=2 , https://www.bebecreation.fr/16-bois?page=3, https://www.bebecreation.fr/16-bois?page=4 ...... Si je clique sur 1 j'obtiendrai cette URL: https://www.bebecreation.fr/16-bois?page=1 alors que j'aurai du obtenir celle-ci: https://www.bebecreation.fr/16-bois Idem avec prev sur la page 2, si je me trouve sur la page 2 de ma catégorie, en utilisant le bouton peview j'aurai l'url avec la fin en : "?page=1" au lieu de https://www.bebecreation.fr/16-bois ceci est alable pour toutes les catégorie de la boutique comportant une pagination. Merci de nous apporter des solutions si il en existe. Amicalement.
  25. Do you have an answer to this very interesting post? we can notice that if we click on the number 1 of the pagination (category for example) we have the url of the page which ends with:? page = 1 The concern is that it is exactly the same page as the basic one without this "? Page = 1" that makes us a duplicate page for google. if you are on page 2 and you use the "prev" function it's the same, you will have the front page with "? page = 1" instead of the base url. I give my personal example: when I go to my "wood" category of my shop the url is: https://www.bebecreation.fr/16-bois if I click on the pagination to see the other pages, (2,3,4 ...) I would have this url: https://www.bebecreation.fr/16-bois?page=2, https://www.bebecreation.fr/16-bois?page=3, https://www.bebecreation.fr/16-bois? page = 4 ...... If I click on 1 I will get this URL: https://www.bebecreation.fr/16-bois?page=1 while I should have obtained this one: https://www.bebecreation.fr/16-bois Ditto with prev on page 2, if I am on page 2 of my category, using the peview button I will have the url with the end in: "? Page = 1" instead of https: // www .bebecreation.fr / 16-wood this is valid for all the categories of the store with pagination. Please bring us solutions if there are any. Kind regards.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More