Jump to content

esteruelas

Members
  • Posts

    24
  • Joined

  • Last visited

Everything posted by esteruelas

  1. URL: http://www.banburyarte.com/ PS: 1.6.1 Módulo: Bloque navegación por facetas v2.1.3 Buenos días. Tengo la tienda en producción y no consigo que se muestre una plantilla de filtro específica que he creado para la Home/Index de la tienda. El módulo lo tengo asociado al hook columna izquierda y ese hook lo tengo activado en muchos tipos de páginas salvo la página de producto y algunas otras. En Preferencias >> Temas >> ajustes avanzados no tengo activadas ni columna derecha ni izquierda por defecto. Otros módulos como productos más vistos o Búsqueda sí se ven en la home/Index pero navegación por facetas no. No sé si es algo que tengo mal configurado o es que directamente no se puede mostrar. Estoy mirando algún módulo de pago para solventarlo pero quiero antes asegurarme de que no es fallo mío. ¿Alguien me puede ayudar? Muchas gracias y un saludo
  2. Hola ¿Vas vender? ¿Vas a facturar? ¿Vas a aplicar impuestos? Puedes hacerlo como empresa o cómo autónomo. Como persona física te va a dar muchos problemas hacer facturas. Habla con algún amigo que tenga una empresa o llama a una asesoría. Un saludo y buena suerte con la parte de facturación e impuestos. Montoro-Hacienda llama a tu puerta.
  3. Hola. Yo también lo he actualizado esta mañana. Lo he hecho con soporte técnico de Redsys al teléfono porque no me fiaba. La última versión es la 2.8.3 ¿Has desinstalado previamente el que tenías? ¿ves la carpeta del modulo con el FTP? Un saludo
  4. Hola. E este caso estoy en contacto con el desarrollador del módulo y estamos haciendo un módulo a medida de lo que necesitamos. Espero que pronto esté online la tienda. Un saludo y gracias
  5. Hola. No tengo la web online. Uso PS 1.6.0.9 En mi menú superior horizontal hay una subcategoria que ya he conseguido sacar al primer nivel. Ahora quiero ocultarla como subcategoría. Se llama "Créalo tu mismo" ¿es posible hacer ésto? OS adjunto imagen. Un saludo y gracias
  6. Hola. Tengo instalado en un PS 1.6.0.9 el módulo http://www.buhoc.com/demo/es/vinilos/15-vinilo-de-dos-colores.html El tema es que genera un producto nuevo con ID y todo cada vez que el usuario añade una personalización concreta del producto a la cesta de la compra. No funciona con atributos. Mi consulta es qué implica esto para mi servidor y la base de datos. Los productos que genera no los puedo borrar porque estarán asociados a la ficha del cliente si llega a pagarlos. Me pregunto si es un sistema sostenible a futuro y si sólo se puede hacer de esta manera. Si alguien conoce algún módulo mejor que no se corte en decirme. Un saludo y gracias
  7. Hola, en la carpeta /config, en el archivo config.inc.php comprueba que tengas esta línea en "false": define('_PS_MODE_DEV_', false); Yo lo he cambiado y ya me ha dejado entrar en Módulos. Yo tengo 1.6.0.9. Un saludo 23/03/2015 :: Corregido el nombre dearchivo, no es el config.inc.php es el defines.inc.php (Gracias por darte cuenta akhen)
  8. Hi, I try GOYO solution and now is working. Thaks Goyo. Why change _PS_MODE_DEV_ to false??????? I have 1.6.0.9 and this problem starts today.
  9. Muchas gracias por responder tan rápido. A veces hay que hacer pequeñas chapucillas con Prestashop, si. Así que a dar marcha atrás Un saludo
  10. Hola Lopezvi. Tengo un problema similar: PS: 1.6.0.9 Multitienda que acabo de reducir a una y un sólo idioma activado. En el frontOffice todo parece funcionar correctamente pero en los listados del BcakOffice los nombres de las categorías se han convertido en "--" Intentos de arreglo: -no me deja tampoco entrar a modificar el nombre. He creado una nueva categoría y también pasa a listarla como "--" en la BD, tabla ps_category he cambiado la columna od_shop_default por "2" que es el ID de la unica tienda que hay activa he revisado que los campos shop en las otras tablas "category" sena el "2" y el campo "name" de la tabla ps_category_lang se lea bien y efectivamente se lee ¿A alguien le ha pasado esto alguna vez o tiene cierta intuición de cómo resolverlo? Gracias Es un rollo porque no puedo manejar ni categorías ni subcategorías. ¿tu pudiste solucionarlo?
  11. Yes, I know, anyway I ´ll tell to my boss again. That´s life. Thank again Enrique I hope find you or read your post here soon.
  12. Hi, Thanks Enrique, Your code works fine. I see your changes and my mistakes. What do you think about my other problem: rescue on mail template the $friendMail send by sendtoafriend_ajax.php? $templateVars = array( '{product}' => $product->name, '{product_link}' => $productLink, '{customer}' => $customer, '{friend_mail}' => Tools::safeOutput($friendMail), /* rescatando la variable mail del amigo */ '{name}' => Tools::safeOutput($friendName) Regards
  13. Hi from Spain. I´m trying to make the same thing in PS 1.6.0.9, "send to a friend module", multistore, bootstrap theme. I´m trying to send the $friendMail to the mail template too. My code is: $templateVars = array( '{product}' => $product->name, '{product_link}' => $productLink, '{customer}' => $customer, '{friend_mail}' => Tools::safeOutput($friendMail), '{name}' => Tools::safeOutput($friendName) ); /* Email sending */ if (!Mail::Send((int)$module->context->cookie->id_lang, 'send_to_a_friend', sprintf(Mail::l('%1$s sent you a link to %2$s', (int)$module->context->cookie->id_lang), $customer, $product->name), $templateVars, $friendMail, null, ($module->context->cookie->email ? $module->context->cookie->email : null), ($module->context->cookie->customer_firstname ? $module->context->cookie->customer_firstname.' '.$module->context->cookie->customer_lastname : null), null, null, dirname(__FILE__).'/mails/')) die('0'); die('1'); /* Email copy sending */ if (!Mail::Send((int)$module->context->cookie->id_lang, 'send_to_a_friend', sprintf(Mail::l('%1$s momomi %2$s', (int)$module->context->cookie->id_lang), $customer, $product->name), $templateVars, "[email protected]", null, ($module->context->cookie->email ? $module->context->cookie->email : null), ($module->context->cookie->customer_firstname ? $module->context->cookie->customer_firstname.' '.$module->context->cookie->customer_lastname : null), null, null, dirname(__FILE__).'/mails/')) die('0'); die('1'); I´m not able to rescue the frienMail var and send the copy of the mail . Could someone help me, please? Thanks
  14. Gracias Enrique. Una cosa más ¿porque no se pasan variables por URL en PS? Gracias
  15. Gracias Enrique Engblom. Lo que me dices, es crear el formulario a partir de, por ejemplo, en el módulo "send to a friend" ¿no?
  16. PS: 1.6.0.9 Theme: Bootstrap-default Multistore Web en desarrollo/mantenimiento Hola Trato de crear un formularios que se habrá en fancybox desde product.tpl adaptando ContactController.php y contact-form.tpl Desde product.tpl hago este link: <p><a href="/index.php?controller=financiacion&content_only=1&pprecio={$product->price}&pnombre={$product->name}" class="iframe" rel="nofollow">{l s='Solicítela'}</a></p> los valores de las variables se ven en la ventana del navegador pero no sé como recuperarlso para usarlos en mi contact-form.tpl adaptado. Me pasa una cosa más: al procesar el formulario, pierde el content_only=1 y me carga header, footer y todo. ¿Si alguien se ha encontrado con algo así y me puede orientar un poco? Muchas gracias.
  17. Hi, I´m using PS 1.6.0.9, a bootstrap child in maintenance mode. Your module don´t work in my shop, still sends the welcome mail for new inactive users. Any idea? Thanks
  18. Hola jsalas, ¿con qué versión y que theme estás? Yo en 1.6.0.9 y con un child del default-bootstrap, estoy adaptándolo con el código de joseFC y el check me muestra el aviso (siempre que no le quite el {/literal} {literal} (fíjate bien que cierra, escribe el texto del aviso y luego lo vuelve a abrir ) aunque eso hace que no me muestre los acentos ) pero si que me funciona, no me deja enviarlo si no lo tengo marcado. He quitado el target="_blank" para ver si consigo abrir en enlace en fancybox. Estoy en ello aún. Mi código actual del checkbox es este: {* // INICIO DEL BOTON DE LAS POLITICAS DE PRIVACIDAD *} <p class="checkbox" id="security_informations"> <input id="acepta_lopd_form" type="checkbox" value="1" {if isset($smarty.post.acepta_lopd_form) AND $smarty.post.acepta_lopd_form == 1}checked="checked"{/if} name="acepta_lopd_form"> <label for="acepta_lopd_form">{l s='Acepto'} </label> <a href="{$link->getCMSLink(11)}{if Configuration::get('PS_REWRITING_SETTINGS') == 1}?{else}&{/if}content_only=1" class="iframe">{l s='la Política de Protección de Datos'}</a> {l s='y estoy conforme con ella.'} </p> <script type="text/javascript"> $(document).ready(function() { $('a.iframe').fancybox({ 'type' : 'iframe', 'width':400, 'height':600 }); }); </script> {* // FIN DEL BOTON DE LAS POLITICAS DE PRIVACIDAD *} A ver si te ayuda. Un saludo
  19. Lo baje de: http://www.prestashop.com/forums/topic/219050-free-module-validate-customer/ Lo único que veo a priori que hace es mandar mail a la cuenta de administrador que le configuras y mandar mail al usuario cunado le has activado pero esto último según he podido ver no lo hacía bien. ¿sabes de algún otro módulo gratuito que lo pueda sustituir? Parece que PHPMadman lo ha adptado a la versión 1.6: http://www.prestashop.com/forums/topic/219050-free-module-validate-customer/page-2 pero no le ha funcionado a algunos usuarios del foro. Y a mi tampoco. Ya no es una opción Si sabes de algún otro modulo... -------------------------------------------------------------------------------------- Después de mirarlo más detenidamente si desactivo el módulo, el usuario que rellena el form de alta, entra automáticamente en la tienda. Así que lo que necesitaría es desactivar esa entrada automática en la tienda y enviar mails al administrador y al usuario de que está pendiente de aprobación por el administrador del comercio. ----------------------------------------------------- Ya he desactivado el registro automático y me gustaría marcar el hilo como solucionado pero no encuentro cómo hacerlo. Un saludo y felices vacaciones a todos.
  20. ñññññññññññññññññññññññññññññññññññ Tenías razón. Al desactivar el módulo funciona. Es mucha locura tocar el código del módulo para ver qué puede interferir??? Voy a buscar otro módulo gratuito que lo sustituya. Después de tu respuesta editaré el post como SOLUCIONADO. Dos mil gracias rafaelamargo Que maravilloso es esto del foro.
  21. Hola rafaelamargo, el modulo VALIDATE COSTUMER hace días que lo tengo instalado y no me ha dado ningún problema. Ha sido al tocal el authentication.tpl que me ha empezado a dar este error. ¿te ha salido este error a ti alguna vez? De todas formas voy a restaurar todo y volver a hacer los cambios a ver si lo acorralo
  22. FTP es algo muy básico, es la forma que tienes de acceder al directorio de tu servidor donde tengas instalado el Prestashop. Una vez en el raiz de ti Prestashop, busca la carpeta /modules y borra el modulo que te da problemas (comprueba que tengas ese mismo modulo en tu PC) para poder volver a subirlo al servidor si es necesario. Antes de reinstalar todo, yo probaría desactivando módulos a ver si localizas el error. Un saludo
  23. Hola soy esteruelas de Zaragoza sumergida en una multitienda B2B en la 1.6.0.9 y aprendiendo mucho de vuestro foro. Un saludo
  24. Antecedentes: Versión: 1.6.0.9 Multitienda Estado: En desarrollo y sólo accesible por IP fija. Theme: un child de la que viene con la PS 1.6 con bastantes cambios en product.tpl que no creo que tengan que ver con este error Errores: activados en defines.inc.php: define('_PS_MODE_DEV_', true); Hola, he estado tocando el authentication.tpl para añadir 3 campos abiertos y comentar otros como VAT number, DNI, fecha de nacimiento y tratamiento. El registro de visitas e invitados está cerrado e instalado el modulo VALIDATE COSTUMER para que si quieres que te muestre el precio te lleve a la página de inicio de sesión. Ahora hago pruebas con el formulario de alta y me da el error: Error: el parámetro "a" está corrupto" He revisado el código y no sé de donde viene. Grabar graba bien y muestar los nuevos clientes con todos sus datos en el BcakOffice pero no consigo saber de dónde viene el error. ¿una ayudida? Gracias a todos.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More