Jump to content

foxnetwork

Members
  • Posts

    37
  • Joined

  • Last visited

Everything posted by foxnetwork

  1. I have just upgraded shop from 1.6 to 1.7 and everything seems to work fine except when I first log into admin panel i get the error The controller ShopParameters is missing or invalid. The url also shows index.php?controller=ShopParameters instead of index.php?controller=AdminDashboard I can press on dashboard and all is ok. Attached images. Anyone has an idea how to correct this
  2. The problem is that I tried getVoucherCode() but I dont think this is even the correct way of getting the code And before the order is created does it put it in the database anywhere I could just pull the information. I know once the order is created then you can get it from the database
  3. I have modified the hook in a payment module to only show payment option if the total amount is above 1000 as below if($cart->getOrderTotal() < 1000) { // return ; return; } This works great but I want to not show the payment option if someone puts a specific voucher code in there eg if($cart->getVoucherCode() = hhdyyhfyr) { // return ; return; } Obviously this is wrong. Is there a way of doing this for the checkout page or can I call it from database somewhere to check Any help appreciated
  4. Can anyone help me out with an afterpay payment module that just wont return to my site and complete order. always get 404 error
  5. I know there is modules out there for this but not quiet what I want. Its nice and simple you would think but I need code to be able to add a new user during registration to 2 groups. One the default and one that I created. There is modules to allow the user to select this but I want this for every user by default and done in the background. Any help appreciated
  6. The module that creates invoices is not mine and to get it updated is going to cost hundreds of dollars. I just needed an automated way to change the user group instead of doing it manually. Just need it change just to send the proforma then changed back to default. It is going to be a lot cheaper since this function is only used a couple of times and the rest pay by cc so they get the default
  7. I am new to coding in prestashop and need a simple task done in module but cant seem to find out how. I am using a module pay by invoice which just puts the order in waiting for payment. I need to change a users group from default to another I created eg proforma group after a user presses on confirm order in this module but before any actions are done to finalize payment and then change users group back to default. The reason is I am using an invoice module that sends out specific invoices based on group they are in, default for all paid invoices and proforma for non paid invoices. so when a user orders from cart and clicks invoice payment they would then get a proforma invoice first then later when payment accepted they would get a normal invoice like other default users. I just need to know how to update the groups for this customer before process and then back to the default group after process. I have attached pay by invoice module to show what I am using Any help appreciated invoicepayment.zip
  8. I am new to coding in prestashop and need a simple task done in module but cant seem to find out how. I am using a module pay by invoice which just puts the order in waiting for payment. I need to change a users group from default to another I created eg proforma group after a user presses on confirm order in this module but before any actions are done to finalize payment and then change users group back to default. The reason is I am using an invoice module that sends out specific invoices based on group they are in, default for all paid invoices and proforma for non paid invoices. so when a user orders from cart and clicks invoice payment they would then get a proforma invoice first then later when payment accepted they would get a normal invoice like other default users. I just need to know how to update the groups for this customer before process and then back to the default group after process. I have attached pay by invoice module to show what I am using Any help appreciated invoicepayment.zip
  9. I have installed the free module from prestashop addons for mailchimp integration and after clicking connect your store i keep getting same error {"status":"KO","errors":["Parameter `final_url` is required","Parameter `ps_version` is required","Parameter `module_version` is required"]} https://partners-subscribe.prestashop.com/mailchimp/request.php?error=redirect_uri_mismatch#oauth_error Has anybody have the same issue or know how to solve this . Using prestashop 1.6.1.16
  10. This is the error from chrome Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check http://xhr.spec.whatwg.org/. jquery-1.11.0.min.js:4 GET http://www.foxsecuritygroup.com.au/fox/index.php?controller=AdminProducts&t…=0&action=Shipping&updateproduct&ajax=1&rand=1452140739756&_=1452140737125 500 (Internal Server Error)send @ jquery-1.11.0.min.js:4n.extend.ajax @ jquery-1.11.0.min.js:4ProductTabsManager.display @ products.js:117ProductTabsManager.displayBulk @ products.js:166(anonymous function) @ products.js:208 products.js:177 Uncaught TypeError: Cannot read property 'replace' of undefined(anonymous function) @ products.js:177j @ jquery-1.11.0.min.js:2k.fireWith @ jquery-1.11.0.min.js:2x @ jquery-1.11.0.min.js:4b @ jquery-1.11.0.min.js:4 VM335:2 'webkitMovementX' is deprecated. Please use 'movementX' instead. VM335:2 'webkitMovementY' is deprecated. Please use 'movementY' instead. When it does work I dont get the 500 error and the save doesnt. I notices sometimes when the module direcetory loads slow I also get one of those 500 errors. What is causing this intermittently update: It seems to be memory problems on shared hosting. They have increased it to max but same problem [:error] [pid 220324:tid 140513649813248] (12)Cannot allocate memory: [client 172.192.213.41:54202] couldn't create child process: /opt/suphp/sbin/suphp for /home/foxsecuritygroup/public_html/fox/index.php, referer: http://www.foxsecuritygroup.com.au/fox/index.php?controller=AdminDashboard&token=b15c85bff6a0a44517f24327c42a90dc Is there anyway to get prestashop to use less memory
  11. I cant even get it to stop spinning on new install of latest version. What do I have to get my hosting provider to look for to solve the spinning save button in products. Using php 5.4 but have tried all.
  12. I am using ps 1.6.0.14 and everything I do on back office is fast except when I try and load the modules tab. Every now and then I get a quick response otherwise it could sit there for ages or even not load at all. I gather it may be a module that is causing this but I have disabled all non prestashop modules and still the same problem. Is there a way to find out what is causing this. I have turned on profiling but do not understand the layout or what I am looking for. Any help appreciated
  13. In the new version can a customer add a custom message and send to another email address. It seems to work if you create order for customer then the box pops up to add details but not in front office. Is it supposed to or is it just in bo that this happens
  14. I am after a way or module to add a product that is not in the shop to a new order from back office create order. I have most products online but some in the catalogue are ordered over the phone and are not in the shop. A way to add the description qty and price to a new order and checkout to create invoice for these products. If anyone can help please
  15. A lot of my products are online but there is also a lot that I have in a catalogue I haven't added yet. Is there a way to create an order from the backfire and add a product manually that is not in the shop catalogue so as an invoice can be created for this. I noticed that you can create orders manually and pick products that are in the shop but just need an added feature , module or way to add non shop products
  16. I have a problem accessing the cgi-bin in my directory when friendly urls is on. Delete the htaccess file and access is ok. When prestashop puts it back I get a 404 page come up from prestashop. Is there any idea what I have to change in htaccess file or prestashop to allow me to access the cgi-bin without removing htaccess altogether or stoping friendly url
  17. ok the problems seems to be only in safari. Tried it using firefox and I get successfully saved and everything ok. Very strange
  18. Tried permission. all of them. It also will not update the database either. ANYTHING IN THE BOTTOM SECTION OF themeconfigurator such as title url image etc
  19. I have installed prestashop 1.6 final release and the themeconfigurator module will not save images or data. The top section works ink but images do not change and I cannot add anymore. I have updated from github the latest, reset, uninstalled and reinstalled but still will not save images or data. Any ideas would be appreciated
  20. Im using prestashop 1.5 and when you are in catalogue mode on the left hand side of the product you get a grey box. This usually has price and add to cart in it when not in catalogue mode, Where do I find the code to add text to this box either in catalogue mode or out of it.
  21. Have been using this module for a while now version 2.1 and has worked great. Since upgrading to prestashop 1.5.3 I need and upgrade and was supplied 2.2 straight away. Very satisfied with this module and service. Get it now
  22. I have recently got this module and find it very useful especially with the added login from the order page. using it on 1.5 and it works great
  23. This works fine but how do I get the image location in the csv file outpit
  24. I am having problems with certain pages from modules coming up with error 500. After turning on degub I get bacically the same message on all errors which is Warning: include_once(PS_ADMIN_DIR/../classes/AdminTab.php) [function.include-once]: failed to open stream: Is there somewhere where this has to be set or do I have file permissions wrong. Any help appreciated
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More