Jump to content

b3drik

Members
  • Posts

    66
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by b3drik

  1. Bonjour, Je sais que ma réponse vient TRÈS tardivement, mais comme j'avais le même problème à l'instant et que je viens de trouver.. je partage, ça peu servir. Dans Apparences > positions, il faut impérativement cliquer sur "Afficher les points d'accroche invisibles". A partir de cet instant, on trouve la position réelle dans paymentOptions.
  2. Thanks a lot! this was very helpful! Pour les francophones, j'ai trouvé une explication claire ici = https://www.matthieu-jalbert.fr/error-address-phone-mobile-prestashop-1-7/
  3. Bonjour, Même problème pour ma part, quelqu'un connait-il la solution précise à effectuer ? Merci! ------- EDIT: Pour info, dans l'urgence j'ai suivi ces conseils ; https://www.prestashop.com/forums/topic/1007674-runtimeexception-in-phpdumperphp-line-1403/ Pour donner une explication rapide, j'ai commenté la ligne 1403 throw new RuntimeException(sprintf('Cannot dump definition because of invalid class name (%s)', $class ?: 'n/a')); dans le fichier /vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Dumper/PhpDumper.php Ce n'est pas une solution fiable sur le long terme, d'ailleurs j'ai maintenant une petite notice d'erreur à la connexion au back-office (liée à psaddonsconnect.php). Je verrais ce que je peux faire de mieux un peu plus tard.
  4. Hi. For information, on v1.7.x there is not suppliers and brands modules anymore. There is an option to enable/disable suppliers and brands on sitemap under Preferences > General. Maybe it will help.
  5. Je confirme sur la 1.7.5.0. même problème juste après l'installation et même solution trouvée ici. Merci à tous !
  6. Please, can someone help me ? I checked OUT logs, and everytime I log in to Admin, I see something like this: [2018 Jul 9 09:47:48] [519262.400833] TCP:57352 => 91.240.109.36:443 [2018 Jul 9 09:47:48] [519262.443906] TCP:57354 => 91.240.109.36:443 [2018 Jul 9 09:47:48] [519262.471083] TCP:57356 => 91.240.109.36:443 [2018 Jul 9 09:47:48] [519262.495827] TCP:57360 => 91.240.109.36:443 [2018 Jul 9 09:47:48] [519262.523949] TCP:57362 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.554737] TCP:57364 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.581817] TCP:57366 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.609212] TCP:57368 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.636652] TCP:57370 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.663196] TCP:57372 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.688753] TCP:57374 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.715050] TCP:57378 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.749276] TCP:57380 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.773883] TCP:57382 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.800047] TCP:57384 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.825974] TCP:57386 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.854013] TCP:57388 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.883454] TCP:57390 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.910470] TCP:57392 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.944204] TCP:57396 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519262.976380] TCP:57398 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.003270] TCP:57402 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.031409] TCP:57404 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.059691] TCP:57406 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.088552] TCP:57408 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.117064] TCP:57410 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.146435] TCP:57412 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.174690] TCP:57414 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.204919] TCP:57418 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.234475] TCP:57424 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.264731] TCP:57430 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.293235] TCP:57432 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.321974] TCP:57434 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.357604] TCP:57436 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.385817] TCP:57438 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.416187] TCP:57440 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.459658] TCP:57446 => 91.240.109.36:443 [2018 Jul 9 09:47:49] [519263.491469] TCP:57448 => 91.240.109.36:443 Please, I need help.
  7. I tried to change my password on Prestashop addons but it did nothing. One of my store is in 1.7.3.3. Anyone? I think I'm not on the right forum section, can an admin move this topic ? thanks.
  8. Hi, (sorry for my not very good english) I work with few shops. With the only two shops in v.1.7, I can't log in to Prestashop Addons. No errors then I try to log in, just infinite spinning loading.. On the other shop v.1.6 : no problem to log in. Any advice please ? Thanks !
  9. Hi This topic is really old now It was for a v1.5, and like I said I used this on .tpl : I don't know if it's possible on back-office right now (v.1.7), I checked quickly and I found nothing :/
  10. Bonjour, Certains serveurs ont un cache CDN, comme con nom l'indique, c'est un système de cache. Votre problème, c'est pas un problème de cache ? Après.. je ne suis pas assez pointu en CDN pour être sur que ça vienne de là.. ce n'est qu'une idée
  11. WOW l'erreur de merde ! merci, je l'avais pas vu celle là!
  12. Bonjour, J'ai un problème très con, je n'arrive pas à faire fonctionner correctement les conditions Smarty dans mes page produits. Si je fait ceci, ça fonctionne : {if $product->id_category_default == 16} TEXTE {/if} {if $product->id_category_default == 17} TEXTE {/if} {if $product->id_category_default == 18} TEXTE {/if} Mais ça, ça ne marche pas : {if $product->id_category_default == 16 || $product->id_category_default == 17 || $product->id_category_default == 18 } TEXTE {if} Dans le doute j'ai testé avec OR, mais ça ne fonctionne pas non-plus. Qu'est-ce que je fais mal ? Merci !
  13. Bonjour, Je dis peut-être une connerie mais avez-vous regardé coté serveur, l'option du cache CDN par exemple ? Bon courage.
  14. (up) Hi, Any solution at this probleme ? Thanks a lot.
  15. Ok sympa, avant que je le fasse, saurais-tu me dire dans quel(s) cas cette modif pourrait poser problème, à ton avis ?
  16. Salut BonCev, je viens d'installer la v3.0.3 d'Atos et le problème reste le même, je perds patience.... J'ai immédiatement envoyé un nouveau message au support Prestashop pour l'indiquer, j'attends donc leur retour, une nouvelle fois. Entre temps, peux-tu m'indiquer quelle manip' tu as fait pour régler ce problème à la mano ? Car perso j'ai pas trouvé malgré quelques tentatives, merci
  17. Bonjour, je vais partager mon expérience sur le sujet. J'ai exactement le même soucis, malgré la dernière version actuelle Atos (v3.0.2). Cela me pose énormément de problèmes pour mes affiliations, et ce depuis le mois de mars environs. J'ai contacté le support et ils m'ont répondu d'attendre la mise à jour, qui allait arriver ce vendredi 10juin. Aujourd'hui toujours pas de mise à jour disponible, j'attends avec beaucoup d'impatience maintenant..
  18. OK ! Alors j'ai pas mal fouillé pour trouver ce que j'avais besoin, mais j'ai l'impression que ça fonctionne correctement maintenant. En espérant que ce soit la bonne démarche, voici ce que j'ai fait : (ça pourrait peut-être aider d'autres personnes) Dans le fichier .PHP du module (modules>nom_du_module/), j'ai supprimé les lignes if (!$this->isCached('nom_du_template.tpl', $this->getCacheId('nom_du_template'))) { } et remplacé return $this->display(__FILE__, 'nom_du_template.tpl', $this->getCacheId('nom_du_template')); par return $this->display(__FILE__, 'nom_du_template.tpl'); Voila, c'est certainement décousu, je ne suis pas un expert PHP/Smarty. Coeos, je te remercie car je crois que ça va me servir cette histoire de gestion de cache dans un module. (j'avais d'autres problèmes avec d'autres modules)
  19. Tu as mis le doigt sur quelque chose de très intéressant ! Lorsque je désactive le cache Smarty, je récupère le bon ID à chaque fois. Ensuite j'ai vidé le cache Smarty (par le biais du bouton "vider le cache" de l'administration), j'ai réactivé le cache (en mode "Vider le cache chaque fois qu'il y a une modification"). Et là rebelotte ! L'ID récupéré n'est pas le bon. J'ai re-testé plusieurs fois cette opération ci-dessus pour être sûr. Une idée ??
  20. Merci xaxa mais je ne suis pas du tout à l'aise avec ces déclaration de classes.. Bon déjà j'ai réussi à faire fonctionner {debug} (j'avais un pb avec Chrome qui m'affichait une page blanche) Mais je n'ai pas de variable qui me récupère l'ID du produit, je vais donc devoir passer par les classes. Je vais essayer de trouver quelques tutos..
  21. Un petit Up après ce long week-end Sinon, même si ce n'est certainement pas terrible, N'est-il pas possible de faire passer une variable à partir de header.tpl pour ensuite pouvoir récupérer cet ID ?
  22. C'est un fichier lié au thème que j'ai acheté : www/modules/csstaticblocks/views/templates/hook/csstaticblocks_productImage.tpl Pour info j'ai tenté de le placer dans le dossier modules du thème (www/themes/nom_du_theme/modules) mais j'ai les mêmes résultats. Je suis certains que ce fichier .tpl est bien affiché dans ma page produit, j'ai fait d'autres tests concluants.
  23. Je comprends ta confusion, ce que j'ai voulu dire c'est que dans ma boutique en test, j'ai 2 produits : un avec ID = 8 et un avec ID = 12 (dans la même catégorie, mais.. on s'en fou) Et ben {$smarty.get.id_product} renvoi un coup 8 et un coup 12, de manière aléatoire. Enfin pour moi c'est aléatoire puisque quand je fait un refresh de la page c'est parfois 8 et parfois 12..
  24. Alors, pour répondre à une question importante, je suis bien dans une page produit ! Je viens de faire quelques test : {$product->id|intval} -> 0 {$product.id_product} -> (pas de réponse) {debug} -> (la popup se lance mais elle est vide! -page blanche)
  25. Bonjour ! Je cherche un peu d'aide. J'utilise un thème sur une v1.6.1.3 et quand on se trouve dans une page produit, j'aimerai afficher une bannière correspondante au produit. Cette bannière est d'abord utilisée dans un .TPL, et ce .TPL je veux le modifier donc. Et je galère pour récupérer l'ID du produit ! D'habitude je fais {$smarty.get.id_product} ou {$id_product} Mais {$id_product} ne renvoi rien, et {$smarty.get.id_product} m'affiche un ID aléatoire parmi tous les produits de la catégorie (ou de la boutique je ne sais pas) Quelqu'un saurait m'aiguiller? j'ai lu comme quoi fallait passer par le controleur PHP mais je ne sais pas du tout comment m'y prendre J'ai hâte de vous lire, merci.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More