Jump to content

schibulski

Members
  • Posts

    174
  • Joined

  • Last visited

Everything posted by schibulski

  1. Ich vermute mal eher dass das Problem in der Datenbank zu suchen ist. Da es eher unwahrscheinlich ist dass Kategorie und Kurzbeschreibungen so unglaublich lang sind, ist das Feld in der Datenbank als "text" deklariert. Wenn du jetzt auch noch html mit im Text hast UND die jeweilige Beschreibung super lang ist, wird das arg eng. Ich hatte den selben Fall mal mit sehr, SEHR langen Produktbeschreibungen. Lösung: Mit phpMyAdmin oder deiner bevorzugten Anwendung in die Datenbank einloggen und folgende Tabellen suchen: "ps_category_lang" (für die Kategoriebeschreibung) oder "ps_product_lang" (für Artikel Kurz- und Langbeschreibung). In der jeweiligen Tabelle (in phpMyAdmin) ganz oben in "Struktur" gehen und das gewünschte Feld bearbeiten (descritiption, description short usw...) hier sieht man in der Standardeinstellung bei "Typ" den Wert "text". Mit einem Klick darauf kannst du den neuen Wert aussuchen ("mediumtext" sollte in den meisten Fällen ausreichen, es sei denn deine Beschreibung ist wirklich so riesig dass es keine "Kurzbeschreibung" mehr ist :-D ). Tädääää, schon fasst die Datenbank an der Stelle mehr und du kannst dich austoben. Hier noch mal die offiziellen Beschreibungen der Textfelder: Type | Maximum length -----------+------------------------------------- TINYTEXT | 255 (2 8−1) bytes TEXT | 65,535 (216−1) bytes = 64 KiB MEDIUMTEXT | 16,777,215 (224−1) bytes = 16 MiB LONGTEXT | 4,294,967,295 (232−1) bytes = 4 GiB
  2. Gibt es denn wichtige Änderungen des Standard Template von 1.6.0.9 zu 1.6.0.11 ? Ich habe mein theme auf Grundlage von 1.6.0.9 erstellt und will nicht wieder von vorne anfangen :-) Wie sieht es eigentlich mit der offiziellen Unterstützung von eu-legal für 1.6.0.11 aus? Kann man das Modul für die neueste Version nutzen?
  3. alles klar, hab es verstanden. Ich werde das am Wochenende direkt mal testen. Hab lange nach einem Modul gesucht was diese Aufgaben übernimmt da ich in SQL nicht so fit bin. Danke dir nochmal für die tolle Arbeit!
  4. Hey Sharak! This is a great solution! Works fine with 1.6, too after readding the (removed?!) function "getProductCategoriesParent" in product.php again. But do you think it is possible to show a specific Subcategory greater then the nearest parent? means following: Start |->Category1 |-|->Subcategory1.1 |-|-|->Subcategory1.2.1 |-|-|->Subcategory1.2.2 |-|-|->Subcategory1.2.3 |->Category2 |-|->Subcategory2.1 |-|-|->Subcategory2.2.1 |-|-|->Subcategory2.2.2 And on the product detail page the following: "This Product belongs to: Category1: -Subcategory1.2.2 -Subcategory1.2.3 Category2: -Subcategory2.2.2
  5. Hallo Luca! Das sind wirklich ein paar sehr hilfreiche Scripts. Habe den Shop mit 1.4 gestartet und würde beim Update auf 1.6 gerne frisch anfangen. Wichtig wäre mir nur der Import des Artikelbaums (ca 6000 Kategorien) und aller Artikel inkl. Varianten. Was auch sehr wichtig wäre: Export und Import der Produktmerkmale. Hast du dazu auch ein SQL Script parat? :-))) Und wenn ich das richtig verstanden habe wäre folgende Vorgehensweise die empfehlenswerteste: 1: Version 1.5 mit dem internen Updatescript (OneClick Update) auf 1.6 updaten 2: Die benötigten Tabellen mit deinen Scripts als cvs speichern. 3. Frischen 1.6 aufsetzen 4. Stammdaten und Einstellungen anpassen 5. Tabellen über phpmyadmin reimportieren. Ist das in etwa richtig so?
  6. works like a charm! :-) thank you very much for the "light speed bug fixing" :-)
  7. Hello Rocky! I have a Problem with the recently bought Module: In backoffice you can chose the sorting for the dropdown "by Name" or "by position". By Name works perfect, but "by position" only works in the second,third,fourth an so on level, but NOT in the first level dropdown. I made screenshots found in the attachment. Sorting by name is no option for my because it is not usable for my other level dropdown menus. What ca i do to force "sort by position" for the first, very important lev1 dropdown? I´m using the 2.4 Version of the module in Prestashop 1.5.6.2 P.S.: I tested the 1.6 module with presta 1.6.0.9, too. Same Issue. The Sorting in the first dropdown is always very strange an weird...
  8. Das Problem ist gelöst und alles funktioniert jetzt einwandfrei. Es hatte wirklich damit zu tun dass ich das vorinstallierte Zertifikat mit einem selbst erstellten ersetzt habe. Der SSD Support hat dafür meinen kompletten Account neu aufsetzen müssen. War wohl ein größeres Problem. Merke für alle Kunden von SSD-Webhosting: niemals ein Zertifikat selbst im Hosting- Backend erstellen!
  9. Hallo zusammen! Da mir die "out of the box" Darstellung der Checkbox bezüglich der AGB Akzeptierung zu wenig auffällig und für den Kunden auf den ersten (und auch zweiten Blick) schwierig zu sehen war, habe ich ein bisschen gesucht um diese etwas deutlicher darzustellen: Möglich ist dies durch das editieren der Sektion "#order-opc #loggedWrapper p.checkbox" in der 4. Zeile der order-opc.css Datei in eurem theme/css Verzeichnis. Für die Darstellung im Bild sieht das wie folgt aus: #order-opc #loggedWrapper p.checkbox {color: red; font-size:16px; border: solid 2px #ff0000; margin: 10px; text-align: center; padding:15px 15px;} Ich hoffe das konnte dem Ein oder Anderen das Suchen ersparen und helfen :-)
  10. Wenn ich SSL über den Datenbankeingriff forciere, dann erscheint im BO auch der Radiobutton für den gesamten Shop zu verschlüsseln (aber komischerweise nicht der generelle SSL Button ) Wenn ich das aktiviere, ist der gesamte Shop nicht zu erreichen mit der wohlgekannten Fehlermeldung. Ich schreibe gerade mal einen ausführlichen Bericht an den Support von SSD Hosting. Eventuell liegt es wirklich daran dass ich seinerzeit das voreingestellte Zertifikat mit meinem überschrieben habe und die dann wieder das Ursprüngliche drübergebügelt haben. Himmel Arsch und Zwirn, meine Nerven :-D
  11. nein, SSL funktioniert auch nicht für den Login Bereich. SSL funktioniert ausschließlich im BO. Alle SSL relevanten Bereiche im FrontOffice enden in der Fehlermeldung mit zu vielen Umleitungen. Ich möchte gar nicht den gesamten Shop verschlüsseln, eben nur die wichtigen Bereiche.
  12. Der Kundendienst hat mir nur geantwortet dass ich kein eigenes Zertifikat erstellen darf da deren Zertifikat dann überschrieben wird. Die haben dann meines gelöscht und das Richtige wieder installiert. Das war´s. Ich bin ehrlich gesagt etwas enttäuscht vom Kundendienst. Ich habe schon mehrmals Anfragen wegen unterschiedlicher Dinge dorthin geschickt und erhalte immer erst 2-3 Tage später eine Antwort :-( Aus diesem Grund habe ich erstmal hier gefragt. Aber ich werde mich dann doch jetzt nochmals dahin wenden.
  13. Danke, das habe ich auch schon probiert. Habe im BO unter SEO und URLs auch schon bei der SSL Adresse die Domain ohne "www." eingetragen. Allerdings auch ohne Erfolg. Das gesamte BO ist danach problemlos mit "https//domain.de" aufrufbar, aber der Radio Button erscheint dennoch nicht. Manueller Datenbankeingriff führt wieder zum Fehler mit zu vielen Umleitungen... :-(
  14. Hallo zusammen und danke für eure Antworten! Ich habe beides überprüft: Gemanext deaktiviert und .htaccess daraufhin neu generieren lassen. -> kein Erfolg Die .htaccess wird ordnungsgemäß neu generiert sobald ich "Benutzerfreundliche URLs" an und ausschalte. (Erkennbar am Zeitstempel der Datei) Merkwürdiges Detail am Rande: Bevor ich wusste dass der Provider das SSL Zertifikat schon vorinstalliert hat, habe ich über das Modul im Plesk Administrationsbereich ein eigenes Zertifikat erzeugt und signiert. Damit hat SSL in Prestashop problemlos funktioniert. Allerdings kann man sich vorstellen dass jeder Browser dann Alarm ohne Ende schlägt weil das Zertifikat ja nicht vertrauenswürdig ist, da selbst ausgestellt. Kann es sein dass der Hoster das Zertifikat irgendwie falsch installiert hat? Wenn ich mir die Zertifaktsdetails im Browser anschaue scheint allerdings alles richtig zu sein ( DNS Name zeigt einmal auf Domain mit "www", und einmal ohne "www".
  15. Hallo zusammen! Ich brauche mal wieder Hilfe, und zwar bei folgendem Problem: Ich habe ein Hostingpaket bei ssd-wehosting.de inklusive domainvalidiertem SSL Zertifikat. Leider schaffe ich es nicht Dieses ordnungsgemäß zu nutzen. Wenn ich im Backoffice SSL aktivieren möchte, wird ja zuerst das BO testweise über "https" aufgerufen und dann erst der Radio Button für die SSL Unterstützung aktiviert bzw. ist dann erst zu sehen. Das ist bei mir aber nicht der Fall! Der Ganze BO Bereich ist problemlos danach über https zu erreichen und auch die Zertifikatsinformationen kann ich mir über den Browser problemlos ansehen. Dort kann ich auch sehen dass das Zertifikat für meine Domain mit und ohne "www" ausgestellt ist. Leider fehlt wie bereits geschrieben der Radiobutton um das Ganze auch für den Shop zu aktivieren. Wenn ich den Umweg gehe die SSL Unterstützung durch einen manuellen Datenbankeingriff zu erzwingen endet dies in einer Fehlermeldung des Browsers dass zu viele Umleitungen aufgetreten sind. Die Einstellungen unter "SEO und URL" sind beide mit "www." angegeben. Die .htaccess habe ich schon mehrmals neu generieren lassen Hat jemand eine Ahnung was ich falsch mache? Edit: Es handelt sich um Prestashop 1.5.6. Einziges Zusatzmodul: germanext 1.5.6
  16. Den Gedankengang hatte ich auch schon, hab mich aber noch nicht wirklich damit auseinandergesetzt da ich solch ein Modul bisher nicht kannte. Aber du hast Recht, damit kann man sich das problemlos selber basteln. Habs gleich mal geladen. Vielen Vielen Dank! :-) :-) :-)
  17. Hallo liebe Silbersaiten Leute! Ich klinke mich mal leicht abschweifend in das Thema ein. Irgendwie ist das Trusted Shops Modul aus den offiziellen Addons verschwunden und auch im Backoffice wird es seit neuestem nicht mehr zur Installation angeboten. Auf eurer Seit finde ich nur die Module für die 1.3 bzw. 1.4 Version von Prestashop. Ich verwende die Version 1.5.6 und auch die neueste Version von Germanext (1.5.6) Kann ich diese Module verwenden? Oder sind gerade neue Module für 1.5 in der Pipeline? Warum ist das Trusted Modul überhaupt so klammheimlich verschwunden? Weiß da einer was?
  18. Bin ich zu zu dumm es zu finden oder existiert das Trusted Shops Modul nicht mehr? Ich wollte mich mal damit beschäftigen und habe gemerkt dass es im BO verschwunden ist. Bei den Addons finde ich nichts und wenn man unter http://www.prestashop.com/de/kostenfreie-partnermodule auf das Trusted Shops Modul klickt kommt auch nur zu der generellen Addons Seite. Weiß hier jemand was genaues??
  19. Guten Tag zusammen! Ich habe das Problem dass ich bei bestimmten Bestellungen gezwungen bin diese manuell abzuändern indem ich den bestellten Artikel lösche und dafür 2 andere hinzufüge. Konkret bedeutet das: Artikel löschen Ersatzartikel Nr.1 hinzufügen Ersatzartikel Nr.2 hinzufügen Da es sich um 3 Schritte handelt bekommt der Kunde im sekundentakt auch 3 mal die E-Mail dass ich seine Bestellung abgeändert habe. Das ist wirklich sehr nervig. Daher würde ich diese E-Mail am liebsten komplett abschalten. In den Statuseinstellungen klappt das aber nicht da hierfür kein konfigurierbarer Status vorhanden ist... Hat jemand eine Idee?
  20. Hallo! Ich möchte hier einmal meine Erfahrungen mit dem Hoster kontent.com schildern. Ich bin jetzt seit einem Jahr mit meinem Shop dort gehosted und hatte keine großen Probleme. Alle erforderlichen Einstellungen für Prestashop lassen sich bequem über deren Website vornehmen. Die Änderungen sind dann auch nach wenigen Minuten tatsächlich vorgenommen (php Version, magic_quotes etc.) Einziger Wermutstropfen: Auch auf Anfrage wird kein Cache System installiert und die erlaubte Anzahl von Feldern in einem Formular lässt sich nicht einstellen (Ich habe allerdings noch nicht probiert ob das über die .htaccess evtl. möglich ist). Das ganze Paket kann man sich über Module selbst konfigurieren. Meine Konfiguration (512MB RAM, 1GB Webspace, 320 execution_time CPU) EMail, domain usw. kostet mich 10€ monatlich. Da kann man nicht meckern. Die Produktzahl ist allerdings mit unter 2000 noch recht niedrig. Ich schreibe nächstes Jahr nochmal wie es sich entwickelt hat wenn da noch einige hinzugekommen sind. Hier noch ein paar interessante Screenshots:
  21. Heiliger BimBam! Wie konnte ich so blind sein! Danke dir vielmals für diesen Hinweis! Ich konnte das Template jetzt finden und anpassen. Und ich war schon am Rande der Verzweiflung! Vielen, vielen Dank für den Tipp!
  22. Hallo Leute! Ich brauche mal Hilfe bei folgendem Problem: Ich habe in meinem Shop Warenrücksendungen aktiviert. Funktioniert soweit auch ganz gut bis auf eine kleine Ausnahme: Wenn ich für den zurück genommenen Artikel eine Gutschrift erstelle wird eine merkwürdige Email an den Kunden versandt die nicht im geringsten etwas mit der Vorlage "credit_slip" zu tun hat. Die Option "Gutschein erstellen" jedoch funktioniert einwandfrei. Die zwei angehängten Bilder zeigen einmal die Vorlage aus dem Menü "Übersetzungen" und einmal was tatsächlich ankommt. Die versendete Email kann ich in dieser Form auch nirgendwo im Ordner /mails/de finden. Ganz schön kurios... Folgendes Experiment habe ich durchgeführt: Ich habe mal zum Test einen weiteren Bestellstatus hinzugefügt und auch hier ausgewählt dass der Kunde daraufhin eine E-Mail mit der Vorlage "credit_slip" bekommt. In der Vorschau im BackOffice wird dann auch das korrekte Template angezeit wenn ich auf das kleine Auge neben der Emailvorlage klicke, aber letzten Endes kommt der selbe Email Müll beim Kunden an wie auch bei dem eigentlichen "Gutschrift erstellen" Vorgang Folgende Lösungen habe ich bereits versucht: Ich habe den kompletten Mails Ordner aus der unberührten aktuellsten PS Version auf den Server kopiert. Ich habe bei den Übersetzungen kleine Modifikationen am Template durchgeführt und dann neu abgespeichert um evtl. der Datenbank zu sagen: "Hey, guck mal diese Vorlage hat sich geändert. Registriere das mal bitte und versende zukünftig diese neue Version von "credit_slip" alle Caches gelöscht und ausgeschaltet einziges Fremdmodul "germanext" deaktiviert Hatt alles nichts gebracht :-( Mein Shop: Aktuellste PS Version 1.5.5.0 -> letzter Upgrade von 1.5.4.1 ->Ursprungsversion irgendeine frühe 1.4. Frage: Falls nicht sowieso schon jemand eine Idee hat, wo wird definiert wann welche Email Vorlage versendet wird? steht das in irgendeiner Datenbank Tabelle oder kann ich das in irgendeiner .php Datei nachschauen?
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More