Jump to content

HerveRenault

Members
  • Posts

    9
  • Joined

  • Last visited

Everything posted by HerveRenault

  1. Pour que ça passe avec PHP 7, ajouter des { } pour lever l'ambiguïté, en ligne 188 : MRTools::{$valueDetailed['methodValidation']}($valueDetailed['value'], $valueDetailed['params'])
  2. Questo è un bug conosciuto. È possibile trovare due soluzioni in questa pagina : http://www.prestashop.com/forums/topic/341955-cannot-set-target-for-external-links-in-cms-page/
  3. To further elaborate your solution, you can override the addCSS function in override/controllers/front/FrontController.php like this: if ($css_uri == _THEME_CSS_DIR_.'global.css' && preg_match('/MSIE [6879]\./', $_SERVER['HTTP_USER_AGENT'])) return; parent::addCSS($css_uri, $css_media_type, $offset); and put your theme CSS file (global in this example) in a conditional comment: <!--[if lte IE 9]><link rel="stylesheet" href="{$css_dir}global.css" type="text/css" media="all" /><![endif]--> then only IE9 and lower will get the uncompressed file which is under 238 Ko, hopefully. (Too bad we still have to do that type of hack in 2014 because of those obsolete browsers...)
  4. Sur Prestashop 1.6, toujours dans js/tinymce.inc.js, il suffit de supprimer le plugin contextmenu de la configuration, et ajouter l'option browser_spellcheck (désactivé par défaut dans TinyMCE, je me demande pourquoi...) Supprimer "contextmenu" dans cette ligne : plugins : "colorpicker link image paste pagebreak table contextmenu filemanager table code media autoresize textcolor", Ajouter cette ligne (en-dessous, par exemple) : browser_spellcheck : true, Recharger la page. C'est tout. Testé sur 1.6.0.6 dans Firefox et Chrome.
  5. En effet, ça ne fonctionne pas parce que lorsqu'on appelle la méthode renderForm de la classe parente (AdminCategoriesControllerCore), ça écrase la propriété fields_form. Mais tu peux redéfinir entièrement AdminCategoriesController en héritant directement de AdminController (class AdminCategoriesController extends AdminController) juste pour pouvoir insérer la ligne 'autoload_rte' => true, dans renderForm() et là, évidemment, ça fonctionne. Mais bon, au moins tu ne touches pas aux fichiers du coeur.
  6. Bonjour, je constate aussi le problème en passant de la 1.4.9 à la 1.5.0.17. Avez-vous trouvé une solution, à part taper directement dans la table ps_stock_available ? (c'est ce que je fais, faute de mieux pour le moment)
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More