Jump to content

Grafics

Members
  • Posts

    701
  • Joined

  • Last visited

Everything posted by Grafics

  1. Il suffit de mettre une condition sur le template car à 1ère vue, la fonction a disparue.
  2. Le moteur smarty compile (dans le dossier compile!) les fichiers tpl en fichier php. Ce cache n'est donc pas à vider si rien ne change au contraire, cela demande moins de travail au serveur qui ne recompile pas le fichier à chaque fois ou ne vérifie pas si le fichier à changer. Le but est de ne pas les toucher. C'est à vider seulement si l'on a fait des modif sur des fichiers tpl et que le résultat ne se voit pas en actualisant. Si les modif sont sur des fichiers php type classe, controler les modifs n'impactent pas les tpl...
  3. La solution niveau BO et de choisir en fonction des groupes soit l'un soit l'autre. Sur les templates, la fonction et généralement en commentaire au niveau des prix (enlever les CCC, les compressions de code... et voir le code source ou directement dans le tpl...) Il y a les 2 mais qui sont soit l'un soit l'autre en fonction du choix par rapport au groupe du visiteur. Il suffit de simplifer la chose en enlevant les if et en ajustant son CSS.
  4. Le dilemme de utf-8 et des include php Google ne sera pas trop perturbé par le code html (il le lit très bien) qui a mon sens aura moins de conséquence qu'un manque d'accent qui gênera les lecteurs humains ou pire un joli □ au milieu Si c'est possible (si, si c'est possible) mettre le terme anglais voir français sans accent en utilisant les traductions. Il y aura comme cela un joli code utf-8 enlevant tout doute possible... si besoin, il est possible de faire des rapports et des états des lieux... et des optimisations à apporter... mais c'est un autre débat.
  5. Il faut mettre la balise title comme dans le template d'origine et cela marchera. <title>TITRE EN DUR</title> Une balise comme ça n'affichera que la même chose.
  6. il n'y a pas de quoi. Mets le topic en résolu, si tout est bon (modifie le 1er message pour changer le titre)
  7. Il faut, dans ce cas, voir avec la personne qui a conseillé La version 1.4 est réellement stable, la 1.5 non. Il faut toujours et toujours faire des sauvegardes. Il faut voir alors avec l'hébergeur. S'il n'y a plus d’espoir, il ne reste plus qu'à chercher la raison et afficher l'erreur (voir plus haut)
  8. Il ne faut pas passer sur la 1.5.5. Reviens à la version précédente. Depuis la 1.5 chez presta, il vaut mieux attendre les correctifs avant de mettre les nouvelles versions. Il faut voir les commentaires sur les mise à jours avant de le faire si l'on y connait pas vraiment.
  9. Vous possédez PrestaShop 1.5Editez votre fichier ./config/defines.inc.php, et modifiez la variable telle qu’elle est présentée ci-dessous :/* Debug only */ define('_PS_MODE_DEV_', true); Vous possédez PrestaShop 1.4Editez votre fichier ./config/config.inc.php, et modifiez les variables telles qu’elles sont présentées ci-dessous :/* Debug only */ @ini_set('display_errors', 'on'); define('_PS_DEBUG_SQL_', true);$start_time = microtime(true);/* Compatibility warning */ define(‘_PS_DISPLAY_COMPATIBILITY_WARNING_’, true);Editez également votre fichier ./config/defines.inc.php, et modifiez la variable telle qu’elle est présentée ci-dessous : define('_PS_MODE_DEV_', true); Voir : http://www.prestashop.com/blog/fr/la-page-blanche/
  10. Le thème est-il d'origine 1.5.3.1 ? Si non, est-ce qu'une commande avec le thème d'origine indique le paquet cadeau?
  11. Ces avertissement sont sur le front office ? Ce qu'il faut voir ce sont les messages du front en mode debug.
  12. Quels sont les répertoires que tu as vidé exactement ? plus précisément le dossier compile de smarty est bien celui qui se trouve dans cache à la racine?
  13. Mon conseil est de passer par la 1.3.7 puis de faire l'upgrade vers la 1.4.11 http://www.prestashop.com/en/developers-versions Le passage vers la dernière 1.3 sera très simple et normalement sans perte. La version 1.4 et à voir ensuite pour tout ce qui va concerner les ajouts ou modules ou thème qui peuvent ne plus être compatibles. Je conseillerai de faire cela sur une boutique test pour avoir un peu de temps pour tester les compatibilités et éviter la maintenance trop longue (sauf si presta n'a pas de secret pour vous). Le passage sur la 1.5 est très simple à première vue, mais très très incertain si on ne maitrise pas. Si la boutique est l'origine sans module ou chose perso, il est possible de monter vers la 1.5.4.1 mais c'est vraiment à tester.
  14. Cela correspond simplement aux pages numéro 2 lorsqu'il y a trop de produits pour s'afficher en une page. Voir ici par exemple : http://www.presto-changeo.com/fr/content/16-duplicate-url-fix
  15. Ce la dépend de l'hébergement php @set_time_limit(3600); //ou @ini_set('max_execution_time',3600); htaccess php_value max_execution_time 3600 php ini max_execution_time = 3600
  16. Ce que je vous conseil est le module de prestochangeo qui est extrêmement utile dans votre cas avec votre type d'hébergement: http://www.presto-changeo.com/fr/attribute-modules/34-attribute-wizard-pro.html Les déclinaisons ne sont créées qu'à la demande.
  17. Bonjour, Déjà, il est possible de revenir sur la version précédente avec le backup (s'il y en a eu un.) Pour le reste, vous pouvez nous contacter pour définir plus précisément vos besoins. Courtoisement, Jonathan
  18. A première vue, ils seraient dans le block search soit dans le dossier module de ton theme, soit dans le dossier module général (s'il n'y a rien dans le 1er). Si ce n'est pas là, voit dans les traductions. S'il n'y a rien, tu peux faire une recherche dans le dossier thème puis dans le dossier module.
  19. Le problème ne vient pas du module mais de la config cache et etag du serveur à configurer sur le httpd de préférence ou par htaccess.
  20. Il suffit de modifier le onHover en onClick et d'appliquer au "triangle" un lien réalisant la fonction. Soit la même avec un si ouvert sinon... ou 2 fonctions une pour l'ouverture, et l'autre pour la fermeture.
  21. Cela se trouve dans le css soit dans le module blocktopmenu du dossier theme/css/module/ soit s'il n'existe pas dans le dossier module général.
  22. Si c'est pour mettre le paiement par cic sur prestashop. Il suffit simplement de prendre le module cybermut gratuit et de renseigner les champs sur le BO.
  23. Oui, c'est effectivement très louche. Je n'ai plus de 1.5.4.0. Si tu passes en mode DEV, les erreurs t'affichent quoi ? Peux-tu mettre ta fonction getMessagesByOrderId d'origine ?
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More