Jump to content

gulix

Members
  • Posts

    47
  • Joined

  • Last visited

About gulix

  • Birthday 04/30/1967

Contact Methods

Profile Information

  • Location
    Boppard - Deutschland
  • Activity
    Web development agency

gulix's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Hallo, ich bekomme folgenden Fehler, wenn ich ein Sonderpreis hinzufügen möchte: Ich habe über den Storemanager über den Import allen Produkten für die Kundengruppe Händler einen Sonderpreis zugefügt... hat sowiet auch alles geklappt. Wenn ich im Shop dann das Produkt im Prestashop-Backend noch einmal ändern möchte bzw. auch wenn ich manuell einen neuen Sonderpreis hinzufügen möchte bekomme ich die Fehlermeldung und er fügt kein neuen Sonderpreis hinzu und ändert auch nichts. Meine Meinung nach sollten die Einstellung aber richtig sein oder was könnte da falsch laufen bzw. fehlen. Anbei einen Screenshot Prestashopversion 1.6.8 also aktuelle 1.6 er
  2. /tools/smarty/sysplugins/smarty_internal_templatebase.php public function registerPlugin($type, $tag, $callback, $cacheable = true, $cache_attr = null) { if (isset($this->smarty->registered_plugins[$type][$tag])) { throw new SmartyException("Plugin tag \"{$tag}\" already registered"); } elseif (!is_callable($callback)) { throw new SmartyException("Plugin \"{$tag}\" not callable"); } else { $this->smarty->registered_plugins[$type][$tag] = array($callback, (bool) $cacheable, (array) $cache_attr); } return $this; } Zeile 449 ist diese throw new SmartyException("Plugin tag \"{$tag}\" already registered");
  3. Hallo, seit einigen Tagen habe ich folgendes Problem... wenn ich im Backend auf die >> CMS Seite gehen möchte kommt eine weiße Seite mit Meldung im apache error log: AH01071: Got error 'PHP message: PHP Fatal error: Uncaught --> Smarty: Plugin tag "includeCOCN" already registered <-- \n thrown in /srv/webdata/tsh/thesofthouse.com/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 449\n', referer: https://thesofthouse.com/24admin/index.php?controller=AdminDashboard&token=b233e4df9c2017e280ae1ba449120196 Ich habe lediglich in den letzten Tagen zwei neue Module installiert... und zwar: Advanced URL Check order and custom number Eigentlich sollten die aber darauf keinen Einfluss haben. Nach dem deaktivieren beider Module ist der Fehler aber immer noch da. Hat jemand eine Idee wo da der Ansatzpunkt ist...
  4. Vielen Dank Whiley, so hat es geklappt... Beste Grüße Ralf
  5. Moin Rainer, vielen Dank... Damit hatte ich es auch schon versucht... auch schon mit dem vollem Pfad und auch der URL... Das scheint doch etwas komplizierter zu sein, oder??? Beste sonnige Grüße und ein schönes Wochenende Ralf
  6. Hallo, irgendwie bekomme ich nicht eine background Grafik in einer tabelle zum generienen des pdf Lieferscheins dargestellt... was ich nicht ganz nachvollziehen kann. Wenn ich die Grafik in einer Zeile der Tabelle darstellen möchte klappt es... wenn ich die gleich Grafik in der gleichen Tabelle als background-image definiere wird diese nicht angezeigt. Gebe ich bei der tabelle eine background-color an, dann wird die Farbe dargestellt. So wird zwar in der Tabellen zeile die Grafik angezeigt... aber als Hintergrund in der Tabelle nicht. <table width="80%" cellpadding="4" cellspacing="0" style="background-img: url('../img/bg_key_01.png');"> <tr> <td style="width: 100%;"><img src="../img/bg_key_01.png"></td> </tr> So wird der Hintergrund in der angezeigt. <table width="80%" cellpadding="4" cellspacing="0" style="background-color: #24a051;"> <tr> <td style="width: 100%;">test-test...</td> </tr> Hat jemand einen Tipp, wo hier mein Denkfehler liegt oder...???
  7. Moin Rainer, Vielen Dank... manchmal sieht man den Wald vor lauter Bäumen nicht. So klappt es auch!!! Beste sonnige Grüße Ralf
  8. Hallo Rainer, in welchen Lieferschein-Optionen bzw. wo sind diese Einstellungen, die du meinst. Beste Grüße Ralf
  9. Hallo, eigentlich wenn ich den code richtig lese müssten doch in den PDF Lieferscheinen auch ein kleines Produktbild zu sehen sein... in den Rechnungen ist es zu sehen, aber im Lieferschein nicht. Hat jemand eine Idee, warum eventuell nicht im Lieferschein... anbei einmal der code vom Lieferschein... <tbody> <!-- PRODUCTS --> {foreach $order_details as $order_detail} {cycle values=["color_line_even", "color_line_odd"] assign=bgcolor_class} <tr class="product {$bgcolor_class}"> <td class="product center"> {if empty($order_detail.product_reference)} --- {else} {$order_detail.product_reference} {/if} </td> <td class="product left"> {if $display_product_images} <table width="100%"> <tr> <td width="15%"> {if isset($order_detail.image) && $order_detail.image->id} {$order_detail.image_tag} {/if} </td> <td width="5%"> </td> <td width="80%"> {$order_detail.product_name} </td> </tr> </table> {else} {$order_detail.product_name} {/if} </td> <td class="product center"> {$order_detail.product_quantity} </td> </tr> {foreach $order_detail.customizedDatas as $customizationPerAddress} {foreach $customizationPerAddress as $customizationId => $customization} <tr class="customization_data {$bgcolor_class}"> <td class="center"> </td> <td> {if isset($customization.datas[Product::CUSTOMIZE_TEXTFIELD]) && count($customization.datas[Product::CUSTOMIZE_TEXTFIELD]) > 0} <table style="width: 100%;"> {foreach $customization.datas[Product::CUSTOMIZE_TEXTFIELD] as $customization_infos} <tr> <td style="width: 30%;"> {$customization_infos.name|string_format:{l s='%s:' pdf='true'[spam-filter] </td> <td>{$customization_infos.value}</td> </tr> {/foreach} </table> {/if} {if isset($customization.datas[Product::CUSTOMIZE_FILE]) && count($customization.datas[Product::CUSTOMIZE_FILE]) > 0} <table style="width: 100%;"> <tr> <td style="width: 30%;">{l s='image(s):' pdf='true'}</td> <td>{count($customization.datas[Product::CUSTOMIZE_FILE])}</td> </tr> </table> {/if} </td> <td class="center"> ({if $customization.quantity == 0}1{else}{$customization.quantity}{/if}) </td> </tr> {/foreach} {/foreach} {/foreach} <!-- END PRODUCTS --> </tbody>
  10. Hallo, irgendwie stehe ich ein bisschen auf dem Schlauch... ich möchte gerne in dem PDF Lieferschein explizit den Vorname und Nachname als Variable ausgeben und anzeigen lassen. Dafür habe ich in der Datei /classes/pdf/HTMLTemplateDeliverySlip.php folgendes eingefügt: $this->smarty->assign(array( 'order' => $this->order, 'order_details' => $order_details, 'delivery_address' => $formatted_delivery_address, 'invoice_address' => $formatted_invoice_address, 'order_invoice' => $this->order_invoice, 'carrier' => $carrier, 'customer' => $customer, 'lastname' => $customer->lastname, 'firstname' => $customer->firstname, 'display_product_images' => Configuration::get('PS_PDF_IMG_DELIVERY') )); und in der /pdf/delivery-slip.addresses-tab.tpl folgendes eingefügt: <tr> <td style="width: 20%; text-align: left;"> </td> <td width="60%"><span class="bold">Sehr geehrte/er Frau/Herr {$customer->firstname}{$customer->lastname},</span></td> <td style="width: 20%; text-align: left;"> </td> </tr> aber es wird nichts angezeigt bzw. ausgeben... weder der Vorname noch der Nachname.
  11. Hallo, ich habe in einem Shop folgendes Problem: Neuer Kunde wählt Produkt und legt es in den Warenkorb Kunde wählt beim Checkout als Zahlungsmethode PayPal Kunde drückt ohne sich einzuloggen und sich zu regstrieren den "Kaufen" Button. Kunde wird weitergeleitet zu PayPal und bezahlt seine Ware mit den korrekten Beträgen Bis dahin ist alles meiner Meinung nach korrekt und "Normal" Bei der Zurückleitung von PayPal in den Shop hingegen wird jetzt ein Neuer Kunde angelegt und eine Bestellung, die allerdings in Netto Beträgen angelegt ist und unter Bestellungen >> Bestellungen nicht sichtbar auftaucht, sondern nur auf der Übersichtsseite im Backend. Das PayPal Modul habe ich hingegen so konfiguriert.... Nutzen Sie Express Checkout Shortcut >> nein Use PayPal In Context Checkout >> nein Nutzen Sie die Funktion "PayPal-Login >> nein Zahlungsweise >> Direct sales (recommended) Handelt es sich hier um einen Bug bei PrestaShop oder Paypal... oder wo liegt da der Ansatzpunkt.
  12. Hallo, ich habe hier bei einer Prestashop Installation ein ganz seltsames Phänomen... Es ist hier jetzt zweimal vorgekommen, dass ein Kunde eine Artikel gekauft hat und diesen dann mit PayPal sofort bezahlt hat. Nur beide Bestellungen von völlig unterschiedlichen Kunden erscheinen nicht im Backend unter den Bestelungen, sondern nur auf der Backend Übersichtsseite. Wenn ich dann auf die Details der Bestellung klicke, dann wird da der Artikel und auch in der Rechnung in netto aufgeführt, also ohne Mehrwertsteuer, die Versandksoten aber incl. MwSt.. In der Rechnung erscheint auch nicht die Adresse des Kunden, wahrscheinlich weil die Adresse von PayPal übertragen wurde. Seltsam ist hier noch, dass bei Paypal der Betrag aber richtig angekommen ist, also Artikel und Versandksoten incl. MwSt.. Ich habe dann da zwei Testbestellungen im Shop mit PayPal gemacht. Einmal mit dem Checkout von Prestashop und einmal mit Paypal Express... aber damit wurden die Bestellung sauber in PrestaShop eingefügt. Ich habe gerade noch eine dritte Testbestellung durchgeführt als Neukunde mit PayPal Express, mit dem Ergebnis, dass da auch alles sauber zu PrestaShop übertragen wurde. Also absolut keine Beanstandungen. Der einzige Unterschied zu der Bestellung von dem Kunden ist, dass die KundenAdresse in dem Adressfeld nicht sichbar ist, aber unter den Kundenadressen richtig angelegt ist. Hat jemand eine Idee, wo da der Ansatzpunkt sein kann.
  13. Hallo, ich habe folgendes Problem: Wenn ich im Admin Bereich die "CMS-Seiten" aufrufen möchte kommt eine weiße Seite und im Debug Modus diese Fehlermeldung: Der php error log sagt dieses: In Zeile 449 der /tools/smarty/sysplugins/smarty_internal_templatebase.php steht dieses: Das Problem bzw. besteht sowohl mit eningschalteten, als auch deaktivierten smarty Cache. Weiß jemand den Ansatz für das Problem.... Danke...
  14. Hallo, es handelt sich um die WaWi "Oktopus". Wir haben es mit den Infos aus dem Bugtracker wohl an s laufen bekommen. Aber an der Datenbank hat sich doch zwischen 1.6.09 und 1.6.0.14 nicht wesentliches geändert... oder habe was verpasst.
  15. Wir haben das jetzt auch nicht bei einem produktivem Shop upgedatet... ich dachte vielleicht hat jemand ein ähnliches Problem und es kann sich eigentlich ja nur um geringfügige Anpassungen handeln.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More