Jump to content

KiriK

Members
  • Posts

    0
  • Joined

  • Last visited

Posts posted by KiriK

  1. Hi people

    1.5.3.1

     

    1) Download the version made by Chirby - http://www.prestasho...prestashop-152/

    2) Look in PostObject.php line 49 for "parent::validateFields;" and change it to "parent::validateFields(false);"

    3) Desactivate Canonical redirection in BO SEO&URL

    4) Delete the 4 URL in BO SEO&URL

    ..................

     

    Have fun

     

    Hello,

     

    Thanks, friendly URL become working, but 404 error still appears.

  2. I have this working, although its not ideal. The module obviously needs recoding to work with the 1.5 SEO system but this is beyond my scope.

    This is what I did:

    Turn on Friendly URL from the Back Office and then open the .htaccess file (in the root folder of your shop).

    Add the following lines at the very top of the file (they must not be in the main part else they will get deleted if you turn off/on Friendly URLs).

     

    RewriteEngine on

    RewriteCond %{HTTP_HOST} ^your_store.com$

    RewriteRule . - [E=REWRITEBASE:/your_dir/]

    RewriteRule ^blog/all-post.html$ %{ENV:REWRITEBASE}modules/plblog/frontent/all-post.php [QSA,L]

    RewriteRule ^blog/([a-zA-Z0-9-]*)/([0-9]*)-([a-zA-Z0-9-]*).html$ %{ENV:REWRITEBASE}modules/plblog/frontent/details.php?plcn=$1&plidp=$2&plpn=$3&.php [QSA,L]

    RewriteRule ^blog/([0-9]*)_([a-zA-Z0-9-]*).html$ %{ENV:REWRITEBASE}modules/plblog/frontent/list-post.php?plidc=$1&plcn=$2&.php [QSA,L]

    RewriteRule ^blog/tag/([a-zA-Z0-9-]*)_([0-9]*).html$ %{ENV:REWRITEBASE}modules/plblog/frontent/list-tags.php?pltn=$1&plidt=$2&.php [QSA,L]

     

    Edit the parts marked in Red to match your site (You'll see the same lines repeated a little further down with the correct information).

    As I said, it isn't the correct way to do it, but it does work.

     

    The Blog breadcrumb link will still give you a missing page error, but you can fudge a fix by editing modules/plblog/frontent/tpl/breadcrumb.tpl

     

    Find (around line 10):

    <a title="{$path['name']}" href="{$path['link']}">{$path['name']}</a>

     

    And Change it to:

    <a title="{$path['name']}" href="{$base_dir}blog/all-post.html">{$path['name']}</a>

     

     

    Added this fields into file? bu it doen't help for me. Continue recieving "page not found"

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More