Jump to content

juju2

Members
  • Posts

    17
  • Joined

  • Last visited

Profile Information

  • Activity
    Freelancer

juju2's Achievements

Newbie

Newbie (1/14)

2

Reputation

1

Community Answers

  1. Salut, on ne doit pas avoir tout à fait la même structure HTML alors. Le mieux est que tu utilises chrome ou firefox, que tu fasses un clique droit sur une des tes icônes et que tu essayes de rentrer le code css suivant: display: none; sur l'élément HTML qui correspond à tes icônes. Une fois que tu l'as trouvé, garde la modif et copie la dans ta surcharge du CSS
  2. Salut, as-tu déjà regardé du côté de la réecriture d'URL ? C'est assez courant que les problèmes de liens viennent de là lors d'une migration quelconque :/ Tiens nous au courant ! Bye
  3. Salut, tu peux procéder de plusieurs façons pour enlever ces icônes, soit tu fais une surcharge graphique dans laquelle tu stipules que ces icônes ne doivent pas s'afficher, du genre .footer-container #footer #block_contact_infos > div ul li i { display: none; } soit tu modifies ou fais une surcharges du template du module. Tu trouves le fichier .tpl dans le dossier du module et tu commentes la partie qui affiche l'icône. Bon courage !
  4. Salut, comme tu l'as dit, il y a plusieurs choses à regarder dans le fichier 'settings.inc.php'. En plus du préfix des tables et des identifiants de connexion à ta base de données, il faut aussi vérifier les Key. De mémoire elles sont générées à l'installation de Prestashop et jouent un rôle au moment de la création du mot de passe. En somme si les clefs ne sont pas les mêmes entre l'ancienne installation et la nouvelle, les mots de passe ne seront plus bon non plus. Bon courage =)
  5. Bonjour, je viens vous demander un conseil par rapport au multiboutique et aux catégories ainsi que les redirections. Nous avons 1 boutiques principales et 4 sous boutiques qui sont donc des images de la boutique principale. Nous avons aussi des catégories différentes dans les sous boutiques, avec des arborescences différentes. Nos produits sont communs à toutes les boutiques, simplement répartis de façon différente en fonction de la sous boutique. Le rôle de la boutique principale est, pour faire simple, de rediriger le client vers la sous boutique qui l'intéresse. Pour cela nous avons donc un menu assez complexe et précis dans la boutique principale pour que le client puisse se retrouver en un click à l'endroit qui l'intéresse sur la sous boutique qui l'intéresse aussi. Nous nous heurtons, du coup, à un problème d'URL. Je m'explique, pour envoyer le client à l'endroit qui l'intéresse à partir du menu de la boutique principale, nous serions obligé de rentrer l'URL de la sous-boutique en dur dans le menu, car nous n'avons pas accès grâce au module du menu aux catégories des sous boutiques. Et c'est là que nous avons un problème car à la moindre modification de catégorie/organisation des sous boutiques le menu devient obsolète car les liens changent. Il faudrait donc changer le menu de la boutique principale à chaque fois que nous faisons une modif sur une sous-boutique: ingérable. Connaîtriez-vous une façon de procéder qui permettrait de faire en sorte que le menu de la boutique principale suive les modifications des sous boutiques, en d'autres termes comme un menu sur une boutique unique (ex: si vous changez une catégorie le menu s'adapte directement). Ou vous êtes vous déjà retrouvé confronté à un cas du même genre et comment avez-vous réussi à palier au problème ? J'espère que c'est assez clair =) Cordialement, Julien
  6. Nous sommes exactement dans le même cas que vous, avez-vous trouvé une solution, ou une alternative pour votre problème ? Cordialement.
  7. Salut, enfin des gens qui ont le même problème que nous ! Triste à dire, mais ça fait plaisir. On a palier au problème des prix HT et TTC en achetant un module, ok c'est pas la solution la moins chère, mais maintenant ça fonctionne. http://addons.prestashop.com/en/billing-invoicing-prestashop-modules/2011-m4-pdf-extensions.html ce module permet de générer les factures sans erreurs de taxe et il a surtout l'avantage de pouvoir être paramétrable très facilement. De plus, modifier le template de la facture, pour qu'il ressemble exactement à la facture de nos rêves, est assez facile. Pour ce qui est de la déclaration en douane CN23, là, c'est une autre histoire. On le faisait sous PDF Creator à chaque fois qu'on en avait besoin (en général 1 à 2 fois par jour max). Evidemment, c'était fastidieux de chercher une déclaration en douane vide et de la remplir pour chaque nouveau client. Du coup depuis peu, on a jeté un coup d'oeil au code et on utilise FPDF pour générer cette déclaration en douane automatiquement. Elle se base sur le numéro de commande et sur un template vide pour le remplir directement avec les bonnes infos. C'est une solution "maison" mais qui fonctionne dans notre cas et nous permet de gagner une bonne trentaine de minutes chaque jour, je vous laisse deviner le temps gagné à la semaine. =) En espérant que ça puisse te donner un chemin de plus dans la résolution de ton problème ! Bon week-end, Julien
  8. Dans le back-office onglet : outils > générateurs, tu as " Configuration spécifique" qui correspond à ce qui sera écrit dans le fichier .htaccess. C'est ici que nous avions trouvé la solution pour notre module de blog (psblog) qui avait le même problème que le tien. On a utiliser une règle de réécriture d'URL pour que les liens fonctionnent. Là il faudra que tu fasses une recherche un peu plus poussée sur l'URL rewriting ou que tu envoies un mail au créateur du module pour qu'il te le fasse. Pour te donner une idée de la tête que ça a pour notre module et la réécriture d'URL : "RewriteRule ^blog(.*) /modules/psblog/content.php [QSA,L] "
  9. Salut, Effectivement, il semblerait que ton problème se situe du côté des URLs. Regarde dans le back office du côté de la réécriture des URLs, est-elle activée ? Si oui, nous avons déjà eu un problème de ce type avec le module PsBlog, il fallait ajouter une "configuration spécifique" lors de la réécriture d'URLs pour ce module, puis générer à nouveau le fichier htaccess Si non, essaie de l'activer et de régénérer le fichier htaccess après. En espérant que ça aide, Cordialement, Julien
  10. Hey, the problem was that the gap, between the header block and the top of left and right column block, was too close. As you can see on the photo i linked before, left and right should fit into the White you can see in the background. But, we found a way to fix it ! We used to reset every module that has a hook on "header of pages". Then we applied the same CSS modifications over them and we finally cleared the smarty cache. Our main problem is that we still use a theme from Ps 1.3.x and we are now running Ps 1.4.8. Obviously our theme isn't optimised for smarty V3 and Ps 1.4.8, that's why we had some CSS issues Hope it helps, sorry for my poor English, Have a nice day ! Julien
  11. Bonjour, nous avons eu un problème de ce type il y a quelques mois, mais ce problème était apparu suite à une mise à jour de prestashop avec le module autoupgrade. Est-ce le cas pour vous ? Cordialement, Julien
  12. Salut, Même si tu as posté il y a longtemps, j'ai eu exactement le même problème lors d'un upgrade récemment. En fait il te suffit d'activer le gestionnaire de thème smarty 2 et non pas 3 dans le backoffice. Tu y as accès dans la section préférence en bas de page ! En espérant que ça fonctionne chez toi aussi !
  13. Bonjour, J'ai actuellement un site prestashop en 1.3.7 qui fonctionne bien, j'ai décidé depuis quelques temps de passer à la dernière version en date: 1.4.8. Pour ce faire j'ai upgrader ma version 1.3.7 en 1.4.8 avec le module autoupgrade (le tout en local). A ma grande surprise, presque tout est fonctionnel. Alors mon problème, comme vous pouvez vous y attendre, se situe sur la facture. En effet, pour mon site en 1.3.7 les factures générées par Prestashop ne me satisfaisaient pas, j'ai donc fais des modifications en dur dans le fichier PDF.php afin d'obtenir ce que je souhaitais (au niveau de la TVA notamment). Evidemment avec la mise à jour, ces modifications en dur ont disparue car le fichier PDF.php a été modifié par le nouveau fichier PDF.php de la version 1.4.8. J'ai donc remis ces modifications sur le nouveau fichier MAIS (on est enfin au problème) celles-ci ne fonctionnent que partiellement. J'entends par là que les modifications atteignant le footer ou le tableau au cours de la génération facture fonctionne comme avant, mais d'autres, comme le calculs de la TVA du transport ne fonctionne plus en 1.4.8 alors qu'elles fonctionnaient en 1.3.7. J'en suis donc venu à penser que c'est l'upgrade de la base de donnée en 1.4.8 qui a changé certaines tables, du genre, celle des transporteurs. Pouvez-vous m'indiquer si c'est bien cela l'origine du problème, Si oui, un moyen de récuperer mes modifications en dur (dois-je par exemple modifier directement ma base de données, ou alors le fichier PDF.php afin qu'il soit en lien avec la nouvelle base de donnée ?) Si non, connaîtriez-vous une solution me permettant de garder ma base de données client/commande tout en obtenant les infos nécessaires lors de la génération de la facture (TVA des produits ET des transporteurs dissociés du prix TTC) En espérant être clair, et en vous souhaitant une bonne journée Cordialement Julien
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More