Jump to content

Nortas

Members
  • Posts

    36
  • Joined

  • Last visited

Profile Information

  • Activity
    User/Merchant

Nortas's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Allora se ho capito bene funziona così: la piattaforma crea un file php con dentro un array di variabili con le traduzioni! Poi queste var vengono richiamate nel TPL con la sintassi: {l s='miaVariabile' mod='nomeMioModulo'} Mentre nel file php (it.php): $_MODULE['<{NomeDelMioModulo}nomeDelMioTema>NomeDelMioModulo_d95cf4ab2cbf1dfb63f066b50558b07d'] = 'Testo traduzione'; Ora quello che non riesco a capire è dove piglia i nomi variabili! Vi faccio un esempio pratico: Ipotizziamo di dover mettere "Il mio Account" nel blocco apposito "blockUserInfo". Troviamo questo: Nel file it.php: $_MODULE['<{blockUserInfo}temaNortas>blockUserInfo_d95cf4ab2cbf1dfb63f066b50558b07d'] = 'Il mio account'; Nel TPL per scrivere la parola tradotta richiamo la variabile: {l s='My Account' mod='blockUserInfo'} La piattaforma sa che se la lingua è quella di default deve scrivere il nome vero e proprio della variabile (in questo caso My Account) se invece la lingua non è quella di default va a pescare nel file apposito della lingua selezionata (in questo caso it.php)... LA DOMANDA E': come fa la piattaforma a sapere che la var "my account" va associata $_MODULE['<{blockUserInfo}temaNortas>blockUserInfo_d95cf4ab2cbf1dfb63f066b50558b07d'] = 'Il mio account'? Anche perchè io pensavo che il problema fosse nel mio tpl dove non avrebbero dovuto esserci variabili ma le stringe pure (era l'unica spiegazione visto che i campi nella sezione me li da e me li fa anche editare ma il blocco resta sempre in inglese) ma così non è! A occhio mi sembra tutto ok! :/ Solo che non si traduce
  2. Si ma anche se lo edito il titolo non me lo fa cambiare! mi fa cambiare solo il corpo del messaggio! Ok devo attivare il Full Editor Grazie ancora!
  3. Salve a tutti vi spiego in breve il mio problema! Ho un template personalizzato acquistato su addon l'unico problema è che 2 dei blocchi in homepage non si traducono. Restano sempre in inglese (nonostante la traduzione sia stata fatta) Effettivamente aprendo il TPL del modulo ho visto che la scritta "Welcome" e "Your Account" son inserite a mano come stringa! Come faccio a caricare le variabili invece che quella stringa in modo che mi pigli la traduzione? Ia struttura di questo CMS mi è un po' ignota! xD I moduli in questioni sono cart 1.2 (ma è moddato da chi ha fato il tema) e blockUserInfo (quello che si vede nella home con scritto Your account ecc ecc ecc) grazie
  4. Grazie ancora! Non riesco ad aggiungere il "RISOLTO" nel titolo però xD
  5. Majezzi GRAZIEEE! Quel file è miracoloso
  6. Ok proverò! Il record del db qual'è?
  7. Scusate la domanda forse idiota...come posso resettare la password del B.O. in locale (visto che da locale non mi manda la mail),,, L'ho perduta e non posso più entrare xD Quella che uso online non funge (anche se ho importato il db da remoto per fare una prova)
  8. Ciao a tutti! Non conoscendo minimamente la struttura del modulo in questione chiedo aiuto! In sostanza io ho inserito un nuovo campo nella tabella ps_poduct (model_product) dove metto il codice del mio prodotto in modo da potermi districare con gli ordini! Vorrei aggiungere tale campo al modulo di ricerca veloce (in modo che se uno digita il codice del modello trovi il prodtto come fa ora con le varie parole chiave del prodotto)! Spero di esser stato comprensibile non riesco a spiegarmi bene! xD grazie
  9. Qualcuno sa a cosa servono i campi Rleft e Rrigth che ci sono nella tabella ps_category? Ma soprattutto: Qualcuno sa come vanno gestiti? :/
  10. Esattamente mi riferifivo proprio a quello! xD
  11. Si si chiaro ma pensavo che essendoci già il campo "id_category" nella tabella del prodotto non fosse necessario associarlo una seconda volta! Forse l'han fatto per rendere il tutto + veloce nell'esecuzione delle query
  12. si si per le immagnini avevo risolto! E grazie a te ora anche il resto era la tabella "ps_category_product" Grazie 1000
  13. ok ho risolto per la gestione delle immagini! Ho capito come le manipolano! Nonostante ciò Sto impazzendo xD Ho inserito i record manualmente in: ps_product ps_product_lang ps_image ps_image_lang però non mi vede i prodotti.... Ho provato a inserirne uno dal pannello di controllo e ovviamente li lo vede...se confronto il record del prodotto inserito a mano e quello del prodotto inserito dal pannello di controllo di prestashop sono IDENTICI...(a parte indici e descrizioni ovviamente) come è possibile che uno lo vede e l'altro no? xD
  14. ti ringrazio! Alla fine mi son studiato la struttura del DB perchè quel file era da uscire di testa! Solo una cosa ancora non capisco....le immagini dei prodotti dove le inserisce non trovo campi nel db :/
  15. Si son un pirla infatti ho fatto così! Chissà perchè non mi accettava la stessa che avevo in locale
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More