Jump to content

SpankyAndy

Members
  • Posts

    18
  • Joined

  • Last visited

Posts posted by SpankyAndy

  1. Hi,

     

    Does anybody know of an Android (or potentially iOS) app that hooks up to Prestashop and allows products to be added with photos taken directly from the phone's camera?

     

    I've looked around everywhere and can't seem to find one, even though this seems like a really obvious thing to offer for those like myself who have to take photos of everything on sale for 'cosmetic condition' purposes.

     

    After an extensive search, I've found that:

     

    • The ebay app allows this, but I don't want to reverse sync products.
    • The Shopify mobile app for iPhone has a camera feature, but apparently its not very good.
    • BigCommerce has a 3rd party app that offers this functionality, but I don't want to use BigCommerce.
    • Magento has a 3rd party app called mVentory which is perfect for the job, but Magento is a nightmare to configure and use.

     

    Anybody have anything to suggest for Prestashop please?

     

    Cheers

     

    Andy

  2. FIXED !!  Thanks to the brilliantly skilled and eagle eyed DrunkBug !!

     

    Using the BO copy tool (Localization > Translations > Copy) to copy our small UK language changes from the old theme to the new one had deleted all of the product names for that language.  I imported them from the pre-upgrade DB backup and all is well again.  

     

    After losing 6 hours from yesterday, having 4 hours sleep last night and having our site offline for over 24 hours, it took just 2 minutes to fix.  Easy when you know how, eh?

     

    Thanks once again to DrunkBug - I was literally at the end of my tether, so can't say how much I appreciate the quick response.

    Cheers

     

    Andy

  3. Hi DrunkBug,

     

    htaccess.txt

     

    .htaccess file attached.  Its the one Prestashop auto-generated and exactly the same as the one that works on the test sites I created on this box.

     

    Route to products  =  {category:/}{id}-{rewrite}{-:ean13}.html

     

    The only modules I have installed are the ones the theme requested to be used, which are the same ones that work on the test sites.  I've just checked through them all and there's nothing that removes product IDs from the URL, which can be confirmed looking at the second image link I posted originally (product ID at the beginning, as per route to products - we don't use EAN's).

     

    Cheers

     

    Andy

  4. Hi,

     

    I've got a problem with SEO friendly URLs which is driving me insane.  I've been trawling the forums trying different things for about 6 hours now and I'm desperate to go to bed!

     

    I upgraded from PS v1.5.6 to v.1.6.09 earlier today.  Everything was fine to start with, right up until the point I copied the English translation file from my old theme to the new one.  The second I did that, URL rewriting has failed to work.

     

    I've done all of the following several times in different orders, but to no avail:

     

    • Disabled/enabled SEO friendly URLs
    • Deleted and regenerated my .htaccess file
    • Regenerated thumbnails
    • Disabled cache and force compiled templates
    • Manually emptied the cache folders
    • CHMOD'd the .htaccess file to 777

     

    I've installed another two test PS instances on the same VPS which are both rewriting fine with the same template and an identical .htaccess file (which I've tried copying across and didn't work), so I know its not a server issue.

     

    One thing I have noticed is that the theme swaps between product images on mouseover and the second image URL rewrites fine, but the product anchor link and main image don't anywhere on the site.  Here are the URL's it produces:

     

    • Product link ... /en/button-clip-on-earrings/-.html
    • Main image ... /22860-home_default/.jpg
    • Second image ... /22861-home_default/deanna-gold-clip-earrings.jpg

     

    As you can see, its a rewrite issue, but I can't figure it out.  If anybody would be kind enough to have a look at this for me, please PM and I'll send over whichever details you need to access FTP or back office.

     

    Much appreciate any help anybody is prepared to give!

     

    Cheers

     

    Andy

  5. Hi,

     

    I've installed the latest version of the ebay module on my v1.4.9.0 shop.  Everything appears to be fine, until I try to sync products with ebay.

     

    I'm attempting to sync over 1900 products, which when clicking the sync button, brings up the loading icon and sits there indefinitely.  I started this at 9pm yesterday and left this running overnight, to find that it sync'd just 3 products at 8:25am today under the ReviseFixedPriceItem call type!

     

    The 3 products it has sync'd are not good sellers, but I don't think its any coincidence that these did sell this morning.  My assumption is that the "Sync with ebay" option within the module is not working at all, but when a product quantity is updated within PS, the module is automatically calling ebay and updating the quantity there.  While the items were not previously listed on ebay, it has used the ReviseFixedPriceItem call to actually enter them into our ebay shop.

     

    Does anybody know why the product sync function isn't working?  I've enabled the request.php debug and attached its output to this post for reference.

     

    Cheers

     

    Andy

    request.txt

  6. Hi,

     

    Does anybody know of a module or script that I can run via cron job, that will allow Prestashop to automatically send out an email to the customer, X number of days after their order has been placed/despatched?

     

    I'm wanting this to send out an automatic feedback request, 5 days after the order has been despatched, but don't want to have to be doing this manually every day.

     

    Any help is much appreciated.

     

    Cheers

     

    Andy

  7. Hi again !

     

    So, I've half fixed my problem after reading this thread:

     

    http://www.prestasho...iting-in-ps-15/

     

    The language issue sounded familiar, as I had deleted US English and kept UK English instead, but the ISO and language codes were wrong. I corrected these, but still no dice.

     

    After changing the friendly URL for authentication.php to something else, it now saves both guest and created accounts with no problem, but I get a weird problem instead. As it reloads the form after saving, the cart block in the left column adds a duplicate item (see two screen captures). The cart contents list in the OPC form doesn't change and the value doesn't increase - its just the cart block.

     

    Any ideas?

     

    Cheers

     

    Andy

    post-362158-0-82599700-1374512796_thumb.jpg

    post-362158-0-81151100-1374512802_thumb.jpg

  8. Hi guys,

     

    Thanks for the reply. Its a theme I bought off a template site. Here's the "HAR" copied from Chrome, which came from a friendly URL named 'authentication' ...

     

    Cheers

     

    Andy

     

     

     

    {

    "log": {

    "version": "1.2",

    "creator": {

    "name": "WebInspector",

    "version": "537.36"

    },

    "pages": [],

    "entries": [

    {

    "startedDateTime": "2013-07-22T09:54:49.153Z",

    "time": 342,

    "request": {

    "method": "POST",

    "url": "http://www.removed.co.uk/authentication",

    "httpVersion": "HTTP/1.1",

    "headers": [

    {

    "name": "Cookie",

    "value": "ffdbd13d96d903c026c4876e97eb63a4=ZNGXH4ET8rlMLzQLtdYZjfkUXySHVRb%2FoZfB2N8ZrbtxzduJ5MY40mfqYEtCgTbSjpoJGSHZlIQtpDrlrBQO9oFs5IJtX54JSgY5%2Fb4gZmfOumDlgYTASp3l515LPJYFWyVM2aojBWVdenPviZMj54gcveB5x4IY5vX5IJjvn%2B8%3D000120; __utma=45845238.174678622.1374478211.1374478211.1374486804.2; __utmb=45845238.2.10.1374486804; __utmc=45845238; __utmz=45845238.1374478211.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)"

    },

    {

    "name": "Origin",

    "value": "http://www.removed.co.uk"

    },

    {

    "name": "Accept-Encoding",

    "value": "gzip,deflate,sdch"

    },

    {

    "name": "Host",

    "value": "www.removed.co.uk"

    },

    {

    "name": "Accept-Language",

    "value": "en-US,en;q=0.8"

    },

    {

    "name": "User-Agent",

    "value": "Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.72 Safari/537.36"

    },

    {

    "name": "Proxy-Authorization",

    "value": "Basic YW5keS53aGl0dGxlOk1henZxZnIx"

    },

    {

    "name": "Content-Type",

    "value": "application/x-www-form-urlencoded; charset=UTF-8"

    },

    {

    "name": "Accept",

    "value": "application/json, text/javascript, */*; q=0.01"

    },

    {

    "name": "Referer",

    "value": "http://www.removed.co.uk/quick-order"

    },

    {

    "name": "X-Requested-With",

    "value": "XMLHttpRequest"

    },

    {

    "name": "Proxy-Connection",

    "value": "keep-alive"

    },

    {

    "name": "Content-Length",

    "value": "535"

    }

    ],

    "queryString": [],

    "cookies": [

    {

    "name": "__utma",

    "value": "45845238.174678622.1374478211.1374478211.1374486804.2",

    "expires": null,

    "httpOnly": false,

    "secure": false

    },

    {

    "name": "__utmb",

    "value": "45845238.2.10.1374486804",

    "expires": null,

    "httpOnly": false,

    "secure": false

    },

    {

    "name": "__utmc",

    "value": "45845238",

    "expires": null,

    "httpOnly": false,

    "secure": false

    },

    {

    "name": "__utmz",

    "value": "45845238.1374478211.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)",

    "expires": null,

    "httpOnly": false,

    "secure": false

    },

    {

    "name": "ffdbd13d96d903c026c4876e97eb63a4",

    "value": "ZNGXH4ET8rlMLzQLtdYZjfkUXySHVRb%2FoZfB2N8ZrbtxzduJ5MY40mfqYEtCgTbSjpoJGSHZlIQtpDrlrBQO9oFs5IJtX54JSgY5%2Fb4gZmfOumDlgYTASp3l515LPJYFWyVM2aojBWVdenPviZMj54gcveB5x4IY5vX5IJjvn%2B8%3D000120",

    "expires": null,

    "httpOnly": false,

    "secure": false

    }

    ],

    "headersSize": 1067,

    "bodySize": 535,

    "postData": {

    "mimeType": "application/x-www-form-urlencoded; charset=UTF-8",

    "text": "ajax=true&submitAccount=true&is_new_customer=0&opc_id_customer=0&opc_id_address_delivery=0&opc_id_address_invoice=0&email=test%40testing.com&id_gender=1&customer_firstname=Test&customer_lastname=TEsting&firstname=Test&lastname=TEsting&address1=123%20Test%20Place&city=TEscity&postcode=CH47%206BE&phone=01234567890&alias=My%20address&alias_invoice=My%20Invoice%20address&submitAccount=Save&id_country=17&customer_lastname=TEsting&customer_firstname=Test&alias=My%20address&other=&is_new_customer=0&token=8a57e77ebe9ff9534c7b98cddcb5f7d3",

    "params": [

    {

    "name": "ajax",

    "value": "true"

    },

    {

    "name": "submitAccount",

    "value": "true"

    },

    {

    "name": "is_new_customer",

    "value": "0"

    },

    {

    "name": "opc_id_customer",

    "value": "0"

    },

    {

    "name": "opc_id_address_delivery",

    "value": "0"

    },

    {

    "name": "opc_id_address_invoice",

    "value": "0"

    },

    {

    "name": "email",

    "value": "test%40testing.com"

    },

    {

    "name": "id_gender",

    "value": "1"

    },

    {

    "name": "customer_firstname",

    "value": "Test"

    },

    {

    "name": "customer_lastname",

    "value": "TEsting"

    },

    {

    "name": "firstname",

    "value": "Test"

    },

    {

    "name": "lastname",

    "value": "TEsting"

    },

    {

    "name": "address1",

    "value": "123%20Test%20Place"

    },

    {

    "name": "city",

    "value": "TEscity"

    },

    {

    "name": "postcode",

    "value": "CH12%203TE"

    },

    {

    "name": "phone",

    "value": "01234567890"

    },

    {

    "name": "alias",

    "value": "My%20address"

    },

    {

    "name": "alias_invoice",

    "value": "My%20Invoice%20address"

    },

    {

    "name": "submitAccount",

    "value": "Save"

    },

    {

    "name": "id_country",

    "value": "17"

    },

    {

    "name": "customer_lastname",

    "value": "TEsting"

    },

    {

    "name": "customer_firstname",

    "value": "Test"

    },

    {

    "name": "alias",

    "value": "My%20address"

    },

    {

    "name": "other",

    "value": ""

    },

    {

    "name": "is_new_customer",

    "value": "0"

    },

    {

    "name": "token",

    "value": "8a57e77ebe9ff9534c7b98cddcb5f7d3"

    }

    ]

    }

    },

    "response": {

    "status": 200,

    "statusText": "OK",

    "httpVersion": "HTTP/1.1",

    "headers": [

    {

    "name": "Date",

    "value": "Mon, 22 Jul 2013 09:54:49 GMT"

    },

    {

    "name": "Server",

    "value": "Apache"

    },

    {

    "name": "Connection",

    "value": "Keep-Alive"

    },

    {

    "name": "Proxy-Connection",

    "value": "Keep-Alive"

    },

    {

    "name": "X-Powered-By",

    "value": "PHP/5.2.17"

    },

    {

    "name": "Transfer-Encoding",

    "value": "chunked"

    },

    {

    "name": "Content-Type",

    "value": "text/html; charset=utf-8"

    }

    ],

    "cookies": [],

    "content": {

    "size": 775,

    "mimeType": "text/html",

    "compression": -18

    },

    "redirectURL": "",

    "headersSize": 220,

    "bodySize": 793

    },

    "cache": {},

    "timings": {

    "blocked": -1,

    "dns": -1,

    "connect": -1,

    "send": 0,

    "wait": 254,

    "receive": 86,

    "ssl": -1

    }

    }

    ]

    }

    }

  9. Hi all -

     

    I've been tearing what's left of my hair out trying to get OPC working on 1.5.4.1. Whenever I press the 'save' button after entering details for a guest or creating an account, I get the following dialogue box popup:

     

    TECHNICAL ERROR: unable to save account

     

    Details:

    Error thrown: [object Object]

    Text status: parsererror

     

    It works fine if I disable friendly URL's, but I can't seem to get it working with them enabled. Is anybody able to offer some advice please?

     

    Cheers

     

    Andy

  10. Hi all,

     

    I'm using the free Lengow Export module to export my products to a CSV file, but I'm not seeing any newly added products.

     

    I've added over 100 products in the last 2 months, but they're not showing within the CSV file. I only see products that were in the catalogue before the module was installed.

     

    I assume this is a caching problem, but I've tried disabling "Force compile" and "Cache" and running an export to update (as suggested on the Lengow website), but its still not showing the new products.

     

    Does anybody know what might be causing this please?

     

    Cheers

     

    Andy

  11. Hi,

     

    I've just discovered that 8% of our shop's visitors are accessing the site via mobile phne browsers - particularly iOS. As our site is currently designed for desktop only, I'm concerned we're losing potential customers.

     

    I've had a look at the official Prestashop theme, but I'm not overly impressed with the checkout process. The $69 iPrestaShop theme looks like an iPhone menu, which doesn't appeal to me either.

     

    Does anybody know of any other mobile modules (other than the PS app itself)?

     

    Cheers

     

    Andy

  12. Hi,

     

    I've just setup my 1.4.9.0 shop in the UK which has been live since last week, but I've realised that some countries are missing from the drop down menu at checkout, despite them being listed within admin and enabled.

     

    The countries that are missing have shipping carriers setup correctly and enabled. There's a handful that I can't see, but most notably is the 'United States' entry.

     

    I can't seem to find any help articles or forum posts describing the same issue. Would anybody be able to give me any pointers on why this might be happening please?

     

    Cheers

     

    Andy

  13. Hi,

     

    My custom theme was originally provided to me with a single row per product in category view, however I swapped product-list.tpl with another theme that had 3 products per row, as I wanted.

     

    This worked fine, except it displays 1 less item per page than required, regardless of how many you set, i.e. in the default view of 30 products per page, 29 are displayed.

     

    Temporarily, I've amended the number of products per page to 31, which displays 30 items, but misses the last on the page out of the product listings.

     

    I've tried amending the pagination function within /classes/FrontController.php to no avail. Does anybody know what may be causing this?

     

    Cheers

     

    Andy

  14. Hi,

     

    I've customised a theme, which is getting towards they way I want it, but I can't figure out how to add multiple products per row in the category view. At the moment, its a single item per line, as can bee seen here:

     

    Ideally, I'd like it to display 3 items per row, as the featured products does on the home page.

     

    Would anybody be good enough to point me in the direction of where I need to look? I've tried product-list.tpl which provides the product details, but it doesn't seem to decide the number per line.

     

    Any help is much appreciated!

     

    Cheers

     

    Andy

  15. Hi,

     

    A friend of mine has modified a theme I bought, but didn't put a background image on it, which I wanted. I tried to do this myself, but unfortunately the header is an image, which has now been hidden behind my full screen background image. Part of the header image is covered by the background on a large screen, but the whole header is gone on a smaller laptop screen.

     

    Does anybody know how I can set the stack order to push the background to the very bottom? I've tried CSS z-index, but this made no difference (I may have got the syntax wrong).

     

    http://newsite.ajfas...jewellery.co.uk

     

    Attached is my global.css file, if anybody would be so kind to give me some pointers.

     

    Cheers

     

    Andy

    global.css

  16. Hi,

     

    I'm looking for a Prestashop theme to be designed. I have a few ideas of what I'm looking for, so just need somebody to quote for the work:

     

    I'd like a front page that looks something like http://www.diy.com

    Category and product info pages that look like http://www.ebuyer.com

     

    Alternatively, I'd like something similar to this - http://presthemes.com/prestashop-themes/mobilis.html - but with a few modifications.

     

    Please feel free to post your quote and examples of your previous work.

     

    Cheers

     

    Andy

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More