Jump to content

Hardik

Members
  • Posts

    24
  • Joined

  • Last visited

1 Follower

Hardik's Achievements

Newbie

Newbie (1/14)

2

Reputation

  1. Hey Gaelle, Did you try it after the support for languages was added to it. Thanks and regards, Hardik
  2. Hi, I have added the code to check for selected language and show accordingly. Kindly check and get back to me. Hope this helps. Thanks and regards, Hardik block search by attributes UPDATED for 1.3.1 with lang support.zip
  3. Great, Can you PM me the files, i will take a look. Thanks for the code. Hardik
  4. The module has been updated to work with prestashop 1.3.1 Dropdown width issue has also been fixed. find module attached. You can take a look at the module in action at http://plasticc.000space.com/presta131/ Forum link for old and new version http://www.prestashop.com/forums/viewthread/54611/third_party_modules/module_search_by_attribute_module_working_fine_now Hope this helps, Hardik block search by attributes UPDATED for 1.3.1.zip
  5. Its strange no ones replied yet i think i should start a new post you can see it working at http://store.hardik.iwantdemo.org This is a test site, therefore please don't place orders
  6. Forgot to mention... the module has been tested on prestashop 1.2.5.... thanks, hardik
  7. "Search by attributes block" is now working. Anyone interested can check it out the forum link http://www.prestashop.com/forums/viewthread/54611/P15/third_party_modules/module_prestashop_1_dot_3_dot_1_compliant_search_by_attribute_module_working_fine_now__advanced_search__filter_by_attributes__filter_search_product/ Adapted for Prestashop 1.3.1 Module is available for download there. Hope this helps. Regards, Hardik
  8. "Search by attribute" block is now working fine. You can check the link http://www.prestashop.com/forums/viewthread/20212/P15/third_party_modules/module_searchbyattribute_frontpage_module/ Hope this helps. blocksearchbyattribute120_package WORKING.zip
  9. Hi All, I got this module to work. Find attached the Advanced Seach filter by attributes modules. Hope this helps. Thanks, Hardik blocksearchbyattribute120_package WORKING.zip
  10. you will have to go to tools.php in classes/tools.php goto the "convertPrice" function round($price,-1); might help, but you'll have to try it out
  11. Hi Steve, Been a little busy so couldnt reply back. here's the code. I saw your website and noticed that you do not have sub categories, so the below mentioned code should work fine. in your header.php add $category = new Category($_GET['id_category']); $parentCategory = $category->id_parent; if (isset($_GET['id_product'])) { $product = new Product(intval($_GET['id_product'])); $categ1 = $product->id_category_default; } $smarty->assign(array( 'HOOK_HEADER' => Module::hookExec('header'), 'HOOK_LEFT_COLUMN' => Module::hookExec('leftColumn'), 'HOOK_TOP' => Module::hookExec('top'), 'static_token' => Tools::getToken(false), 'token' => Tools::getToken(), 'priceDisplayPrecision' => _PS_PRICE_DISPLAY_PRECISION_, 'content_only' => intval(Tools::getValue('content_only')), 'id_parentcategory' => $parentCategory, 'categ1' => $categ1 )); in your header.tpl {if $categ1 == 2 || $id_parentcategory == 2 } {elseif $categ1 == 6 || $id_parentcategory == 6 } {elseif $categ1 == 12 || $id_parentcategory == 12} {elseif $categ1 == 13 || $id_parentcategory == 13} {else} {/if} Hope you can go live as soon as possible.
  12. Hi steven, I had the same problem. This is how i solved it 1) in your header.php you have to do add the code to get the parent category id using the _.Get method as pointed out by rocky earlier in this post 2) pass it as a smarty assign for the header.tpl 3) compare the parent id in if statemet in header.tpl for appropriate banner per parent id You will also have to check for product id by doing a _get(id_product) then use that to get the parent of that product to compare in the header.tpl just in case the user is on the product details page.
  13. i sorted out my issue... the problem was that as per one forum post i needed to order my attributes and attribute groups... so i had 001. 002. 003. in all my attributes... now when prestashop was indexing for the search, it was indexing 001.Atribute name instead of only the "attribute name". I had to sit and add a space to all my attributes and regenerate the index and it works fine now... kindly note, this problem occured because if prestashop has indexed "001.attribute name" and one searches for "attribute" it doesnt seem to be picking up parts of words... so only a search for "name" or "001.attribute" would lead to a match. hope this helps...
  14. doesnt seem to work... is there any $smarty->assign that i need to do in the block-categories.php ???
  15. thanks a mil. the earlier code that you had given me to access the parent category id to change the banner worked great. however i want to use the same in the category-tree-branch.tpl but the $id_parentcategory doesnt seem to be accessible there. is there a way to set it globally or something if not how can one achieve that?
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More