Jump to content

japarisid

Members
  • Posts

    112
  • Joined

  • Last visited

Profile Information

  • Activity
    Developer

japarisid's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. El problema es que he modificado cosas y ya está en marcha la tienda. Me resulta muy raro que nada mas instalarla sí que vi que estaba dicho módulo y hace poco me di cuenta que había dejado de salir. Todo el footer es un mismo módulo en el que se configura los bloques que tienen que salir, el de las redes sociales no es un módulo en sí, sino un texto html que debería insertar en la posicion que se le pone.
  2. Buenas, Tengo mi tienda montada a partir de la plantilla leo sport shoes a partir del quickstart. En el footer, nada mas instalar la tienda, habian dos módulos configurados (el del newsletter y el de redes sociales) como se puede ver en su demostración de la plantilla: http://www.leotheme.com/demo/prestashop14x/?template=leo_sportshoes Tras tener toda la tienda lista me he dado cuenta el módulo de las redes sociales ha desaparecido. Lo encuentro bien configurado pero no aparece. He probado también a sustituir el newletter por este otro pero entonces no sale ni uno ni otro. Podéis encontrarla en steamkey.es Alguien se ha topado con lo mismo?
  3. Subo el tema ya que necesito algún tipo de ayuda. He instalado la tienda desde cero otra vez. Utilizo la plantilla leo sports theme usando el quickstart donde viene ya todo configurado. Antes de tocar absolutamente nada he instalado el modulo de paypal europa ya que en el quickstart solo viene la versión americana, y lo configuro con mis credenciales. Voy a hacer un pedido y al pinchar en paypal como método de pago me da un 500 Internal Server Error. que dice: "The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error. More information about this error may be available in the server error log." Si modifico el fichero paypal_connect.php y pongo el verbose en false, cuando hago el mismo proceso, sí que me redirige a paypal para introducir cuenta de paypal o tarjeta para pagar pero en cuanto meto los datos y le doy a pagar se queda todo en blanco y no sé porque. La url en la que se queda en blanco es esta: mi_dominio.es/modules/paypal/express_checkout/payment.php?token=EC-46313736P2309770D&PayerID=3C3YY6U9KHB7S Tengo todo a punto pero me falla esto para poder empezar a vender. ¿Que puedo hacer por favor? Gracias. EDITO: He puesto el display error en on y donde la página en blanco ahora me aparece lo siguiente: "Fatal error: Uncaught exception 'PrestaShopException' with message 'Property Address->address1 is empty' in /htdocs/public/www/classes/ObjectModel.php:837 Stack trace: #0 /htdocs/public/www/classes/ObjectModel.php(255): ObjectModelCore->validateFields() #1 /htdocs/public/www/classes/ObjectModel.php(596): ObjectModelCore->getFields() #2 /htdocs/public/www/classes/Address.php(186): ObjectModelCore->update(false) #3 /htdocs/public/www/classes/ObjectModel.php(417): AddressCore->update(false) #4 /htdocs/public/www/modules/paypal/express_checkout/payment.php(199): ObjectModelCore->save() #5 {main} thrown in /htdocs/public/www/classes/ObjectModel.php on line 837" A ver si con esta info alguien puede darme alguna idea.
  4. Hola, gracias por el aporte. Despues de reinstalar el módulo e introducir los datos mediante el "obtener mis datos de identificacion de paypal" para que sean correctos, me vuelve a pasar lo de la página en blanco. Ya no sé que más hacer, me redirecciona a la pasarela de paypal donde me pone el importe a pagar, pongo datos de tarjeta o de cuenta de paypal y tras unos segundos se queda todo blanco y en la url: dominio_tienda.es/modules/paypal/express_checkout/payment.php?token=EC-83W13264F1297133R&PayerID=S3G3KP4LW2G26 No encuentro forma de solucionarlo..
  5. Por favor necesito ayuda. He intentado de todo, he desinstalado el modulo y vuelto a descargar e instalar (v.3.6.6) Si dejo el verbose en true, siempre me da error 500 del servidor. Si lo pongo en false ahora me muestra el siguiente error: Please try to contact the merchant: <b>PayPal response:</b> TIMESTAMP -> 2014-03-26T09:48:15Z L_ERRORCODE0 -> 10002 L_SHORTMESSAGE0 -> Security error L_LONGMESSAGE0 -> Security header is not valid L_SEVERITYCODE0 -> Error
  6. Buenas Tengo mi tienda lista y por último estaba probando el módulo de paypal haciendome una pequeña compra. Al principio, cuando pulsaba en el enlace que lleva a la pasarela de pago me daba un error 500 y buscando información modifiqué un archivo del módulo creo que paypal_connect.php y cambié una opción que se llamaba verbose de true a false. Con esto se solucionó y ya entra a paypal para proceder al pago. Pero ahora me ha pasado que tras introducir los datos y darle al boton para que se efectue el pago se queda la pagina toda en blanco y la url del navegador así: ww.dominio_de_mi_tienda.es/modules/paypal/express_checkout/payment.php?token=EC-XXXXXXXXXXXXXXXX&PayerID=XXXXXXXXXXXX (Las X son letras y numeros) Parece que no ha llegado ni a cobrarse el importe. ¿Que puedo hacer? Gracias.
  7. Lo del backoffice ya lo he solucionado añadiendo el idioma español y actualizandolo desde el backoffice. Ahora me queda el frontoffice. He probado a hacer lo que me has comentado y he copiado el idioma del castellano del tema default al español que he creado para el tema leo. Lo único que está en castellano es el carrito y el bienvendido, entrar. Como puedo cambiar lo demás? Gracias.
  8. Muchas gracias por toda esta info Nadie. Me he quedado con uno gratuito de la web leotheme que me viene muy bien. Ahora la duda que tengo es lo del idioma, ya que este viene en inglés. He usado el quickstart para no tener que configurar posiciones y demás y tengo toda la tienda en inglés front y back. Me gustaría poner ambos en castellano, ya que en el apartado de empleados, no puedo cambiar el usuario al idioma español. Y el front office aún tengo que probar lo que me has pasado, pero primero quisiera traducir el backoffice. Muchas gracias
  9. Buenas, Estoy montando un prestashop de videojuegos y no encuentro una plantilla para la 1.5.x que esté en español y el tema esté relacionado con ese mundo. Agradecería cualquier ayuda que me puedan dar. Un saludo.
  10. Sí, acabo de conseguir de ocultarla del proceso de compra. Más adelante la quitaré del perfil. Ahora mismo me ha surgido un problema para dejarlo todo a punto. En el formulario, en el campo nombre o apellidos necesito que se puedan introducir también números, no solo letras. Ya que uno de los dos es nombre de usuario que los puede contener. Hay forma de admitirlos?
  11. Gracias. He quitado todo los <p> y <div> del formulario para que solo quedaran los input y ya no queda ese vacio tan grande. Ahora he visto que hace lo que yo quiero ya que la dirección se rellena sola con los datos que yo he puesto pero cuando se guarda, se muestra al cliente todos esos datos. No se puede configurar prestashop o modificarlo de alguna forma para que no aparezcan direcciones por ningun lado? ya que todo es digital.
  12. Gracias por responder. Poner los input hidden hace lo mismo que poner el div del formulario entero hidden. Y es que queda un cuadro vacío muy grande. Solo me falta que no haya un hueco vacío tan grande.
  13. Buenas, Tengo una tienda de software y no necesito que los clientes pongan su dirección a la hora de hacer un pedido. Después de muchos intentos de cancelar la validación del formulario, ahora estoy intentando tener el formulario oculto y con datos para que se valide siempre automáticamente. Hasta ahora ya he conseguido rellenarlo pero el problema está al ocultarlo ya que con un "display:none;" es como si lo hubiera borrado y da error de validación. Con "visibility:hidden;" lo hace bien ya que no aparece y se traga la validación pero el hueco que ocupaba sigue estando ahí. ¿Como puedo quitar ese hueco vacio que tengo ahora? Gracias.
  14. Nadie ha tenido el mismo problema que yo? Tan solo quiero "desactivar" los usuarios y que todos los pedidios se puedan realizar como invitado tan solo rellenando 2 campos del formulario que necesito.
  15. Buenas, Vengo a ver si alguien me puede echar una mano que llevo tiempo con esto y no termino de conseguirlo. Tengo un ps 1.5.6 y no necesito que los usuario se registren ni pongan dirección para realizar una compra. He activado el pedido rapido (1 sola pagina en vez de 5 pasos). Y he modificado el formulario (order-opc-new-account.tpl) para que me pida los campos que yo quiero tan solo y no salga nada de dirección. Cuando se le da a guardar, la tienda hace la validación del formulario que me da error todo del apartado de dirección. Y no encuentro el archivo que hace esta validación. ¿Como puedo quitar la validación de la dirección? Gracias.
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More